[Support] ich777 - Gameserver Dockers


Recommended Posts

7 hours ago, Hyperion said:

Hello,

is there a methode to acess the gameserver-console? like in minecraft the web-console or with screen

Which game are you talking about.

 

2 hours ago, C_James said:

Trying to set up an acc server (Assetto Corsa Competizione) getting a tcp error and something about connecting to server. What did I do wrong?

Can you post the log please?

But I think the master server can't talk to your server.

Have you forwarded all the ports with the right protocol in your router/firewall?

Link to comment
5 hours ago, ich777 said:

Which game are you talking about.

 

Can you post the log please?

But I think the master server can't talk to your server.

Have you forwarded all the ports with the right protocol in your router/firewall?

Ive port fowarded 9201 tpc and udp. as thats the port the docker is using. and here the log and the error. thank you.image.png.b8caeda432dc0c94b4b8d48bf2b4d966.png

Link to comment
48 minutes ago, C_James said:

Ive port fowarded 9201 tpc and udp. as thats the port the docker is using. and here the log and the error. thank you.

Seems like there is something wrong with the connection to the Master server, this occurs if the master server can't contact your server.

Is eventually your ISP blocking some ports or something similar?

 

Please check your port forwarding again, just to double check.

Link to comment
8 minutes ago, ich777 said:

Seems like there is something wrong with the connection to the Master server, this occurs if the master server can't contact your server.

Is eventually your ISP blocking some ports or something similar?

 

Please check your port forwarding again, just to double check.

Ye. the docker container is using port 9201 so thats been port fowarded internal and external. on tpc and udp. so im not sure what the problem is. image.png.f4a8e26b497512f6a6bb519ec056bd2b.png

Link to comment
1 minute ago, C_James said:

Ye. the docker container is using port 9201 so thats been port fowarded internal and external. on tpc and udp. so im not sure what the problem is.

I'm also not 100% sure where the issue is but eventually try to contact your ISP about that, I only know this message when the ACC can't connect to your server from outside.

 

My suspicion is that your ISP eventually blocks some ports or there is a general routing problem...

Link to comment
7 minutes ago, ich777 said:

I'm also not 100% sure where the issue is but eventually try to contact your ISP about that, I only know this message when the ACC can't connect to your server from outside.

 

My suspicion is that your ISP eventually blocks some ports or there is a general routing problem...

i will try running some different ports for the docker and see what happens. surely not every port is blocked.

  • Like 1
Link to comment
Posted (edited)
26 minutes ago, ich777 said:

I'm also not 100% sure where the issue is but eventually try to contact your ISP about that, I only know this message when the ACC can't connect to your server from outside.

 

My suspicion is that your ISP eventually blocks some ports or there is a general routing problem...

tried port 9012 tpc and udp same thing. so on to my isp now. joy. also the videos ive seen of setting up acc server wants a https fort foward. does this one not need it?

Edited by C_James
forgot to add something in
Link to comment
43 minutes ago, C_James said:

tried port 9012 tpc and udp same thing. so on to my isp now. joy. also the videos ive seen of setting up acc server wants a https fort foward. does this one not need it?

I don't think so: Click

Link to comment

Is there a way to limit the RAM usage in the Valheim Server? I've been getting ~89% RAM usage with no other intensive Dockers or VMs running (I have 32GB total RAM). Updated and restarted my UNRAID but still seeing the same issue.

Link to comment
19 minutes ago, BBLV said:

Is there a way to limit the RAM usage in the Valheim Server? I've been getting ~89% RAM usage with no other intensive Dockers or VMs running (I have 32GB total RAM). Updated and restarted my UNRAID but still seeing the same issue.

Something like '--memory=5G' (without quotes) should do the trick.

 

If you are getting such high memory usage it is likely the case that something is wrong with your map...

  • Like 1
Link to comment
2 hours ago, ich777 said:

Something like '--memory=5G' (without quotes) should do the trick.

 

If you are getting such high memory usage it is likely the case that something is wrong with your map...

Thanks I'll give that a try and report back.

  • Like 1
Link to comment
On 9/25/2020 at 2:46 AM, Holynub said:

Hey Ich777,

 

I have a very peculiar use-case that I could use some assistance with. I'm running a 7 Days To Die instance with the Darkness Falls mod on it. The scenario is like this:

  • We have a group playing 7 Days to Die Alpha19, with Darkness Falls V3.02
  • There is an update for both 7 Days to Die (Alpha 19.1) and Darkness Falls (3.10)
  • Both of those are completely incompatible with our current game, and requires a complete map restart
  • Everyone is running a rolled back instance of 7dtd on their client and the server was not updated so we can keep playing on our current map
  • A power outage hits the server causing it to reboot
  • On boot, steamcmd runs through and updates the server 7dtd instance making the server no longer compatible with our Darkness Falls version and game save
  • I have a backup of the server files prior to today's power-outage/update
  • I can restore the files on the 7dtd server to put it back to how it was before
  • Is there any way to start the container and not have steamcmd update the 7dtd base application?

Any advice would be super helpful. 

Can you share how you installed darkness falls in the container?

Link to comment

Hi,

 

I'm having some trouble getting any of these containers to work now.  I replaced my cache drive a few weeks ago, restored everything from a backup and haven't really gamed since then.  Now, whenever I try to run, or even re-install (for example) conan exiles, I get the following in my logs.

 

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
ERROR! Failed to install app '443030' (Disk write failure)

---Prepare Server---
---Looking for config files---
-----------------------------------------------------------
---Something went wrong can't find folder 'ConanSandbox'---
--------------Putting Server into sleep mode---------------

 

I've searched as much as I could, and didn't run into anyone with this specific issue.  What am I look for here exactly to get these back up and working?  Any help is appreciated, and let me know what else I need to post info-wise.

 

Thank you!

Link to comment
1 hour ago, audioclass said:

I've searched as much as I could, and didn't run into anyone with this specific issue.  What am I look for here exactly to get these back up and working?  Any help is appreciated, and let me know what else I need to post info-wise.

Please check you Shre configuration for your appdata directory if it's set to Use Cache Only or Prefer if it's set to Yes or No, the containers won't work.

 

Please keep in mind if you change it, you have to invoke the Mover so that it moves the files from the Array back to the Cache.

Link to comment

Hey, I'm new to using Unraid but I noticed when shutting down the Minecraft docker through the web GUI, upon restarting the world had been reverted to it's state several minutes prior to shutting down. Is there a way to fix this when shutting down the Docker?

Link to comment
1 hour ago, MarioRPGGeno said:

Hey, I'm new to using Unraid but I noticed when shutting down the Minecraft docker through the web GUI, upon restarting the world had been reverted to it's state several minutes prior to shutting down. Is there a way to fix this when shutting down the Docker?

Which Minecraft container?

 

It should not do that at least on my system it does not do that.

 

Is the game running of off the Cache drive?

Eventually the world takes too long to save and the Docker forces the container to shutdown, but that's only a guess.

Link to comment
28 minutes ago, ich777 said:

Which Minecraft container?

 

It should not do that at least on my system it does not do that.

 

Is the game running of off the Cache drive?

Eventually the world takes too long to save and the Docker forces the container to shutdown, but that's only a guess.

I'm using "MinecraftBasicServer" with a Forge modded server, and I'm running off the cache drive.

Link to comment
26 minutes ago, MarioRPGGeno said:

I'm using "MinecraftBasicServer" with a Forge modded server, and I'm running off the cache drive.

I usually don't support modded servers but I think this can be a problem with Forge itself since it gave me other troubles on my server in the past and I switched to Spigot.

 

You can always run the save command from the WebTerminal or in game before you stop the server.

Link to comment
2 minutes ago, ich777 said:

I usually don't support modded servers but I think this can be a problem with Forge itself since it gave me other troubles on my server in the past and I switched to Spigot.

 

You can always run the save command from the WebTerminal or in game before you stop the server.

That'll work, thanks!

  • Like 1
Link to comment
Posted (edited)
7 hours ago, ich777 said:

Please check you Shre configuration for your appdata directory if it's set to Use Cache Only or Prefer if it's set to Yes or No, the containers won't work.

 

Please keep in mind if you change it, you have to invoke the Mover so that it moves the files from the Array back to the Cache.

My cache is set to prefer for appdata and I’ve confirmed that everything appdata related IS on the cache.  Any other ideas what it might be?

Edited by audioclass
Link to comment
3 hours ago, audioclass said:

My cache is set to prefer for appdata and I’ve confirmed that everything appdata related IS on the cache.  Any other ideas what it might be?

It seems like that the permissions are completely messed up, even SteamCMD can't write to it, can you reset the permissions only for this folder?

Are you familiar with the command line a little bit and where the files are located?

Link to comment
49 minutes ago, ich777 said:

It seems like that the permissions are completely messed up, even SteamCMD can't write to it, can you reset the permissions only for this folder?

Are you familiar with the command line a little bit and where the files are located?


Yes I can get to them in the terminal, what exactly should I do?

Link to comment
Just now, audioclass said:


Yes I can get to them in the terminal, what exactly should I do?

Do a:

chown -R 99:100 /mnt/user/appdata/conanexiles (the path is only a guess)

chmod -R 777 /mnt/user/appdata/conanexiles (the path is only a guess)

(eventually do the same to your SteamCMD directory, just in case... :) )

 

Stop the container in the first place before doing this...

After that try to start the container and see what the log says.

Link to comment
Posted (edited)
15 minutes ago, ich777 said:

Do a:

chown -R 99:100 /mnt/user/appdata/conanexiles (the path is only a guess)

chmod -R 777 /mnt/user/appdata/conanexiles (the path is only a guess)

(eventually do the same to your SteamCMD directory, just in case... :) )

 

Stop the container in the first place before doing this...

After that try to start the container and see what the log says.

 

Error is persisting after this :(

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
---Update Server---
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
"@sSteamCmdForcePlatformType" = "windows"
[0m
Connecting anonymously to Steam Public...Logged in OK
Waiting for user info...OK
ERROR! Failed to install app '443030' (Disk write failure)

---Prepare Server---
---Looking for config files---
-----------------------------------------------------------
---Something went wrong can't find folder 'ConanSandbox'---
--------------Putting Server into sleep mode---------------

 

I checked access after with stat:

 

root@Serenity:/mnt/user/appdata# stat steamcmd
  File: steamcmd
  Size: 100             Blocks: 0          IO Block: 4096   directory
Device: 32h/50d Inode: 13510798885729765  Links: 1
Access: (0777/drwxrwxrwx)  Uid: (   99/  nobody)   Gid: (  100/   users)
Access: 2021-06-07 22:48:32.915992336 -0400
Modify: 2021-06-08 12:00:26.725914370 -0400
Change: 2021-06-08 12:00:26.725914370 -0400
 Birth: -

root@Serenity:/mnt/user/appdata# stat conanexiles
  File: conanexiles
  Size: 0               Blocks: 0          IO Block: 4096   directory
Device: 32h/50d Inode: 13510798885729766  Links: 1
Access: (0777/drwxrwxrwx)  Uid: (   99/  nobody)   Gid: (  100/   users)
Access: 2021-06-07 22:48:32.915992336 -0400
Modify: 2021-06-07 22:48:32.915992336 -0400
Change: 2021-06-08 12:00:24.142910874 -0400
 Birth: -

 

 

Edit:  The weird part is that the container MADE these folders successfully, and was able to download/extract all of the info to steamcmd folder without trouble.  I'm lost haha.

Edited by audioclass
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.