[Support] ich777 - Gameserver Dockers


Recommended Posts

3 hours ago, Skylinar said:

I have one question: Is there a way to connect to the Rust Server Console?

From in game you should be able to issue commands to the server if you are registered as admin.

 

Is this something that is really needed?

I think many people install Oxidemod to RUST from what I know and if that's installed you have other ways to connect to the console if I'm not mistaken.

Link to comment
On 7/22/2021 at 9:50 PM, ich777 said:

No it doesn't have to go further.

Fir eup the game, open up the in game console and enter: 'c_connect("IP", 10890, "Password")' (without single quotes eg: 'c_connect("192.168.0.1", 10890, "Docker")'.

 

Are you sure that you have forwarded the ports correctly?

Yeah, triple checked my port forwarding and it also matches the other working ones. canyouseeme.org sees the port as open, as well.

 

When I run the console command to connect with my credentials, it tries connecting for a bit then says server not responding.

Edited by Simmer
Link to comment
6 hours ago, Simmer said:

When I run the console command to connect with my credentials, it tries connecting for a bit then says server not responding.

What command do you exactly run?

I will try to setup a server so that is visible from outside when I got time so you can connect and test, only have tried it like the method mentioned above.

Link to comment

Hi, to give a bit of context I had been running your SCP server container successfully a while back. My gaming group lost interest so I just shut it down. Fast forward, my group interested in the game again so I updated the same container but now it is just stuck on a loop.

Here's my log:
 

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Waiting for user info...OK
---Update Server---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK

Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Success! App '996560' already up to date.
---Installing MultiAdmin---
---MultiAdmin found---
---Installing ServerMod---
---ServerMod found---
---Prepare Server---
---Checking for old logs---
---Server ready---
---Start Server---
---Installing MultiAdmin---
---MultiAdmin found---
---Installing ServerMod---
---ServerMod found---
---Prepare Server---
---Checking for old logs---
---Server ready---
---Start Server---
ls: cannot access '/serverdata/serverfiles/logs/*_MA_log*.txt': No such file or directory
tail: cannot open '' for reading: No such file or directory
tail: no files remaining
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Waiting for user info...OK
---Update Server---
Redirecting stderr to '/serverdata/serverfiles/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK


Looking at the errors I thought permission errors, but I haven't made any manual changes to, and it was running perfectly fine before. ( I even checked the log folder that it can't find and there are logs in there from when it was running fine.)

Link to comment

Actually, relooking at the log folder for the scp server it self I realize it is writing logs correctly. And the server itself is full of errors.
First glance I didn't look closely at the dates and when I rechecked just now I saw more of them lol.

I think I just found my issue... and it'll be because of the server back end updating it seems:
 

ERROR: Shader Sandbox/VolumetricLight shader is not supported on this GPU (none of subshaders/fallbacks are suitable)
ERROR: Shader Hidden/BilateralBlur shader is not supported on this GPU (none of subshaders/fallbacks are suitable)


 

Link to comment
On 7/25/2021 at 7:28 PM, ich777 said:

From in game you should be able to issue commands to the server if you are registered as admin.

 

Is this something that is really needed?

I think many people install Oxidemod to RUST from what I know and if that's installed you have other ways to connect to the console if I'm not mistaken.

 

I checked Oxidemod and you are right, it's not 100% needed if you want to make a server listed in the modded section. But if you want to administrate an "unmodded" server and want to be listed in the official tab this would be a usecase I think. Would it be much effort?

Link to comment
4 minutes ago, maskullking said:

And the server itself is full of errors.

These errors are just normal, a dedicated sever has no volumeteic lighting because it has no display output and you see on a few dedicated server such errors related to the graphics engine because of the above mentioned reason and they can be safely ignored.

 

2 minutes ago, Skylinar said:

Would it be much effort?

Yes and no, actually I try to avoid making the console available through for example a webgui/webterminal because this can lead to other various problems...

 

You should be also able to issue commands from ingame on your server if you are a admin on the server.

Link to comment
4 minutes ago, ich777 said:

These errors are just normal, a dedicated sever has no volumeteic lighting because it has no display output and you see on a few dedicated server such errors related to the graphics engine because of the above mentioned reason and they can be safely ignored.

 

Yeah I realized that after comparing the logs of when it was originally working just now. It still had those same errors.

I can't find anything to specifically call out why it's crashing/looping. There are a lot of errors like:
 


The referenced script (WorkStationUpgrader) on this Behaviour is missing! 
(Filename:  Line: 199)

But these also existed in the copy of the log when it was working last year.
 

Link to comment
37 minutes ago, maskullking said:

I can't find anything to specifically call out why it's crashing/looping. There are a lot of errors like

Have you tried to start from scratch?

 

Is the share that the game is on set to Use Cache "Only" or "Prefer"?

Link to comment
16 hours ago, ich777 said:

What command do you exactly run?

I will try to setup a server so that is visible from outside when I got time so you can connect and test, only have tried it like the method mentioned above.

I run
c_connect("ip", 10890, "pw")

With both ip and pw changed to reflect my actual ip and password, but keeping the quotes.

Link to comment

Was just wondering if there was a way to add your own maps to the atlas Docker? If there Is just need to be pointed in the right direction. Never messed with making a Docker so don't want to mess it up. 

Link to comment
5 hours ago, mithos said:

Was just wondering if there was a way to add your own maps to the atlas Docker? If there Is just need to be pointed in the right direction. Never messed with making a Docker so don't want to mess it up. 

This should be theoreticaly possible, you have to create the map on your PC and then copy it over to the container with all needed files.

  • Like 1
Link to comment

hello, i can see the ARK server on steam and getting  this ? I did forward ports 7777,7778, and tryed 27015,27020

 

Setting breakpad minidump AppID = 346110
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Update SteamCMD---
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
---Update Server---
Redirecting stderr to '/serverdata/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Success! App '376030' already up to date.
---Prepare Server---
---Server ready---
---Start Server---
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 346110

Edited by Crashdogy
Link to comment
2 hours ago, Crashdogy said:

Setting breakpad minidump AppID = 346110

This indocates that the server is running and waiting for connections.

 

2 hours ago, Crashdogy said:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.

This is just a normal message because the game can't detect a running version from Steam because it's a dedicated server, you see this message on a lot of dedicated servers.

Link to comment
2 hours ago, Crashdogy said:

thanks for reply, so its running why cant i  see my ark server online ?

Maybe something is wrong with the port forwarding, have you made sure that you've also enabled to display Community Servers in the in game server browser (haven't played the game in a long time but I remember that here are plenty of options you can choose from what to display)?

 

Can you connect from the Steam Server Browser through your public IP to the container?

 

Maybe @Cyd can help here.

Link to comment
7 hours ago, Crashdogy said:

thanks for reply, so its running why cant i  see my ark server online ?

 

If you can see it in steam then it’s just a mater of finding it in ark,  ich777 is probably right you need to set the correct options in the server selection window. You are looking for “unofficial” servers, then set the toggles for password, mods, ect…

  • Thanks 1
Link to comment

When I install one of your gameservers it works perfectly. But when I go to install another gameserver that uses SteamCMD, I only get the option to "edit" and it thinks I am editing an existing install instead of showing me the new template for the game I am trying to setup. For example, I install CS:GO and that installs as expected. Then I go to install the ChivalryMW server and my only option is "Edit" instead of "install". When I click edit, I have the template for CS:GO show up, not the ChivalryMW. This wasn't my experience before and wondered if you knew of a fix.

Link to comment

What are the chances we can get Enigma-BBS Built with DOSEMU included so we can add door games?

 

I installed the DOSEMU Docker and it works but i can't get it to talk to the Enigma docker container or even know if that's even possible and i have no idea how to manually go inside the docker container to install it. so having it included in the docker container sounds like a good solution.

 

thanks,

-Dev

Link to comment
6 hours ago, Bad5ector said:

Then I go to install the ChivalryMW server and my only option is "Edit" instead of "install".

Go to the CA App, scroll down to the bottom and on the left side click on "Settings" there you should see that the option "Enable Reinstall Default" is set to "No" please change it to "Yes" and click "Apply".

grafik.png.329b87245e683bab1e351ca82ae215a8.png

 

3 hours ago, DevXen said:

What are the chances we can get Enigma-BBS Built with DOSEMU included so we can add door games?

I already had a Enigma-BBS container but had to deprecate it because the developers changed something that completely broke the container.

 

This is still something on my to do list, but please note that I'm currently not having much time and to create such a container could also take some time because I'm not very familiar with the options that are available and out there that are currently working in 2021.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.