[Support] ich777 - Gameserver Dockers


Recommended Posts

1 minute ago, ich777 said:

Please make also sure that the files stay on this Pool and are not moved to the Array in the Share settings because otherwise you will run into problems again.

 

 

understood!

 

I dont really have an array.. I have 1 drive to just make it work and the other 44 are a zfs pool

  • Like 1
Link to comment
On 3/31/2024 at 6:35 PM, RomanRichter said:

Hello!

I got this strange behavior from The Forest server container:

It never authorizes with serverSteamAccount *MyGeneratedToken* in container template (I think it don't pass it, or don't use it), only if token explicitly set in config.cfg.

Any help, please? At least direction where to dig?

 

When I set "GAME_PARAMS serverSteamAccount *MyToken*" it start's server anonymously:

GameServer init success. Port: 27015
Set a LogOnAnonymous
Connected to Steam successfully
The Forest Server is not VAC Secure!
Game server SteamID:901***

 

When I put my token in config.cfg

GameServer init success. Port: 27015
Set a Logon
Connected to Steam successfully
The Forest Server is not VAC Secure!
Game server SteamID:855***

 

Edited by RomanRichter
Link to comment
49 minutes ago, RomanRichter said:

Any help, please?

Sorry, I completely overlooked your post.

 

49 minutes ago, RomanRichter said:

At least direction where to dig?

Can you please post a screenshot from your template (maybe blur the token).

 

May I ask for what Game ID did you create the token?

Link to comment
4 hours ago, ich777 said:

Sorry, I completely overlooked your post.

 

No problems :)

 

4 hours ago, ich777 said:

May I ask for what Game ID did you create the token?

 

242760, also tried 556450 just for testing (also tried change appid in steam_appid.txt).

 

Screenshot 2024-04-02 at 12-58-30 towerofbabel_UpdateContainer.png

Screenshot 2024-04-02 at 12-58-19 towerofbabel_UpdateContainer.png

Link to comment
27 minutes ago, RomanRichter said:

No problems :)

Sorry, I can't help here since the documentation here also says that you can enable VAC with:

enableVAC on

 

I think you have to set those values now in the config.txt (please be sure to do that also in the config file).

 

EDIT: I just tried it on a fresh installation and it is working perfectly fine:

grafik.png.fcf469b3e244da545498bf664aae1552.png

 

Make sure to change these two lines:

grafik.png.d48e47ab0b0f5394221c1fddd1c476ca.png

 

The file is located: .../theforest/config/config.txt <- please make sure to stop the container first and then edit the file.

Link to comment
3 hours ago, ich777 said:

Sorry, I can't help here since the documentation here also says that you can enable VAC with:

enableVAC on

 

I think you have to set those values now in the config.txt (please be sure to do that also in the config file).

 

EDIT: I just tried it on a fresh installation and it is working perfectly fine:

grafik.png.fcf469b3e244da545498bf664aae1552.png

 

Make sure to change these two lines:

grafik.png.d48e47ab0b0f5394221c1fddd1c476ca.png

 

The file is located: .../theforest/config/config.txt <- please make sure to stop the container first and then edit the file.

 

 

Oh, so I supposed to manually set token in config.txt?

I done that already (put token in config.txt), and it works without enabling VAC (I don't need VAC, server for me and my friends).

My problem is that server logons only of I put token in config.txt, but doesn't logon if I put token in GAME_PARAMS, I was expecting that it will work otherwise.

Edited by RomanRichter
Link to comment
1 hour ago, RomanRichter said:

My problem is that server logons only of I put token in config.txt, but doesn't logon if I put token in GAME_PARAMS, I was expecting that it will work otherwise.

Maybe they changed it again, I have already changed the description from the container so that it says to put the server token in the config.txt

 

If you don't need VAC then don't enable it.

  • Like 1
Link to comment

Having issues with the newest update for ARK: Ascended. I removed the default port 7777 and made a new binding with 7779. Opened the port in firewall. But the game still tries to connect to 7777 regardless.

Link to comment
52 minutes ago, Ewok said:

Having issues with the newest update for ARK: Ascended. I removed the default port 7777 and made a new binding with 7779. Opened the port in firewall. But the game still tries to connect to 7777 regardless.

You need to use -port=#### and not ?port=%%%%

Link to comment
5 hours ago, Ewok said:

You need to use -port=#### and not ?port=%%%%

Can you please clarify that a bit more?

According to the documentation (which is not very clear) you have to user ?Port=7779

Link to comment
2 hours ago, ich777 said:

Are you talking about ARK:Survival Evolved or ARK:Survival Ascended?

 

Please note these are two different games and basically using a different Engine.

Oh sorry.. Ascended.. They just released the 2nd map yesterday, so I put that on a different port so I could transfer from TheIsland to ScorchedEarth.. putting ?port=7779 (or -port=7779, in my case) in Game Parameters, wasn't working, but after adding it to Gaameusersettings.ini, I was good..

  • Like 1
Link to comment

Getting this after the most recent Palworld Server update:
 

https://pastebin.com/t0sdLfNp

 

Was available/able to login prior, once I had updated-it had disallowed me to login due to not finding the files. I've searched the file folder and everything seems to be there.

Unsure if I messed something up? I just told it to update by turning the docker off, then turning it back on so the files would pull and update the server. I hope I didn't break it >.<

I appreciate everything for helping me despite my most likely annoying messages. :2

Edited by StabbyMeowkins
Updated Pastebin
  • Upvote 1
Link to comment

Hi, I am trying to setup a Project Zomboid server, and I follow the guide online with the servertest.ini configuration (like wan ip, port forward, etc), but still I cannot connect with server without any mod, it says server unresponsive.

In log everything look good to me but only one error.

LOG  : General     , 1712208699576> 201,211,834> ERROR: Mannequin zone missing properties in media/maps/Muldraugh, KY/objects.lua at 13583,1299,0

Not sure it is the problem or not, please help me out, thanks a lot!

Link to comment

Hello! I've been using your Pal World Docker for a while now, and love it. However, tonight when I restarted it(because of the patch) I got this in the logs: 
 

Connecting anonymously to Steam Public...OK
Waiting for client config...OK
Waiting for user info...OK
Success! App '2394010' already up to date.
---Checking if configuration is in place---
---Configuration found, continuing...---
---Checking if PublicIP is in place---
---Nothing to do, PublicIP: xxx.xxx.xx.xxx still up-to-date!---
---Prepare Server---
---Server ready---
---Starting Backup daemon---
---Start Server---
---Something went wrong, can't find the executable, putting container into sleep mode!---

 

Any helpt o get back up would be appreciated! I did run a force update on the docker, to see if that was the issue, but no such luck. I have rebooted the Unraid PC as well, no joy. I don't know what directory/filename its looking for for the executable to see if its really missing or the update moved it, etc. Thank you! 

Link to comment
28 minutes ago, Waneng said:

Hi, I am trying to setup a Project Zomboid server, and I follow the guide online with the servertest.ini configuration (like wan ip, port forward, etc), but still I cannot connect with server without any mod, it says server unresponsive.

In log everything look good to me but only one error.

LOG  : General     , 1712208699576> 201,211,834> ERROR: Mannequin zone missing properties in media/maps/Muldraugh, KY/objects.lua at 13583,1299,0

Not sure it is the problem or not, please help me out, thanks a lot!

And I just setup the server on my main pc, works perfectly fine, my friends can join the server, I believe that means port forwarding is working.

Link to comment
39 minutes ago, Waneng said:

but still I cannot connect with server without any mod, it says server unresponsive.

Then it's most likely a issue with the port forwarding, please double check the forwarded ports and also if the correct protocol is set.

I would also recommend that you try it with the default settings and see if that is working properly (I would recommend if you try it with the default configuration that you at least change the server name).

 

39 minutes ago, Waneng said:

Not sure it is the problem or not

This is not an issue and nothing to worry about.

Link to comment
45 minutes ago, StabbyMeowkins said:

Getting this after the most recent Palworld Server update

35 minutes ago, zanth said:

However, tonight when I restarted it(because of the patch) I got this in the logs

Thanks for the report.

Please update the container itself and it will work again. :)

  • Thanks 1
Link to comment
3 minutes ago, zanth said:

After updating the container, I am getting the exact same error in my log file. 

How did you update the container? Did you click force update on the container page:

grafik.png.6a00433b660b37685f3e854827dd35da.png

Did it pull a update from DockerHub?

 

Everything is working over here:

grafik.thumb.png.54d67749c6f0acfb95574a08d694f2ed.png

Link to comment
5 minutes ago, ich777 said:

How did you update the container? Did you click force update on the container page:

grafik.png.6a00433b660b37685f3e854827dd35da.png

Did it pull a update from DockerHub?

 

 

   Yes, I clicked that to force it, it seemed to pull an update when I ran it. Just back to the same old error each time.

Link to comment
1 minute ago, zanth said:

Yes, I clicked that to force it, it seemed to pull an update when I ran it. Just back to the same old error each time.

Can you please share a screenshot from your Docker template within Unraid?

Do you use /mnt/user/... or /mnt/cache/... in the template for the game files. If you are using /mnt/cache/... just make sure that the share stays on the cache and is not moved to the Array in the Share settings.

 

Please open a container terminal (while the container is running) and execute:

tail -n 10 /opt/scripts/start-server.sh
ls -la ${SERVER_DIR}/Pal/Binaries/Linux/

and post the output here.

 

Link to comment
2 minutes ago, ich777 said:

Then it's most likely a issue with the port forwarding, please double check the forwarded ports and also if the correct protocol is set.

I would also recommend that you try it with the default settings and see if that is working properly (I would recommend if you try it with the default configuration that you at least change the server name

Thank you for replying so fast, my port forwarding is like this:image.png.e89e76ce23e8860a3934bfdc99bcbb5c.png

Like my later reply said, I use my main PC to open a build-in server in game, and it works perfectly.

And I just tried to remove the whole docker and delete all the appdata files, start with default configuration with only server name change, and the server still doesn't respond.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.