Jump to content
Squid

[Plug-In] Community Applications

2740 posts in this topic Last Reply

Recommended Posts

9 hours ago, Tailchakra said:

Hi,

 

Looks amazing and heard a lot about it! Planning to set up the plugin once I get home. I however do already have dockers installed, will they automatically be taken over or do I have to rebuild my dockers? I'm pretty new in dockers at that..

No changes to installed applications required.

Share this post


Link to post

Just a quick query,

 

When I go in to "Cleanup Appdata" it shows my current Sonarr folder as available to delete. The reason for this is that I changed my docker for Sonarr but the new docker uses the same appdata folder as the old one. Is there a way to stop Cleanup Appdata from thinking that this is an abandoned folder?

Share this post


Link to post
Just a quick query,
 
When I go in to "Cleanup Appdata" it shows my current Sonarr folder as available to delete. The reason for this is that I changed my docker for Sonarr but the new docker uses the same appdata folder as the old one. Is there a way to stop Cleanup Appdata from thinking that this is an abandoned folder?
In CA go to previous apps and delete (hit red x) the other template

Sent from my LG-D852 using Tapatalk

Share this post


Link to post
1 minute ago, Squid said:

In CA go to previous apps and delete (hit red x) the other template

Sent from my LG-D852 using Tapatalk
 

WinRAR! Cheers Squid :)

Share this post


Link to post

Where do I find info on Docker Safe Fix Permissions? 

 

I understand that this is installed as part of CA but it's not listed in the OP post at the top of this thread.

Share this post


Link to post
16 minutes ago, CHBMB said:

Click it.

 

Oh I have. What I want is more information on how these default permissions affect user shares. Like, if I send a file to an SMB share from a logged in user, are these the same permissions that the OS would have set?

 

What are the repercussions of running this tool?

 

Can any user access to files be damages by doing this?

 

You know, a discussion on the tool. Was there never anything like that published when the tool was made? Like there's a page for CA AutoUpdate (

) etc.

 

 

 

Share this post


Link to post

Its part of fix common problems.  And like it says, its identical to New Permissions that comes with unRaid, but won't touch appdata.

Share this post


Link to post

Hi,

 

I do maintant 3 Dockers :

 

  • UniFi
  • UniFi-Video-Controller (NVR)
  • PlexConnect

The issue I have is now, my 2 UniFi dockers are not displayed anymore, only the PlexConnect is returned if searching "pducharme".

 

I wonder why ? and how to get it back on the results? (probably me that didn't do a thing that prevent it from being removed... )

 

@Squid If you can give me instructions :)

 

Share this post


Link to post
4 hours ago, Pducharme said:

Hi,

 

I do maintant 3 Dockers :

 

  • UniFi
  • UniFi-Video-Controller (NVR)
  • PlexConnect

The issue I have is now, my 2 UniFi dockers are not displayed anymore, only the PlexConnect is returned if searching "pducharme".

 

I wonder why ? and how to get it back on the results? (probably me that didn't do a thing that prevent it from being removed... )

 

@Squid If you can give me instructions :)

 

If you got to statistics within CA and look at template errors you'll see why CA is automatically dropping them.

Share this post


Link to post
4 minutes ago, Pducharme said:

@Squid Thanks, I added the missing Description.  I suppose it will reappear at the next appFeed refresh (?).

 

Correct.  Within 2 hours

Share this post


Link to post

My Apps screen fails to load and I see only script. The beginning of the error reads Download of appfeed failed.

And then....

Community Applications requires your server to have internet access. The most common cause of this failure is a failure to resolve DNS addresses. You can try and reset your modem and router to fix this issue, or set static DNS addresses (Settings - Network Settings) of 8.8.8.8 and 8.8.4.4 and try again.
 

Share this post


Link to post
1 hour ago, Bugman1400 said:

My Apps screen fails to load and I see only script. The beginning of the error reads Download of appfeed failed.

And then....

Community Applications requires your server to have internet access. The most common cause of this failure is a failure to resolve DNS addresses. You can try and reset your modem and router to fix this issue, or set static DNS addresses (Settings - Network Settings) of 8.8.8.8 and 8.8.4.4 and try again.
 

 

I'm also seeing the same.... I even changed my DNS settings to googles like it suggested and still no dice.... Restarted modem and router... and that didn't work either...

 

I tried legacy mode and that doesn't work either.... I did receive json payload for a few apps... but it just spit it out like a string

{
"apps": 475,
"requests": 726,
"last_updated": "28th August 2017 at 14:00:00",
"last_updated_timestamp": "1503925200",
"applist": [
{
"TemplateURL": "https://raw.githubusercontent.com/linuxserver/docker-templates/master/linuxserver.io/htpcmanager.xml",
"Beta": "False",
"Category": "MediaApp:Video MediaApp:Music MediaApp:Other",
"Date": "2016-08-08",
"Name": "htpcmanager",
"Changes": "[center][img width='300px' src='https://raw.githubusercontent.com/linuxserver/docker-templates/master/linuxserver.io/img/linuxserver_small.png'][/center]\n\n[center][font size=4]Htpcmanager Change Log[/font][/center]\n[font size=4]2016-08-08[/font]\nRebase to alpine linux\n[font size=4]2016-01-14[/font]\nRemove loglevel from run command, user can set in webui\n[font size=4]2015-11-12[/font]\n- Change log level to info\n[font size=4]2015-10-07[/font]\n- Add psutil pip package\n",
"Support": "http://lime-technology.com/forum/index.php?topic=43318.0",
"Description": "Htpcmanager, a front end for many htpc related applications. Hellowlol version.\n [br][br]\n [b][u][span style='color: #

 

i reinstalled the plugin and tried to pull a few times and it eventually worked? not sure if source for repo lists were down or not

Edited by tyty123

Share this post


Link to post
9 hours ago, Bugman1400 said:

My Apps screen fails to load and I see only script.

Can you elaborate and post a screen shot?  Not sure what you mean exactly by see only script.

 

9 hours ago, tyty123 said:

I tried legacy mode and that doesn't work either....

This implies that both the application feed and GitHub were both down at the same time.  The two different methods (appfeed and legacy) hit completely different sources.  Probably the problem lied somewhere from your ISP.

 

 

I tried this morning and everything is all hunky-dory...

 

Edited by Squid

Share this post


Link to post

Oddly enough, things seem to be okay now....without having to do a thing. Perhaps it was an ISP issue or the app feed and Github server or the access to them were down. I'm not sure where tyty123 is located but, I am located in NC and use Spectrum. All other Internet access seemed to be unaffected at the time. Oh well.

Share this post


Link to post

deep-thoughts-1.jpg.ee8dd8539c7dc3e92a8659f4150244a1.jpg

 

  • Limit display to 6.4RC8Q's limit of 1920 pixels (previously CA and unRaid supported any arbitrary maximum window width)
  • Only display Legacy mode option in case of an appfeed download error
  • Under certain circumstances, random app of the day could actually be blacklisted or incompatible
  • Minor CSS changes.

If any author / maintainer wishes to use Legacy Mode at will (to see how their template will display within CA rather than waiting for the next appfeed update), the button can be displayed by going to CA's general settings and turning on developer mode.

Edited by Squid

Share this post


Link to post

If I come accross dockers that I think should be part of the "app store" that is not in it yet, where should I post that?

Share this post


Link to post
3 minutes ago, isvein said:

If I come accross dockers that I think should be part of the "app store" that is not in it yet, where should I post that?

But I'm tougher on "requirements" for newbie maintainers, especially if they're not doing the maintenance on the docker files themselves

Edited by Squid

Share this post


Link to post

Funny-bulletproof-vest.jpg

 

Mainly an update to bullet proof CA (at least the important parts  9_9)

 

  • Fixed: If multiple browser tabs opened to apps tab, detect if app database is out of sync between windows and update tab accordingly.
  • Fixed: Prevent possibility of duplicate app appearing in app of the day.
  • Enhanced: Previously, app of the day would return errors if unRaid CSS and window width support horizontal resolution greater than 5700 pixels.
  • Changed: Clicking Repository from popup will now search for applications contained within the repository
  • Added: App info popup now has link to go directly to docker hub page for application
  • Changed: Allow moderation to whitelist an application without appfeed update
Edited by Squid

Share this post


Link to post

Hi,

I created a new docker container on my template repository. Everythink is working fine. The only think is that "Community application" can not find the version. I think the problem is that I am using not the latest tag.

 

<Repository>coderaiser/cloudcmd:latest-alpine</Repository>

 

Support-Thread: Link

Template on GitHub: Link

 

image.png.8ef21914a6632f559378870532361a68.png

 

Regards Thomas

Share this post


Link to post
Hi,
I created a new docker container on my template repository. Everythink is working fine. The only think is that "Community application" can not find the version. I think the problem is that I am using not the latest tag.
 
<Repository>coderaiser/cloudcmd:latest-alpine</Repository>

 
Support-Thread: Link
Template on GitHub: Link
 
image.png.8ef21914a6632f559378870532361a68.png
 
Regards Thomas

CA is passing the template fine as you'll see on the template screen. What you're seeing is unraid 6.3 not properly handling any tag other than latest when checking for updates. That's fixed in 6.4

Sent from my SM-T560NU using Tapatalk

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.