Jump to content

[Plug-In] SNMP

157 posts in this topic Last Reply

Recommended Posts

1 hour ago, pluginCop said:


Ha! Sorry. I run unRAID within a VM under ESXi. Thus, I only use it for its NAS functionality with only a couple plugins: Nerd Tools, Open Files, SNMP, and a couple Dynamix ones. No need for CA with a setup as simple as this! Not to mention this is all on a 1GB USB key with very little free space :) 

Share this post

Link to post
Posted (edited)

I've installed the new version of the plugin by @kubed_zero on three servers and it's working fine on two of them, with Observium generating graphs. On the third I'm getting this error message repeatedly (every three seconds) in my syslog starting immediately after installing the plugin and Observium believes the server to be offline:

May 31 18:16:30 Mandaue root: plugin: creating: /usr/local/emhttp/plugins/snmp/snmpd.conf - from INLINE content
May 31 18:16:30 Mandaue root: plugin: running: anonymous
May 31 18:16:30 Mandaue kernel: r8169 0000:05:00.0 eth2: Invalid ocp reg 2a3fe!
May 31 18:16:30 Mandaue root: plugin: running: anonymous
May 31 18:16:33 Mandaue kernel: r8169 0000:05:00.0 eth2: Invalid ocp reg 2a3fe!

If I uninstall the plugin the error message continues until I reboot. If I don't install the plugin my syslog is clean. I Googled the error message but got nothing relevant - Google seems fixated by military uniforms, latching on to "ocp" and failing to find a match for everything else. The two major differences between this server and the other two: firstly, it's running Unraid 6.7.1-rc1 (as opposed to 6.7.0 on the others) as a test; secondly, eth2 is the onboard Realtek NIC, which is unconfigured and unused, though not disabled in the BIOS, with eth0 and eth1 forming a bond, while the other servers have no unused NICs. One of them has a single Realtek NIC, which is configured as eth0 and is in use. The other has two Broadcom NICs in a bond. Diagnostics attached.




EDIT: I was only running Unraid 6.7.1-rc1 as a test. The server doesn't have an Intel processor and doesn't need the MDS mitigations but in the light of this comment by Tom,

I thought it would be useful to test it. Anyway, I reverted to Unraid 6.7.0 on this server and the problem persists if I install the SNMP plugin. Attached diagnostics for Unraid 6.7.0.




Edited by John_M
Reverted to 6.7.0 and error persists; typos

Share this post

Link to post
5 minutes ago, John_M said:

The two major differences between this server and the other two: firstly, it's running Unraid 6.7.1-rc1 (as opposed to 6.7.0 on the others) as a test; secondly, eth2 is the onboard Realtek NIC


Wild. A quick Google for "realtek invalid ocp" gave me https://lists.openwall.net/netdev/2012/07/09/143 which makes me think it's something to do with the Realtek software stack, although I can't pinpoint exactly what's up. I wonder if it's the SNMP Slackware package trying to query/bind the different network interfaces in the system, and since the Realtek interface isn't disabled in the BIOS it finds that as well. This is just speculation though.


I'd suggest BIOS-disabling the unused Realtek NIC that's causing you issues, but would be interested in hearing anything else you find. Assuming the motherboards or network cards are different, maybe the working Realtek NIC is a different model than the one that's causing issues. Maybe the single Realtek NIC doesn't have problems because it's actively bound to an IP and is in use.



Share this post

Link to post

I tried giving the unused port a static IP address but that didn't change anything. I want to try adding the port to the existing bond but today is scheduled parity check day so I'll leave it alone for now. I'll probably end up disabling the port in the BIOS.

Share this post

Link to post
Posted (edited)
On 5/31/2019 at 5:21 PM, kubed_zero said:

Just created a new repo for this: https://github.com/kubedzero/unraid-community-apps-xml I don't use CA myself but I can spin up a test instance of unRAID later to confirm this works. That is assuming there's a way to reference this new XML file manually. 

Thanks for the updated plugin, test via CA on my test server Will update live server soon.

Edited by SimonF

Share this post

Link to post

Thank you for working to get this Plugin compatible with 6.7, but I can't get anything for the individual shares to work as I've seen in the thread:


root@Gothmog:~# snmpwalk -v 2c -c public localhost NET-SNMP-EXTEND-MIB::nsExtendOutLine
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".1 = STRING: WDC_WD100EMAZ-00WJTA0_2YJ0ZH9D: 31
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".2 = STRING: WDC_WD100EMAZ-00WJTA0_JEGKPT5N: 30
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".3 = STRING: WDC_WD100EFAX-68LHPN0_JEHM4AMN: 29
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".4 = STRING: WDC_WD100EFAX-68LHPN0_JEHM0D0N: 28
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".5 = STRING: WDC_WD80EMAZ-00WJTA0_7SJEAMEW: 32
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".6 = STRING: WDC_WD80EMAZ-00WJTA0_7SJHUD2W: 31
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".7 = STRING: WDC_WD40EFRX-68N32N0_WD-WCC7K3NHHZVR: 26
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".8 = STRING: WDC_WD40EFRX-68N32N0_WD-WCC7K2EC6CNJ: 25
NET-SNMP-EXTEND-MIB::nsExtendOutLine."disktemp".9 = STRING: WDC_WD100EMAZ-00WJTA0_2YHVUKVD: 31
NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".1 = STRING: Plex_Media_Backup: 23271758839808
NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".2 = STRING: appdata: 1012790734848
NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".3 = STRING: domains: 1012790734848
NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".4 = STRING: isos: 22258968104960
NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".5 = STRING: system: 1012790734848

root@Gothmog:~# snmpwalk -v 2c -c public localhost NET-SNMP-EXTEND-MIB::nsExtendOutLine."sharefree".1
NET-SNMP-EXTEND-MIB::nsExtendOutLine.sharefree.1: Unknown Object Identifier (Index out of range: sharefree (nsExtendToken))



Cannot get it to work remotely at all either:

root@nagios:/# /opt/nagios/libexec/check_snmp -H -C public -m NET-SNMP-EXTEND-MIB::nsExtendOutLine -o sharefree
External command error: MIB search path: /root/.snmp/mibs:/usr/share/snmp/mibs:/usr/share/snmp/mibs/iana:/usr/share/snmp/mibs/ietf:/usr/share/mibs/site:/usr/share/snmp/mibs:/usr/share/mibs/iana:/usr/share/mibs/ietf:/usr/share/mibs/netsnmp
Cannot find module (nsExtendOutLine): At line 0 in (none)
sharefree: Unknown Object Identifier (Sub-id not found: (top) -> sharefree)


Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.