[Support] Linuxserver.io - Rutorrent


669 posts in this topic Last Reply

Recommended Posts

Hello, so I've been trying to get the RSS Feed working, but I can't seem to figure out the regex filter no matter what I do.
A torrent I want is:

Kaguya-sama: Love is War? - TV Series [2020] :: Web | MKV | h264 | 720p | AAC 2.0 | Softsubs (HorribleSubs) | Episode 2 | Freeleech

and the filter I'm trying to use is:

/^Kaguya-sama:.Love.is.War?.720p.HorribleSubs.Episode/i

If anyone could please tell me what I'm doing wrong or missing, that would be appreciated. Thank You

Link to post
  • Replies 668
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: Rutorrent Application Site: https://github.com/Novik/ruTorrent/ Docker Hub: https://hub.docker.com/r/linuxserver/rutorrent/ Github: https://github.com/linuxserver/dock

Just added note to the first post on how to resolve this.  

Done got it working. How I did it. 1.)  SSH into your machine   2.)  Enter the following command replacing your file structure.  Note I could not get it to work if I changed the 443 port. docke

Posted Images

26 minutes ago, MyNameHand said:

Yes, I've tried a couple testers, but being completely new to regex, I have absolutely no idea what it is it wants me to fix.

Why not just use Sonarr instead of messing about with regex filters?

Link to post

Ah, that's because sonarr doesn't allow different save paths per show, it will download every show to the same path. Since I only use rss feed for airing shows, they get uploaded in single .mkv files per torrent. So I set the save path for each rss filter to a different folder per show, like so:

/downloads/Anime/Kaguya-sama Love is War/Season 2/

or 

/downloads/Anime/Plunderer/Season 1/

EDIT: I don't want to have duplicate copies of my files and I could never figure out how to get hardlinks to work, so I've given up on sonarr for my airing shows.

Edited by MyNameHand
Link to post
2 minutes ago, Spies said:

That's not true, Sonarr has various options to use season folders mine puts them in /media/show/season

 

/media is the only constant.

yes, that's true, but I'd be limited to /downloads/Anime (in my case), but I also want to use /downloads/TV Shows

Link to post
5 minutes ago, MyNameHand said:

yes, that's true, but I'd be limited to /downloads/Anime (in my case), but I also want to use /downloads/TV Shows

You can have multiple mapping on the container and just set the Anime shows to use that.

 

Sonarr will do what you want, you just need to look into it.

 

For example I have Radarr add kids movies to media/kids and regular movies to media/movies

 

Sonarr is the same.

Edited by Spies
Link to post

I have a habit of deleting just the downloaded files after I have reviewed them, and leaving the torrent file to the torrent software. uTorrent (Windows) marked the files with error permanently. ruTorrent seems to mark them too, but if ruTorrent is restarted, it forgets the error state. It then looks like the torrent has never been downloaded. This leads to unnecessary redownloads.

 

Is there a workaround? 

Link to post

Also, it seems like the autotools tool fails to hardlink. I have this setup

 

/share1/movies/movie1.ext

 

 want to hard link them to the following when files are done downloading. 

 

/share1/links/movie1/movie1.ext

 

But autotools copies the file instead. 

Edited by kakmoster
Link to post

Having a few issues.

 

1. Every time the docker container restarts, it resets the default directory back to /downloads/incoming which is not a valid path and hence no torrents start

 

image.png.50f45f8b7c1197e3897fc9cbe4ae0472.png

 

2. Autotools move isn't working.

 

3. I can't find  rtorrent.rc or autotools/conf.php anywhere!

Link to post

Would it be possible to implement the fix depicted here:
https://github.com/rakshasa/rtorrent/issues/861

Currently, the bug presented in that thread is present in this container. I've been having to screen -r my docker and manually stop and start torrents because I still cannot seem to stop getting the errors in regard to the getplugins.php (my previously implemented resolution stopped working, after a couple of months and incidental docker updates... This seems to be a constant struggle with rtorrent on unraid. Regardless of the number of active torrents.)

EDIT:

I'm at a loss. I'm back to square one basically. I'm going to backup my rutorrent config folder; and try starting over but I'm back to the abysmal 20-30kb/s and unresponsive (or not even loading) webui. Nothing in the logs seems of relevance. I've read through logs and even enabled advanced logging. There's no "errors" so to speak, just the rtorrent application sitting at 99.99% IOWAIT. I'm wondering if it doesn't like the merged filesystem that unraid uses? I'm downloading to an NVME SSD and the only application with this issue is rtorrent. I'll post back with what I figure out.

Edited by Xaero
Link to post
  • 2 weeks later...
On 4/29/2020 at 9:06 PM, cinereus said:

Having a few issues.

 

1. Every time the docker container restarts, it resets the default directory back to /downloads/incoming which is not a valid path and hence no torrents start

*snip*

3. I can't find  rtorrent.rc or autotools/conf.php anywhere!

In case you didn't already find it yourself, rtorrent.rc is located in "/mnt/user/appdata/rutorrent/rtorrent" and in it you can change the default directory, global download/upload rates and other things that will reset if changed through webui.

Edited by Nizkus
Link to post
26 minutes ago, Nizkus said:

In case you didn't already find it yourself, rtorrent.rc is located in "/mnt/user/appdata/rutorrent/rtorrent" and in it you can change the default directory, global download/upload rates and other things that will reset if changed through webui.

Thanks I found it. What was hard is all the plugins are in a completely different directory root.

 

Even if you get past that, I'm having a lot of issues with watch folders not working correctly and inability to change the listen port.

 

It's also really hard to map folders from two different shares as I keep getting very inconsistent results.

Link to post

Hey everyone, anyone have advice on config for an instance with a large amount of torrents (>4k)?

 

My current issue is that the download speed caps out at ~15-30 mbps (I have gigabit) and it was using the full gigabit when I had ~200 torrents.

Additionally, the hash recheck is very slow, some few times slower than when I had ~200 torrents.

CPU and RAM aren't getting maxed out so that's not it, not sure if there's a particular config setting I should change to fix it.

Link to post
19 minutes ago, oldsweatyman said:

Hey everyone, anyone have advice on config for an instance with a large amount of torrents (>4k)?

 

My current issue is that the download speed caps out at ~15-30 mbps (I have gigabit) and it was using the full gigabit when I had ~200 torrents.

Additionally, the hash recheck is very slow, some few times slower than when I had ~200 torrents.

CPU and RAM aren't getting maxed out so that's not it, not sure if there's a particular config setting I should change to fix it.

I've asked this many places and not received any good answers to be honest. I ruled out transmission because it doesn't seem to have any features. Haven't gone too far into deluge. Rtorrent seems to be okay if you run multiple instances with 5k max per instance. 

 

The issue is running as a docker it seems impossible to get auto watch to work and automove is very flaky. Nobody seems to know how to mount multiple shares either. 

Link to post
4 minutes ago, oldsweatyman said:

The .torrent files? My appdata is on cache. The downloading/seeding files are on the array.

there is most likely your issue, the array isn't meant for lots of i/o which torrents cause, I use an unassigned drive for my downloading/seeding.

Edited by Spies
Link to post
2 hours ago, cinereus said:

I've asked this many places and not received any good answers to be honest. I ruled out transmission because it doesn't seem to have any features. Haven't gone too far into deluge. Rtorrent seems to be okay if you run multiple instances with 5k max per instance. 

 

The issue is running as a docker it seems impossible to get auto watch to work and automove is very flaky. Nobody seems to know how to mount multiple shares either. 

 

Same with transmission. Deluge poops itself with far less than rtorrent. It's good for small numbers.

 

2 hours ago, Spies said:

there is most likely your issue, the array isn't meant for lots of i/o which torrents cause, I use an unassigned drive for my downloading/seeding.

 

I was wondering if in the rtorrent config there was maybe a setting that would work around this, say, the network.max_open_files.setmax_open_files setting. I've tried toying around with this and haven't had much success.

EDIT: It seems it resolved after some time after I set "Maximum number of open files" under Connection in the settings to 1024. My download speeds are much better, just hit ~50 mbps, the rest probably being taken up by some background processes I have running. After changing it many torrents paused, but I just hit resume on all of them and they are now all seeding. I'll have to monitor to see if my upload speeds are affected/see if they're actually seeding..

Edited by oldsweatyman
Link to post
  • 3 months later...

Hi, I'm new to Unraid and having trouble setting some default parameters in ruTorrent. I want to change the default port and global throttle rates, but I noticed any settings that I manually change or set in the GUI are all lost whenever the docker is restarted.

 

Is this Normal? Is there a way I can make GUI changes permanent?

 

I tried added the following lines to the rtorrent.rc file, but the Global throttle still defaults to 327625 for both upload and download after a restart.

Quote

 

throttle.global_down.max_rate.set_kb= 6144

throttle.global_up.max_rate.set_kb = 4480

 

 

I also want to change the default Host Port from 51413 to 62499. I have forwarded port 62499 on my router to the internal Unraid IP but the port is listed as closed in ruTorrent. Is there any other settings I am missing?

 

Thanks

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.