Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2924 posts in this topic Last Reply

Recommended Posts

From what I can tell it's the same, just missing the two options I added and then deleted.  Is there any harm in posting the whole thing?

 

I do the Spaceinvader Appdata backup of the folder and flashdrive, would last night's file be in there to grab or compare?

 

I appreciate the help.

Share this post


Link to post
1 minute ago, ur6969 said:

From what I can tell it's the same, just missing the two options I added and then deleted.  Is there any harm in posting the whole thing?

 

I do the Spaceinvader Appdata backup of the folder and flashdrive, would last night's file be in there to grab or compare?

 

I appreciate the help.

I would say it should be in there, I would definitely grab it and compare.... I don't think there is any harm top posting the the whole thing, I don't think secret keys or other info like that is in it.. have a look first to make sure.

Share this post


Link to post
9 minutes ago, ur6969 said:

From what I can tell it's the same, just missing the two options I added and then deleted.  Is there any harm in posting the whole thing?

 

I do the Spaceinvader Appdata backup of the folder and flashdrive, would last night's file be in there to grab or compare?

 

I appreciate the help.

 

Here is my full config:

upstream php-handler {
    server 127.0.0.1:9000;
}
server {
    listen 80;
    listen [::]:80;
    server_name _;
    return 301 https://$server_name$request_uri;
}
server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name _;
    ssl_certificate /config/keys/cert.crt;
    ssl_certificate_key /config/keys/cert.key;
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    add_header Referrer-Policy no-referrer;
    add_header X-Frame-Options "SAMEORIGIN";
    fastcgi_hide_header X-Powered-By;
    root /config/www/nextcloud/;
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }
    location = /.well-known/carddav {
      return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
      return 301 $scheme://$host/remote.php/dav;
    }
    client_max_body_size 10G;
    fastcgi_buffers 64 4K;
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf>
    location / {
        rewrite ^ /index.php$request_uri;
    }
    location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
        deny all;
    }
    location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
        deny all;
    }
    location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|ocs-provider\/.+|ocm-provider\/.+)\.php(?:$|\/) {
        fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
        include /etc/nginx/fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param HTTPS on;
        fastcgi_param modHeadersAvailable true;
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }
    location ~ ^\/(?:updater|ocs-provider|ocm-provider)(?:$|\/) {
        try_files $uri/ =404;
        index index.php;
    }
    location ~ \.(?:css|js|woff2?|svg|gif)$ {
        try_files $uri /index.php$request_uri;
        add_header Cache-Control "public, max-age=15778463";
        add_header X-Content-Type-Options nosniff;
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Permitted-Cross-Domain-Policies none;
        add_header Referrer-Policy no-referrer;
        access_log off;
    }
    location ~ \.(?:png|html|ttf|ico|jpg|jpeg)$ {
        try_files $uri /index.php$request_uri;
        access_log off;
    }
}

 

 

Share this post


Link to post
54 minutes ago, Smooth Beaver said:

 

Here is my full config:


upstream php-handler {
    server 127.0.0.1:9000;
}
server {
    listen 80;
    listen [::]:80;
    server_name _;
    return 301 https://$server_name$request_uri;
}
server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name _;
    ssl_certificate /config/keys/cert.crt;
    ssl_certificate_key /config/keys/cert.key;
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    add_header Referrer-Policy no-referrer;
    add_header X-Frame-Options "SAMEORIGIN";
    fastcgi_hide_header X-Powered-By;
    root /config/www/nextcloud/;
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }
    location = /.well-known/carddav {
      return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
      return 301 $scheme://$host/remote.php/dav;
    }
    client_max_body_size 10G;
    fastcgi_buffers 64 4K;
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf>
    location / {
        rewrite ^ /index.php$request_uri;
    }
    location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
        deny all;
    }
    location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
        deny all;
    }
    location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|ocs-provider\/.+|ocm-provider\/.+)\.php(?:$|\/) {
        fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
        include /etc/nginx/fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param HTTPS on;
        fastcgi_param modHeadersAvailable true;
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }
    location ~ ^\/(?:updater|ocs-provider|ocm-provider)(?:$|\/) {
        try_files $uri/ =404;
        index index.php;
    }
    location ~ \.(?:css|js|woff2?|svg|gif)$ {
        try_files $uri /index.php$request_uri;
        add_header Cache-Control "public, max-age=15778463";
        add_header X-Content-Type-Options nosniff;
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Permitted-Cross-Domain-Policies none;
        add_header Referrer-Policy no-referrer;
        access_log off;
    }
    location ~ \.(?:png|html|ttf|ico|jpg|jpeg)$ {
        try_files $uri /index.php$request_uri;
        access_log off;
    }
}

I give up.  I tried to compare both mine and yours in Word and it doesn't like the positions of some of the { } but they look the same to me so I think it may be formatting from the copy/paste.  Yours has the two "add_header" options added that I did not have, added, and then removed trying to get it to work. 

The only other difference is you have

vnd.ms-fontobject application/x-font-ttf>

at the end of your gzip_types.

 

Below is mine.  Any help is appreciated.  I have a lot in Nextcloud I can reproduce but the hassle will be enormous.

 

upstream php-handler {
    server 127.0.0.1:9000;
}
server {
    listen 80;
    listen [::]:80;
    server_name _;
    return 301 https://$server_name$request_uri;
}
server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name _;
    ssl_certificate /config/keys/cert.crt;
    ssl_certificate_key /config/keys/cert.key;
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    add_header Referrer-Policy no-referrer;
    fastcgi_hide_header X-Powered-By;
    root /config/www/nextcloud/;
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }
    location = /.well-known/carddav {
      return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
      return 301 $scheme://$host/remote.php/dav;
    }
    client_max_body_size 10G;
    fastcgi_buffers 64 4K;
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application>
    location / {
        rewrite ^ /index.php$request_uri;
    }
    location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
        deny all;
    }
    location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
        deny all;
    }
    location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|ocs-provider\/.+|ocm-provider\/.+)\.php(?:$|\/) {
        fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
        include /etc/nginx/fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param HTTPS on;
        fastcgi_param modHeadersAvailable true;
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }
    location ~ ^\/(?:updater|ocs-provider|ocm-provider)(?:$|\/) {
        try_files $uri/ =404;
        index index.php;
    }
    location ~ \.(?:css|js|woff2?|svg|gif)$ {
        try_files $uri /index.php$request_uri;
        add_header Cache-Control "public, max-age=15778463";
        add_header X-Content-Type-Options nosniff;
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Permitted-Cross-Domain-Policies none;
        add_header Referrer-Policy no-referrer;
        access_log off;
    }
    location ~ \.(?:png|html|ttf|ico|jpg|jpeg)$ {
        try_files $uri /index.php$request_uri;
        access_log off;
    }
}

 

 

 

Edited by ur6969

Share this post


Link to post

If that is the only thing different I think the issue is elsewhere the two lines that you added did two things;

 

The STS line forces the browser to interact with the site via HTTPS.

Where you using HTTPS or just HTTP?? If you where using HTTPS was your certificate valid or a self signed cert?

 

And the X Frame option simply means a page can only be embedded in a frame on a page with the same origin as itself. 

 

So what are the errors you are getting again are they the same across browsers?

I am still thinking this maybe the issue:

 

How to Delete HSTS Settings in Chrome:

Navigate to chrome://net-internals/#hsts This is Chrome’s UI for managing your browser’s local HSTS settings. First, to confirm the domain’s HSTS settings are recorded by Chrome, type the hostname into the Query Domain section at the bottom of the page. Click Query. If the Query box returns Found with settings information below, the domain’s HSTS settings are saved in your browser. Note that this is a very sensitive search. Only enter the hostname, such as www.example.com or example.com without a protocol or path. Type the same hostname into the Delete domain section and click Your browser will no longer force an HTTPS connection for that site! You can test if its working properly by refreshing or navigating to the page. Note that depending on the HSTS settings provided by the site, you may need to specify the proper subdomain. For example, the HSTS settings for staging.yoursite.com may be separate from yoursite.com so you may need to repeat the steps as appropriate.

 

How to Delete HSTS Settings in Firefox: Close all open tabs in Firefox. Open the full History window with the keyboard shortcut Ctrl + Shift + H (Cmd + Shift + H on Mac). You must use this window or the sidebar for the below options to be available. Find the site you want to delete the HSTS settings for – you can search for the site at the upper right if needed. Right-click the site from the list of items and click Forget About This Site.This should clear the HSTS settings (and other cache data) for that domain. Restart Firefox and visit the site. You should now be able to visit the site over HTTP/broken HTTPS.

Read more at: https://www.thesslstore.com/blog/clear-hsts-settings-chrome-firefox/

Share this post


Link to post

I found the Default file in the AppData backup and was able to unzip it and open it up in Notepad then copy it over into Unraid.  It should be exactly the same as it was yesterday.

 

Browser cleared.  Everywhere.

Restarted Unraid server.

Restarted computer I am using.

 

Unable to connect error.  Cannot log in.  So damn frustrating.

 

So now how screwed am I getting my data?  Most of my folders sync but a few don't...

 

 

Share this post


Link to post
2 minutes ago, ur6969 said:

I found the Default file in the AppData backup and was able to unzip it and open it up in Notepad then copy it over into Unraid.  It should be exactly the same as it was yesterday.

 

Browser cleared.  Everywhere.

Restarted Unraid server.

Restarted computer I am using.

 

Unable to connect error.  Cannot log in.  So damn frustrating.

 

So now how screwed am I getting my data?  Most of my folders sync but a few don't...

 

 

One way to do this would be to mount your Nextcloud share via SMB, once its mounted you should be able to see all of your data and copy what you need...

 

When you reinstall Nextcloud I would highly recommend following @SpaceInvaderOne YouTube videos including the one on how to set it up using a reverse proxy using letsencrypt.

Edited by Smooth Beaver

Share this post


Link to post

Is there a way to replace the actual "default" file from the backup onto the flash drive?  To eliminate any copy/paste errors?

 

What is my NextCloud is encrypted?

 

Edit:  I followed the SpaceInvaderOne video on the initial install.  I have no need for syncing outside on the web and use it to locally sync phones and computers.

Edited by ur6969

Share this post


Link to post
Just now, ur6969 said:

Is there a way to replace the actual "default" file from the backup onto the flash drive?  To eliminate any copy/paste errors?

 

What is my NextCloud is encrypted?

You can try mounting your flash drive via SMB and overwriting the "default" file that route.

 

Nextcloud data will not be encrypted unless you specifically told it to in the settings of Nextcloud:

 

 

 

Screen Shot 2019-10-23 at 10.34.05 PM.png

Share this post


Link to post
1 minute ago, ur6969 said:

It's encrypted.

Ummm I am going to venture out and say the data not on your PC is lost... sit tight if you can, someone else might be able to help you more than I can....

 

Will the sync app not connect either? I guess not it uses WebDAV which is probably though Nginx....

Have you tried copying the nextcloud app data folder over from the backup?

Share this post


Link to post
34 minutes ago, Smooth Beaver said:

Ummm I am going to venture out and say the data not on your PC is lost... sit tight if you can, someone else might be able to help you more than I can....

 

Will the sync app not connect either? I guess not it uses WebDAV which is probably though Nginx....

Have you tried copying the nextcloud app data folder over from the backup?

I made a backup of all the synced folders on my PC before I tried to replace the "default" file in appdata.

 

When I got to appdata there were 4 "default" files...for some reason it wasn't saving correctly.  I deleted them and replaced with the backup file.

 

It works.  What a stressful night but SpaceInvaderOne deserves a beer or two for showing me how to set up an appdata backup that just saved me.

Share this post


Link to post
2 hours ago, d8sychain said:

Sharing with the community in case someone hasn't seen this yet. https://nextcloud.com/blog/urgent-security-issue-in-nginx-php-fpm/

Came here for this.. Running nginx proxy manager to serve nextcloud.. do I need to take any action other than update when available? I'd rather not mess around with the core config files.

I guess I can always take it offline until a fix is available.

Share this post


Link to post

Ok so I am using LetsEncrypt for a reverse proxy and got nextcloud up and running except I get 2 erros, I have searched and read way to much on the issue of "X-Frame-Options", and its oll old outdated info more than a year old, and the recommendations i found are not in the files to comment out.

 

So i someone can help point me in the right direction for these 2 issues.

The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.
The "X-Frame-Options" HTTP header is not set to "SAMEORIGIN". This is a potential security or privacy risk, as it is recommended to adjust this setting accordingly.

 

Also noticed this issue that I cant figure out: (set to Cron)

Background jobs  Last job execution ran 10 minutes ago. Something seems wrong

 

Edited by almulder

Share this post


Link to post
19 minutes ago, almulder said:

Ok so I am using LetsEncrypt for a reverse proxy and got nextcloud up and running except I get 2 erros, I have searched and read way to much on the issue of "X-Frame-Options", and its oll old outdated info more than a year old, and the recommendations i found are not in the files to comment out.

 

So i someone can help point me in the right direction for these 2 issues.


The reverse proxy header configuration is incorrect, or you are accessing Nextcloud from a trusted proxy. If not, this is a security issue and can allow an attacker to spoof their IP address as visible to the Nextcloud. Further information can be found in the documentation.
The "X-Frame-Options" HTTP header is not set to "SAMEORIGIN". This is a potential security or privacy risk, as it is recommended to adjust this setting accordingly.

 

Also noticed this issue that I cant figure out: (set to Cron)


Background jobs  Last job execution ran 10 minutes ago. Something seems wrong

 

The cron error will likely resolve itself.

 

The X-Frame error can be resolved by editing the Nextcloud NGINX default config.  There is a guide on the previous page of this thread showing what you need to add.

 

I had the trusted proxy error as well, I had to add letsencrypt to the Nextcloud config.php file.  

 

'trusted_proxies' =>
array (
0 => 'letsencrypt',
),

 

Also on page 86 of this thread.  Search is your friend.  

Share this post


Link to post
The cron error will likely resolve itself.
 
The X-Frame error can be resolved by editing the Nextcloud NGINX default config.  There is a guide on the previous page of this thread showing what you need to add.
 
I had the trusted proxy error as well, I had to add letsencrypt to the Nextcloud config.php file.  
 
'trusted_proxies' =>
array (
0 => 'letsencrypt',
),
 
Also on page 86 of this thread.  Search is your friend.  


I’ve tried it before with “letsencrypt” as you show before and still had that error. I’m currently just living with it out of fear for yesterday’s debacle I created for myself lol

Share this post


Link to post
5 hours ago, Froberg said:

Came here for this.. Running nginx proxy manager to serve nextcloud.. do I need to take any action other than update when available? I'd rather not mess around with the core config files.

I guess I can always take it offline until a fix is available.

ha ha came here for the same issue.  I am going to assume if there's a fix it will be push out this Friday when LSIO updates their containers.

Share this post


Link to post
55 minutes ago, darcon said:

The cron error will likely resolve itself.

 

The X-Frame error can be resolved by editing the Nextcloud NGINX default config.  There is a guide on the previous page of this thread showing what you need to add.

 

I had the trusted proxy error as well, I had to add letsencrypt to the Nextcloud config.php file.  

 

'trusted_proxies' =>
array (
0 => 'letsencrypt',
),

 

Also on page 86 of this thread.  Search is your friend.  

Ok i see what I was doing wrong, I tried them but it did not work. I was putting one in the wrong file and the other i typed in wrong. LOL details details. 

 

Now one last thing. its slow, and I have read about many complaining about it. but did not see where anyone resolved it. Any ideas?

Share this post


Link to post
14 hours ago, blaine07 said:

 


I’ve tried it before with “letsencrypt” as you show before and still had that error. I’m currently just living with it out of fear for yesterday’s debacle I created for myself lol

 

 

be sure you adding it to the correct file and location.

appdata\nextcloud\www\nextcloud\config\config.php

 

I added it just after the array section, 

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'oclhll8iza6g',
  'passwordsalt' => 'vzhofu9+O5n8h7gO4T+NM&*hhn78TlahPb',
  'secret' => 'QZrs52ulA6RWatw8CvkUYgbkjulSTvLSJbrcVHaj7U8WW',
  'trusted_domains' => 
  array (
    0 => '10.1.10.230:2443',
    1 => 'mysubdomain.ddns.net',
  ),
  'trusted_proxies' => ['letsencrypt'],
  'dbtype' => 'mysql',
  'version' => '17.0.0.9',
  'overwrite.cli.url' => 'mysubdomain.ddns.net',
  'overwritehost' => 'mysubdomain.ddns.net',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '10.1.10.230:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,

 

Edited by almulder

Share this post


Link to post
 
be sure you adding it to the correct file and location.
appdata\nextcloud\www\nextcloud\config\config.php
 
I added it just after the array section, 
$CONFIG = array ( 'memcache.local' => '\\OC\\Memcache\\APCu', 'datadirectory' => '/data', 'instanceid' => 'oclhll8iza6g', 'passwordsalt' => 'vzhofu9+O5BbCxQO4T++lye7TlahPb', 'secret' => 'QZrs52ulA6RWatw8CvwRji367qo6ZnSTvLSJbrcVHaj7U8WW', 'trusted_domains' =>  array (   0 => '10.1.10.230:2443',   1 => 'huskycloudstorage.ddns.net', ), 'trusted_proxies' => ['letsencrypt'], 'dbtype' => 'mysql', 'version' => '17.0.0.9', 'overwrite.cli.url' => 'mysubdomain.ddns.net', 'overwritehost' => 'mysubdomain.ddns.net', 'overwriteprotocol' => 'https', 'dbname' => 'nextcloud', 'dbhost' => '10.1.10.230:3306', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true,

 


In yours in shows it WITH brackets? So for clarification is it with or without brackets?


Sent from my iPhone using Tapatalk

Share this post


Link to post
46 minutes ago, almulder said:

 

be sure you adding it to the correct file and location.

appdata\nextcloud\www\nextcloud\config\config.php

 

I added it just after the array section, 


$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'oclhll8iza6g',
  'passwordsalt' => 'vzhofu9+O5BbCxQO4T++lye7TlahPb',
  'secret' => 'QZrs52ulA6RWatw8CvwRji367qo6ZnSTvLSJbrcVHaj7U8WW',
  'trusted_domains' => 
  array (
    0 => '10.1.10.230:2443',
    1 => 'huskycloudstorage.ddns.net',
  ),
  'trusted_proxies' => ['letsencrypt'],
  'dbtype' => 'mysql',
  'version' => '17.0.0.9',
  'overwrite.cli.url' => 'mysubdomain.ddns.net',
  'overwritehost' => 'mysubdomain.ddns.net',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '10.1.10.230:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,

 

I think you have the trusted proxies wrong, here is what mine looks like:

Notice no brackets.... only

 

0 => 'letsencrypt',

and notice the array 

'trusted_proxies' =>
array (
    0 => 'letsencrypt',
),

 

1473460381_ScreenShot2019-10-24at8_45_54PM.thumb.png.dc8ca1042bbfb3beb6313309ce798dfb.png

 

Edited by Smooth Beaver
Added array comment

Share this post


Link to post
I think you have the trusted proxies wrong, here is what mine looks like:
Notice no brackets.... only
 
0 => 'letsencrypt',

and notice the array 

'trusted_proxies' =>array (    0 => 'letsencrypt',),

 
1473460381_ScreenShot2019-10-24at8_45_54PM.thumb.png.dc8ca1042bbfb3beb6313309ce798dfb.png
 


To edit config.php are you stopping Nextcloud, making changes, saving and restarting Nextcloud? Tried to fix mine yesterday and ... went through like a fixing itself process when Nextcloud came back up. So reverted file back.

Share this post


Link to post
12 minutes ago, blaine07 said:


To edit config.php are you stopping Nextcloud, making changes, saving and restarting Nextcloud? Tried to fix mine yesterday and ... went through like a fixing itself process when Nextcloud came back up. So reverted file back.

I don't stop anything.

I mount my appdata share via SMB, drill down into the Nextcloud file to find the config.php, open it with Atom (atom.io) edit the config.php save it, and then in the UnRAID GUI on the docker tab click the Nextcloud icon and select restart. Once that is done, just because I can, I restart the letsencrpt docker as well but I really don't think its needed.

Edited by Smooth Beaver

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.