[Support] selfhosters.net's Template Repository


353 posts in this topic Last Reply

Recommended Posts

  • Replies 352
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

A template repository from a group of Unraid users that wants to bring more awesome containers into this community. We already have 40 containers in Community applications, Including; Bitwarden

you sir are a legend !! running it and restarting container done the trick    Many thanks for your time !!

You should be able to go into the prefs.xml file located in your Crushftp9 folder located in your Appdata (if you use the standard locations) share.  Open the XML file and the banned ip's should be li

Posted Images

22 hours ago, DontWorryScro said:

this still working?

Yes, it is still working. Does the container log say "starting services"? Are you using the new port "6595"?

Edited by Roxedus
Link to post
2 hours ago, HynesJeff said:

started getting this yesterday with speedtest-tracker, tried removing/wiping the container and reinstalling:
 

 

Annotation 2020-07-02 143130.png

Can you do post a screenshot of the settings for the container?

Link to post

now it just keeps looping through htis:

 

_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
-------------------------------------

To support LSIO projects visit:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 911
User gid: 911
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 40-config: executing...
Starting 2019/12/30, GeoIP2 databases require personal license key to download. Please manually download/update the GeoIP2 db and save as /config/geoip2db/GeoLite2-City.mmdb
[cont-init.d] 40-config: exited 0.
[cont-init.d] 50-speedtest: executing...
##################################################################################################################################
##################################################################################################################################
You haven't accepted the Ookla EULA. Please re-create the container with the environment variable 'OOKLA_EULA_GDPR' set to 'true'.
##################################################################################################################################
##################################################################################################################################
[cont-init.d] 50-speedtest: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 01-envfile: executing...
[cont-init.d] 01-envfile: exited 0.
[cont-init.d] 10-adduser: executing...
usermod: no changes

-------------------------------------

adding the variable OOKLA_EULA_GDPR (with value 'true') fixes it..... but it should prob be added to the template

Edited by HynesJeff
Link to post

I'm trying to use radarrsync.  I set it up yesterday and it synced part of the entries between the two instances, then it threw this error message and hasn't done anything since:

 

File "/RadarrSync.py", line 86, in <module>
searchid.append(int(r.json()['id']))
TypeError: list indices must be integers or slices, not str

 

Can anyone shed any light as to what is causing this issue and how it can be resolved?

 

Thanks in advance

Link to post
2 hours ago, rbjap said:

I'm trying to use radarrsync.  I set it up yesterday and it synced part of the entries between the two instances, then it threw this error message and hasn't done anything since:

 

File "/RadarrSync.py", line 86, in <module>
searchid.append(int(r.json()['id']))
TypeError: list indices must be integers or slices, not str

 

Can anyone shed any light as to what is causing this issue and how it can be resolved?

 

Thanks in advance

Using radarr 3?

Link to post

Hello,

 

Today ive tried CrushFTP9 from you. Initial setup went fine, but got popup from CrushFTP Update to 9.3.2 and then it stopped to work...

So in App update is not wanted and need to wait for docker update?

 

Thanks

image.png.8d9148636c853c3bc261295f275912d9.png

Link to post

Any tips for adding the configuration file to PrivateBin?

 

I tried following the docker hub page:

 

Quote

Custom configuration

In case you want to use a customized conf.php file, for example one that has file uploads enabled or that uses a different template, add the file as a second volume:


docker run -d --restart="always" --read-only -p 8080:8080 -v conf.php:/srv/cfg/conf.php:ro -v privatebin-data:/srv/data privatebin/nginx-fpm-alpine

Note: The Filesystem data storage is supported out of the box. The image includes PDO modules for MySQL, PostgreSQL and SQLite, required for the Database one, but you still need to keep the /srv/data persisted for the server salt and the traffic limiter.

 

But Not sure I have done it correctly...

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='privatebin' --net='proxynet' -e TZ="Pacific/Auckland" -e HOST_OS="Unraid" -p '8888:8080/tcp' -v '/mnt/user/appdata/privatebin/cfg':'/srv/cfg':'rw' -v 'conf.php':'/srv/cfg/conf.php':'ro' -v '/mnt/user/appdata/privatebin':'/srv/data':'rw' --read-only 'privatebin/nginx-fpm-alpine' 

 

Link to post
14 hours ago, Energen said:

Looks like this works...

 

-v '/mnt/user/appdata/privatebin/conf.php':'/srv/cfg/conf.php':'rw'

 

Untitled.png.628b2f350f99b771db902cd788b970ed.png

Thanks for the reply, however this gives me the same result but in a slightly different place, which is just a folder named conf.php and no file to edit. Unless I am misunderstanding something?

Link to post

I ended up copying and pasting the default sample conf from gitlab and threw it in the folder conf.php but it threw out an error when the container started.

 

2020/07/14 06:09:56 [error] 200#200: *1 FastCGI sent in stderr: "PHP message: PHP Warning: parse_ini_file(/srv/cfg/conf.php): failed to open stream: No such file or directory in /srv/lib/Configuration.php on line 121PHP message: PHP Warning: array_key_exists() expects parameter 2 to be array, bool given in /srv/lib/Configuration.php on line 123PHP message: PHP Fatal error: Uncaught Exception: PrivateBin requires configuration section [main] to be present in configuration file. in /srv/lib/Configuration.php:124

 

Link to post
13 hours ago, BadCo. said:

Thanks for the reply, however this gives me the same result but in a slightly different place, which is just a folder named conf.php and no file to edit. Unless I am misunderstanding something?

Not sure on that error but yes you need to start with the sample file from the site.

 

Then put that file into /mnt/user/appdata/privatebin  ---  not into a folder named conf.php

Link to post
On 7/15/2020 at 7:29 AM, Energen said:

Not sure on that error but yes you need to start with the sample file from the site.

 

Then put that file into /mnt/user/appdata/privatebin  ---  not into a folder named conf.php

Thanks for the help Energen.

 

Unfortunately I was still having issues, and after pondering it for a bit I realised that the instructions on docker hub didn't make sense.

 

I then wiped the install and started from scratch, mounted the /srv/cfg folder (instead of /srv/cfg/conf.php) and added the sample conf.php, edited to allow file uploads and BAM! It works!

 

https://paste.hardnet.nz/?4f6ba2bc6f9225a2#DSwKBzeB5mC37CjoB4wjwawFj2BQu6pHvt6uHmNFsR6w

 

-v '/mnt/user/appdata/privatebin/cfg':'/srv/cfg':'rw'

 

Edited by BadCo.
Added path variable
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.