[Plugin] DVB-Driver


ich777

353 posts in this topic Last Reply

Recommended Posts

7 minutes ago, ich777 said:

Can you also give me a 'lspci -vv' when you are using the LibreELEC drivers and also the Diagnostics?

The strange thing is that only the CI Interface is listed and not the addon cards with the DigitalDevices drivers.

 

These are the results with the xbox driver selected:

tower-diagnostics-20210321-1815.zip

lspci-dvbdriveplugin-xbox.txt 

 

11 minutes ago, ich777 said:

Yes and no, I can build it for you since this involves some tinkering with my Kernel Helper since I'm only allowing currently the newest driver to be built.

 

Only if it s easy to do and you have the time / or if you want to get to the bottom of the mistery :)

 

Link to post
  • Replies 352
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

DVB-Driver (only Unraid 6.9.0beta35 and up) This Plugin will add DVB Drivers to Unraid. Please note that this Plugin is community driven and if a newer version of Unraid is released the driv

@anon1105 may ask in his support thread, maybe some dependencies not added in his container ...

Keep in mind he's probably sleeping.  

Posted Images

54 minutes ago, suyac said:

with the xbox driver selected

The Xbox drivers are basically the same as the LibreELEC drivers, haven't got time to remove the Xbox option from the plugin but it will vanish soon... :D

 

54 minutes ago, suyac said:

Only if it s easy to do and you have the time / or if you want to get to the bottom of the mistery :)

I don't think it's a driver issue, also wrote a PM to you.

Link to post

i often get these warnings:


2021-03-22 19:56:12.593 [WARNING] linuxdvb: DVB-S/S2X #4 : DVB-S #0 - poll TIMEOUT
2021-03-22 19:56:12.660 [WARNING] linuxdvb: DVB-S/S2X #5 : DVB-S #0 - poll TIMEOUT
2021-03-22 19:56:12.666 [WARNING] linuxdvb: DVB-S/S2X #7 : DVB-S #0 - poll TIMEOUT
2021-03-22 19:56:13.119 [WARNING] linuxdvb: DVB-S/S2X #7 : DVB-S #0 - retune nodata
2021-03-22 19:56:13.144 [WARNING] linuxdvb: DVB-S/S2X #4 : DVB-S #0 - retune nodata
2021-03-22 19:56:13.119 [WARNING] linuxdvb: DVB-S/S2X #7 : DVB-S #0 - retune nodata
2021-03-22 19:56:13.144 [WARNING] linuxdvb: DVB-S/S2X #4 : DVB-S #0 - retune nodata

 

whats happend?

Link to post
18 minutes ago, Gee1 said:

whats happend?

Which drivers are you using?

 

Are the tuners properly grounded? It seems like there is some kind of problem with the cable itself or the connections.

 

Does this affect the function of the cards (stutters, or something similar)?

 

Does this only happen on tuners #4, #5, #7? If so are these physical connections?

Link to post
13 minutes ago, Gee1 said:

it happens to all tuners

Does this affect the function of the cards itself?

 

As said above this could or is most likely a problem with the cable between your satellite dish and the cards itself.

Link to post
  • 2 weeks later...
1 minute ago, mhweb said:

@ich777 How can install the Hauppauge WinTV-quadHD on unraid version 6.8.0?

Thanks,

First things first, if you want to mention me, you also have to click my name.

 

Install the DVB Driver Plugin, check if the LibreELEC drivers are selected and reboot. After that you should see the tuners in the Plugin.

Link to post
11 minutes ago, ich777 said:

First things first, if you want to mention me, you also have to click my name.

 

Install the DVB Driver Plugin, check if the LibreELEC drivers are selected and reboot. After that you should see the tuners in the Plugin.

 

How to install the DVB Driver Plugin, when I search the Community Applications, I get a "No Matching Applications Found" message.

Also, I'm not sure what you mean with the mention. When I click your name it takes me to your profile and won't let me reply to the message.

Thanks,

Link to post
1 minute ago, mhweb said:

How to install the DVB Driver Plugin

On what Unraid version are you? You have to be on Unraid version 6.9.0rc2 or higher to see the Driver in the CA App.

 

@mhweb you have to actually click my name so that I get a notification:

IMG_20210403_171334.jpg.36a3aade4f3344d7813de05ca3c89ade.jpg

Link to post
3 minutes ago, mhweb said:

I'm in version 6.8.0. Is there any other way to get it work with this version?

Nope not on such an old version.

I only have a version for 6.8.3 with the LibreELEC drivers built in ready to download in my Unraid-Kernel-Helper thread.

 

I strongly recommend you to upgrade not only because I don't support such old versions but from also from a security perspective...

Link to post
22 minutes ago, mhweb said:

@ich777 the only reason I didn't upgrade was because I have important data in the store array and didn't want to come across unknown or known bugs that could cause data loss. Thanks,

But I think 6.8.3 was long enough around... :D

Also I really don't know anyone who have lost his data because of an upgrade...

But that's up to you, I would have more fear from a security perspective to run such an old build.

Link to post
3 minutes ago, mhweb said:

@ich777when I check for updates, i only get 6.9.1. any way to update only to 6.8.3?

Download the LibreELEC build from my Unraid-Kernel-Helper and replace all bz* files on your USB Boot device with the ones from the downloaded archive, that's pretty much also a upgrade...

Link to post
8 hours ago, mhweb said:

Did something go wrong?

I don't think so, have you rebooted after installing the plugin?

 

If not, please try to shut down the server completely, pull the power cord from the wall, press the on/off and rest button on your server a few times (to empty the caps) wait for 30 seconds, put the power cord back into the socket and turn on the server.

After you booted please attach the Diagnostics (Tools -> Diagnostics -> Download) and drop the downloaded zip file here in the text box if it doesn't work after the reboot.

Link to post

@ich777Is it possible that you update the TBS driver to the latest version?

 

With the current version of the TBS drive in the DVB plugin I'm not able to use my new TBS 6902 card with unraid. No or only a handfull of service s are found with tvheadend.

 

I also passed the card to an Ubuntu VM and compiled the driver by myself 2 weeks ago --> same result.

Now I've seen the following post in the TBS forum:

https://www.tbsdtv.com/forum/viewtopic.php?f=183&t=25560

 

Compiling with the current version (including this fix: https://github.com/tbsdtv/linux_media/commit/942af455a1fca71dc15a248dea72a94aae6dd030) fixed the problem for me in the VM.

 

But it would be nice to use the card directly in Docker by using your plugin 😁.

Link to post
5 minutes ago, tka99a said:

But it would be nice to use the card directly in Docker by using your plugin 😁.

I will look into this ASAP.

Link to post
35 minutes ago, tka99a said:

But it would be nice to use the card directly in Docker by using your plugin 😁.

Drivers are updated now.

Uninstall the DVB Driver plugin, reboot, install the DVB Driver plugin and reboot again.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.