webGui on github


264 posts in this topic Last Reply

Recommended Posts

Here's what I'm aiming for:

 

1/ Publish 5.0.5 - this has a couple minor fixes

2a/ Publish 5.1-beta1 - this is 5.0.5 with latest 'webGui' integrated.

2b/ Push this 'webGui' onto github as 'webGui-master'.

3/ Publish 6.1-beta1 - this is 64-bit unRaid with numerous updates including 'webGui-master' and virtualization support.

 

Idea is webGui will run on both platforms.

 

JOY!!!!

 

=D

 

Link to post
  • Replies 263
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Use an actual flash drive, just like on a bare metal system. Check this out:    

https://github.com/limetech/webGui   Let's give this a try.  For you non-coders, you can monitor and download the "latest".  For you coders, you can fork the repository and send me pull requests if

I've modified smb-extra.cfg to export /usr/local/emhttp/plugins over the network to simplify directly modifying the webGUI files from my Windows box.

Posted Images

Right, I really apologize for this guys.  Here's what I'm aiming for:

 

1/ Publish 5.0.5 - this has a couple minor fixes

2a/ Publish 5.1-beta1 - this is 5.0.5 with latest 'webGui' integrated.

2b/ Push this 'webGui' onto github as 'webGui-master'.

3/ Publish 6.1-beta1 - this is 64-bit unRaid with numerous updates including 'webGui-master' and virtualization support.

 

Idea is webGui will run on both platforms.

 

Really thanks for this update on the topic.

 

Link to post
  • 3 weeks later...

Just installed the new GUI, but on the stats page I get this error:

Parse error: syntax error, unexpected $end in /usr/local/emhttp/plugins/webGui/include/myPage_content.php(31) : eval()'d code on line 1

 

Also the images of the disks are missing on the "health" page.

 

Any idea how I can fix this?

Link to post

Just installed the new GUI, but on the stats page I get this error:

Parse error: syntax error, unexpected $end in /usr/local/emhttp/plugins/webGui/include/myPage_content.php(31) : eval()'d code on line 1

 

Also the images of the disks are missing on the "health" page.

 

Any idea how I can fix this?

Sounds like you have SimpleFeatures installed or maybe Dynamix. These are not compatible with the Limetech "new" webGUI, which is the subject of this thread. Go read the Dynamix thread to get stats and health set up.

 

Link to post
  • 2 weeks later...

I have been running the new webgui since day one on 2 machines and it has never died on me. I run virtually no plugins though (cache dirs only) could this be a red herring?

 

I think so. I have been running the new GUI from day one also and I have done all kinds of things to unRAID without it failing. unRAID running in a VM on unRAID (hope that makes sense) and even "baking" unRAID in other Distros and torture testing it without it failing.

 

I suspect it has to do with the various packages (and versions) that the plugins use.

Link to post

yeah I reckon that is probably more common than we think it is. Unsurprising really

 

Whatever webGui is chosen, it all comes down whether emhttp stays alive or not ...

 

Isn't it about time that all of the developers of webGUI's set the priority level of emhttp (I probably have the wrong terminology here as I am not  a Linux expert) so that it does NOT get killed when resources get tight?  I seem to recall seeing that it only takes a simple command that can be run from a script.

Link to post

yeah I reckon that is probably more common than we think it is. Unsurprising really

 

Whatever webGui is chosen, it all comes down whether emhttp stays alive or not ...

 

Isn't it about time that all of the developers of webGUI's set the priority level of emhttp (I probably have the wrong terminology here as I am not  a Linux expert) so that it does NOT get killed when resources get tight?  I seem to recall seeing that it only takes a simple command that can be run from a script.

I think that would be a function of emhttp and the OS and therefore up to Tom, not the webGUI developer.

Link to post

Isn't it about time that all of the developers of webGUI's set the priority level of emhttp (I probably have the wrong terminology here as I am not  a Linux expert) so that it does NOT get killed when resources get tight?  I seem to recall seeing that it only takes a simple command that can be run from a script.

 

emhttp combines a lot of different things / programs / functions into one and the webserver is one of those. From what Tom has indicated, he is going to pull the webserver "portion" out of emhttp (leave the other functions there) and perhaps use a "better" more stable one like Sickbeard, Couchpotato, Webmin, etc. do.

Link to post

 

WebGUI  usability, minor.

 

I've completely forgotten that I should enable user shares first, then create one. So I tried just to create a share, say "share1".

 

Got error message (on console, not on WebGUI!) something like "...  /mnt/user/share1 no such file or directory"

 

I created directory /mnt/user manually (this is my test server, so yes, I do stupid things)

 

Share, naturally, did not appear anyways.

 

I tried to powerdown (via WebGUI) and got an infinite loop of something like "trying to unmount user shares...".

 

Suggestion: It would be nice to have "create share" buttons disabled until user shares are enabled. Or a popup like "Enable user shares first - go there and click that!" if user tries to create a share with shares disabled.

 

Reasoning: I'm not the only stupid guy out there.

 

WebGUI  2014.01.24a, unRAID Pro 6.0-beta2

 

P.S. Sorry if this is off topic here, could not find were it belongs.

 

A better place to report issues is on the github page, but this is ok too.  I'll look into this.  Fixes won't make -beta3 however.

Link to post
  • 2 months later...

I can't install the new webgui. I try to install it manually over the terminal with this commands

/usr/local/emhttp/plugins/webGui/scripts/upgrade_webGui
wget -q --no-check-certificate -O - https://github.com/limetech/webGui/raw/master/webGui-latest.plg > /boot/plugins/webGui-latest.plg
installplg webGui-latest.plg 

And it gives me this error

 

installing plugin: webGui-latest

 

Warning: simplexml_load_file(): webGui-latest.plg:1: parser error : Document is empty in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): webGui-latest.plg:1: parser error : Start tag expected, '<' not found in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Im on 5.05, deleted simple features completely and rebooted the system. Only running unmenu.

Any advice?

Link to post

I can't install the new webgui. I try to install it manually over the terminal with this commands

/usr/local/emhttp/plugins/webGui/scripts/upgrade_webGui
wget -q --no-check-certificate -O - https://github.com/limetech/webGui/raw/master/webGui-latest.plg > /boot/plugins/webGui-latest.plg
installplg webGui-latest.plg 

And it gives me this error

 

installing plugin: webGui-latest

 

Warning: simplexml_load_file(): webGui-latest.plg:1: parser error : Document is empty in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): webGui-latest.plg:1: parser error : Start tag expected, '<' not found in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file():  in /usr/local/sbin/installplg on line 13

 

Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13

Im on 5.05, deleted simple features completely and rebooted the system. Only running unmenu.

Any advice?

Bad download or corrupt flash drive. Does

ls -al /boot/plugins

show the webGui-latest.plg file? Is its size zero?

 

Link to post

 

webGui on github is only for unRaid 6.  Sorry, I need to make that clear somewhere.

does that mean that 5.0.5 will not get to benifit from webGUI enhancements from here on? And will 5.0.6 fix this?

 

Let me ask a question I am curious about. Is your system not capable of running 64bit?

Link to post

 

webGui on github is only for unRaid 6.  Sorry, I need to make that clear somewhere.

does that mean that 5.0.5 will not get to benifit from webGUI enhancements from here on? And will 5.0.6 fix this?

 

Let me ask a question I am curious about. Is your system not capable of running 64bit?

 

Let me answer from my point of view.  My system is capable of  64bit but there so far aren't the plugins available on 6.0 that is use on 5.x.

 

I also haven't found a prepackaged VM that includes all the plugin alternatives iwant.

 

Add to the fact there is no test server for me to play with and the fact time is limited to when the kids and wife are asleep, and the reasons for needing to stay on 5 are pretty strong.

Link to post

 

webGui on github is only for unRaid 6.  Sorry, I need to make that clear somewhere.

does that mean that 5.0.5 will not get to benifit from webGUI enhancements from here on? And will 5.0.6 fix this?

 

Let me ask a question I am curious about. Is your system not capable of running 64bit?

 

Let me answer from my point of view.  My system is capable of  64bit but there so far aren't the plugins available on 6.0 that is use on 5.x.

 

I also haven't found a prepackaged VM that includes all the plugin alternatives iwant.

 

Add to the fact there is no test server for me to play with and the fact time is limited to when the kids and wife are asleep, and the reasons for needing to stay on 5 are pretty strong.

 

no that's absolutely fine and senisble. What i was curious about is  getting a feel for why people are essentially asking for v6 webgui features back ported to v5.

 

So the crux of this is its a waiting game. At some point v6 will be stable and contain all the features needed from v5. Limetech may back port but thats not what i was intersted in here.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.