Dynamix - V6 Plugins

Recommended Posts

10 hours ago, PaulF said:

So it seems to see my sensors.  But when I run the "sensors" command I get these errors:

I have the same issue with the B550 Taichi and the temp plugin. I haven't been able to find a solution, I am now considering swapping my PC and NAS motherboards to test if I get more luck with Asus.

Link to comment
Posted (edited)

So I'm having an issue with my supermicro board. 


When I try to use the auto fan control plugin. The system crashed with this. 

I have been fighting this for a while but can not figure out what it causing it. 


Any thoughts?


Edit: sorry for the screenshot, currently on my phone. 


Edited by SC8198
Link to comment
Posted (edited)

Okay, I have an X8 board. I figured out with some more research that if you use this plugin while the bios is set to smart fan control, or if the ipmi is taking control, it will corrupt the controller and hard lock the system. There are scripts that I found that can control them via python. But when I disabled the plugin and rebooted the fans were actually pretty quite.


So rule of thumb if you are running into this issue, either

1. Disable all bios and ipmi control of the fans, i.e. set to full so the bios only sends one command at the beginning of boot up

2. Don't use the auto fan control plugin and let the bios or ipmi control the fans

3. Use a python script to control them but that is more involved that I wanted to get. 


Feel free to DM me or whatever and I can possibly help if someone is going through these issues. 


Edit: also the X8 boards are not supported by the ipmi plugin for fan control. Afaik

Edited by SC8198
Link to comment

Hi there! These day my Unraid Server is acting... strange! :D
As you can see, AutoFan is enable and running, but the setting page is blank:



It's logging anyway:


May 19 11:18:35 Tower autofan: autofan process ID 26891 started, To terminate it, type: autofan -q -c /sys/devices/platform/it87.2608/hwmon/hwmon3/pwm2 -f /sys/devices/platform/it87.2608/hwmon/hwmon3/fan1_input


Did I mess something?

Link to comment
41 minutes ago, Andiroo2 said:

I tried searching but can't find it here...what's the path for the logs for plugins?  Specifically looking for my Cache Dirs logs to troubleshoot disks spinning up. Thanks!

Most plugins will log into the syslog (if they log / have an option to).  For those that don't log to syslog (CA is the prime example), they have their own specific area and there is no requirement / convention that they be placed anywhere

Link to comment

Hi. guys

I have started to use dynamix auto fan control which is working on my unraid server. But what is troubling me is that I can't get it started automatically at system boot/reboot. So I have to manually start it each time after the server boots up. Can anyone tell me how to? Thanks

  • Like 1
Link to comment
3 hours ago, alturismo said:

user scripts or go file


command to startup is


/usr/local/emhttp/plugins/dynamix.system.autofan/scripts/rc.autofan start




Thanks. Got it done. It's now working perfectly for me.


Link to comment
On 5/20/2023 at 11:23 AM, Squid said:

Most plugins will log into the syslog (if they log / have an option to).  For those that don't log to syslog (CA is the prime example), they have their own specific area and there is no requirement / convention that they be placed anywhere


OK, so...I'm posting this in the Dynamix plugins thread.  Can anyone tell me where the Cache Dirs plugin logs ae stored?

Link to comment
  • 2 weeks later...

Question about Dynamix System Autofan: Is there a way to fully disable turn off a FAN?

I have a set of Fans to cool the HDDs. They also indirectly help to cool other components.
When the HDDs sleep, the auto fan turns the FANs off and I would like instead to just slow them down instead of turning them off.


Link to comment
2 hours ago, luzfcb said:

When the HDDs sleep, the auto fan turns the FANs off and I would like instead to just slow them down instead of turning them off.

may take a closer look at the settings of your fan




this should be set to "something" which should be then the lowest run speed ...



Link to comment

Hi all, I have been using the Fan Control plugin for sometime after successfully built my first unraid server just 2 weeks ago. While it is working well, it requires me to alter the config after startup in order for it to detect the HDD temperatures.


This is shown upon booting:

Highest disk temp is 0C, adjusting fan speed from: FULL (100% @ 337rpm) to: OFF (0% @ 0rpm)


If I don't change any of the config and click Apply, it continues to detect the temperature as 0C. But if I change any of the config e.g. High temp from 45 to 46C, then click Apply, it works:

Highest disk temp is 41C, adjusting fan speed from: FULL (100% @ 1059rpm) to: 164 (64% @ 1217rpm)


I tried to automate it by using a script to directly modify the .cfg file and run

/usr/local/emhttp/plugins/dynamix.system.autofan/scripts/rc.autofan restart

but it still goes back to 0C. For some reasons, only clicking the "Apply" button in the web GUI works trigger it.


Any idea how can I solve this? If there's a way to trigger it using a script I will be fine with it. The problem is that it only works using the GUI buttons.

Link to comment

Hi just completed a new build using a MSI B760 motherboard.

I can't seem to get Auto Fan and System Temps to detect. According to nerd tools my perl packages are up to date. Do I need install anything in addition for this to be detected?

Sent from my SM-G991B using Tapatalk

  • Like 1
Link to comment

System stats plugin have swap read / write reading in 6.12rc6 & 7, have try server reboot. But no problem on 6.11.5


Below are reading on array disk, but STATS show it is writing, same on UD disk.



Edited by Vr2Io
Link to comment

Auto fan plug-in .. error when detecting.



but fan temps & rpm show up fine in the other temp plug-in.




any idea how to fix? 

currently fan rpm controller by bios

motherboard is MSI b560 mortar wifi


Edited by dopeytree
Link to comment

Also noticed this message about s3 sleep plugin while in safe mode: 


Warning: file_get_contents(plugins/dynamix.s3.sleep/Sleep.php): failed to open stream: No such file or directory in /usr/local/emhttp/plugins/dynamix/include/Translations.php on line 66


Link to comment

Probably a stupid question, but I'm trying to get auto fan configured. The dropdown in the settings screen identifies 3 fan controllers on my system - how do I know which one to specify for auto fan to take control of? 

Link to comment

Wondering about System Info.  It reports the maximum capacity for RAM on my Supermicro X11SCZ-F as 64GB.  When the MB was originally released this was true, but for many years it's supported 128GB after firmware upgrade.  Is this something that can be fixed in System Info, or is this what my MB is reporting to System Info?


I just jumped from 64GB to 128GB in my server.  System Info still says max capacity 64GB and in the System Overview tab I now get:


Memory:	128 GiB DDR4 Single-bit ECC (max. installable capacity 128 GiB*)


I think the * is new and probably there because in the Memory Summary tab we have:


Maximum Capacity:	64 GB


Not a big deal, just wondering if it might be fixed?


Thanks for all the great apps and dockers!

Link to comment

Updated to 6.12


Then my PSU gave up.. it even made that electric zapping noise as some dodgy Chinese component must have finally given up. (it had been randomly rebooting for a while).

Have swapped to a temporary MAG PSU while a new 1u flex psu arrives tomorrow.


Powered up started a parity check. 


Then went for lunch. Came back an hour later and s3 sleep had activated during parity check.


Have disable sleep until any further comment from others.



Edited by dopeytree
Link to comment
11 hours ago, bonienl said:


The capacity is as reported by your BIOS, only a fix in the BIOS of your motherboard can resolve it.



As I presumed, just thought I'd ask.  I doubt SuperMicro will address this as my MB is nearing EOL and they have had years to make the change.  Perhaps the 64GB max capacity is stored somewhere their BIOS updates can't reach.  However, they do have updates occasionally that require jumper changes so factory sections can be reprogrammed.  I'll send them a note and see if maybe they will fix it.


Thank you again for all your outstanding work!  I use sooo many of your dockers and plugins.


EDIT: Sent Supermicro a message.



Edited by craigr
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.