[Plug-In] Community Applications


Recommended Posts

8 minutes ago, trurl said:

The archives of the OS live on the flash drive. Those are unpacked fresh at each boot into RAM, and the OS runs completely in RAM. I always like to think of it as firmware, except easier to upgrade without bricking anything.

Yep, I was just being as brief as possible to reinforce the point that the USB isn't an installer, it is absolutely required.  As we've seen here, it can not live in RAM alone...

Link to comment

Thank you all for this information - I didn't know any of this, but realize now that I probably should had. Unfortunately, I both re-formatted AND loaded new data onto my drive, so it looks like I'll have to contact unraid support in order to get my server up and running properly again. I had been using an Unraid Plus paid license.

 

In retrospect I guess I thought I had installed the OS onto one of my drives? However, when I think about it for a second that doesn't make any sense - where else would the OS live? I won't make this mistake again 😅

Link to comment

They won’t be able to help you recover the lost data - but with the license, just rerun the installer on the same thumb drive and you should be able to boot. As long as the WWN of the thumb drive hasn’t changed, your license should be fine. Then just follow the information the rest have provided here regarding getting back up and operational. 

Link to comment
24 minutes ago, jdlancaster13 said:

Will the WWN change after re-formatting?

No, it is a unique identifier, often referred to as the GUID. It is built in to the USB drive and is unique to that specific USB drive. Or, at least, it is required to be unique in order to have an Unraid license associated with it. If you were able to get a license then it must be OK.

Link to comment
8 hours ago, comet424 said:

was told to post in here from the screen shot.. i can not seem to install  mopidy that constantly fails to install.. same with the one firefox app constanly crashes when u use it

 

statscreen.PNG

lol  I meant the support forum for CA with a screen shot of CA's statistics screen.  But, on a re-read of the banner, I can see where the confusion lies.

 

Net result is that your server is unable to reach the internet.  Usual answer is to reboot modem / switches, and use static DNS addresses of 208.67.222.222 and 208.67.220.220 in Settings - Network settings

 

 

As an aside, I am unable to replicate why this message shows up.  If I disconnect my server from the internet, I get the proper error message (which basically states the above).  If you are so inclined, I would love if you could (assuming Chrome as a browser)

 

  • Go to the Apps Tab
  • Hit F12 on your keyboard (This loads the developer console)
  • Something like this will appear (make sure that you're on "user messages" on the left hand side)image.thumb.png.3f98891a08fce312df61eff209dc3cdf.png
  • Hit the arrow next to every "Result", and also the arrow next to every "Object" that appears (don't hit the arrow next to ___proto___)
  • image.thumb.png.003206b59eb231fcc96c32bf21b54450.png

Right Click anywhere on the wall of text and hit save-as.  Upload the resulting file here.  (This is CA's logging of what is going on, and only a record of CA's communication back and forth to the server - No personal info is present, and nothing relating to any settings on any templates, etc is present)

 

While this won't solve your problem (unable to hit the internet), it will help me figure out WTF you guys aren't seeing the proper message

Link to comment

oh i didnt even know there a communuty apps forum  just knew it was a addon to get the apps and apps have there own support page  so since i didnt know i googled  unraid support page statstics  and got the dynamic...   maybe a link that opens a new window  on that line  like  

Take a screen shot of this unknown Error  Click Here to Post  Results

 

and maybe have a display of your error reporting for chrome so other people will know too

 

aside i didnt use Chrome at the time i just loaded up Tower on Chrome  and did your steps  i could get user messages  and shows 17 apps under that but thats as far as it goes 

 

i was using Microsoft Edge... the error hasnt come back but i found  i left a page up  that had a CA error  this was under  MS Edge..  i had 2 openings going i was trying to install Mopidy 5  or more times in a row to try it out   it constantly Fails downloads couple hunderd meg  works  or doesnt but try to run it  i get an error so i delete and retry..  sometimes i get the EOF in red line at the bottom..

i also found this with the one version of FireFox in the CA  one works the other is broken  if it runs   when you get inside the Firefox  you cant use it  tells you the tabs crashed  you need some app added..  When i do a restart of Firefox (restart option)   it spins doesnt do nothing.. I refresh  and when it freshes  the App is actually gone..  you have to go back to CA  and try to reinstall  i noticed this for mopidy too... i have had issues when the Docker tells you. you used a beta  and need to reinstall everything.. but never used the beta... it pops up every so often when i check it.. it will say it and thats using the current version of Unraid  so  when i do the Preveious installs and check box all the ones i had... sometimes it fails reinstalling some etc..  not sure

and what are those 2 ip address?  

and this is the screen capture i just took  i left the page open..  from MS  Edge.. i dunno if Diaganostics will help  i can upload it i havent rebooted unraid

 

not sure if that screen shot will help..  what i guess i did is i loaded the apps  got the first error.. tried again in a 2nd window got the 2nd error... and i scraped it and watched PLEX after posting the first screen shot not thinking of the 2nd.. as i was getting tired of the mopidy and firefox  issues  everytime you start firefox  app you get the error i get.. makes this version of Firefox broken i guess  jlesega version. The ich777 version seems to be working on for now..

 

oh and i didnt close MS Edge .. if it reports the errors you need i maybe able to get any logs for it if you need

 

 

statsscreen2.PNG

firefox.PNG

Edited by comet424
Link to comment
13 minutes ago, comet424 said:

and what are those 2 ip address?  

 

They are the addresses for OpenDNS.  There's many DNS servers around the world, and those 2 I find are great.  Generally speaking, the standard DNS addresses that your ISP tries to choose are terrible.

Link to comment
9 hours ago, comet424 said:

is the 1.1.1.1 .1.0.0.1 a good dns  i have used it

 

hopefully i did it right  i attached a log   i didnt close the tab  they the logs from the 2 images errors

 

 

tower-1600265401651.log 5.55 kB · 0 downloads 192.168.0.3-1600265492406.log 5.32 kB · 3 downloads

 

If you're on WOW (Wide Open West) cable, this might be relevant as some users have encountered issues trying to route to 1.1.1.1. I haven't experienced it, but I have seen other places that have also messed up 1.1.1.1 as it's used in too many examples.

 

https://www.dslreports.com/forum/r32875282-What-is-this-tomfoolery-with-1-1-1-1-not-cool

 

Link to comment

If you're still having problems @comet424 with the downloads, update CA then go to Apps, Settings, Enable Debugging, Apply.  After going back to the Apps Tab (and the wrong error shows up in the banner), click "Debugging" at the bottom left of CA's menu and upload the file here.  (Then disable debugging)

 

While it won't solve the problem for you, it will tell me why the wrong error is appearing as I still am unable to replicate it - I always get the correct error on my systems no matter how much I try and screw up my internet connection from the server..

Link to comment

@Squid  that jsdn syntax error didnt show you anything?  and the 2 Log files  didnt show you anything that happened?

 

but the issues or the FireFox and installing the other apps  ya still get either  EOF error, failed to complete  after it downloading alot..  i dont always have the best internet as i live in country so people that live in a town or city have better internet...

 

but ok ill enable apps debugging so far hasnt come back as i did what you mentioned reboot modem router  switchs.. havent done a reboot of unraid  and i just doing the APPS update

 

also  just noticed the banner changes  does  APPS/community app  detect my other unraid servers? like my backup server  as i see this

 

but ill update none the less and also change settings and maybe that error comes back will the debugging etc figure out the issues of  not able to install apps  like the EOF or failed to complete?

 

update 1.PNG

update 2.PNG

Link to comment
27 minutes ago, comet424 said:

also  just noticed the banner changes  does  APPS/community app  detect my other unraid servers? like my backup server  as i see this

 

Backup server active means that the primary server for downloads wasn't able to be reached (GitHub), so CA switched to it's backup server (Limetech Hosted via Amazon AWS).  Main difference when this happens is that plugins probably will fail when downloading, and most of the icons for the Apps won't appear.

 

But, since it's downloading off of the backup, posting CA's log won't give me any info as to your problem previously (since a router reboot solved that) where nothing would download at all and the incorrect error message was appearing in CA regarding that.

Link to comment

@Squid  not sure  if matters  i did update of CA  and i saw app i wanted to try  the pihole   been a few hours and and the thing is still stuck on please wait....

 

this is common issue i find installing apps from what i mentioned about firefox being broken to apps disappearing if there is a crash from the docker   or a a failed to save  after a docker app edit update after making change it fails to save and boom its i guess an orphane or not but its gone..

i thought upgrading my motherboard  from intel cpu to latest amd  product a ryzen would fixed things but didnt maybe i have a conflict in my unraid that causes like in the pics its still stuck  please wait... and why dockers crash and are gone  or failed to save etc

is there anything i can scan for that could be causing the issues

 

 

pihole.PNG

pihole2.PNG

Link to comment

oh ic  the 2nd pic  unraid is still stuck in  please wait...  its flashing    i havent reset it.. so figured maybe an issue with ym unraid.. as they normal download    but they never install properly  from the CA     and it also glitchs too when you do Previous installed  apps when you check mark them not alll always install  properly.

 

and ok i guess  i can do that  ill just re boot  unriad maybe it fixes it.. im in Ontario Canada

live in the country where we have lousy internet compared to anyone that lives in town

 

Link to comment
On 9/20/2020 at 7:44 AM, Squid said:

Wow... You must be in the middle of nowhere.  What do you have Satellite Internet?

no i live in Rural  out on a farm    i use dsl  5 megabits download  500kiliobites upload and pay like 90+  bucks a month for it..  where as people in town get 10 times faster and pay less or so  its madning and i dont even get 5megabites  more like 3 on a good day

 

in the 90s/ to mid 2000s   i was using dial up  i only had DSL for like 8 yrs or so  as you couldn get high speed 

 

28.8k modem connection  i was getting and issues with phone lines too

 

still have my 1200 baud modem i got in the 80s  for my C64 computerlol

Edited by comet424
Link to comment

The one thing to look at is that since you're using Bell (and even if you're not then you still are as everything coming over the phone line is ultimately supplied by Bell) is to check back every once in a while on the packages.

 

Every ISP in the world loves to screw you over.  Their speeds always go up, the prices always go down, and yet you'll be stuck in your grandfathered plan unless you notice it.

 

While you're probably more than 5km from the nearest bell junction, what ISPs do now with DSL is offer bonding on their modems.  Effectively they reconfigure your line at the junction to not send you one phone line, but rather two.  The modem then has 2 phone connections on it and it effectively doubles your speed at a minimum.  ie: While it's a guarantee you won't have fiber running to your house and are stuck on DSL (also assuming Cogeco / Rogers have no service to you), Bell's maximum DSL nowadays is 100mbit.  You won't get that due to the distance from the junction, but you will get faster and at a lower price.

Link to comment

ah ok ya i not too sure how far i from a bell box..  but ya im with bell..  im grandfathered in for unlimited dsl  they dont offer unlimited they onl offer 100gb  for 79 bucks before taxes     

i did  call bell resp and contacted the loyality program as we been with bell more then 40 yrs  but guy was happy to disconnect to me as i said id go with techsavy and if they price match    but he was happy to unhook me  go figure lol  but never did it yet  i was going to wait...  as when i called  no promotions they cant do anything ..

 

i remember talkging to bell and Nexicom last year about bonding but they couldnt do it.. as i watched a linus tech video  he was doing bonding    but another company aside from the ISP was doing the bonding not right in the modem..  in the end  if i did something like that i be paying 2-300 bucks a month and for a home user it isnt worth it..  

 

when i checked with bell they told me 6mbit  i can get...  nexicom  said i can get 10megabit to my line  and 10megabit upload  yet bell says like 600kiliobyte upload

and be nice if they didnt display it like thjat more like Megs per second more realistic understanding to a file size like a mp3  4 megs  so 4 seconds 

 

but bell just raised there rates 10 bucks and no faster speed... could be also the law suit from techsavy..  but ill re look into the dual modem..  i just remember they didnt even do a deal    so id have 2 modems 1 could be 5mbs send other be 5mbs receive...  bt they told me they cant and id have to pay 2 seperate internet packages...  and ya no cable  out my way  i was told if i wanted a cable to get to my house id have to pay 1.2 million for them to come out to me    kinda seems excessive to lay a cable lol  told them ill run it my self get it from home depot lol

 

but thanks squid ill look into about bonding again

 

 

Link to comment

ok thanks  illl look that up   like primus  is too expensive and people say why dont i have cell internet.. cant afford 2 internet packages

1 or the other..  maybe if i could get internet  for 45 bucks and not 90+ for dsl lol

 

but sounds good ill teake a look and see if toast.net is in my area

 

update..   toast.net  only usa not canada.. but will keep looking and see if bell offer something etc

Edited by comet424
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.