[Support] binhex - DelugeVPN


8725 posts in this topic Last Reply

Recommended Posts

55 minutes ago, MothyTim said:

Hi, so a few hours of reading and trying things out leads me to think that privoxy is broken!

This is not accurate.  I have everything still running under the privoxy setup.  The change that is needed though is you need to add your network IP range into the 'Ignored Addresses' parameter in Radarr/Sonarr.  There is not an option in Jackett for this that I found.

 

For reference I tested the new setup routing Jackett/Radarr/Sonarr through Deluge but Radarr and Sonarr are unable to communicate with containers outside the VPN, mainly Plex in may case.  I did not want to run my Plex container through Deluge, but I am assuming it might work if you did that.  Also I run 2 containers of Radarr and the new setup did not like having 2 of the same container running through Deluge.

Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

On 2/28/2021 at 5:08 PM, TRusselo said:

rolled back to binhex/arch-delugevpn:2.0.4.dev38_g23a48dd01-3-01
and working again.

Where do you run that? On terminal or console for deluged? Having issues with sonar and radar connecting and would like to try this version and see if it fixed my issue. Thank you. 

Link to post
42 minutes ago, Tucubanito07 said:

Where do you run that? On terminal or console for deluged? Having issues with sonar and radar connecting and would like to try this version and see if it fixed my issue. Thank you. 

You enter a colon after the name in the repository field and then the version tag. Then click apply. The tagged version will be installed.

Link to post

high in-bond traffic (100+ Mbps) on the dashboard when running delugevpn.  Traffic normalizes when downloads are completed or container is stoped. Any help resolving this matter i would i appreciated. 

Edited by Tolete
Link to post

Hi, I've managed to get all my dockers working through VPN eg sonarr etc except for couchpotato.  I can't seem to find any way in couchpotato to ignore the proxy for local addresses or specific addresses.  Has anyone found a solution for couchpotato?

Link to post

From the new FAQ Q26:

 

Quote

An alternative method to this is to setup Jackett, then configure Jackett to use Privoxy. You then simply point Sonarr/Radarr/Lidarr...etc at Jackett as an 'Indexer' and you are done, there is NO need to configure a proxy for Sonarr/Radarr/Lidarr...etc in this configuration, as Jackett is already doing the proxying for you.

 

What does this mean? After updating:

  • I can still access the deluge web gui
  • Radarr and Sonarr can access deluge successfully
  • Radarr and Sonarr (which were/are configured to use Jackett) can NOT access any indexers
  • Jackett, which was set to use privoxy, cannot access any of its indexers.

What config changes am I supposed to make to Jackett to get things working again? Thanks!

Link to post
1 hour ago, RollinDolan said:

What config changes am I supposed to make to Jackett to get things working again? Thanks!

Assuming Jackett is running on the UnRAID server you should probably just need to add the server address to ignored addresses in the proxy settings for deluge as described in Q26.

Link to post
16 hours ago, Burizado said:

This is not accurate.  I have everything still running under the privoxy setup.  The change that is needed though is you need to add your network IP range into the 'Ignored Addresses' parameter in Radarr/Sonarr.  There is not an option in Jackett for this that I found.

 

For reference I tested the new setup routing Jackett/Radarr/Sonarr through Deluge but Radarr and Sonarr are unable to communicate with containers outside the VPN, mainly Plex in may case.  I did not want to run my Plex container through Deluge, but I am assuming it might work if you did that.  Also I run 2 containers of Radarr and the new setup did not like having 2 of the same container running through Deluge.

Why is it not accurate?? Privoxy is not working and infact consantly restarts, quite a few others are reporting the same! As Jackett is working fine conected directly through DelugeVPN container not using the proxy, you don't need to use proxy for Radarr/Sonarr etc so have turned it off in both!(Hopefully that is correct?) I have tried turning it on to test privoxy but iplocation still reports as home so privoxy is not working there either! Ignored addresses is just to allow Radarr/Sonarr etc to connect to local network if you're using proxy so not relavant here, but is how it's set in Bazarr!

 

Hoping for a fix soon.

Cheers,

Tim

 

Forgot my docker run command in last post!

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='binhex-delugevpn' --net='proxynet' --privileged=true -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'VPN_ENABLED'='yes' -e 'VPN_USER'='********' -e 'VPN_PASS'='*********' -e 'VPN_PROV'='pia' -e 'VPN_OPTIONS'='' -e 'STRICT_PORT_FORWARD'='yes' -e 'ENABLE_PRIVOXY'='yes' -e 'LAN_NETWORK'='10.19.64.0/24' -e 'NAME_SERVERS'='209.222.18.222,37.235.1.174,1.1.1.1,8.8.8.8,209.222.18.218,37.235.1.177,1.0.0.1,8.8.4.4' -e 'DELUGE_DAEMON_LOG_LEVEL'='info' -e 'DELUGE_WEB_LOG_LEVEL'='info' -e 'DEBUG'='false' -e 'UMASK'='000' -e 'PUID'='99' -e 'PGID'='100' -e 'VPN_CLIENT'='wireguard' -e 'ADDITIONAL_PORTS'='9117' -p '8112:8112/tcp' -p '58846:58846/tcp' -p '58946:58946/tcp' -p '58946:58946/udp' -p '8118:8118/tcp' -p '9117:9117/tcp' -v '/mnt/user/Downloads/':'/data':'rw' -v '/mnt/user/appdata/binhex-delugevpn':'/config':'rw' 'binhex/arch-delugevpn'
1098a4d6c1e7d3c8e349c7f554c30f3fa1bf4df4f26c3f392be20c23a47c9c0f

 

A more complete log attached:

 

delugevpnlog.rtf

Link to post
26 minutes ago, MothyTim said:

Why is it not accurate??

 

It is not accurate because some, like myself, have privoxy working successfully with the Deluge upgrade.  You have to make some changes to the settings namely adding your network range to the 'Ignored Addresses' but it does work.

 

I agree there are some bugs, and I do see the privoxy restarting in the logs as well, but that does not mean it is not working.  I am also hoping for a fix for any bugs, and Binhex has posted that they are being worked on (at least the ones that can be replicated).

 

Adding captures of my setup to hopefully help anyone that needs to get privoxy working.

 

Deluge Docker Settings:

2021-03-03 11_17_07-Window.png

 

Radarr Settings:

2021-03-03 11_17_25-Window.png

 

Sonarr Settings:

2021-03-03 11_17_39-Window.png

 

Jackett Settings:

2021-03-03 11_17_52-Window.png

Edited by Burizado
Link to post
12 hours ago, wgstarks said:

You enter a colon after the name in the repository field and then the version tag. Then click apply. The tagged version will be installed.

Thank you so much. Switching to that version resolved the issues I was having with Sonarr and Radarr not connecting and also the indexer not connecting. 

Link to post
1 hour ago, Burizado said:

 

It is not accurate because some, like myself, have privoxy working successfully with the Deluge upgrade.  You have to make some changes to the settings namely adding your network range to the 'Ignored Addresses' but it does work.

 

I agree there are some bugs, and I do see the privoxy restarting in the logs as well, but that does not mean it is not working.  I am also hoping for a fix for any bugs, and Binhex has posted that they are being worked on (at least the ones that can be replicated).

 

Adding captures of my setup to hopefully help anyone that needs to get privoxy working.

 

Deluge Docker Settings:

2021-03-03 11_17_07-Window.png

 

Radarr Settings:

2021-03-03 11_17_25-Window.png

 

Sonarr Settings:

2021-03-03 11_17_39-Window.png

 

Jackett Settings:

2021-03-03 11_17_52-Window.png

Ok, which is exactly how mine was configured! How have you tested it? Have you used console in sonarr/radarr etc to check that they are actually going out through your VPN? If not then you don't actually know!

Cheers,

Tim

Link to post
6 hours ago, wgstarks said:

Assuming Jackett is running on the UnRAID server you should probably just need to add the server address to ignored addresses in the proxy settings for deluge as described in Q26.

Sorry, can you explain this?

 

Deluge does not have "ignored addresses" in its proxy settings. Do you mean I should change the "ignored addresses" in the proxy settings for Radarr and Sonarr? Because as stated, Sonarr and Radarr aren't having any issues connecting to Deluge.

 

The issue is that Jackett cannot connect to any indexers ("Found no results while trying to browse this tracker"), which I think means Jackett cannot talk to Privoxy? 

 

I just want things to function as they originally did :)

 

EDIT - is there also no way to set the IP address to the name of my unraid server? It would be much easier to maintain if I could enter "tower" rather than an IP address which isn't guaranteed to remain static.

Edited by RollinDolan
Link to post
14 minutes ago, RollinDolan said:

Sorry, can you explain this?

 

Deluge does not have "ignored addresses" in its proxy settings. Do you mean I should change the "ignored addresses" in the proxy settings for Radarr and Sonarr? Because as stated, Sonarr and Radarr aren't having any issues connecting to Deluge.

 

The issue is that Jackett cannot connect to any indexers ("Found no results while trying to browse this tracker"), which I think means Jackett cannot talk to Privoxy? 

 

I just want things to function as they originally did :)

 

EDIT - is there also no way to set the IP address to the name of my unraid server? It would be much easier to maintain if I could enter "tower" rather than an IP address which isn't guaranteed to remain static.

You set the ignored address in the proxy settings of the dockers using the proxy (eg Sonarr, Radarr etc). DelugeVPN doesn’t need any change.

 

As far as your server IP, just give it a static IP from your address range. I reserve the address in my router and set UnRAID to always assign the same address under network settings.

3B6DA0DB-EE51-49E1-BE57-D471B335ADB8.jpeg

Link to post
6 minutes ago, betaman said:

You set the ignored address in the proxy settings of the dockers using the proxy (eg Sonarr, Radarr etc). DelugeVPN doesn’t need any change.

....

As far as your server IP, just give it a static IP from your address range. I reserve the address in my router and set UnRAID to always assign the same address under network settings.

 

Thanks for the tip on the server IP.

 

As for the first issue (Jackett) - shouldn't I NOT do that, if I'm trying to use Jackett as recommended. (As opposed to routing Sonarr and Radarr each through privoxy individually.)

No worries. I'll just wait for someone to come along and ask the exact same question so we can both find a solution.

Link to post

Anyone here using NZBgetVPN along with DelugeVPN? I’m using privoxy for Radarr/Sonarr/Lidarr etc thru DelugeVPN and I’m able to connect to my indexers and DelugeVPN through each docker (after putting my server address in the ignore list) but now NZBgetVPN isn’t able to connect since the update to DelugeVPN. I assume this issue is related to the one referenced prior about dockers “outside the VPN” communicating with dockers inside it but then again, I’m using privoxy so not sure it’s the same issue? Can anyone confirm? Bungy (docker creator for NZBgetVPN) is asking about my network LAN_IP setting but this hasn’t changed (ie UnRAID server is 192.168.1.71 and LAN_IP setting is 192.168.1.0/24).

Edited by betaman
Link to post
10 minutes ago, RollinDolan said:

Thanks for the tip on the server IP.

 

As for the first issue (Jackett) - shouldn't I NOT do that, if I'm trying to use Jackett as recommended. (As opposed to routing Sonarr and Radarr each through privoxy individually.)

No worries. I'll just wait for someone to come along and ask the exact same question so we can both find a solution.

Sorry, thought you were using Privoxy. If you’re using Jackett then net binding to Deluge is probably your best option.

Link to post
Ok, which is exactly how mine was configured! How have you tested it? Have you used console in sonarr/radarr etc to check that they are actually going out through your VPN? If not then you don't actually know!
Cheers,
Tim

If you are using a proxy in the app settings of radarr/sonarr you can’t check from the container console wether they are using the VPN or not.
The console works on a OS level in the container, and the OS is unaware of the proxy that the apps are using.
I don’t know how to check that the app itself is actually using the VPN via the proxy, maybe someone else has a solution for that.


Sent from my iPhone using Tapatalk
Link to post

I seem to be having an issue with the latest update to DelugeVPN. When I start the new version, I'm able to access the WebGUI but all of my torrents have a Tracker Status Error: Host not found and there is no external IP indicated at the bottom. I'm not too familiar with the logs but this error seems to keep coming up:

 

2021-03-03 14:18:50,778 DEBG 'start-script' stdout output:
[info] WireGuard interface 'down'

2021-03-03 14:18:50,778 DEBG 'start-script' stderr output:
/root/getvpnport.sh: line 1: kill: (1020) - No such process

2021-03-03 14:18:50,779 DEBG 'start-script' stderr output:
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]

2021-03-03 14:16:54,495 DEBG 'start-script' stdout output:
[warn] PIA VPN info API currently down, skipping endpoint port forward check

 

2021-03-03 14:21:13,106 DEBG 'start-script' stdout output:
[info] DNS failure, creating file '/tmp/dnsfailure' to indicate failure...

2021-03-03 14:21:13,108 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using 'http://checkip.amazonaws.com'...

2021-03-03 14:21:13,115 DEBG 'start-script' stdout output:
[info] Failed on last attempt, attempting to get external IP using 'http://whatismyip.akamai.com'...

2021-03-03 14:21:13,122 DEBG 'start-script' stdout output:
[info] Failed on last attempt, attempting to get external IP using 'https://ifconfig.co/ip'...

2021-03-03 14:21:13,129 DEBG 'start-script' stdout output:
[info] Failed on last attempt, attempting to get external IP using 'https://showextip.azurewebsites.net'...

 

I attempted to roll back the update to the previous version, which appears successful and the above issues are gone but I'm no longer able to access the WebGUI. I'm not using privoxy and I'm at a loss for what I can try next. I did change the endpoint for PIA but that didn't resolve the issue either.

 

Thanks for any suggestions!

Link to post
1 hour ago, betaman said:

Sorry, thought you were using Privoxy. If you’re using Jackett then net binding to Deluge is probably your best option.

I am using Privoxy. I am using Privoxy in jackett.

 

Is anyone else familiar with this topic, or experiencing similar issues? I'll try to be more descriptive.

 

Config:

  • Jackett (all these settings are from Jackett's web GUI)
    • Server port: 9117
    • Proxy type: HTTP
    • Proxy URL: tower
    • Proxy port: 8118
    • Web GUI is accessible after update
    • All configured indexers fail after update. When I test them, I get one of two errors:
      • "Exception (<indexer-name> Unexpected character encountered while parsing value: <. Path '', line 0, position 0.: Unexpected character encountered while parsing value: <. Path '', line 0, position 0."
      • "Found no results while trying to browse this tracker"
  • Radarr (all these settings are from Radarr's web GUI)
    • Port number: 7878
    • Proxy: enabled, HTTP(S), hostname=tower, port=8118, "Bypass Proxy for Local Addresses"=Yes
      • Note - I'm not sure if I even need to enable this proxy, if I'm also using Jackett for all my indexers, and Jackett is (supposed to be) through Privoxy
    • Download client - set to Deluge (I give the hostname "tower", password, etc. This is still working and accessible from Radarr, even after the delugeVPN update
    • Indexers:  4 indexers using the Torznab and API info from Jackett. They all worked pre-update.
    • Now, all indexers fail in Radarr. I get one of two error messages when testing them:
      • "Query successful, but no results were returned from your indexer. This may be an issue with the indexer or your indexer category settings."

      • "Unable to connect to indexer, check the log for more details"

  • Sonarr (all these settings are from Radarr's web GUI):

    • Same as radarr, except the port number is 8989

  • DelugeVPN

    • ENABLE_PRIVOXY = yes

    • LAN_NETWORK = 192.168.86.0/24

    • Web GUI IS accessible, even after update

It seems that my issue is Jackett? I can't access my indexers on Jackett, and so Radarr and Sonarr cannot use them either.

 

 

EDIT - Binhex's FAQ number 26 says

Quote

An alternative method to this is to setup Jackett, then configure Jackett to use Privoxy. You then simply point Sonarr/Radarr/Lidarr...etc at Jackett as an 'Indexer' and you are done, there is NO need to configure a proxy for Sonarr/Radarr/Lidarr...etc in this configuration, as Jackett is already doing the proxying for you.

Is this not what I am doing above?

  • I have set up Jackett to use privoxy by setting the proxy url / port to tower / 8118
  • I have configured Radarr and Sonarr to use Jackett as an indexer by adding my indexers with Jackett's torznab links.
Edited by RollinDolan
Link to post
34 minutes ago, ryanclark21 said:

I seem to be having an issue with the latest update to DelugeVPN. When I start the new version, I'm able to access the WebGUI but all of my torrents have a Tracker Status Error: Host not found and there is no external IP indicated at the bottom. I'm not too familiar with the logs but this error seems to keep coming up:

 

...

 

2021-03-03 14:21:13,106 DEBG 'start-script' stdout output:
[info] DNS failure, creating file '/tmp/dnsfailure' to indicate failure...
 

 

I'm seeing this too, have reported it to Binhex on github and will patiently wait for a new image build.

 

39 minutes ago, ryanclark21 said:

I attempted to roll back the update to the previous version, which appears successful and the above issues are gone but I'm no longer able to access the WebGUI. I'm not using privoxy and I'm at a loss for what I can try next. I did change the endpoint for PIA but that didn't resolve the issue either.

 

Thanks for any suggestions!

 

Could you post new supervisord.log from the older version? Don't forget to redact user names and passwords first.

Link to post
20 minutes ago, RollinDolan said:
  • Jackett (all these settings are from Jackett's web GUI)
    • Server port: 9117
    • Proxy type: HTTP
    • Proxy URL: tower
    • Proxy port: 8118
    • Web GUI is accessible after update
    • All configured indexers fail after update. When I test them, I get one of two errors:
      • "Exception (<indexer-name> Unexpected character encountered while parsing value: <. Path '', line 0, position 0.: Unexpected character encountered while parsing value: <. Path '', line 0, position 0."
      • "Found no results while trying to browse this tracker"

It seems that my issue is Jackett? I can't access my indexers on Jackett, and so Radarr and Sonarr cannot use them either.

 

Yes, you need to get Jackett working first.

I don't use jacket via Proxy, so I'm just guessing here, but could you try using the IP of unraid, instead of "tower" for Proxy URL?

Edited by Jorgen
spelling
Link to post
15 minutes ago, Jorgen said:

 

I'm seeing this too, have reported it to Binhex on github and will patiently wait for a new image build.

 

 

Could you post new supervisord.log from the older version? Don't forget to redact user names and passwords first.

 

Here is the supervisord.log with the user/pass redacted. Although I'm unable to access the WebGUI, I know it's running in the background as one of the sites it's connected to shows that I'm still seeding. I will note that prior to the most recent update, I was able to access the WebGUI with the same settings.

 

Created by...
___.   .__       .__                   
\_ |__ |__| ____ |  |__   ____ ___  ___
 | __ \|  |/    \|  |  \_/ __ \\  \/  /
 | \_\ \  |   |  \   Y  \  ___/ >    < 
 |___  /__|___|  /___|  /\___  >__/\_ \
     \/        \/     \/     \/      \/
  https://hub.docker.com/u/binhex/

2021-03-03 15:14:17.879810 [info] System information Linux a3ae0bc95527 5.10.19-Unraid #1 SMP Sat Feb 27 08:00:30 PST 2021 x86_64 GNU/Linux
2021-03-03 15:14:17.902740 [info] OS_ARCH defined as 'x86-64'
2021-03-03 15:14:17.925277 [info] PUID defined as '99'
2021-03-03 15:14:17.961362 [info] PGID defined as '100'
2021-03-03 15:14:17.999641 [info] UMASK defined as '000'
2021-03-03 15:14:18.018840 [info] Permissions already set for volume mappings
2021-03-03 15:14:18.052731 [info] Deleting files in /tmp (non recursive)...
2021-03-03 15:14:18.076554 [info] VPN_ENABLED defined as 'yes'
2021-03-03 15:14:18.098471 [info] VPN_CLIENT defined as 'wireguard'
2021-03-03 15:14:18.118000 [info] VPN_PROV defined as 'pia'
2021-03-03 15:14:18.826884 [info] WireGuard config file (conf extension) is located at /config/wireguard/wg0.conf
2021-03-03 15:14:18.856927 [info] VPN_REMOTE_SERVER defined as 'nl-amsterdam.privacy.network'
2021-03-03 15:14:18.903000 [info] VPN_REMOTE_PORT defined as '1337'
2021-03-03 15:14:18.920143 [info] VPN_DEVICE_TYPE defined as 'wg0'
2021-03-03 15:14:18.937387 [info] VPN_REMOTE_PROTOCOL defined as 'udp'
2021-03-03 15:14:18.957400 [info] LAN_NETWORK defined as '192.168.1.0/24'
2021-03-03 15:14:18.976995 [info] NAME_SERVERS defined as '209.222.18.222,84.200.69.80,37.235.1.174,1.1.1.1,209.222.18.218,37.235.1.177,84.200.70.40,1.0.0.1'
2021-03-03 15:14:18.996444 [info] VPN_USER defined as 'redacted'
2021-03-03 15:14:19.016306 [info] VPN_PASS defined as 'redacted'
2021-03-03 15:14:19.036055 [info] STRICT_PORT_FORWARD defined as 'yes'
2021-03-03 15:14:19.056010 [info] ENABLE_PRIVOXY defined as 'no'
2021-03-03 15:14:19.075956 [info] ADDITIONAL_PORTS not defined (via -e ADDITIONAL_PORTS), skipping allow for custom incoming ports
2021-03-03 15:14:19.096330 [info] DELUGE_DAEMON_LOG_LEVEL defined as 'info'
2021-03-03 15:14:19.116006 [info] DELUGE_WEB_LOG_LEVEL defined as 'info'
2021-03-03 15:14:19.136635 [info] Starting Supervisor...
2021-03-03 15:14:19,380 INFO Included extra file "/etc/supervisor/conf.d/delugevpn.conf" during parsing
2021-03-03 15:14:19,380 INFO Set uid to user 0 succeeded
2021-03-03 15:14:19,383 INFO supervisord started with pid 6
2021-03-03 15:14:20,385 INFO spawned: 'shutdown-script' with pid 156
2021-03-03 15:14:20,386 INFO spawned: 'start-script' with pid 157
2021-03-03 15:14:20,388 INFO spawned: 'watchdog-script' with pid 158
2021-03-03 15:14:20,388 INFO reaped unknown pid 7 (exit status 0)
2021-03-03 15:14:20,395 DEBG 'start-script' stdout output:
[info] VPN is enabled, beginning configuration of VPN

2021-03-03 15:14:20,395 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-03 15:14:20,395 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-03 15:14:20,395 INFO success: watchdog-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-03-03 15:14:20,397 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.222 to /etc/resolv.conf

2021-03-03 15:14:20,400 DEBG 'start-script' stdout output:
[info] Adding 84.200.69.80 to /etc/resolv.conf

2021-03-03 15:14:20,402 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.174 to /etc/resolv.conf

2021-03-03 15:14:20,405 DEBG 'start-script' stdout output:
[info] Adding 1.1.1.1 to /etc/resolv.conf

2021-03-03 15:14:20,407 DEBG 'start-script' stdout output:
[info] Adding 209.222.18.218 to /etc/resolv.conf

2021-03-03 15:14:20,409 DEBG 'start-script' stdout output:
[info] Adding 37.235.1.177 to /etc/resolv.conf

2021-03-03 15:14:20,412 DEBG 'start-script' stdout output:
[info] Adding 84.200.70.40 to /etc/resolv.conf

2021-03-03 15:14:20,414 DEBG 'start-script' stdout output:
[info] Adding 1.0.0.1 to /etc/resolv.conf

2021-03-03 15:14:20,585 DEBG 'start-script' stderr output:
parse error: Invalid numeric literal at line 4, column 0

2021-03-03 15:14:21,282 DEBG 'start-script' stdout output:
[info] Trying to connect to the PIA WireGuard API on 'nl-amsterdam.privacy.network'...

2021-03-03 15:14:21,819 DEBG 'start-script' stdout output:
[info] Default route for container is 172.17.0.1

2021-03-03 15:14:21,829 DEBG 'start-script' stdout output:
[info] Docker network defined as    172.17.0.0/16

2021-03-03 15:14:21,831 DEBG 'start-script' stdout output:
[info] Adding 192.168.1.0/24 as route via docker eth0

2021-03-03 15:14:21,832 DEBG 'start-script' stdout output:
[info] ip route defined as follows...
--------------------

2021-03-03 15:14:21,833 DEBG 'start-script' stdout output:
default via 172.17.0.1 dev eth0 
172.17.0.0/16 dev eth0 proto kernel scope link src 172.17.0.2 
192.168.1.0/24 via 172.17.0.1 dev eth0 
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1 
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1 
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1 
broadcast 172.17.0.0 dev eth0 table local proto kernel scope link src 172.17.0.2 
local 172.17.0.2 dev eth0 table local proto kernel scope host src 172.17.0.2 
broadcast 172.17.255.255 dev eth0 table local proto kernel scope link src 172.17.0.2 

2021-03-03 15:14:21,833 DEBG 'start-script' stdout output:
--------------------

2021-03-03 15:14:21,835 DEBG 'start-script' stdout output:
iptable_mangle         16384  1
ip_tables              28672  4 iptable_filter,iptable_raw,iptable_nat,iptable_mangle

2021-03-03 15:14:21,836 DEBG 'start-script' stdout output:
[info] iptable_mangle support detected, adding fwmark for tables

2021-03-03 15:14:22,251 DEBG 'start-script' stdout output:
[info] iptables defined as follows...
--------------------

2021-03-03 15:14:22,252 DEBG 'start-script' stdout output:
-P INPUT DROP
-P FORWARD DROP
-P OUTPUT DROP
-A INPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A INPUT -s 89.187.174.152/32 -i eth0 -j ACCEPT
-A INPUT -s 89.187.174.172/32 -i eth0 -j ACCEPT
-A INPUT -s 89.187.174.161/32 -i eth0 -j ACCEPT
-A INPUT -s 89.187.174.132/32 -i eth0 -j ACCEPT
-A INPUT -s 89.187.174.162/32 -i eth0 -j ACCEPT
-A INPUT -i eth0 -p tcp -m tcp --dport 8112 -j ACCEPT
-A INPUT -i eth0 -p udp -m udp --dport 8112 -j ACCEPT
-A INPUT -s 192.168.1.0/24 -i eth0 -p tcp -m tcp --dport 58846 -j ACCEPT
-A INPUT -p icmp -m icmp --icmp-type 0 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -i wg0 -j ACCEPT
-A OUTPUT -s 172.17.0.0/16 -d 172.17.0.0/16 -j ACCEPT
-A OUTPUT -d 89.187.174.152/32 -o eth0 -j ACCEPT
-A OUTPUT -d 89.187.174.172/32 -o eth0 -j ACCEPT
-A OUTPUT -d 89.187.174.161/32 -o eth0 -j ACCEPT
-A OUTPUT -d 89.187.174.132/32 -o eth0 -j ACCEPT
-A OUTPUT -d 89.187.174.162/32 -o eth0 -j ACCEPT
-A OUTPUT -o eth0 -p tcp -m tcp --sport 8112 -j ACCEPT
-A OUTPUT -o eth0 -p udp -m udp --sport 8112 -j ACCEPT
-A OUTPUT -d 192.168.1.0/24 -o eth0 -p tcp -m tcp --sport 58846 -j ACCEPT
-A OUTPUT -p icmp -m icmp --icmp-type 8 -j ACCEPT
-A OUTPUT -o lo -j ACCEPT
-A OUTPUT -o wg0 -j ACCEPT

2021-03-03 15:14:22,253 DEBG 'start-script' stdout output:
--------------------

2021-03-03 15:14:22,255 DEBG 'start-script' stdout output:
[info] Attempting to bring WireGuard interface 'up'...

2021-03-03 15:14:22,263 DEBG 'start-script' stderr output:
Warning: `/config/wireguard/wg0.conf' is world accessible

2021-03-03 15:14:22,270 DEBG 'start-script' stderr output:
[#] ip link add wg0 type wireguard

2021-03-03 15:14:22,271 DEBG 'start-script' stderr output:
[#] wg setconf wg0 /dev/fd/63

2021-03-03 15:14:22,279 DEBG 'start-script' stderr output:
[#] ip -4 address add 10.23.166.5 dev wg0

2021-03-03 15:14:22,283 DEBG 'start-script' stderr output:
[#] ip link set mtu 1420 up dev wg0

2021-03-03 15:14:22,295 DEBG 'start-script' stderr output:
[#] wg set wg0 fwmark 51820

2021-03-03 15:14:22,296 DEBG 'start-script' stderr output:
[#] ip -4 route add 0.0.0.0/0 dev wg0 table 51820

2021-03-03 15:14:22,297 DEBG 'start-script' stderr output:
[#] ip -4 rule add not fwmark 51820 table 51820

2021-03-03 15:14:22,298 DEBG 'start-script' stderr output:
[#] ip -4 rule add table main suppress_prefixlength 0

2021-03-03 15:14:22,300 DEBG 'start-script' stderr output:
[#] sysctl -q net.ipv4.conf.all.src_valid_mark=1

2021-03-03 15:14:22,302 DEBG 'start-script' stderr output:
[#] iptables-restore -n

2021-03-03 15:14:22,334 DEBG 'start-script' stderr output:
[#] '/root/wireguardup.sh'

2021-03-03 15:14:23,714 DEBG 'start-script' stdout output:
[info] Attempting to get external IP using 'http://checkip.amazonaws.com'...

2021-03-03 15:14:24,383 DEBG 'start-script' stdout output:
[info] Successfully retrieved external IP address 89.187.174.152

2021-03-03 15:14:24,384 DEBG 'start-script' stdout output:
[info] WireGuard interface 'up'

2021-03-03 15:14:24,388 DEBG 'start-script' stdout output:
[info] Script started to assign incoming port

2021-03-03 15:14:24,388 DEBG 'start-script' stdout output:
[info] Port forwarding is enabled
[info] Checking endpoint 'nl-amsterdam.privacy.network' is port forward enabled...

2021-03-03 15:14:25,380 DEBG 'start-script' stdout output:
[info] PIA endpoint 'nl-amsterdam.privacy.network' is in the list of endpoints that support port forwarding

2021-03-03 15:14:25,381 DEBG 'start-script' stdout output:
[info] List of PIA endpoints that support port forwarding:-

2021-03-03 15:14:25,381 DEBG 'start-script' stdout output:
[info] al.privacy.network
[info] ad.privacy.network
[info] austria.privacy.network
[info] brussels.privacy.network
[info] ba.privacy.network
[info] sofia.privacy.network
[info] czech.privacy.network
[info] denmark.privacy.network
[info] ee.privacy.network
[info] fi.privacy.network
[info] france.privacy.network
[info] de-frankfurt.privacy.network
[info] de-berlin.privacy.network
[info] gr.privacy.network
[info] hungary.privacy.network
[info] is.privacy.network
[info] ireland.privacy.network
[info] man.privacy.network
[info] italy.privacy.network
[info] lv.privacy.network
[info] liechtenstein.privacy.network
[info] lt.privacy.network
[info] lu.privacy.network
[info] mk.privacy.network
[info] malta.privacy.network
[info] md.privacy.network
[info] monaco.privacy.network
[info] montenegro.privacy.network
[info] nl-amsterdam.privacy.network
[info] no.privacy.network
[info] poland.privacy.network
[info] pt.privacy.network
[info] ro.privacy.network
[info] rs.privacy.network

2021-03-03 15:14:25,382 DEBG 'start-script' stdout output:
[info] sk.privacy.network
[info] spain.privacy.network
[info] sweden.privacy.network
[info] swiss.privacy.network
[info] ua.privacy.network
[info] uk-london.privacy.network
[info] uk-southampton.privacy.network
[info] uk-manchester.privacy.network
[info] uk-2.privacy.network
[info] bahamas.privacy.network
[info] ca-montreal.privacy.network
[info] ca-toronto.privacy.network
[info] ca-ontario.privacy.network
[info] ca-vancouver.privacy.network
[info] greenland.privacy.network
[info] mexico.privacy.network
[info] panama.privacy.network
[info] ar.privacy.network
[info] br.privacy.network
[info] venezuela.privacy.network
[info] yerevan.privacy.network
[info] bangladesh.privacy.network
[info] cambodia.privacy.network
[info] china.privacy.network
[info] cyprus.privacy.network
[info] georgia.privacy.network
[info] hk.privacy.network
[info] in.privacy.network
[info] israel.privacy.network
[info] japan.privacy.network
[info] kazakhstan.privacy.network
[info] macau.privacy.network
[info] mongolia.privacy.network
[info] philippines.privacy.network
[info] qatar.privacy.network
[info] saudiarabia.privacy.network
[info] sg.privacy.network
[info] srilanka.privacy.network
[info] taiwan.privacy.network
[info] tr.privacy.network
[info] ae.privacy.network
[info] vietnam.privacy.network
[info] aus-perth.privacy.network
[info] au-sydney.privacy.network
[info] aus-melbourne.privacy.network
[info] nz.privacy.network
[info] dz.privacy.network
[info] egypt.privacy.network
[info] morocco.privacy.network
[info] nigeria.privacy.network
[info] za.privacy.network

2021-03-03 15:14:28,161 DEBG 'start-script' stdout output:
[info] Successfully assigned and bound incoming port '28291'

2021-03-03 15:14:28,648 DEBG 'watchdog-script' stdout output:
[info] Deluge listening interface IP 0.0.0.0 and VPN provider IP 10.23.166.5 different, marking for reconfigure

2021-03-03 15:14:28,666 DEBG 'watchdog-script' stdout output:
[info] Deluge not running

2021-03-03 15:14:28,669 DEBG 'watchdog-script' stdout output:
[info] Deluge Web UI not running

2021-03-03 15:14:28,669 DEBG 'watchdog-script' stdout output:
[info] Deluge incoming port 6890 and VPN incoming port 28291 different, marking for reconfigure

2021-03-03 15:14:28,669 DEBG 'watchdog-script' stdout output:
[info] Attempting to start Deluge...
[info] Removing deluge pid file (if it exists)...

2021-03-03 15:14:28,967 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'listen_interface' currently has a value of '10.53.243.214'
[info] Deluge key 'listen_interface' will have a new value '10.23.166.5'
[info] Writing changes to Deluge config file '/config/core.conf'...

2021-03-03 15:14:29,101 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'outgoing_interface' currently has a value of 'wg0'
[info] Deluge key 'outgoing_interface' will have a new value 'wg0'
[info] Writing changes to Deluge config file '/config/core.conf'...

2021-03-03 15:14:29,231 DEBG 'watchdog-script' stdout output:
[info] Deluge key 'default_daemon' currently has a value of 'f80518af7f5e4c308c07ac8bdbac13bc'
[info] Deluge key 'default_daemon' will have a new value 'f80518af7f5e4c308c07ac8bdbac13bc'
[info] Writing changes to Deluge config file '/config/web.conf'...

2021-03-03 15:14:29,487 DEBG 'watchdog-script' stdout output:
[info] Deluge process started
[info] Waiting for Deluge process to start listening on port 58846...

2021-03-03 15:14:29,700 DEBG 'watchdog-script' stdout output:
[info] Deluge process listening on port 58846

2021-03-03 15:14:31,431 DEBG 'watchdog-script' stdout output:
Setting "random_port" to: False
Configuration value successfully updated.

2021-03-03 15:14:33,231 DEBG 'watchdog-script' stdout output:
Setting "listen_ports" to: (28291, 28291)
Configuration value successfully updated.

2021-03-03 15:14:35,100 DEBG 'watchdog-script' stdout output:
[info] No torrents with state 'Error' found

2021-03-03 15:14:35,100 DEBG 'watchdog-script' stdout output:
[info] Starting Deluge Web UI...
[info] Deluge Web UI started

 

Link to post
1 hour ago, betaman said:

Anyone here using NZBgetVPN along with DelugeVPN? I’m using privoxy for Radarr/Sonarr/Lidarr etc thru DelugeVPN and I’m able to connect to my indexers and DelugeVPN through each docker (after putting my server address in the ignore list) but now NZBgetVPN isn’t able to connect since the update to DelugeVPN. I assume this issue is related to the one referenced prior about dockers “outside the VPN” communicating with dockers inside it but then again, I’m using privoxy so not sure it’s the same issue? Can anyone confirm? Bungy (docker creator for NZBgetVPN) is asking about my network LAN_IP setting but this hasn’t changed (ie UnRAID server is 192.168.1.71 and LAN_IP setting is 192.168.1.0/24).

There's a fix coming for this, see https://github.com/binhex/arch-delugevpn/issues/258

Although, if you want to run NzbGet through a VPN tunnel, an alternative is to use the normal binhex NzbGet container and bind it's network to the DelugeVPN container. See Q24 here: https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.