[Support] binhex - SABnzbdVPN


1327 posts in this topic Last Reply

Recommended Posts

42 minutes ago, jonathanm said:

spaceinvader one has a video on youtube about sending one container through another for exactly what you are talking about.

Thanks. I will check that out.

Would this method be in any way better than just using the qbittorrentvpn Docker with its own vpn connection?

Link to post
  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

hi guys, spotted the issue regards dos2unix.sh and corrected it, image now  building, should be done in around an hour.. then pull and you should be back up and running.

ok guys, spotted the issue. it was a legacy bug that the additional logging picked up causing the exit of sabnzbd (even though it was running). sadly i cannot currently build a new image with the fix

The new image has built so if you now pull down latest it should work as expected Sent from my EML-L29 using Tapatalk

Posted Images

18 minutes ago, Agamemnon said:

Would this method be in any way better than just using the qbittorrentvpn Docker with its own vpn connection?

Depends on how many concurrent logins your vpn provider lets you use vs. how many you are currently using.

Link to post

Hi, 

 

I thought I would post here as my issue seems to be Sabnzbdvpn specific. 

 

I am utilising Wireguard to access my UNRAID remotely and can fire up all dockers and use them as if I was local, except for Sabnzbdvpn, it just times out. 

 

Sabnzbdvpn is configured the same as the other Binhex containers in that it uses a custom network so they can all talk to one another, and I'm able to access them the same as any other container, except for Sabnzbdvpn. 

 

I'm sure this is a simple error on my behalf, but if anyone can advise, it will be greatly appreciated. 

 

Thanks. 

Screenshot_20210210-082845_Bromite.thumb.jpg.299e2982ab543c981f73ca7b0bc705ed.jpg

 

Link to post
20 hours ago, LoneTraveler said:

Hi, 

 

I thought I would post here as my issue seems to be Sabnzbdvpn specific. 

 

I am utilising Wireguard to access my UNRAID remotely and can fire up all dockers and use them as if I was local, except for Sabnzbdvpn, it just times out. 

 

Sabnzbdvpn is configured the same as the other Binhex containers in that it uses a custom network so they can all talk to one another, and I'm able to access them the same as any other container, except for Sabnzbdvpn. 

 

I'm sure this is a simple error on my behalf, but if anyone can advise, it will be greatly appreciated. 

 

Thanks. 

Screenshot_20210210-082845_Bromite.thumb.jpg.299e2982ab543c981f73ca7b0bc705ed.jpg

 

 

 

I'm actually fighting with the same problem, I just set up wireguard and can access any container not under a binhex-VPN enabled container. There is a FAQ to address this here under Q2: https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

 

My issue is that I did add that script to my go file and also enable it immediately with /sbin/modprobe iptable_mangle , but I still cant access the containers. 

Is there any way to debug and see if the connection attempt is happening and where it is failing? :(

Link to post
On 2/10/2021 at 8:35 AM, LoneTraveler said:

I am utilising Wireguard to access my UNRAID remotely and can fire up all dockers and use them as if I was local, except for Sabnzbdvpn, it just times out. 

most probably you need to add your wireguard network to the LAN_NETWORK env var for sabnzbdvpn, otherwise it will be blocked when you are on the vpn, if you want more than one network then use a comma to seperate the values.

Link to post
45 minutes ago, binhex said:

most probably you need to add your wireguard network to the LAN_NETWORK env var for sabnzbdvpn, otherwise it will be blocked when you are on the vpn, if you want more than one network then use a comma to seperate the values.

 

Worked first go, many thanks as always. 👍🏻

Link to post
6 hours ago, binhex said:

most probably you need to add your wireguard network to the LAN_NETWORK env var for sabnzbdvpn, otherwise it will be blocked when you are on the vpn, if you want more than one network then use a comma to seperate the values.

This fixed my issue as well, thanks a ton!

Link to post
  • 2 weeks later...

Trying to set this up for the first time, but can't seem to get it going with the VPN enabled. I have your DelugeVPN one running just fine now with it (knocks on wood), but can't get this one going. I copied the openvpn files over from the Deluge folder that's working fine there. Anything I should check? I'm still def a novice user with Unraid haha.

 

Update: Switched around the STRICT_PORT_FORWARD, ENABLE_PRIVOXY yes/no settings but don't think that did it. What did was changing my LAN_NETWORK setting to match my router, that seemed to do the trick. Now to set it up and hopefully get it going with Sonarr/Radarr. Wish me luck!

Edited by yanksno1
Link to post
16 hours ago, binhex said:

 

IMPORTANT:- As part of the tightening up if you run multiple containers through a single vpn container then please ensure you define all web ui ports (if more than 1 port then use comma to separate) for all routed containers in 'ADDITIONAL_PORTS' env var for the vpn container.

Came here exactly to ask about what I broke, and you already called out what I need to do. Back in business!

Link to post
16 hours ago, binhex said:

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A new image has now been rolled out for all vpn enabled docker images (25th Feb 2021) i produce with the fix in place, i would encourage everyone to update to the recently created 'latest' tagged image.
 

You can force the upgrade by toggling 'basic view' to 'advanced view' and then clicking on 'force update' link for each container, or by clicking on the 'check for updates' button at the bottom and then click on 'update all'.
 

for transparency, here is the link to the (now closed off) issue:- https://github.com/binhex/arch-qbittorrentvpn/issues/80

 

IMPORTANT:- As part of the tightening up if you run multiple containers through a single vpn container then please ensure you define all web ui ports (if more than 1 port then use comma to separate) for all routed containers in 'ADDITIONAL_PORTS' env var for the vpn container.

Container was updated today..

I started to have issues with Radarr and Sonarr tonight with them saying they can't connect to SAB I have them using proxy with the port 8118... I'm not sure what steps I should take to resolved... I added Radarr and Sonarr ports 7878 and 8989 to the ADDITIONAL_PORTS but that did not change resolve the issue. If I point a windows machine to use Proxy via the UNRAID server IP:8118 I can get to the internet and it IS the VPN ip.... Only seems to be an issue with Radarr and Sonarr.. VPN Provider is PIA...

is the the area to make changes??

1748921990_containervaradditionalports.PNG.0c76a67f6a584a92a684df0b101a535c.PNG

Link to post
2 hours ago, CarlP said:

Only seems to be an issue with Radarr and Sonarr..

Same for me. Radarr and Sonarr using privoxy from the sabvpn container can't connect to anything local anymore.  Accessing the web works just fine (searching for new series/movies)

Edited by sillywalks
Link to post
3 hours ago, CarlP said:

Container was updated today..

I started to have issues with Radarr and Sonarr tonight with them saying they can't connect to SAB I have them using proxy with the port 8118... I'm not sure what steps I should take to resolved... I added Radarr and Sonarr ports 7878 and 8989 to the ADDITIONAL_PORTS but that did not change resolve the issue. If I point a windows machine to use Proxy via the UNRAID server IP:8118 I can get to the internet and it IS the VPN ip.... Only seems to be an issue with Radarr and Sonarr.. VPN Provider is PIA...

is the the area to make changes??

1748921990_containervaradditionalports.PNG.0c76a67f6a584a92a684df0b101a535c.PNG

see recommended post at the top, see the Note

Link to post
1 hour ago, binhex said:

see recommended post at the top, see the Note

So what do we change to get Sonarr and Radarr to work via Privoxy if it's not the ADDITIONAL_PORTS var?

 

EDIT: I got Sonarr and Radarr to work again by going to (in Sonarr and Radarr) Settings > Config > General > Proxy and adding my server's IP in "Ignore addresses" ("Bypass proxy for local addresses" was already checked, and I left it so).

Additionally, in SABnzbd, if you have under General > Security a "List of local network ranges" defined, be sure to add the ranges for your Sonarr and Radarr Dockers, as well as your LAN IP range (or just leave it blank). Frustratingly, if you add it as CIDR notation, you will be locked out of the UI, so add it in the following format:

192.168.1.,172.17.0.

(the second range covers both my Sonarr and Radarr Dockers)

Edited by jademonkee
Added extra info to the solution
Link to post
1 hour ago, jademonkee said:

EDIT: I got Sonarr and Radarr to work again by going to (in Sonarr and Radarr) Settings > Config > General > Proxy and adding my server's IP in "Ignore addresses" ("Bypass proxy for local addresses" was already checked, and I left it so).

thanks for sharing this, still at a loss as to why you needed to add your server to the ignore addresses field for sonarr and radarr, i cannot replicate the issue as of now.

Link to post
1 hour ago, jademonkee said:

So what do we change to get Sonarr and Radarr to work via Privoxy if it's not the ADDITIONAL_PORTS var?

 

EDIT: I got Sonarr and Radarr to work again by going to (in Sonarr and Radarr) Settings > Config > General > Proxy and adding my server's IP in "Ignore addresses" ("Bypass proxy for local addresses" was already checked, and I left it so).

Additionally, in SABnzbd, if you have under General > Security a "List of local network ranges" defined, be sure to add the ranges for your Sonarr and Radarr Dockers, as well as your LAN IP range (or just leave it blank). Frustratingly, if you add it as CIDR notation, you will be locked out of the UI, so add it in the following format:

192.168.1.,172.17.0.

(the second range covers both my Sonarr and Radarr Dockers)

This worked for me.... BUT doesn't this BYPASS the 2 apps from using the VPN connection?

Link to post
44 minutes ago, CarlP said:

This worked for me.... BUT doesn't this BYPASS the 2 apps from using the VPN connection?

I think it means that it won't use the proxy when it talks to SABnzbd. It will still use the proxy for connecting to servers on the internet.

Link to post
2 hours ago, binhex said:

thanks for sharing this, still at a loss as to why you needed to add your server to the ignore addresses field for sonarr and radarr, i cannot replicate the issue as of now.

 

I also had this problem as of a few hours ago. Ignoring the address did help with sonarr, but not radarr. I am sure this is not what is supposed to be done to get it to work because it was working fine 24hrs ago. It leaves me a little uneasy having to use the "ignore addresses" workaround.

Link to post
47 minutes ago, dopester said:

 

I also had this problem as of a few hours ago. Ignoring the address did help with sonarr, but not radarr. I am sure this is not what is supposed to be done to get it to work because it was working fine 24hrs ago. It leaves me a little uneasy having to use the "ignore addresses" workaround.

 

actually i take back what i said, it must of been a nuance with sonarr, because i was able to replicate the issue and the workaround is indeed to 'ignore addresses', i certainly wouldnt worry about it, it looks secure to me, if you want to sleep well then simply drop your vpn container running privoxy, then go to sonarr and 'test' your index site, it should fail, if it does then you know its using the proxy still (works for me).

Link to post

had similar problems as others with Sonarr after updated SABnzbdvpn.  added Unraid server to "ignore addresses" field in Sonarr (settings - general - proxy).  then restarted SAB, NZBHydra2 and Sonarr.  still wouldn't yield search results.  so went into Sonarr indexer and downloader settings to "verify" them, though environment did not change, so settings were not changed.  then clicked "test" for each.  after testing both, now searches work.

Edited by DoItMyselfToo
Link to post

Ok so I suppose I really should of not updated my sabnzbdvpn docker until reading the forums. Been running stable with OpenVPN configured and once I performed the docker update I am seeing a couple of things.

 

1. The first thing is I can't access the Dockers WebUI

2. The second is my other dockers such as Radarr/Sonarr can't connect to the sabnzbdvpn docker

3. I am also seeing in the logs (supervisord logs) the following errors.

 

021-02-26 16:21:34,066 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

2021-02-26 16:21:34,071 DEBG 'start-script' stdout output:
Options error: Maximum number of 'remote' options (64) exceeded
Use --help for more information.

2021-02-26 16:21:34,075 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

2021-02-26 16:21:34,080 DEBG 'start-script' stdout output:
Options error: Maximum number of 'remote' options (64) exceeded
Use --help for more information.

2021-02-26 16:21:34,083 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

2021-02-26 16:21:34,088 DEBG 'start-script' stdout output:
Options error: Maximum number of 'remote' options (64) exceeded
Use --help for more information.

2021-02-26 16:21:34,092 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

 

Also note that I have been searching the internet based on this error and I see results like this from this forum. Not sure if its related but it looks like I can't complete the VPN connection process for some reason and I have verified that the endpoint remote sites are reachable. https://unix.stackexchange.com/questions/386105/openvpn-daemon-not-using-config-file

 

I have attached screen shots on my docker config to help better paint the picture as to what could be the issue. Please provide some guidance as to what might help. I have read through what other users have done with small workarounds but its a bit hard to follow without better screenshots & documentation to try. Thanks for the help, support, and development of a great docker/app .1383894846_sabnzbddockerconfig2.thumb.JPG.926ca9d94786e5796a27657b2030433e.JPG1215215065_sabnzbddockerconfig1.thumb.JPG.423a6a56b6333c315d525ccb608575b5.JPG

Edited by SubRetro
Link to post

So I was able to resolve my issue after a bit of testing.

 

1. I tried the ignore proxy option work around. Didn't work.

2. I tried removing the docker and its imagine and pull back down comparing the config I had. Didn't work.

3. I tried updating ovpn conf file and didnt' work.

 

What I did find that worked was I shut off the docker, removed the ovpn conf file and started the docker up so I can clearly get the expected log message - 

"[crit] No OpenVPN config file located in /config/openvpn/ (ovpn extension), please download from your VPN provider and then restart this container, exiting... "

 

Then based upon the following error message I was getting.

 

2021-02-27 02:05:55,578 DEBG 'start-script' stdout output:
[info] Starting OpenVPN (non daemonised)...

2021-02-27 02:05:55,583 DEBG 'start-script' stdout output:
Options error: Maximum number of 'remote' options (64) exceeded

Use --help for more information.

 

I noticed in my ovpn conf file that there was several entries such as.

*****EXAMPLE******

remote.vpnpiatunnel.com TCP 1111

remote.vpnpiatunnel.com TCP 1111

remote.vpnpiatunnel.com TCP 1111

remote.vpnpiatunnel.com UDP 1234

remote.vpnpiatunnel.com TCP 1111

 

So I removed the duplicate entries for the TCP line items and kept the UDP. Ultimately resulting in this.

 

remote.vpnpiatunnel.com TCP 1111

remote.vpnpiatunnel.com UDP 1234

 

I saved and copied the file over to the proper directory for the docker and started it back up. Now I get expected behavior in the logs and get the end results once the VPN communication gets established. 

 

 SABnzbd process is listening on port 8080

 

Now I am able to get into the WebUI and my reinstalled docker already had all of its config settings in tack as well. I ran verification tests to my nzb providers and made sure my other dockers such as sonarr/raddar were able to verify test connectivity to sabnzbd and to go through the download request process.

 

As of result of all this I have no idea why my conf file had multiple entries. If it was there before and whatever change/requirement was made in this docker update that occurred must of tightened up some requirements and saw that this was an issue in the conf file. Not a deal breaker but when you start to understand the order of behavior with this docker and your setup it certainly helps to walk through the process to better troubleshoot.

 

Thanks for taking the time to read this and hope this might help someone down the line. Thanks.

 

 

 

Link to post

Got everything back up and running, I have sonarr, radarr and nzbyhdra2 running inside this container, and I was able to quickly get nzbhydra back up and running but I ran into a wall with sonarr. I ended up fixing by mapping the port to the internal port vs the external port. For example for my SABNZBD installation, the port 8080 is mapped to 6700 externally, and while I previously connected sonarr and radarr via IP:6700, I not only had to change from IP -> localhost but also 6700 -> 8080. 

 

Not sure if its worth adding to the FAQ because my setup was weird/bad, but if anyone else runs into issues trying to connect sonarr and radarr, make sure not only is the internal IP set to localhost, but also the internal ports. 

 

Thanks again for everything @binhex! you the GOAT.

Link to post

Hi ,

 

After the last two updates of binhex/arch-sabnzbdvpn (3.2.0)  I have also had issues with Radarr & sonarr connecting to binhex/arch-sabnzbdvpn .

Found that I needed to turn of proxy function for Radarr & sonarr that runs through 8118 in sabnzbdvpn.

 

This is not what I want to do, but so far have been the option where I can keep all the functions in the arch-sabnzbdvpn ON. (VPN, STRICT_PORT_FORWARD and ENABLE_PRIVOXY)

It does not seem like the tick off for the "Bypass Proxy for Local Addresse" in sonarr & Radarr does what it should do.

 

So any help on this issue would be greatly appreciated. 

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.