Jump to content
Squid

[Plugin] CA Fix Common Problems

1136 posts in this topic Last Reply

Recommended Posts

Hello

I am getting the warnings seen in attached screenshot.

Where does this plugin find the urls suggested? Sorry if I seem a bit paranoid, but I get red flags adding stuff from repos that doesn't seem associated with the main projects :P

Also, was this check recently added to the plugin, or did something suddenly go missing from my install?

Thanks

warnings.PNG

Share this post


Link to post

Just hit apply fix. The template guys weren't filling out the field properly so CA is now doing it automatically for them

Sent from my NSA monitored device

Share this post


Link to post

Months ago I reported an issue where this plugin stopped working. It would stall while scanning and never refresh the page. If there were no errors, you could never see the plugin page because it would auto-scan (undesirable) and then hang with no feedback. This behavior is gone now. I don't know if you made changes but assuming you didn't there are some environmental changes on my end that could have contributed to this.

I recently relocated my machine back to a network I manage (HOME) from the network I was a guest (INLAWS) in. HOME is the same network my server was in for years before the problem with the FCP plugin emerged. It's the same router and same setup.

Two differences between these environments:

First, at HOME I control the router and I have internal horizon DNS with reverse records for everything. This cleans up a lot of networking.

Second, at HOME the unraid server is on a physical connection to the LAN whereas at the INLAWS it was on a wireless bridge due to lack of proper wiring.

 

I hope this contributes something to others' troubleshooting.

Share this post


Link to post

I am currently setting up a new and upgraded install for an existing array that I has served me well for some time. 

 

Initially I was able to use the Fix Common Problems. Now every time it begins to Scan it either hangs or stops on the pop up menu. 

 

The only action I can think of prior to this was moving various common folders off of Disk 1 to the Cache Drive (SSD), i.e. appdata, isos etc. I see other posts on various forums reporting it hanging, but have had no success from suggestions. Uninstalling and reinstalling has not been successful. 

 

I would be very open to any community suggestions.

Share this post


Link to post

Let it sit for 5 minutes.  Then just reload the page.

Share this post


Link to post
On 9/19/2019 at 8:07 AM, Squid said:

Let it sit for 5 minutes.  Then just reload the page.

Unfortunately, I tried and let it run whilst at work and overnight - many hours with the dialog box still in place. 

 

In fact I had a window open when I saw your suggestion and tried to reload - no good.

Share this post


Link to post

I think maybe I'm getting a false positive-

SafariScreenSnapz174.thumb.jpg.d196b535bfdf481821d1f58744912787.jpg

 

Applying the fix didn't work, got the same message after a rescan. Went to the url shown in the fix popup window (https://raw.githubusercontent.com/ninthwalker/docker-templates/master/Ninthwalker/NowShowing v2.xml) and copy/pasted to /boot/config/plugins/dockerMan/templates-user/my-NowShowingv2.xml. Still getting the same warning when I rescan.

Share this post


Link to post

I heard about it in another thread for that template.  Won't have time to look at that one until tomorrow night.

Share this post


Link to post
1 hour ago, Squid said:

I heard about it in another thread for that template.  Won't have time to look at that one until tomorrow night.

 

26 minutes ago, Squid said:

fixed

It’s tomorrow already? 😀

Share this post


Link to post
On 9/19/2019 at 5:52 PM, zzsprade said:

Unfortunately, I tried and let it run whilst at work and overnight - many hours with the dialog box still in place. 

 

In fact I had a window open when I saw your suggestion and tried to reload - no good.

I was able to fix mine hanging by updating my DNS settings in the router & then rebooting UnRaid to pick up those changes.  My DNS server was no longer available, so somehow it was causing Fix Common Problems to hang at the scan screen.

Share this post


Link to post
Posted (edited)

Today's update should fix (and by that I mean damn well better fix) the occasional problem with some users and the "Scanning" popup never disappearing.

 

One side-effect of the fix though is that now the minimum unRaid version required for FCP is 6.7.0

 

Upshot is that *if* for some reason the popup now never goes away, the test hanging will be displayed in the popup.

Edited by Squid

Share this post


Link to post

For those of us stuck on 6.6.7 until the slow array performance is fixed in 6.8, is there a way to revert FCP to the prior version?

Share this post


Link to post
Posted (edited)

It won't let you upgrade to the new version.  But, when on 6.6 the plugin system will continually let you know an upgrade is available even though you can't upgrade to it (this behavior was fixed in 6.7.x)

Edited by Squid

Share this post


Link to post

Ah, thank you. I misinterpreted the 'incompatible' error message to mean that it had updated, but the new version was incompatible. Now I see that it didn’t actually update. My mistake, apologies. 

Share this post


Link to post
Posted (edited)
9 minutes ago, Lignumaqua said:

Ah, thank you. I misinterpreted the 'incompatible' error message to mean that it had updated, but the new version was incompatible. Now I see that it didn’t actually update. My mistake, apologies. 

Yeah, FCP will complain about that.  But it's not valid and a false positive (that I never considered and will ultimately have to pop out an update to FCP to handle it -> although that'll be a catch-22 as you won't be able to install the update to stop the false positive)

 

Eventually, most of my plugins will gradually be gravitating over to requiring 6.7+ as the fix that went into FCP is a far better way of handling certain things that the various plugins do.  

 

The next plugin queued up for me to fix is Cleanup Appdata.  Followed possibly by Appdata Backup/Restore.  I'd love to add the change into CA itself, but can't actually justify putting it in when there's no issues with it.

Edited by Squid

Share this post


Link to post
Posted (edited)

Dear developer, I note this morning you have made the minimum unraid version 6.7.  While this may be sensible or required for some reason, it would be great to at least wait until it is not required for most people to run 6.6.7 due to the two horrendous and seriously impactful bugs present in newer versions of unraid (apparently fixed in 6.8 only).

 

EDit: Just saw previous posts.  So it won't upgrade.  Awesome - you guessed my query before I even asked it!

 

Many thanks.

Edited by Marshalleq

Share this post


Link to post

Running Unraid 6.7.2. I had an issue with the hanging FCP scan screen a couple weeks ago that I was able to resolve.

 

After updating FCP today, I am now getting the hanging screen error.

 

The scan never completes, and the screen has not closed for over 30 min. I've tried multiple different attempts, uninstalling/reinstalling FCP, and rebooting Unraid. So far I haven't been able to find a solution to this issue.

 

Here is a thread where I discuss what solved the issue last time.

 

Unraid FCP hang.jpg

Share this post


Link to post
1 hour ago, Giggity_Grant said:

Running Unraid 6.7.2. I had an issue with the hanging FCP scan screen a couple weeks ago that I was able to resolve.

 

After updating FCP today, I am now getting the hanging screen error.

 

The scan never completes, and the screen has not closed for over 30 min. I've tried multiple different attempts, uninstalling/reinstalling FCP, and rebooting Unraid. So far I haven't been able to find a solution to this issue.

 

Here is a thread where I discuss what solved the issue last time.

Can you confirm that you're running v2019.10.06  Also, has anything ever showed up underneath the "... This may take a minute.."  What browser are you running?

Share this post


Link to post
Posted (edited)

@Squid Just confirmed that I am running v2019.10.06 (see attached screenshot).

 

IMG_0204.thumb.jpg.f5f0d578ccc39e162d2ed0937ad60e97.jpg

 

Nothing has shown up under "...this may take a minute" on any of the attempts that I can recall. I just ran another attempt to verify, and I didn't see anything show up. 

 

I'm using Safari on iOS at the moment. I had to VPN into my network from my phone, since I can't do so from my work computer. I'll give Chrome and Firefox a shot when I get home later tonight.

Edited by Giggity_Grant

Share this post


Link to post

Running 6.7.2. The latest update to FCP won't install; I get a 502, Bad Gateway error.

So I figured I'd uninstall the plugin, and download the new version. But when I try to uninstall, I get a 502, Bad Gateway error.

I went to the apps tab, searched for FCP, and when the window opened, clicked on "Install the Update Here," and it took me back to the plugins page. Once again, I get the 502 Bad Gateway error.

 

Any suggestions as to what I might be doing wrong?

Share this post


Link to post
On 10/10/2019 at 1:30 AM, SJOWG said:

Any suggestions as to what I might be doing wrong?

You'd need to post the diagnostics.  There is something else going on with your server.

Share this post


Link to post

plugin: updating: fix.common.problems.plg
plugin: downloading: https://raw.githubusercontent.com/Squidly271/fix.common.problems/master/archive/fix.common.problems-2019.10.12-x86_64-1.txz ... failed (Invalid URL / Server error response)
plugin: wget: https://raw.githubusercontent.com/Squidly271/fix.common.problems/master/archive/fix.common.problems-2019.10.12-x86_64-1.txz download failure (Invalid URL / Server error response)
 

 

Unable to update.  

 

 

--------------

 

DISREGARD

 

That was strange.  From the plugins page, I got the aforementioned error.  However, when I went to the update assistant under tools, a yellow bar appeared on the top of the browser window telling me Fix Common had an update, and "click here", so I did.  Updated fine at that point.

 

Edited by tucansam

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.