Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

4077 posts in this topic Last Reply

Recommended Posts

On 2/19/2020 at 1:05 PM, Kewjoe said:

I'm having an issue with Only Office. I followed spaceinvaderone's video. OnlyOfficeDocumentServer docker is set up. When i go to my "documentserver.mydomain.com" it shows "Document Server is running" with a green checkmark. I install the Only Office app in Nextcloud, i added the "documentserver.mydomain.com" to the Only Office options. It accepts it and saves. I create a document and go inside and i just get a blank screen. No errors (Using Firefox)

 

The only clue I have, using Chrome i notice i get an error message in the middle of the screen only if i hover my mouse over which says "documentserver.mydomain.com refused to connect". I triple checked my nextcloud settings, my letsencrypt settings.. the documentserver subdomain conf file. I've removed and re-added both the docker and the only office app. Nextcloud, Let's Encrypt and the DocumentServer docker are on my proxynet network.

 

Any one got any ideas?

I'm having the same issue, has anyone figured this out?.  The only browser that seems to load the OnlyOffice Editor is Internet Explorer, other browsers show a blank page as @Kewjoe stated above.

 

Share this post


Link to post

Hi Guys,

 

I'm having an issue that I would really like to solve myself... but struggling to do so.

 

I'm getting an error when trying to copy large files from my desktop (anything 3GB or larger it seems) and the files simply refuse to sync. In the windows application I see:

[file location]: Connection Closed

 

Then then when I log into the nextcloud control panel and look at the logging I see a whole string of fatal errors such as:

[webdav] Fatal: Sabre\DAV\Exception: Error while copying file to target location (copied bytes: 0, expected filesize: 100000000 ) at <<closure>>

 0. /config/www/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php line 156
    OCA\DAV\Connector\Sabre\File->put(null)
 1. /config/www/nextcloud/apps/dav/lib/Upload/UploadFolder.php line 47
    OCA\DAV\Connector\Sabre\Directory->createFile("00000012", null)
 2. /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 1096
    OCA\DAV\Upload\UploadFolder->createFile("00000012", null)
 3. /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 525
    Sabre\DAV\Server->createFile("uploads/paul/2178915309/00000012", null, null)
 4. <<closure>>
    Sabre\DAV\CorePlugin->httpPut(Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {})
 5. /config/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    call_user_func_array([Sabre\DAV\CorePlugin {},"httpPut"], [Sabre\HTTP\Requ ... }])
 6. /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 479
    Sabre\Event\EventEmitter->emit("method:PUT", [Sabre\HTTP\Requ ... }])
 7. /config/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 254
    Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {})
 8. /config/www/nextcloud/apps/dav/lib/Server.php line 319
    Sabre\DAV\Server->exec()
 9. /config/www/nextcloud/apps/dav/appinfo/v2/remote.php line 35
    OCA\DAV\Server->exec()
10. /config/www/nextcloud/remote.php line 165
    require_once("/config/www/nex ... p")

PUT /remote.php/dav/uploads/paul/2178915309/00000012
from [removed] by paul at 2020-04-04T17:45:56+00:00

A bit of googling has lead me to believe this is related to a PHP config, but I can't for the life of me figure out where the config file is that I should be changing.

Everything in the server is up to date, as far as I am aware. I'm using Nextcloud along with LetsEncrypt and MariaDB. Is it a file in LetsEncrypt that I should be adjusting?

Share this post


Link to post
On 4/1/2020 at 8:41 AM, nraygun said:

My instance of Nextcloud is also stuck.

I edited the config.php file as you recommended and now it just says "Update in process". Before it said it was on step 6.

Has anyone else gotten their Nextcloud back up and running after trying to upgrade to 18.03? Mine is dead in the water right now!

If it is not continuing, try a repair.

Open a nextcloud console and enter something like this

sudo -u abc php /config/www/nextcloud/occ maintenance:repair

after the repair you could try 

sudo -u abc php /config/www/nextcloud/occ upgrade

to attempt the completion of the upgrade via commandline.

Then restart and see if it starts up.

 

Another way to turn maintenance mode off is something like below.

sudo -u abc php /config/www/nextcloud/occ maintenance:mode --off

 

If all else fails, there should be a backup of your old config in the nextcloud data folder. You can copy the directory structure back to the appdata directory using crusader and restart nextcloud.

 

 

Share this post


Link to post

Hi,

I have several errors with moving files through the web interface of nextcloud. I sadly have no clue how to fix them.

Problem:

I have an external share connected via smb. It´s a share from a friends server, also running Nextcloud.

Download through the the web interface works, but whenever I try to copy/ move/ delete files from the external share it i get an error e.g." file can´t be copied". Strange thing is, some of those files are copied to my own nextcloud share, even with the error message.

 

Could someone explain to me how to trouble shoot this?

 

 

 

Share this post


Link to post
On 4/3/2020 at 12:47 AM, Edvard_Grieg said:

I've been running into an issue and just banging my head on a wall for the past few days.  I've been trying to get nextcloud installed- I've followed the lsio blog instructions and SpaceInvaders video to a t, but invariably I'm never able to complete the Nextcloud install setup.  Each time I go through and at a minimum drop the nextcloud database, but have on multiple occasions nuked the mariadb and nextcloud containers and their respective appdata folders (and the lingering nextcloud files from the \data directory).

 

I am not even trying to get a reverse proxy working yet, even local access would be a good first step.

 

So at this point what I run into is I'm able to install the mariadb just fine without any issues, and update the bind address and create the nextcloud user and database in the db without any issue. 

 

I then create the lsio nextcloud container; however when I run the actual nextcloud setup (populating credentials etc), I ultimately get a 504 Bad Gateway Nginx Timeout.  It appears to be a legit timeout as there are tables being written into the database, so it doesn't appear to be a full communication/access issue, but there is definitely something going wrong.

 

Docker configs are essentially the defaults with the lsio changes (setting password for mariadb, changing port to 444 for the nextcloud docker, and then pointing to appropriate shares)

 

From a log perspective, the \data\nextcloud.log only gives some information about not being able to process a file during the install.

 

The appdata/nextcloud/logs/nginx/error.log has the following:


2020/04/02 21:40:30 [error] 349#349: *7 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <LAPTOP_IP>, server: _, request: "POST /index.php HTTP/2.0", upstream: "fastcgi://127.0.0.1:9000", host: "<UNRAIDSERVERIP>:444"

The appdata/nextcloud/logs/nginx/access.log doesn't have much


<DOCKER IP> - - [02/Apr/2020:21:34:37 -0600] "GET /data/htaccesstest.txt HTTP/1.1" 400 255 "-" "Nextcloud Server Crawler"
<LAPTOP IP> - - [02/Apr/2020:21:34:37 -0600] "GET /favicon.ico HTTP/2.0" 200 2464 "https://<UNRAID IP>:444/index.php" "Mozilla/5.0 (X11; CrOS x86_64 12871.57.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.81 Safari/537.36"
<DOCKER IP> - - [02/Apr/2020:21:39:13 -0600] "GET /data/htaccesstest.txt HTTP/1.1" 400 255 "-" "Nextcloud Server Crawler"
<LAPTOP IP> - - [02/Apr/2020:21:39:13 -0600] "GET / HTTP/2.0" 200 2475 "-" "Mozilla/5.0 (X11; CrOS x86_64 12871.57.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.81 Safari/537.36"
<DOCKER IP>- - [02/Apr/2020:21:39:30 -0600] "GET /data/htaccesstest.txt HTTP/1.1" 400 255 "-" "Nextcloud Server Crawler"
<LAPTOP IP>- - [02/Apr/2020:21:40:30 -0600] "POST /index.php HTTP/2.0" 504 569 "-" "Mozilla/5.0 (X11; CrOS x86_64 12871.57.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.81 Safari/537.36"
<DOCKER IP> - - [02/Apr/2020:21:40:30 -0600] "GET /data/htaccesstest.txt HTTP/1.1" 400 255 "-" "Nextcloud Server Crawler"
<LAPTOP IP> - - [02/Apr/2020:21:40:30 -0600] "GET /favicon.ico HTTP/2.0" 200 2474 "https://<UNRAID IP>:444/index.php" "Mozilla/5.0 (X11; CrOS x86_64 12871.57.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.81 Safari/537.36"
<DOCKER IP> - - [02/Apr/2020:21:40:31 -0600] "GET /data/htaccesstest.txt HTTP/1.1" 400 255 "-" "Nextcloud Server Crawler"
<LAPTOP IP> - - [02/Apr/2020:21:40:31 -0600] "GET /favicon.ico HTTP/2.0" 200 2470 "https://<UNRAID IP>:444/index.php" "Mozilla/5.0 (X11; CrOS x86_64 12871.57.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.81 Safari/537.36"

 

The appdata/nextcloud/logs/php/error.log doesn't have much


[02-Apr-2020 21:28:29] NOTICE: fpm is running, pid 337
[02-Apr-2020 21:28:29] NOTICE: ready to handle connections
[02-Apr-2020 21:37:52] NOTICE: Terminating ...
[02-Apr-2020 21:37:52] NOTICE: exiting, bye-bye!
[02-Apr-2020 21:39:12] NOTICE: fpm is running, pid 330
[02-Apr-2020 21:39:12] NOTICE: ready to handle connections

 

I'm hopeful someone has an idea of what might be going wrong and how to fix it.

I ended up getting this working with the other docker image, a few things I tweaked...

set binlog_format = ROW and transaction_isolation = read-committed per nextcloud documentation

 

I ended up with the same error, but from some other googling, looks like it's a purely front-end error, so I ran "mysql -uroot -p -e "show processlist" from inside the mariadb container to watch until there were no more nextcloud processes being run.  I then restarted the nextcloud container and it appears to be working (albight slower than expected)

Share this post


Link to post

I need some help.

I had nextcloud working fine just a few days ago. But decided to add a onlyoffice document server to better manage documents. I followed the walk through by spaceinvader One and was 95% of the way done. But at the end when I was trying to add the document server to the nextcloud settings. I got an ssl error. After doing some digging realized i forgot to add the subdoamin. So I went and added the subdomain to letsencrypt and the provider.

 

Here is where I think i messed up. I went back to nextcloud but instead of refreshing the page i just tried to click connect again. I don't know if nextcloud was still trying to connect to the document server. But Boom! Nextcloud fails to refresh the webpage, then i get a message that the connection with the server has been lost. I've tried opening nextcloud in a different tab. new browser. Restarted the nextcloud image. updgraded the nextcloud image. restarted all associated images like let's encrypt and MariaDB. i have restarted them a couple of times now to no avail.

 

I can't connect to nextcloud through the web at all. I started trying to dig into the logs and errors. but honestly I don't really know where they are. The log next to the docker looked fairly normal. Except for the S6-finish warning. (Shown Below)

 


[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
s6-svwait: fatal: supervisor died
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.

 

In the Nextcloud docker log folder the error.log is empty which makes me wonder if its a nextcloud issue or an issue with letsencrypt but i'm completely out of ideas. I haven't changed the nextcloud subdomain.conf file since i was just adding the document server.

 

I don't know if it was a timing error that i ran into or if I corrupted the nextcloud settings. But i don't know how to refresh nextcloud and some settings like the onlyoffice one i was trying to change without loosing my data and the other user's / settings i've set.

 

Any help would be greatly appreciated.

Share this post


Link to post
Posted (edited)

Just a heads up OnlyOffice removed Web/mobile editing from version 5.5.0 of Community Document Server. Please take a look at the Next cloud forum here.

 

I tried opening office document in iOS app and got the warning of viewing only, I am able to edit in desktop browser just not in mobile browser/app. I am running seperate only office docker.

 

 

Edited by harshakavuri

Share this post


Link to post
On 3/31/2020 at 6:41 PM, nraygun said:

My instance of Nextcloud is also stuck.

I edited the config.php file as you recommended and now it just says "Update in process". Before it said it was on step 6.

Has anyone else gotten their Nextcloud back up and running after trying to upgrade to 18.03? Mine is dead in the water right now!

 

Just saw this and I was stuck for a long time. 

 

The solution was to follow the instructions found in this forum -

 

All hail CHBMB! 😉

 

The problem is that a lot of folks don't use the container from linuxserver.io method of installing Nextcloud - therefore most trying to help assume it is a manual docker install or some other method and provide fixes based on that. Especially if you are using some other forum (ie Nextcloud forum).

 

It's important to make sure when asking a question in any forum with regards to this container is to state what and how you have installed.

 

This method has worked for me every time - on Nextcloud latest.

 

Be careful, some of the commands don't work if you copy and paste from the forum. If you copy and paste a command and it doesn't work - enter it in manually. Or, enter them all manually.

 

Hope this helps.

 

 

 

 

Share this post


Link to post

I'm having a problem with auto uploader from my phone. Pictures and files are uploading twice, causing a file upload conflict and each time I have to select which I've I want to keep. 

What's seems to be happening is that the files are uploading via the domain (user@cloud.mydomain.tld) and the server IP address (user@10.10.10.10).

I'm not sure if it's relevent, but I'm using letencrypt reverse proxy.

What's the best way to resolve this please?

Share this post


Link to post

Hey, I am planning to use NextCloud as Webinterface to UNRAID's shares.

 

However, I feel quite uncomfortable that i would have the same users+passwords stored on more than one location. If a password would have to get changed, we have to change it on unraid AND nextcloud.

What is the best way to prevent this?

 

Is there something like using unraid as LDAP server and using this LDAP server on NextCloud?

Share this post


Link to post
1 hour ago, Greyberry said:

Hey, I am planning to use NextCloud as Webinterface to UNRAID's shares.

 

However, I feel quite uncomfortable that i would have the same users+passwords stored on more than one location. If a password would have to get changed, we have to change it on unraid AND nextcloud.

What is the best way to prevent this?

 

Is there something like using unraid as LDAP server and using this LDAP server on NextCloud?

Why do you need the users on both nextcloud and unraid?

If you create a file with a user in nextcloud, that file will get the user:group nobody:users and not the user in nextcloud.

Share this post


Link to post
6 minutes ago, saarg said:

Why do you need the users on both nextcloud and unraid?

If you create a file with a user in nextcloud, that file will get the user:group nobody:users and not the user in nextcloud.

I create(d) users on the unraid-server. These users should be able to login into nextcloud aswell, without the hassle of creating them on both.

Share this post


Link to post
11 minutes ago, Greyberry said:

I create(d) users on the unraid-server. These users should be able to login into nextcloud aswell, without the hassle of creating them on both.

But if they are only going to use nextcloud, why didn't you create them there?

 

There is no way to get the users created in unraid automatically created in nextcloud.

Share this post


Link to post
20 minutes ago, saarg said:

But if they are only going to use nextcloud, why didn't you create them there?

 

There is no way to get the users created in unraid automatically created in nextcloud.

They are using both nextcloud and the smb shares.

 

Therefore the question if it is somehow possible to use unraid (+ its credentials) as an ldap server. Because NextClaud should be able to use ldap or use them directly.

Share this post


Link to post
22 minutes ago, Greyberry said:

They are using both nextcloud and the smb shares.

 

Therefore the question if it is somehow possible to use unraid (+ its credentials) as an ldap server. Because NextClaud should be able to use ldap or use them directly.

Unraid doesn't support LDAP, so you then need to build a plug-in that enables LDAP or make a feature request.

Share this post


Link to post

oh, i thought because of it supporting active directory its also supporting ldap.

okay, there it goes my vision of one central user-database for all services. 🤷‍♂️ Thank you for your time and clarifying this up. 🙂

Share this post


Link to post
Posted (edited)

Hey i got another question regarding certificates.

 

I don't really feel the need of a reverse proxy. Nextcloud will be the only service exposed to the Internet.

So i have this wildcard certificate of my domain (e.g. *.server.com) which is provided by the company where i bought my Domain. This is a .pem file and in it is the Certificate Request, Private Key and Certificate and gets extended every 30 days automatically.

 

Can I install this Certificate on the container somehow? Or why would this be a bad idea?

Edited by Greyberry

Share this post


Link to post

Hi, hope everyone is ok during these strange times?

 

I suddenly finding I have the time am trying to fix all the annoying little problems with my server! I'm mostly getting there and have found solutions to most things and so thought I'd fix my docker image filling up whenever anyone downloads from Nextcloud! I started Nextcloud which has been off for over a month and get a blank web page with this text on it?

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

 

tower-diagnostics-20200417-1519.zip error.log

Share this post


Link to post

Nextcloud log attached also it was one of only 2 files in the nextcloud folder, I'm sure there were more? Other one is owncloud.db

nextcloud.log

Share this post


Link to post
Nextcloud log attached also it was one of only 2 files in the nextcloud folder, I'm sure there were more? Other one is owncloud.db
nextcloud.log

I don’t know enough but I think docker img filling up has something to do with why large file upload is an issue using iOS client app.

Share this post


Link to post
7 minutes ago, blaine07 said:


I don’t know enough but I think docker img filling up has something to do with why large file upload is an issue using iOS client app. emoji848.png

Thanks but don't use the iOS client this is happening whenever anyone downloads from the server not uploads and happens whether they use Windows or Mac!

Share this post


Link to post

 

Hello,

I'm fairly new to unraid (about 4 months) and love it so far but I'm having a small issue and I hope someone can shed light on it.

 

When sharing a file in Nextcloud using the share via email app it seems that the file is being copied into the docker image before its sent. Unraid kept sending alerts of docker image usage at 95% while the file was being downloaded from my server. The file in question was about 8GB in size. It was also not coming from the Nextcloud share, I have an external storage folder added in Nextcloud and mapped in the docker with config type: Path, Host path: /mnt/user/public and Container path: /public.

 

Hope someone has see this before become I'm lost.

Share this post


Link to post

I know the "config" should be in a cache-prefer share, and my appdata is in a cache-prefer share.

 

What about the "data" folder? Should it be on a cache-prefer/enable share? or just cache:no share? I followed spaceinvaderone guide on YouTube and he used cache-enable, just want to make sure if it is right, cuz I just suddenly thought that would be a breach of not having the things on cache in the array until mover does its job.

 

P.S. I used mariadb as the db.

 

Thanks!

Share this post


Link to post
On 4/19/2020 at 10:04 AM, PzrrL said:

What about the "data" folder? Should it be on a cache-prefer/enable share? or just cache:no share? I followed spaceinvaderone guide on YouTube and he used cache-enable, just want to make sure if it is right, cuz I just suddenly thought that would be a breach of not having the things on cache in the array until mover does its job.

WHen cache prefer is used, mover does not move the files to array unless the Cache drive is full. So that's why you want the config to stay on the SSD.

for the 'data' folder I wold use Cache Yes if you want to write the data fast to the SSD and later mover gets the files to the array, or Cache No to write the files directly to the array.

If you have enough free space on cache drive, you may want to use Cache Yes.

Share this post


Link to post

Do I need to regularly update Nextcloud from within Nextcloud or do the Docker updates keep Nextcloud up to date?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.