[Support] Linuxserver.io - TVHeadend


1209 posts in this topic Last Reply

Recommended Posts

14 hours ago, Zan said:

 

This could also be due to an issue with the cx23885 code not working well with VT-d /VT-x enabled. See https://www.spinics.net/lists/linux-media/msg119385.html

I've changed my syslinux.cfg to set the cx23885 to debug level 5 which has helped - you might want to give that a try and see if it helps

eg.

append initrd=/bzroot,bzroot-gui cx23885.debug=5

 

I changed my syslinux.cfg file in the flash\syslinux folder to the following and rebooted but it didn't seem to help :(

default menu.c32
menu title Lime Technology, Inc.
prompt 0
timeout 50
label unRAID OS
  menu default
  kernel /bzimage
  append initrd=/bzroot
label unRAID OS GUI Mode
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui cx23885.debug=5
label unRAID OS Safe Mode (no plugins, no GUI)
  kernel /bzimage
  append initrd=/bzroot unraidsafemode
label unRAID OS GUI Safe Mode (no plugins)
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui unraidsafemode
label Memtest86+
  kernel /memtest
label Xen/unRAID OS
  kernel /syslinux/mboot.c32
  append /xen --- /bzimage --- /bzroot
label Xen/unRAID OS Safe Mode (no plugins)
  kernel /syslinux/mboot.c32
  append /xen --- /bzimage --- /bzroot unraidsafemode


 

Edited by Yousty
Link to post
  • Replies 1.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: TVHeadend Application Site: https://tvheadend.org/ Docker Hub: https://hub.docker.com/r/linuxserver/tvheadend/ Github: https://github.com/linuxserver/docker-tvheadend

You need to install the driver to use your adapter. Then use /dev/dvb as the path for the device pass through. If you are using 6.9.x I don't know if the permissions are set correctly, so make sure no

You need to configure the grabber you want to use, then run it, then map epg source to the channel. There is a link in the first post to the readme on github which has information about configuring yo

Posted Images

Someone has this running with plex plugin? 

 

https://forums.plex.tv/discussion/271068/rel-livetvh-live-tv-streaming-with-tvheadend

 

I would like to install this on my server, but im note sure which hardware i should buy.

 

I would like a usb stick, because my server is already very full, and so i also read the stick could get hot, so i would liek to place it outside the case.

 

Someone can give me any advice and or can say anthing about the plex plugin, do i need plex pass for it? (i guess not, but not sure)

 

How good is this overall working!?

 

Do my server need any special hardware like vtd or seomthing?


Edit: okay, i need DVBS(2?) i have sat antenna...

Edited by nuhll
Link to post

I have no idea whats wrong.

Edit: this forum software is so annoying. I cant edit the last quote and cant write something under it.

So i write here now.

 

I use the guided steps from tvheadend, select german, add a plex user, select network 2 "DVB-S Network" (it shows my adapter), at defined muxes i choose astra 19.2E, it scans, but only find 1 muxe, while scanning it shows 84db signal power.

 

THe fun part is, i had it one time scanning (and it was finding things and adding more and more muxe), but i choose some random muxe, because i had to look up which is the correct one.


Between every try i rebooted unraid, removed app config and removed docker.

 

Can anyone help me?

 

Es scheint ein Problem mit dem Datenabruf von Tvheadend zu geben. Versuche neu zu verbinden...
Wiederverbunden mit Tvheadend
2018-01-30 00:15:53.369 mpegts: 12551.5V in DVB-S Netzwerk - tuning on Montage Technology M88DS3103 #0 : DVB-S #0
2018-01-30 00:15:53.720 subscription: 0001: "epggrab" subscribing to mux "12551.5V", weight: 4, adapter: "Montage Technology M88DS3103 #0 : DVB-S #0", network: "DVB-S Netzwerk", service: "Raw PID Subscription"
2018-01-30 00:15:53.939 linuxdvb: Unable to provide UNC value.

 

Quote

 


Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: EEPROM ID = 26 00 01 00, EEPROM hash = 0xba3c7fa0 Jan 29 22:29:08

Unraid-Server kernel: em28xx 3-4:1.0: EEPROM info:

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: microcode start address = 0x0004, boot configuration = 0x01

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: AC97 audio (5 sample rates)

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: 500mA max power

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: Table at offset 0x27, strings=0x148c, 0x1874, 0x0a6a

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: Identified as PCTV DVB-S2 Stick (461e) (card=92) Jan 29 22:29:08

Unraid-Server kernel: em28xx 3-4:1.0: dvb set to isoc mode.

Jan 29 22:29:08 Unraid-Server kernel: usbcore: registered new interface driver em28xx

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: Binding DVB extension

Jan 29 22:29:08 Unraid-Server kernel: i2c i2c-2: Added multiplexed i2c bus 3

Jan 29 22:29:08Unraid-Server kernel: sd 7:0:1:0: [sdc] Write Protect is off

Jan 29 22:29:08 Unraid-Server kernel: sd 7:0:1:0: [sdc] Mode Sense: 7f 00 00 08

Jan 29 22:29:08Unraid-Server kernel: sd 7:0:1:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

Jan 29 22:29:08Unraid-Server kernel: ts2020 3-0060: Montage Technology TS2022 successfully identified

Jan 29 22:29:08 Unraid-Server kernel: a8293 2-0008: Allegro A8293 SEC successfully attached

Jan 29 22:29:08 Unraid-Server kernel: dvbdev: DVB: registering new adapter (3-4:1.0)

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: DVB: registering adapter 0 frontend 0 (Montage Technology M88DS3103)...

Jan 29 22:29:08 Unraid-Server kernel: dvbdev: dvb_create_media_entity: media entity 'Montage Technology M88DS3103' registered.

Jan 29 22:29:08 Unraid-Server kernel: dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: DVB extension successfully initialized

Jan 29 22:29:08 Unraid-Server kernel: em28xx: Registered (Em28xx dvb Extension) extension

Jan 29 22:29:08 Unraid-Server kernel: em28xx 3-4:1.0: Registering input extension

Jan 29 22:29:08 Unraid-Server kernel: Registered IR keymap rc-pinnacle-pctv-hd

 

 

Quote
unRAID Version: 6.4.1-rc1
DVB Version: LibreELEC
Driver Version: 1.2.2
DVB Kernel: Detected
DVB Adapter Drivers: Detected
DVB Adapter 0:

Montage Technology M88DS3103

 
 

 

Using  "linuxserver/tvheadend:release-4.2" but i also tried other versions.

 

The adapter shows up (i added device /dev/dvb). Btw i want to use dvb-s.

 

I tried adding astra 19.2E. But under muxes it just shows "ERROR"

Edited by nuhll
Link to post

I don t know why. But now its working, since yesterday i probably tried it 20 times, with restarting unraid, removing docker inkl. config. This time it addes much muxes and services for astra... lets say i get it working now... should i upgrade when a new update comes out? Or do i risk its not working anymore? 

 

(should i enable auto update)

Edited by nuhll
Link to post

Only problem left is that (i want to use plex with tvheadend, so i got LiveTVh.Bundle) when i watch a TV show, and i close it... tvheadend doesnt recognize it and under connections i can see its still sending data... after.. i think 5 min, the old stream gets stoped and i can play back again.

 

Just btw, it doesnt matter if i watch via .m3u or plex, most times he dont recognize when i stop watching. So i need to wait 5 min to switch to the next TV.

Link to post
15 hours ago, nuhll said:

Only problem left is that (i want to use plex with tvheadend, so i got LiveTVh.Bundle) when i watch a TV show, and i close it... tvheadend doesnt recognize it and under connections i can see its still sending data... after.. i think 5 min, the old stream gets stoped and i can play back again.

 

Just btw, it doesnt matter if i watch via .m3u or plex, most times he dont recognize when i stop watching. So i need to wait 5 min to switch to the next TV.

Hard to do anything about this if you aren't providing any logs/examples of this happening. If you are having issues with the Plex TVH plugin, you need to seek support from the plugin developer, not us.

 

Just an FYI, I've never seen an issue with tvheadend leaving a channel stream open, possibly something to do with your hardware? My setup is a Digitbit R1 Network Tuner which is controlled by TVHeadend and the content is viewed via Kodi and it's TVHeadend PVR plugin.

Link to post
On 14.12.2017 at 9:48 AM, saarg said:

 

You can try to add :xenial_test in the repository field. It's a test we did 7 months ago. 

But thinking back, I think I didn't find this on my own tvheadend container when you mentioned it the last time? It was Ubuntu based. 

 

On 17.12.2017 at 8:05 AM, himisk71 said:

Ok, no problems so far! docker is working good. Only the tvheadend is not the best choice, because around this version (4.3-48) it comes to problems with lagging on some channels with the following spamming logs:

 


2017-12-17 07:56:40.975 [WARNING] parser: DVB-C Netzwerk/642MHz/zdf_neo HD: DVBSUB @ #540: PTS and PCR diff is very large (400498)

 

this was solved since around version ~ 4.3-100 i think.  so it has nothing to do with the docker.

 

hi there!

 

i am really happy with the  ":xenial_test"-release of the docker! but is there a chance to get a updated version of this to get a newer tvheadend release?  on some channels the stuttering described above is a little bit annoying..

Link to post
9 hours ago, himisk71 said:

 

 

hi there!

 

i am really happy with the  ":xenial_test"-release of the docker! but is there a chance to get a updated version of this to get a newer tvheadend release?  on some channels the stuttering described above is a little bit annoying..

 

No. It was a test build only. 

Link to post

Hi all,

 

I had been using this docker successufully with Plex DVR  and tvhproxy up until approx 6 weeks or so ago when I noticed that none of my IPTV channels would work any more (DVB-S2 Is fine) To be honest I mainly use the IPTV for Motorsport and because it is off season and not had much time I have only got around to looking at it now.  

 

Basically none of my IPTV channels scan any more they all fail with authentication errors/no data stream etc.. and despite uninstalling, re-adding the m3u link nothing will make it work so I decided to install tvheadend on one of my Linux VM's and using exactly the same setup it works perfectly! 

 

What has changed since? is it the unraid OS? tvheadend? there have been loads of tvheadend docker updates but none ever work.  The version I installed on my VM is HTS Tvheadend 4.2.5-18~g951777a51~xenial and the version on my docker is HTS Tvheadend 4.3-1028~g7de759e83

 

Is anyone suffering with the same issues? 

 

Thanks in advance!

Link to post

Hi, 

 

Thanks for your help earlier, I can confirm that the IPTV is again working after installing 4.2 but I have just noticed that my DVB tuners are no longer detected in TVheadend?  I thought it maybe because I installed tvheadend on a VM so I uninstalled that and rebooted, still nothing, installed the latest Crazycat DVB OS (they are showing as detected on the DVB Plugin page) but still nothing in tvheadend, installed openelec DVB OS, again detected in the OS but not tvheadend, uninstalled tvheadend docker and deleted tvheadend folder from my appdata, reinstalled still nothing, rebooted, still nothing in tvheadend although they are both detected in the DVB OS ? Any ideas?

 

Many Thanks

Link to post
1 minute ago, mbc0 said:

Hi, 

 

Thanks for your help earlier, I can confirm that the IPTV is again working after installing 4.2 but I have just noticed that my DVB tuners are no longer detected in TVheadend?  I thought it maybe because I installed tvheadend on a VM so I uninstalled that and rebooted, still nothing, installed the latest Crazycat DVB OS (they are showing as detected on the DVB Plugin page) but still nothing in tvheadend, installed openelec DVB OS, again detected in the OS but not tvheadend, uninstalled tvheadend docker and deleted tvheadend folder from my appdata, reinstalled still nothing, rebooted, still nothing in tvheadend although they are both detected in the DVB OS ? Any ideas?

 

Many Thanks

 

Post the tvheadend template with advanced view turned on and the docker run command. 

Have you stopped the vm? 

Link to post

I've started using this docker and it's working great but I can't get it to work externally via tvhclient for instance. Has anyone else managed this? I've set firewall ports etc. but the client just always says access denied. It works fine on my internal network.

Link to post
3 hours ago, allanp81 said:

I've started using this docker and it's working great but I can't get it to work externally via tvhclient for instance. Has anyone else managed this? I've set firewall ports etc. but the client just always says access denied. It works fine on my internal network.

 

I only use it through a VPN, but might be some ports you didn't open. 

Link to post
3 minutes ago, allanp81 said:

As far as I can tell it only uses 2 ports and I've tried both. 

 

You need both 9981 and 9982. 

Are you using the wrong username password? 

Have you set allowed networks for the user to only accept local IPs? 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.