[Support] Linuxserver.io - SWAG - Secure Web Application Gateway (Nginx/PHP/Certbot/Fail2ban)


Recommended Posts

On 3/2/2022 at 9:02 PM, Matmat07_2 said:

Edit: I made a new container using swag instead of the old letsencrypt. Only changed the domain and email settings: Same result

 

Edit2: using "nc -l localhost -p 80" and shutting down the Swag container, I made sure I could access port 80 from outside. I'm not sure what else I changed, but now it works. You can always help me, but now I'l be trying to add back my old settings slowly.

 

Hi, I just had to change my domain and now I can't seem to make letsencrypt/swag work again. I changed the domain name in most files/area I could think of, but I guess I'm forgetting something important.

 

Requesting a certificate for mydomain.fun and www.mydomain.fun

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:

Domain: mydomain.fun
Type: connection
Detail: Fetching http://mydomain.fun/.well-known/acme-challenge/AxgorMtHjklmjngO0kvrKsu3Pi-EuATqWmPA9x-tvUc: Timeout during connect (likely firewall problem)

Domain: www.mydomain.fun
Type: connection
Detail: Fetching http://www.mydomain.fun/.well-known/acme-challenge/Lo35xswjM0aVaWMmlHuYYLNu3VgF5GEHvGHSGGPeiao: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.


Some challenges have failed.

Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

 

"www" is the only subdomain I tried adding so far.

 

Over at Namecheap, I've got:

AAAA Record        @       *IPV6 address*

Cname Record      ombi   mydomain.fun

Cname Record      www   mydomain.fun

 

 

Any idea what I might have forgotten, or where I could find more info? The logs I'm getting aren't super usefull (from the little I understand)

 

 

Hi there.
I'm having the same issue as you. Where did you added "nc -l localhost -p 80" ?

 

Thanks

Link to comment
  • 2 weeks later...

hello, I had a power failure that wiped my pfsense vm, and now my proxy containers don't work.

Everything is up and running, no errors; I've checked that ports 80 and 443 are open on the rebuilt pfsense vm, and SWAG, Vaultwarden, and Guac are all running/accessible locally.

 

I'm stumped on what to troubleshoot next - I've looked at the proxy config files, everything looks correct.
What couldI be missing?

Link to comment
On 1/30/2022 at 12:48 PM, Rex099 said:

Wondering if someone might be willing to help point me in the right direction to what is going on with my Issue. 

As of 3am this morning everything was working fine with my swag setup, then i went to bed... when I awoke today my website (dlongo.net)  is no longer accessible from inside my local network.(The site just times out ERR_CONNECTION_TIMED_OUT) But it seems to work fine if I turn on my VPN or access it from my mobile connection. Also if I ping dlongo.net it seems to resolve the correct IP. Anyone have any ideas on what I can check? Im just kinda lost at this point. 

hi,i have got the same problem

did you solve that?

Link to comment
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.