Preclear plugin


Recommended Posts

Hi there

 

Im trying to run preclear on unRAID 6.3.1 but when I open preclear from tools it seems to be stuck on

 

Please wait... retrieving information!

 

I've also tried running the script in a terminal from /boot/config/plugins/preclear.disk/preclear.sh and it fails saying

 

sfdisk: invalid option -- 'R'
For more details see sfdisk(.
Sorry: Device /dev/sdp is busy.: 1

 

I've also tried clicking the icon on the main page under the unassigned device section, and the button doesn't do anything.

 

I've also tried using a different browser (Chrome instead of Safari)

 

Any ideas, as I'm very keen to start a preclear on a new disk, especially as its 6TB and I'm expecting it will take much longer than I'm used to. Thanks in advance for any help!!

 

Hi.

 

First step is to remove and install this plugin again, to make sure it's in the latest version. The next step is choose which script you want to use to preclear; if you use mine, all you have to do is start the preclear. If you want to Joe L. script, you have to follow the steps on the OP, and then patch the script like described here: http://lime-technology.com/forum/index.php?topic=13054.msg510567#msg510567

 

Thanks for the quick reply, I'll give this a go now. I was planning to use yours as I understand I should be faster - an important factor with a 6TB drive!  :)

Link to comment

Yes, you need to isolate this issue before it corrupts your data.

 

Thanks trurl, my thoughts exactly.

 

I plan to continually preclear the drive off the motherboard SATA until my new cable arrives this week.  Then do a 3 cycle preclear with the new cable if possible.  If I am able to get good results on all of those preclears, I will feel confident that the original cable was the issue.

Link to comment

@gfjardim could you explain what the Statistics plugin does please and does it have a separate support page? Is this part of the preclear plugin?

 

I'm not suggesting this is the cause but I have recently had a security breach with the email account I use to send reports out of unRAID and I'm just looking into each new or updated item that I have changed in the past week. This just happens to be one of them!

 

Thanks in advance.

Link to comment

@gfjardim could you explain what the Statistics plugin does please and does it have a separate support page? Is this part of the preclear plugin?

 

I'm not suggesting this is the cause but I have recently had a security breach with the email account I use to send reports out of unRAID and I'm just looking into each new or updated item that I have changed in the past week. This just happens to be one of them!

 

Thanks in advance.

 

Hi Poprin.

 

The Statistics plugin is an optional part of Preclear that sends reports using TOR and Google Forms. All data is anonymous (no passwords or serial numbers) and sent using TOR to avoid your IP address get logged. You can see what gets reported by opening one of the report files (*.sreport | *.sreport.sent) under /boot/config/plugins/preclear.disk/.

 

TOR is only enabled as client and only activated while sending the report, so I highly doubt it's the key of your problems. The source code of the script that sends the report can be found here.

 

If you find any security hole in that routine, please don't hesitate in contacting me, ok?

Link to comment

Hi Poprin.

 

The Statistics plugin is an optional part of Preclear that sends reports using TOR and Google Forms. All data is anonymous (no passwords or serial numbers) and sent using TOR to avoid your IP address get logged. You can see what gets reported by opening one of the report files (*.sreport | *.sreport.sent) under /boot/config/plugins/preclear.disk/.

 

TOR is only enabled as client and only activated while sending the report, so I highly doubt it's the key of your problems. The source code of the script that sends the report can be found here.

 

If you find any security hole in that routine, please don't hesitate in contacting me, ok?

 

Thanks gfjardim, as I say I don't think this plugin or anything on unRAID itself is to blame. Just doing a bit of due diligence. I'm not concerned about the email account just more concerned of a 'key logger' or some other such bit of nastiness poaching my passwords for things that could cost me money!

Link to comment

New update 2016.03.20a which pause the preclear while starting/stopping the array.

 

Please let me know if it helps.

 

Was this feature removed? I'm using latest preclear and trying to stop the array during a preclear doesn't work anymore, stuck on sync filesystems...

 

Any idea why this stopped working? It's not just me as I've seen at least a couple of users with the same problem recently.

Link to comment

Hello - I'm attempting to preclear a 4TB drive to expand my array but after each successful preclear, the array appears to want to Clear it again before adding it.

 

I've attached diagnostics, preclear reports and a screenshot of the "Start will bring the array on-line and start Clearing new data disks" message I'm concerned about. Please let me know what else might be helpful to troubleshoot.

 

I'm hoping to avoid multiple hours of downtime by pre clearing and the language I'm seeing seems to tell me thats what unRAID intends to do once I click start. Am I misunderstanding the meaning or is something not right?

 

Thanks for your help,

Brian

Screen_Shot_2017-02-15_at_12_12.37_PM-small.jpg.64b73d7c0422e87ebd38f87508ea3b3b.jpg

tower-diagnostics-20170215-1213.zip

TOWER-preclear.disk-20170215-1211.zip

Link to comment

Hello - I'm attempting to preclear a 4TB drive to expand my array but after each successful preclear, the array appears to want to Clear it again before adding it.

 

That's normal, unRAID only checks for the preclear signature after starting the array.

 

Many thanks Johnnie! Been quite a while since I expanded my array. Wanted to make sure I wasn't giving the go-ahead for 9+ hours of downtime.

Link to comment

Many thanks Johnnie! Been quite a while since I expanded my array. Wanted to make sure I wasn't giving the go-ahead for 9+ hours of downtime.

 

FYI, since v6.2 clear is done with the array online, but disk is not tested like when using preclear.

 

Thanks for that info too. I'll take advantage of that when I upgrade my parity drives again (and look to use them as data drives in the array).

 

As a follow up to what you noted above, I proceeded with starting the array and unRAID picked up the preclear signature and prompted for only a quick format. Everything as you indicated. thx

Link to comment

Thanks for that info too. I'll take advantage of that when I upgrade my parity drives again (and look to use them as data drives in the array).

unRAID won't clear a new parity drive. There is no need for it to be clear since it will be completely overwritten by the parity sync. So if you want to test your new parity drive you may want to preclear it anyway.

 

And, when replacing a parity drive and adding the old parity as a new data disk, you don't really need to clear the old parity/new data disk. You can just follow bjp999's method.

Link to comment

Thanks for that info too. I'll take advantage of that when I upgrade my parity drives again (and look to use them as data drives in the array).

unRAID won't clear a new parity drive. There is no need for it to be clear since it will be completely overwritten by the parity sync. So if you want to test your new parity drive you may want to preclear it anyway.

 

I meant I would be preclearing the OLD parity drive to be used as a new data drive in the array (like you discuss below).

 

And, when replacing a parity drive and adding the old parity as a new data disk, you don't really need to clear the old parity/new data disk. You can just follow bjp999's method.

 

Thanks for this, I'll be sure to keep a link to it for the future.

 

Link to comment

New update 2016.03.20a which pause the preclear while starting/stopping the array.

 

Please let me know if it helps.

 

Was this feature removed? I'm using latest preclear and trying to stop the array during a preclear doesn't work anymore, stuck on sync filesystems...

 

Any idea why this stopped working? It's not just me as I've seen at least a couple of users with the same problem recently.

 

Bug found and squashed in 2017.02.16 update.

 

Thank you for reporting this.

Link to comment

I wanted to start a new unRAID server und now I wanted to start with preclearing all the disks.

 

I started the preclearing and waited some time (15min) but the GUI is showing " Starting..." and nothing happens.

 

Here is the log:

 

ErrorWarningSystemArrayLogin

 

 

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: Command: /usr/local/emhttp/plugins/preclear.disk/script/preclear_disk.sh --notify 2 --frequency 4 --cycles 1 --no-prompt /dev/sdd

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: Preclear Disk Version: 0.8.4-beta

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: S.M.A.R.T. info type: default

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: S.M.A.R.T. attrs type: default

 

It's a WD Red 6 TB running fine so far.

 

What is going on? :)

The whole system with all Plugins is up to date.

Link to comment

I wanted to start a new unRAID server und now I wanted to start with preclearing all the disks.

 

I started the preclearing and waited some time (15min) but the GUI is showing " Starting..." and nothing happens.

 

Here is the log:

 

ErrorWarningSystemArrayLogin

 

 

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: Command: /usr/local/emhttp/plugins/preclear.disk/script/preclear_disk.sh --notify 2 --frequency 4 --cycles 1 --no-prompt /dev/sdd

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: Preclear Disk Version: 0.8.4-beta

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: S.M.A.R.T. info type: default

Feb 17 08:12:18 preclear_disk_WD-xxxxxxx: S.M.A.R.T. attrs type: default

 

It's a WD Red 6 TB running fine so far.

 

What is going on? :)

The whole system with all Plugins is up to date.

 

Possibly still a plugin thing... Try and remove the plugin and reinstall it..

Link to comment
  • trurl featured, unfeatured and pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.