Jump to content
limetech

unRAID OS version 6.5.0 Stable Release Available

282 posts in this topic Last Reply

Recommended Posts

On 3/13/2018 at 4:36 PM, limetech said:
  • webgui: vm manager: VM Edit: Hide Cdrom bus dropdown if cdrom is blank

 

Can we add the optical drive to a VM to burn cds/dvds now?

Share this post


Link to post
6 hours ago, ken-ji said:

Yes this issue is annoying, docker's documentation doesn't say anything about this

 

Wouldn't be the first time.

Share this post


Link to post
3 hours ago, dmacias said:

I saw your RC6 call traces thread about Emby. https://lime-technology.com/forums/topic/70083-rc6-call-traces/?tab=comments#comment-641788

Are you still getting them with 6.5? I am getting the exact same errors with 6.5 and Emby Server. Had to roll back to 6.4.1.

 

Here's the Diagnostics from 6.5 before rolling back

 

server-diagnostics-20180314-1752.zip

 

Think this is the same (I think probably)?

https://www.spinics.net/lists/netdev/msg488984.html

 

Share this post


Link to post
8 hours ago, limetech said:

That's part of 'mover logging' which can be turned back on.

Limetech - I just checked my server under Settings > Scheduler > Mover Settings > Mover logging, and it was already set to Enabled. I still don't see any Mover finished notifications as I did previously. Is there anywhere else I need to adjust my Mover notifications?

Share this post


Link to post
8 hours ago, dmacias said:

I saw your RC6 call traces thread about Emby. https://lime-technology.com/forums/topic/70083-rc6-call-traces/?tab=comments#comment-641788

Are you still getting them with 6.5? I am getting the exact same errors with 6.5 and Emby Server. Had to roll back to 6.4.1.

 

Here's the Diagnostics from 6.5 before rolling back

 

server-diagnostics-20180314-1752.zip

There was no more! I continue to observe.

Share this post


Link to post

Updated from 6.4.1. to 6.5 with no issues so far.

 

I just needed to remove the Advanced Buttons and Libvirt USB Hotplug plugin (old-version) due to incompatibility. I'm just reminding people that before upgrading, they should run the Tools -> Update Assistant, to check for possible issues before updating :)

 

That being said, I really liked and used Advanced Buttons a lot. Any idea if there will be a compatible version out anytime soon?

 

Thanks upfront!

Share this post


Link to post
3 minutes ago, eybox said:

Any idea if there will be a compatible version out anytime soon?

Much of its functionality has been integrated in 6.5

Share this post


Link to post

I really like the docker/vm/app spinning icons vs reloading the entire page. Pretty slick.

Share this post


Link to post
23 minutes ago, Squid said:

Much of its functionality has been integrated in 6.5

 

Yeah, I read that part before upgrading. But either we're not talking about the same thing, or I haven't enabled something in the Settings page somewhere. I'm actually missing the stylized buttons specifically on the Dashboard and Docker tab being able to control multiple items at once. Otherwise there are the standard text buttons down below on the Docker tab, which are fine, I guess.

 

But I'm also missing the "remove orphaned images" button. So now I have a bunch of orphaned images I can't remove.

Share this post


Link to post

I've upgraded and everything appears to be working fine, but I can't access any information about my dockers. I know they're running but when I visit the docker page I just get the spinner and eventually see this in chrome developer tools

 

"http://192.168.1.114:8008/plugins/dynamix.docker.manager/include/DockerUpdate.php 504 (Gateway Time-out)"

 

Tried in different browsers and the same, but not restarted the server yet (I have some maintenance to do  in a few days so waiting for that, especially as the dockers are working)

Plugins page works and various plugins have had updates

Share this post


Link to post

Upgraded to 6.5, realized that advances buttons was not supported after updating, now I am unable to remove/update any plugins. I can force an update by manually installing the whole plugin over again via url, but I can't remove advance buttons. I am assuming that this is what is causing the issue in the first place so how can we manually remove plugins? 

Thanks

Share this post


Link to post
3 minutes ago, manofcolombia said:

Upgraded to 6.5, realized that advances buttons was not supported after updating, now I am unable to remove/update any plugins. I can force an update by manually installing the whole plugin over again via url, but I can't remove advance buttons. I am assuming that this is what is causing the issue in the first place so how can we manually remove plugins? 

Thanks

 

Remove the .plg from /boot/config/plugins and reboot.

Share this post


Link to post

Or just refresh the page after removing Advanced Buttons

Share this post


Link to post
On 3/13/2018 at 8:15 PM, Hoopster said:

Stuck at loading /bzroot...ok

 

Hard reboot, same thing.  Rolling back to 6.4.1 until I can figure it out.

 

UPDATE: backup server upgraded without incident from RC6.  Main server had the issue upgrading from 6.4.1

 

I will try downloading and installing manually, could be I got a corrupt bzroot from download.

 

UPDATE 2:  Manual download and install of 6.5.0 failed.  Copying bzroot from flash drive of backup server (successfully upgraded to 6.5.0) failed.  Rolling back to 6.4.1 worked.  For some reason, my main server will not boot with 6.5.0

I have this problem, but I was able to work around it by booting into the web gui. If I select the option to boot into the web gui, the server starts fine. If I try to boot into the command line, the server locks up at /bzroot...ok

 

Hope this helps.

Share this post


Link to post
57 minutes ago, Hanzo404 said:

I have this problem, but I was able to work around it by booting into the web gui. If I select the option to boot into the web gui, the server starts fine. If I try to boot into the command line, the server locks up at /bzroot...ok

 

Hope this helps.

There is a discussion about this now in the General Support forum.  There are several of us with the issue and the only solution is to boot the GUI, otherwise, the server will not start.  Neither "normal" mode nor safe mode will boot.

 

 

Share this post


Link to post

I'm not sure whether I'm posting in the correct thread. But I've started noticing these issues when trying to upgrade from 6.5.0-rc to 6.5.0 (DVB edition, but now I'm on 6.5.0 stock).

 

I can't seem to install (some) plugins, I get tar errors.

 

I think I've narrowed it down to the fact that my /var is full?

 

Can someone take a look at my diagnostics to see if that's whats the problem. (and if it  is, how can I correct it)?

 

I've also posted in the unraidDVB thread, but I don't think my problem is specific to that plugin. (I've also had CA failed to install after I noticed my APPS tab was missing, however it showed back up on 6.5.0 stock)

server-diagnostics-20180315-1617.zip

Share this post


Link to post
12 minutes ago, tbrasser said:

I'm not sure whether I'm posting in the correct thread. But I've started noticing these issues when trying to upgrade from 6.5.0-rc to 6.5.0 (DVB edition, but now I'm on 6.5.0 stock).

 

I can't seem to install (some) plugins, I get tar errors.

 

I think I've narrowed it down to the fact that my /var is full?

 

Can someone take a look at my diagnostics to see if that's whats the problem. (and if it  is, how can I correct it)?

 

I've also posted in the unraidDVB thread, but I don't think my problem is specific to that plugin. (I've also had CA failed to install after I noticed my APPS tab was missing, however it showed back up on 6.5.0 stock)

server-diagnostics-20180315-1617.zip

You need to fix whatever it is that is filling up your log with these:

Mar 15 15:55:41 Server kernel: resource sanity check: requesting [mem 0x000a0000-0x000bffff], which spans more than PCI Bus 0000:20 [mem 0x000a0000-0x000b0000 window]
Mar 15 15:55:41 Server kernel: caller vfio_pci_vga_rw+0xc4/0x1b4 mapping multiple BARs

 

Share this post


Link to post
15 minutes ago, trurl said:

You need to fix whatever it is that is filling up your log with these:


Mar 15 15:55:41 Server kernel: resource sanity check: requesting [mem 0x000a0000-0x000bffff], which spans more than PCI Bus 0000:20 [mem 0x000a0000-0x000b0000 window]
Mar 15 15:55:41 Server kernel: caller vfio_pci_vga_rw+0xc4/0x1b4 mapping multiple BARs

 

Thanks, I just found it as well.

 

Not sure what is causing it, any ideas on where to look for?

 

 

So after some googling I didn't get much wiser other than that those log entries don't indicate anything serious. However they do fill up my /var ....

 

It seems to be a result of my NVIDIA GTX 970 + Some linux kernel changes that have happened in the past.

 

To pass through my gpu (it's the only one I have) I use an extracted bios that since 6.5 I can point to without modifyin the xml. I have 1 VM on autostart which probably resulted in above spamming in the logs.

 

I can confirm that if I don't start any VM I don't get these log entries, and everything is functioning like it normally would.

 

However I would like to start VM's with my GPU without getting this behaviour. Is there any way I can reduce the logging or any other fix?

Edited by tbrasser
Found a way to bypass the problem, narrowed it down to VM+GPU passthrough.

Share this post


Link to post

Upgraded 3 machines from 6.4.1 to 6.5.0, two out of three smooth no issue, 3rd didn't get an IP on first boot, plugged in local console, rebooted to GUI, had IP. Scratched head, rebooted to normal mode, got IP just fine.

 

<shrug> No outstanding issues, just wanted to report the blip on first boot.

 

No, I didn't collect diagnostics, sorry. Pretty useless report, I know.

Share this post


Link to post
On 3/13/2018 at 4:36 PM, limetech said:
  • webgui: vm manager: VM Edit: removed help regarding usb hotplug not supported yet

 

Does that mean it is supported now? I read through the release notes but it doesn't seem to say anything else about it.

 

I use the Libvit Hotplug USB plugin to do this currently, but according to the Update Assistant, this plugin is no longer supported in 6.5:

 

Quote

Issue Found: libvirt.hotplug.usb.plg (libvirt.hotplug.usb) is deprecated with 6.5.0. It is recommended to uninstall this plugin

 

Share this post


Link to post
2 hours ago, Transient said:

 

Does that mean it is supported now? I read through the release notes but it doesn't seem to say anything else about it.

 

I use the Libvit Hotplug USB plugin to do this currently, but according to the Update Assistant, this plugin is no longer supported in 6.5:

 

 

I was in the same boat this morning, as you are.

 

The original plugin has been created a while back, and hasn't been updated for a while. There is an updated version of the plugin, by a different developer. All you need to do now is to just uninstall it (your old version) from Plugins page. And then simply go to Apps and search for "hotplug". A plugin by the developer "dlandon" should come up. Just install that one, and you should be good to go!

 

Hope this helps :)

Share this post


Link to post
9 minutes ago, eybox said:

I was in the same boat this morning, as you are.

 

The original plugin has been created a while back, and hasn't been updated for a while. There is an updated version of the plugin, by a different developer. All you need to do now is to just uninstall it (your old version) from Plugins page. And then simply go to Apps and search for "hotplug". A plugin by the developer "dlandon" should come up. Just install that one, and you should be good to go!

 

Hope this helps :)

 

Thanks, that's exactly what I was looking for. I had no idea there was a new plugin. The new one looks and functions identical to the old one. :)

 

I appreciate the help!

Share this post


Link to post

FYI - for those with the Loading /bzroot...ok hanging issue when booting normally (no GUI or Safe mode) with unRAID 6.5.0 there is an apparent fix  in the discussion linked below.

 

It appears all of us with the issue so far have the ASRock C236 WSI motherboard.  For two of us, the "fix" has worked and we can boot now in "normal" mode. Thanks to @gamephreak for discovering BIOS tweaks that made a difference.

 

 

Share this post


Link to post

Is it by design now ( @bonienl ) that every time you go to the Plugins page a check for updates is performed, regardless of the Setting to never check automatically?  Prior behavior was when set to never check, the plugin page also wouldn't check automatically.

Share this post


Link to post
On ‎3‎/‎14‎/‎2018 at 6:32 PM, spencers said:

Hmm, my NGINX docker app is having trouble connecting to the internet after the update.

 

And all of my docker apps show an update is available. When I click update on any of them, it tries to but 0 bytes are changed and it stays showing update available.

 

edit: I downgraded and all is good again.

This sounds like it might be similar to an issue I was having. It seems for me, the docker and vm pages are at least one step behind the current state of things. Recently installed dockers aren't showing, orphaned images that have already been removed still showing, stopped VMs still showing as running, yet everything on the dashboard works fine. Does that sound like what you are experiencing with the docker updates?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.