[Support] binhex - MinecraftBedrockServer


370 posts in this topic Last Reply

Recommended Posts

On 6/9/2020 at 9:39 PM, binhex said:

 

so by default a backup will get created every 12 hours, obviously you need to keep the container running, then check the above folder and you will see a folder created named after <date of backup>-<time of backup>

Left it for 2 days and there is still no backups folder.

Link to post
  • Replies 369
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

new feature coming soon, minecraft console accessible via web ui, thought this might please a few people, no nasty docker exec

yes, create a /config/permissions.json file, edit it and add your xuid and grant yourself whatever permissions you need, e.g.:-   [ { "permission": "operator","xuid": "12345678123

Also note that the order of the pack you have selected (once you fix the comma) will mean fuserealism is secondary to peegs, so if peegs has any textures it will overwrite fuses's. They apply bottom t

Posted Images

1 hour ago, urhellishntemre said:

Hey @binhex how do I turn on Show Coordinates on the server? I can’t figure it out in the server.properties file, or via command line. Any tips?

taken from the minecraft wiki:-

Quote

if the "Show Coordinates" option is turned on in the game settings screen or /gamerule showcoordinates true is used.

so looks like you can do it from the minecraft client or via the above option at the minecraft console.

 

 

Link to post
1 hour ago, binhex said:

taken from the minecraft wiki:-

so looks like you can do it from the minecraft client or via the above option at the minecraft console.

 

 

So I checked settings in the client, and it shows all GAME settings unable to change. Two settings I would like to change would be enabling show coordinates, and changing world size to Xtra-Large rather than infinite. Also, I pulled up the command prompt from the unraid interface when I click on the container, and click on the console button, and tried inputting the command /gamerule showcoordinates true, select world_name; /gamerule showcoordinates true, for world_name; /gamerule showcoordinates true, and about 15 variations of different ways to type the command. Am I missing something, or doing something wrong?

Show Coordinates in game.PNG

Link to post
1 minute ago, urhellishntemre said:

So I checked settings in the client, and it shows all GAME settings unable to change. Two settings I would like to change would be enabling show coordinates, and changing world size to Xtra-Large rather than infinite.

try changing these settings before going into the world, i think if you hop back to settings whilst still in the world then the options will be greyed out.

 

3 minutes ago, urhellishntemre said:

Also, I pulled up the command prompt from the unraid interface when I click on the container, and click on the console button, and tried inputting the command /gamerule showcoordinates true, select world_name; /gamerule showcoordinates true, for world_name; /gamerule showcoordinates true, and about 15 variations of different ways to type the command. Am I missing something, or doing something wrong?

you are running the command inside the container, you need to do it from the host 'Terminal' link (although it is possible to run from container), see Q1 in the following link:-

https://github.com/binhex/documentation/blob/master/docker/faq/minecraftbedrockserver.md

 

Link to post

Thanks! I didn’t see that page before. Got it working now. But sorry to be such a bother, I did notice that when I restart the container it loses the change for showcoordinates. I tried to follow the section later on where it says that you can run a command on a Schedule via shell, by running this command in a script. 
 

docker exec -u nobody -i <name of container> screen -S minecraft -p 0 -X stuff "<command to execute>^M"

 

I changed the name to my container name, and I added the “gamerule showcoordinates true” and left the ^M. However when I ran the script and logged in it didn’t make the change. 
 

Should I remove the ^M? Or is there a special way I need to format the script to get it to log into the docker from UserScripts?

Link to post
15 hours ago, urhellishntemre said:

Should I remove the ^M?

Yes, that gets inserted when a file is edited on an incompatible editor.

Scratch that, I must have been thinking about something different. Sorry for the bad advice.

Link to post
20 hours ago, binhex said:

are you running the latest image?, click on 'force update'.

My auto updater updates every week and I did a force update when I saw that you add the feature.

I manually created the backups folder and backups started appearing. That was the solution.

Link to post
3 hours ago, Pure said:

My auto updater updates every week and I did a force update when I saw that you add the feature.

I manually created the backups folder and backups started appearing. That was the solution.

thanks for this!, you are right it was missing creation of the backups folder, corrected and new image building.

Link to post
12 hours ago, jonathanm said:

Should I remove the ^M?

 

12 hours ago, jonathanm said:

Yes, that gets inserted when a file is edited on an incompatible editor.

actually i think that should be no, dont remove it - the ^M forces a return character to be sent after the command, otherwise i think you will find it wont execute.

Link to post

You have to login and run the command as a user who you made an admin on the server for the coordinates change to be permanent. You edit the permissions config file to do that. I did it a while ago, rebooted docker and upgraded it multiple times, coordinates always on everytime no script needed.

Link to post
20 hours ago, jonathanm said:

Yes, that gets inserted when a file is edited on an incompatible editor.

Scratch that, I must have been thinking about something different. Sorry for the bad advice.

It's okay, I know sometimes it's added because of editors, which is why I asked. No harm, no foul!

8 hours ago, binhex said:

 

actually i think that should be no, dont remove it - the ^M forces a return character to be sent after the command, otherwise i think you will find it wont execute.

You are correct, it does force a return character. I gave up testing yesterday afternoon when I noticed that it was not returning, and had to do other things. In the event that this ever needs to be question again, here is the command I used (With minecraftserver, being the name of my docker)

 

docker exec -u nobody -i minecraftserver screen -S minecraft -p 0 -X stuff "gamerule showcoordinates true"^M

I noticed that it the ^M was inside the quotes, like the documents said it should be, it wouldn't work. However, on the outside it does work. 

3 hours ago, binhex said:

new feature coming soon, minecraft console accessible via web ui, thought this might please a few people, no nasty docker exec

OH THANK GOD! I am so rusty on any sort of command line interface, I just installed Ubuntu in a VM and will start re-exploring programming and CLI. You, @binhex, are a god among men, for all the dockers you do. Thank you for all the help you have provided me, and the community at large. 

Link to post
On 6/12/2020 at 2:51 PM, binhex said:

new feature coming soon, minecraft console accessible via web ui, thought this might please a few people, no nasty docker exec

feature is now complete and in the latest image, please pull down and then for existing users you will need to add the following port and env vars:-
 

image.png.5c16383e2032dd55fd793da9ea6e0924.png

 

OPTIONAL (if not defined it will set to 'yes'):-

 

image.png.e927f6dc44c333755dbeffee5b64462e.png

 

OPTIONAL (if not defined it will set to 'Minecraft Server'):-

 

image.png.2e04e133150620b768b8dd18911b63ef.png

 

OPTIONAL (if not set then you wont have a llink to 'web ui' from left click of icon):-
 

image.png.dfc6587242d34a81f790120efd94ff1b.png

 

 

 

New users will see all of the above already defined in the template.

 

Access to the minecraft console is then done through http://<host ip address>:8222

 

Edited by binhex
Link to post
4 hours ago, binhex said:

feature is now complete and in the latest image, please pull down and then for existing users you will need to add the following port and env vars:-

I tried modifying my existing container with the port and variables mentioned without luck. Maybe it had something to do with the other WEBUI_ variables? 

 

Regardless, I was able to remove the container and reinstall and it works great! Thanks so much for this console support! Much easier to get to now (added and Organizr tab for it as well). 

Edited by planetarymotion
typo
Link to post
8 hours ago, planetarymotion said:

I tried modifying my existing container with the port and variables mentioned without luck.

hmm odd that should of worked.

 

8 hours ago, planetarymotion said:

Maybe it had something to do with the other WEBUI_

these are new env vars i introduced last night, as i was a little nervous about having an unsecured minecraft console available, so i am introducing basic auth via 3 new env vars, the image is currently in testing, more on that shortly.

Link to post

If it helps, I updated the container and like pm, I didn't see the options for the webgui variables.  But when I started the container, I noticed 8222 was in the startup command so I sent a browser to the container IP:8222 and it connected great.  So it's there, just no displaying.

Link to post
2 minutes ago, dalben said:

I didn't see the options for the webgui variables. 

sorry re-read your reply, did you have 'advanced view' on? - it might also be because im in templating authoring mode and thus can see the field available hmmm

Edited by binhex
Link to post

So as i mentioned above i wanted to have the minecraft console secured, at least via basic auth (please dont expose this over the internet!). so i have created a further 3 env vars:-

 

OPTIONAL - turns authentication on or off (prompts for creds), if not defined then it will be set to 'yes'

 

image.png.8f490acc44b89bc3c690d71e7d5f6304.png

 

OPTIONAL - username for authentication (if enabled), if not set it will set to 'admin'
 

image.png.184d11c01f7b927112bec2d2f74428f6.png

 

OPTIONAL - password for authentication (if enabled), if not set it will a random string stored in a file located at '/config/minecraft/security/WEBUI_PASS'

 

image.png.77efb900a3ee9a6f231322f62997dd38.png

 

the authentication changes will be in the next image released, in preparation for this you can create the above env vars now, if you do NOT do the above then by default authentication will be turned on and you will be prompted to login with username 'admin' and a random password as detailed above.

Link to post
40 minutes ago, binhex said:

the authentication changes will be in the next image released

building right now, should be available for pull down in the next 30 mins or so.

Link to post
1 hour ago, binhex said:

sorry re-read your reply, did you have 'advanced view' on? - it might also be because im in templating authoring mode and thus can see the field available hmmm

Yeah, I tried advance view, they weren't there,  Also check "show more settings", not there either

Link to post
24 minutes ago, dalben said:

Yeah, I tried advance view, they weren't there,  Also check "show more settings", not there either

you got two options:-

1. Edit the xml directly for your template that you have defined (stored on flash drive). file stored at '/boot/config/plugins/dockerMan/templates-user/my-binhex-minecraftbedrockserver.xml' edit line starting with '<WebUI>' and change it to:-

  <WebUI>http://[IP]:[PORT:8222]/</WebUI>

OR

2. Enable template authoring mode in settings, docker (need to stop the service) then on the container screen switch to advanced view and show more settings

Edited by binhex
Link to post
3 hours ago, binhex said:

you got two options:-

1. Edit the xml directly for your template that you have defined (stored on flash drive). file stored at '/boot/config/plugins/dockerMan/templates-user/my-binhex-minecraftbedrockserver.xml' edit line starting with '<WebUI>' and change it to:-


  <WebUI>http://[IP]:[PORT:8222]/</WebUI>

OR

2. Enable template authoring mode in settings, docker (need to stop the service) then on the container screen switch to advanced view and show more settings

Thanks.  I'm actually not too fussed as your defaults work fine for me and I now get the Webgui.  Was more trying to help you track down the issue.

Link to post

I can confirm this does not work for me either. The relevant lines in .xml read (even after doing a force update on the docker):

  <Category>GameServers:</Category>
  <WebUI/>
  <TemplateURL>https://raw.githubusercontent.com/binhex/docker-templates/master/binhex/minecraftbedrockserver.xml</TemplateURL>

Edited by PeteAsking
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.