Reduce power consumption with powertop

Recommended Posts

11 hours ago, mgutt said:

Extremely bad. Consider a better and smaller power supply. If you stay with your dGPU then a Seasonic Titanium would be the best option.

I do have a Cosrair RM 850x 80+ GOLD I know it's not much better but it is something I do have just laying around. Would you say it's worth swapping? (My unraid server is really just my re purposed old gaming pc)


11 hours ago, mgutt said:

Replace against an ASM1166 6 port card and use onboard SATA ports.

I have a ASM1062 10 port card, would that be just as good? this one exactly:


11 hours ago, mgutt said:

Used in an VM or in unRAID? If by a VM: Do you set the GPU to standby if the VM is shutdown? German thread:ätze/

I would say you are wasting at least 40W.

Using it for a plex docker container. Most of the time it's in proper standby mode using 10W


11 hours ago, mgutt said:

Only warnings, can be ignored.

Ok great.

Edited by Kronos_
Link to comment
24 minutes ago, Kronos_ said:

Would you say it's worth swapping?

No. It has simply to much power. More power means less efficiency. This means an 850W power supply looses 10 to 15W for nothing while operating in a 90W range. Example (~12W loss at 90W):




25 minutes ago, Kronos_ said:

I have a ASM1062 10 port card, would that be just as good?

No. 6 port (ASM1166) is the current maximum. All other cards use multiple controllers / port multiplies which have a huge negative impact on power consumption. ASM1062 is for example only a 2 port controller. Because of that your linked card has 2 additional JMB575 Port multipliers to provide finally 10 ports. And this does not only mean more power consumption, in addition it's extremely slow (~30 to 50 MB/s per SATA port while parity check is running).





  • Like 1
  • Upvote 1
Link to comment

Hi everyone,


First of all, thank you for the excellent write-up. So far this helped me greatly reducing the power consumption of my setup. However, just as described above I am stuck at sleep state C3 and it is refusing to go any higher than that. I was hoping some of you might have the answer to the thing that has been annoying me for the last few days. The hardware is as follows;


Asrock C246 WSI motherboard

Intel i3 9100 with Noctua NH-L9i fan

2x 16gb Kingston Server Premier KSM26ED8/16HD DDR4 RAM


1TB Sabrent 2242 NVMe SSD


Jonsbo N1 NAS case

32gb Sandisk Unraid usb


I've also tried booting a clean install of Ubuntu, no avail, still only C3. Thereafter I tried disconnecting all the hardware besides the CPU fan, still C3.


Also I tried updating the BIOS to the latest version, this also didn't help. You will find my BIOS settings below. (sorry for the reflections)




This is the result from power top:




I'm really hoping someone has the answer to this since I have no clue what to do next.


Thank you!!


Link to comment
3 hours ago, diedjb said:

1TB Sabrent 2242 NVMe SSD


Please test without the disks (disable Array Autostart and reboot without them). And in addition test while the USB stick is using a different port. 


If you scroll down in powertop C-States view then the iGPU is in sleep state, which means the drivers are working?


If nothing helps: Ask ASRock.

Link to comment
1 hour ago, mgutt said:

Please test without the disks (disable Array Autostart and reboot without them)

Unfortunately I’ve this, also without the nvme. This didn’t help either. I will try a different usb port though! 

This is the result I get from the gpu in powertop:



could it be that RC6 is not enough to reach a higher c state then c3? 

thanks for your response! 

Link to comment

Hi everyone, 

I'm really new to Unraid, linux and home servers as a whole, in fact this is my first home server/nas build. 

I've been trying to get this working for past few days and really can't get it to decrease the power usage. 



M/B: Fujitsu D3243-S12 updated to the latest BIOS version

CPU: i7-4790T

RAM: single stick 8GB DDR3

USB stick with Unraid (tried in multiple different ports)

All SATA drives disconnected (thus Array stopped ofcourse); no PCIE devices connected, 

Power supply: Seasonic M12II-850 Bronze tried in both ways - ATX mode, and 12V only - since the M/B supports this. I know I could save a few watts by upgrading to another power supply (and I intend to).


So, the CPU c-states are working just fine - most of the time being at C7; but the package c-state never reaches even C2.


Have tried on Ubuntu also - the same.


On Windows 10, a tool Throttlestop reports that Package C states are locked to C1.


I've tried changing settings in BIOS through and through, disabling all unused devices as far as disabling all sata etc. 


What could be the cause of this? could it be just that BIOS/motherboard does not support it? 

Please, if you have any ideas what could cause this, do let me know.


Link to images -

Link to comment
Just now, mgutt said:

ASPM is required:


− BIOS Setup item "ASPM Support" (at "Advanced PCI Subsystem Settings" submenu) no longer selectable.


ASPM settings got grayed out (disabled) after BIOS update. 

I had tried getting this to work before updating BIOS also, although not so extensively, but with the same results. 


Just now, mgutt said:

No C-State Settings?!

Usually there is a setting to enable the C-States.



Sadly no, there is no setting with a title or description mentioning c-states.

The setting I thought would affect this was 'Package power limit lock', but this one becomes available only if setting 'Turbo mode' is enabled, so I think that this setting actually allows the cpu to pull more power than it's TDP and is not about power saving. 


I'm really frustrated with this especially since others with Fujitsu board (albeit other model, D3222 but with the same chipset) have achieved C6 / C7 mentioned in the google sheet.

Link to comment

Hey there,


sorry if this should have been convered somewhere before. But I struggle to get an output with powertop on v6.1 with my 5600G on a Gigabyte B550:




Any idea why it fails to read my hardware?

Are there any prerequisites for AM4?





EDIT: I tried the CoreFreq plugin instead. Looks like that works for me. :)

Edited by Gemuesefraumann
Link to comment
On 1/27/2023 at 2:44 PM, Spin-Master said:

I have the same motherboard as you (Asrock H370) and can reach C7.


Have you enabled all the ASPM settings in the BIOS? I also disabled the sound card and a few other settings in the BIOS.



@Spin-MasterThanks for thinking along.

I belive I do have the correct BIOS settings. If you wouldn't mind, please have a look at my settings here: 

Looks correct to me, right?


I think my old PSU is the cause of the system not going beyond C3. I don't have any other PSU lying around right now. Will consider upgrading but hopefully a couple of brands introduce some new PSU's with 500W or less power with the ATX 3.0 spec. That should mean they are pretty efficient, also at 10W load. Not a lot of choice with ATX spec 2.53 or 3.0 right now. Not sure approx 100 euro is worth the investment (I have solar panels and am producing more power than I use in my house over a year).

Edited by Wabs
Link to comment



First of all GREAT GREAT WORK in this thread. Thanks!!


I'm in the process of changing my unraid server from a Gigabyte brix (nuc style) with an i3 8130u to something more robust (don't want usb discs in the array).

I found a refurbished i3 8100 with an asrock H310M-HDV. I would pair it with 32GB ddr4 ram and a couple of 3.5 discs and 3-4 SSD's.

In the near future i'll need a pci-sata expansion.

Not decided about the psu yet

Is this a power efficient system?
My use is mainly plex/torrent with ocasional windows 10 vm.


Link to comment
On 10/21/2020 at 1:05 PM, mgutt said:

Obtain ASPM status of all devices:

lspci -vv | awk '/ASPM/{print $0}' RS= | grep --color -P '(^[a-z0-9:.]+|ASPM )'

Hi, with this command i obtain this result :


00:1c.0 PCI bridge: Intel Corporation Tiger Lake-H PCI Express Root Port #5 (rev 11) (prog-if 00 [Normal decode])
                LnkCap: Port #5, Speed 8GT/s, Width x4, ASPM not supported
                LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk+
00:1d.0 PCI bridge: Intel Corporation Device 43b2 (rev 11) (prog-if 00 [Normal decode])
                LnkCap: Port #11, Speed 8GT/s, Width x1, ASPM not supported
                LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk+
01:00.0 Non-Volatile memory controller: Sandisk Corp WD Blue SN550 NVMe SSD (rev 01) (prog-if 02 [NVM Express])
                LnkCap: Port #0, Speed 8GT/s, Width x4, ASPM L1, Exit Latency L1 <8us
                LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk+
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
                LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk+


My config:


CPU:  I3-10100T

RAM: 2*8GB ( CMV8GX4M1A2666C18 )


What is the first and second device ?

In BIOS i set ASPM on but why with this command PCI Bridge are not supported (and disabled)?

Edited by Pepeanuts
Link to comment
1 hour ago, Simone Valmacco said:

I have a 10G switch between my NAS and my PC. How do I setup the 10G card as secondary so when my desktop is off I can either put in standby the 10G card on my NAS?

Why don't you connect the PC and server directly and use a separate connection for your PC like 1G or WIFI do remove the 10G switch at all?


Another idea: Buy two Aqara ZigBee Plugs and a ZigBee Sonoff device and install home assistant. Now use one plug to measure the power of your PC. The other plug is used to switch the power of the 10G switch. If your PC is switched off, the measured power falls under x Watt and this is used to trigger the power of the 10G switch.


Regarding your question: Simply change the order of your servers network devices and make the 1G your primary. The 10G as a secondary with a fixed IP address. Now you need to use the IP address to reach the server through 10G. If you would use the servers hostname, it will use the IP of the 1G connection, so don't use it through your PC. The next step is disabling the 10G connection. Maybe through "ifconfig eth1 down"?! But I'm not sure if this would save really much energy.





Link to comment


I'm building a new server: 


CORSAIR Vengeance LPX 64GB (2 x 32GB) DDR4 2400 (PC4-21300) C16 1.2V

Corsair CX550M (2021)
1x pcie M2 SSD

1x Western digital red 4TB SSD
2x 3,5 16TB disc (most of time spin down)

What power consumption can I expect while running plex/radarr... and qbitorrent?


Now i have a 6600k + GTX 950 and my idle power is 40w with all motherboard settings + powertop


Link to comment

The problem I have with this is no matter what nvme drive I use, it creates errors.


Feb 19 09:51:50 Media kernel: pcieport 0000:00:1d.0: AER: Corrected error received: 0000:03:00.0
Feb 19 09:51:50 Media kernel: nvme 0000:03:00.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
Feb 19 09:51:50 Media kernel: nvme 0000:03:00.0:   device [1987:5012] error status/mask=00000001/00006000


I've tried on several gen8/9 gigabyte and asus motherboards.

I've tried with 1TB Samsung 960 EVO and SN770, Intel 666P. 2TB 970 EVO, WD SN850, XPG SX8200P, Silicon Power A80.


Looking up the error, it has to do with ASPM, and if you turn it off the error goes away. BUT the issue I have with that, is it works fine on Windows.


I believe powertop has a ways to go before it's considered stable with nvme drives. (Or ASPM in linux).

Way to many components that just break this.  It seems there's only a handful of components that could actually take advantage of this, which makes it kind of worthless imo, like tryiing to find these elusive outdated motherboards for $400+, which makes no sense going forward.


Edited by fwiler
Link to comment
5 hours ago, fwiler said:

I've tried on several gen8/9 gigabyte and asus motherboards.

I've tried with 1TB Samsung 960 EVO and SN770, Intel 666P. 2TB 970 EVO, WD SN850, XPG SX8200P, Silicon Power A80.

I've never faced this error with a C246N, C246M and W480M and a Samsung 970 Evo Plus, but I had it with a C246N and  WD SN75. I even don't know any user which had AER errors with Samsung SSDs except the 980 (without Pro). Is it maybe possible that your power supply has a problem providing a stable 3.3v and/or 5v?! Or are you using any M.2 adapter cards?

Link to comment
4 hours ago, mgutt said:

I've never faced this error with a C246N, C246M and W480M and a Samsung 970 Evo Plus, but I had it with a C246N and  WD SN75. I even don't know any user which had AER errors with Samsung SSDs except the 980 (without Pro). Is it maybe possible that your power supply has a problem providing a stable 3.3v and/or 5v?! Or are you using any M.2 adapter cards?

I'm using Corsair RM5550x 2021, and I've tried Corsair SF750.   The difference could be that you aren't using 'consumer' motherboards or your Samung is EVO plus. I've tried Gigabyte z390, h310n, and Asus strix z390. (all mini itx) with Intel 9100T.

I'm not ruling out an issue with Unraid either, but I suspect. 

I've had too many issues with changing hardware lately and weird configuration issues that come back that shouldn't after completely new hardware.  Example, new drvies, with all new config.  Transfer new data over.  Run mover.  I can see in logs errors because it's trying to move custom share that is no longer there.  That shouldn't be happening. (Ended up finding those on flash drive).  Point is, there could be other configs not renewing with new hardware.

But way too much time spent.  I'm not going to recoup money in power savings from lost time working on this.

Edited by fwiler
Link to comment





- enable ASPM (Active-State Power Management) in the PCI settings

I am trying to set the best settings on my motherboard and I am confused as to what is the best option in this case.

I am using the ASRock X470D4U which has multiple options for the ASPM (screenshot below).


I've read the differences between L1, L1.1 and L1.2 here but I am still unsure of what could be the best option.

As for the  "L1.1_L1.2" option, I don't understand what it could mean. A mix between L1.1 and L1.2 ?

No explanation whatsoever in the bios or in the motherboard manual, but it's not a surprise coming from ASRock.

Thank you, any help appreciated.

Link to comment


In the aim to reduce power, when i use Powertop auto tune command, it seems to write some random files on 1 disk which keeps it awake and unable to spin down




** Disk 2 Jan 13 18:55:08 CREATE => /mnt/disk2/230875907.tmp Jan 13 18:55:08 OPEN => /mnt/disk2/230875907.tmp Jan 13 18:55:08 DELETE => /mnt/disk2/230875907.tmp Jan 13 20:01:03 CREATE => /mnt/disk2/660760271.tmp Jan 13 20:01:03 OPEN => /mnt/disk2/660760271.tmp Jan 13 20:01:03 DELETE => /mnt/disk2/660760271.tmp


at first i thought it was Fix commoin problems plugin doing it but have uninstalled it 


any ideas how to fix this? when i reboot unraid server and do not run th auto tune command all disks go to standby fine



Link to comment
2 hours ago, bigup said:

when i use Powertop auto tune command,

Doesn't make sense. Powertop has nothing to do with mounted disks or similar. It sets some Kernel options and this is a single execution. Nothing which runs permanently in the background.

  • Thanks 1
Link to comment


I think I am doing something wrong.

This is the output of Powertop Autotune:



Idle Stats:



Tunables: all good

My Hardware:
i3 8100
bequiet Pure Power 11 400W


No hard drives connected yet.

So far no settings in unraid.


I would have expected a little less consumption (15W) or no error messages.
Are there any obvious errors? (except ATX board)
Or tips on how or where I could still intervene?

Only reaching C3 -> Bios Settings?

I have adjusted the BIOS settings according to this thread.














Edited by ruezi
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.