Unraid OS version 6.12.6 available


Recommended Posts

17 minutes ago, JorgeB said:

Not from what I can see in the diags, only see an AMD onboard controller and an LSI HBA, both should work fine.

I appreciate you looking at it. I didn't go into details to check, I knew that I was stable on 6.12.4 and after updating to 6.12.6 I lost stability. This was the first time my UnRaid instance has ever been unstable. 

Initially I went to use it one night, noticed it was very very unresponsive, got into the dashboard everything was maxed out. 100% cpu, ram, drives we're just stacking up errors. I had to reboot the server, then after about ~12 hours the same thing happened again. I had turned off any unused containers/services the 2nd time to see if that was the cause. 

So after reading around the forums I seen the kernel had some incompatibles with Realtek ethernet controllers (I have Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)), some LSI cards, and some other stuff and I was like hmm, I'll just go ahead and down grade. 

Admittedly I didn't read the patch notes properly until I started having issues/down graded back. I seen that there was a couple issues that could have effected me that I did not check/change/test I just went ahead and did a roll back. I know this is not very helpful for developers but I have services running on my UnRaid that I use for work and have to maintain stability at all costs.


Call traces and crashes related to macvlan
Problems due to Realtek network cards

Thanks for the responses!

Edited by jlw_4049
Link to comment
On 12/14/2023 at 3:40 PM, sonic6 said:

May that is one of the bigger Part of those Problems.


This is not friendly at all. I asked a few times, Reading the bugs threads @JorgeB provided


i don't have right idea about if the issue is being reverted or not. I don't even know exactly how this threads/patches system works. Is not very user friendly, isn't it? Not very friendly UI, isn't it? Not for every noob linux user, don't you think? So would be great, developers, who I guess control much more about this kind of forums and issues, could answer this question, providing a short intructions to achieve what you say:

the more people are reporting the, the higher is the chance that this issue will be solved.


As I say, I completely agree with these, but no one is making this steps digestible for us. 


By the way, some of you say solve the issues of the realtek drivers using the plugins. So this plugins achieve to change it on the fly? can source code of drivers be modified from here and apply them directly for testing purposes? Because I have also read opposite statements, saying that the mantainer only mantains latest drivers. If the plugin only have latest drivers,what's the point? A little bit of detailer explanation (covering these doubts) about this plugin would be fine. If it exists, I haven't found it.


But one more time, patience please, we are trying, just need someone who kindly make us the road easier.






Link to comment
13 hours ago, JorgeB said:

Not from what I can see in the diags, only see an AMD onboard controller and an LSI HBA, both should work fine.

I still seem to be having some issues after down grade. I posted new logs before reboot that might lead to some errors. I posted it on a new post here 


Edited by jlw_4049
  • Like 1
Link to comment

Just did the upgrade from 6.12.3 to 6.12.6 and now I am unable to log in via a web browser.  Incorrect username/password reported.

but I can log in with the same account via putty ??

so now the "fun" start with me trying to find how to reset the password from the ssh shell or downgrade back to the previous version





I had tried another browser which had cleared cookies, but actually had to close the other browser down, so perhaps there was a tab that was locking the account out before i could log in,  but I am in again and the array is running :)

Edited by hwextreme
  • Like 1
Link to comment
On 12/22/2023 at 12:29 PM, hwextreme said:

and now I am unable to log in via a web browser.  Incorrect username/password reported.


This behavior can happen when SSL is disabled, the browser gets fixated on the SSL URL and doesn't want to use the non-SSL URL. The fix is to clear your cache and restart your browser as mentioned in the warning shown when you disable SSL:

I would not expect the upgrade from 6.12.3 to 6.12.6 to have disabled SSL, but I'm glad you are back in. If you need help setting up SSL in the new version see https://docs.unraid.net/unraid-os/manual/security/secure-webgui-ssl/

Link to comment

The Tower is primarily used as a media server and file storage. The emby docker is used daily. Have streamed movies, TV Shows, etc. since the upgrade. In addition I have used a number of other dockers including Sonaar, Crashplan Pro backup (daily), Diskspeed, and others with no issues or errors in the logs. Have also booted and upgraded a Windows 10 VM. As I was away for Christmas, I also was able to access the Tower (all shares) and via VPM Manager (Wireguard) with no issues.


Hope this helps.



I did backup the flash drive and create a diagnostics report prior to the upgrade as this is a best practice, Didn't need them thankfully.



  • Like 1
Link to comment
On 12/10/2023 at 10:08 AM, dlandon said:

Try removing the '/flash/config/modprobe.d/i915.conf' file and reboot.


Had a little downtime so thought I would revisit this. Made no difference.


Still hangs on every reboot, have to force reset.

No iGPU access.


Had to rollback to 6.12.4, again. And everything was back to working immediately.


However, noticed this time on reboot I had a bunch of extra random stuff appear onscreen, followed by the message

"not automatically fixing this"

Research suggested running chkdsk on the USB. I did that, but no errors found. Plugged back in to the same USB port and rebooted. However now it seems to be stuck at "Verifying bzfirmware checksum...", but it does let me login to the GUI.

Further research suggested copying over the original bz* files. Did that, doesn't get stuck on verifying anymore, but the random stuff and "not automatically fixing this" remained.

Now found this thread https://forums.unraid.net/bug-reports/prereleases/there-are-differences-between-boot-sector-and-its-backup-r1745/ and followed it. Seems to have fixed that issue.


TL;DR back on 6.12.4 and going to leave it alone at this point. Once something newer than 6.12.6 comes out I will wait and see if others report success before I even try.

Link to comment

Similar to mrhanderson, I made another attempt at 6.12.6 from a working 6.12.4 with the 13th gen Intel & W680 board. This time I captured diagnostics I'm attaching. The system doesn't seem to fully start not reaching the login prompt via command line (while watching via IPMI). However, the GUI comes up successfully and I'm able to interact with the system. The array starts (although I had Docker disabled this time), but I can see same iGPU access issues. It also hangs on every shutdown and forces a hard power down.


I also booted the system using a new, cleanly installed USB. It booted to the login fully. No plugins, so I didn't check the iGPU issues. However, the system still hung during shutdown on the clean USB and I had to manually power off again. I captured the diagnostics for this boot as well, but not sure if it's helpful.


For now, I'm also rolled back to 6.12.4 with everything fully functional again.

tower-diagnostics-20231231-0829.zip tower-diagnostics-20231231-0931_clean install.zip

  • Like 1
Link to comment
On 12/31/2023 at 6:44 PM, jakea333 said:

Similar to mrhanderson, I made another attempt at 6.12.6 from a working 6.12.4 with the 13th gen Intel & W680 board.

BTW, just got a W680 Supermicro board with an i5 13500 CPU, and although this is to upgrade my desktop, not going to be an Unraid server, did a quick test and have no issues booting Unraid 6.12.6, with the AST and iGPU GPUs enable, it loads both drives and outputs image from both also.

  • Like 1
Link to comment
1 hour ago, 0x0x0x said:

I am having issues with stability since updating to 6.12.6. After roughly 20 minutes of uptime the entire server goes down and doesn't even respond to pings. Attached please find my diagnostics.


Please review the updated release notes:


particularly these sections:

  • Call traces and crashes related to macvlan
  • Problems due to Realtek network cards
Link to comment

After spending a couple of days to test things I am still having instability issues even after going through the linked release notes and disabling or changing settings in the recommended fashion. I can no longer access the Community Applications. I have Intel drivers for my NICs not realtek. I do have a realtek device that's an SDR for Piaware.


I am unsure how to proceed and would genuinely welcome some advice on returning to a stable platform. Thanks for all your help friends.

Link to comment



i updated from 6.12.4 everything is fine...im using the new macvtap method with no bridging and everything is good..the only thing i noticed is at settings>docker >custom network type is not hidden like the release notes :


With bridging disabled for the main interface (eth0), then the Docker custom network type will be set to macvlan and hidden


Screenshot 2024-01-09 181541.png

Screenshot 2024-01-09 181606.png

Link to comment

I do (also) have stability problems (with any of the versions after 6.12.3)... the server is just getting unresponsive after some time (sometimes half an hour, sometimes a few hours; seems to happen sooner if the web interface is open on another machine). Does not longer respond to pings (no screen output due to GPU passthrough).

Docker is disabled (always), have tried the Realtek driver plugin, but that did not help....


Edited by t3
Link to comment

stability problems appeared after a planned shutdown today...server hanged and never shut down...when i connected on the webui its was at stopping array.... stopping services...when i pressed again shutdown then it was done...After the reboot parity check started 🤨🤨..then something was missing..no docker tab😶 i went into the docker settings and it was at off.. and also has reset my custom docker timeout to 10 sec..and access to custom networks setting also to default setting..tried to start again and my docker containers are working ...phewwww...posting diagnostics from tools page...flash diagnostics not created..


edit: also now discovered that resized my docker.img container to default 20g...👺



Edited by tgiannak
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.