[Support] Linuxserver.io - Plex Media Server


5021 posts in this topic Last Reply

Recommended Posts

I tried to switch to this dokcer image, why does it not accept spaces in "host path" or "Contrainer volume"? (/mnt/user/Tv Shows/ and /Tv_Shows)

 

Can you try the following, download and unzip the attached file docker.zip and copy the docker script to:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts

 

Make sure the docker script is executable (chmod +x /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker) if needed.

 

Like to hear your feedback.

I really dont want to just try out things on my main server, sorry. Maybe someone else can test this?

Link to post
  • Replies 5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Go to the appdata share and look in Plex\Library\Application Support\Plex Media Server\Crash Reports You will find folders for your previous versions named as the release version.

Yep, seems like the problem.   Not to be outdone... google.  And what do I find.... Hoopster's post from over a year ago. I see your post here regarding the iGPU not being enabled corr

Application Name: Plex Media Server Application Site: https://plex.tv/ Docker Hub: https://hub.docker.com/r/linuxserver/plex/ Github: https://github.com/linuxserver/docker-plex  

Posted Images

I tried to switch to this dokcer image, why does it not accept spaces in "host path" or "Contrainer volume"? (/mnt/user/Tv Shows/ and /Tv_Shows)

 

Can you try the following, download and unzip the attached file docker.zip and copy the docker script to:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts

 

Make sure the docker script is executable (chmod +x /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker) if needed.

 

Like to hear your feedback.

 

Yep that worked.  Just tried it in my VM...

Link to post

I tried to switch to this dokcer image, why does it not accept spaces in "host path" or "Contrainer volume"? (/mnt/user/Tv Shows/ and /Tv_Shows)

 

Can you try the following, download and unzip the attached file docker.zip and copy the docker script to:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts

 

Make sure the docker script is executable (chmod +x /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker) if needed.

 

Like to hear your feedback.

 

Pretty good timing bonienl, whilst you were fixing this I was posting a defect report...  ;D

Link to post

I tried to switch to this dokcer image, why does it not accept spaces in "host path" or "Contrainer volume"? (/mnt/user/Tv Shows/ and /Tv_Shows)

 

Can you try the following, download and unzip the attached file docker.zip and copy the docker script to:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts

 

Make sure the docker script is executable (chmod +x /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker) if needed.

 

Like to hear your feedback.

 

Pretty good timing bonienl, whilst you were fixing this I was posting a defect report...  ;D

... Just did the same, haha  :P :P

https://lime-technology.com/forum/index.php?topic=47186.0

Link to post

I tried to switch to this dokcer image, why does it not accept spaces in "host path" or "Contrainer volume"? (/mnt/user/Tv Shows/ and /Tv_Shows)

 

Can you try the following, download and unzip the attached file docker.zip and copy the docker script to:

 

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts

 

Make sure the docker script is executable (chmod +x /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker) if needed.

 

Like to hear your feedback.

 

Pretty good timing bonienl, whilst you were fixing this I was posting a defect report...  ;D

 

Guess time for a 'hot-fix'  :'(

Link to post

It's working now.  Thank you.  I've been contacted by family members because Plex isn't working all day.

 

Out of interest can you post your mappings, because I thought you weren't using spaces in your share names, which was the cause of the issue that has been fixed.  :-\

Link to post

It's working now.  Thank you.  I've been contacted by family members because Plex isn't working all day.

 

Out of interest can you post your mappings, because I thought you weren't using spaces in your share names, which was the cause of the issue that has been fixed.  :-\

 

I do use spaces for my TV Shows folder share.

 

mnt/user/Media/TV Shows

Link to post

Successfully switched from needo to Linuxserver.io Plex Media Server. Permissions change took less than 20 seconds. Plex Pass version up and running as if nothing changed.  8)

 

Tried to add a new TV episode tonight and Plex refused to acknowledge the new file in season folder. Looked on Plex site and found others complaining about this latest version too. Mods were asking for logs so I load up the appdata share and while drilling in to the folder I noticed a .lock file. Looks like the permissions failed to finish?

 

Anyway I investigate further and find that ALL my TV shows are shown as "unavailable" in Plex. Its like it can't read that share at all. Movies are fine it seems.

 

I removed Linuxserver.io Plex docker and reinstalled Needo Plex docker. Presto chango, all my TV shows are back and it found the new episode. Same version of Plex. Clearly something failed in the switch to Linuxserver.io and failed silently.

Screenshot_1.png.f4d5575c8ab6a5796f18fc1b29b77f8c.png

Link to post

Successfully switched from needo to Linuxserver.io Plex Media Server. Permissions change took less than 20 seconds. Plex Pass version up and running as if nothing changed.  8)

 

Tried to add a new TV episode tonight and Plex refused to acknowledge the new file in season folder. Looked on Plex site and found others complaining about this latest version too. Mods were asking for logs so I load up the appdata share and while drilling in to the folder I noticed a .lock file. Looks like the permissions failed to finish?

 

Anyway I investigate further and find that ALL my TV shows are shown as "unavailable" in Plex. Its like it can't read that share at all. Movies are fine it seems.

 

I removed Linuxserver.io Plex docker and reinstalled Needo Plex docker. Presto chango, all my TV shows are back and it found the new episode. Same version of Plex. Clearly something failed in the switch to Linuxserver.io and failed silently.

 

Having the same issue.  Moves are fine, but added new TV Show files, and it won't update.

Link to post

I've looked everywhere and can't find an answer to my question.

 

Why do I not have the option to configure the server? The we GUI keeps telling me to download a server instance.

 

I'm moving PMS off of my windows server to the docker and for some reason the docker found the windows server and has never let me configure the docker server.

 

I've followed https://support.plex.tv/hc/en-us/articles/201370363-Move-an-Install-to-Another-System and it did not help.

 

I'm trying to look at the preferences.xml to see if there is something there that is causing this, but I've removed the docker and the share to start over. Everything has been recreated without any errors, but I still can't configure the server. Even after the preferences.xml is re-created I can't edit or view it.

 

Could something be stored in the docker.img that is causing this? How would I find out? I can start over, but I'd rather not delete the docker.img and have to re-configure all of my dockers.

 

I've got to be missing something simple.

 

EDIT: It was simple. I had network set as bridged instead of host. Woops.

Link to post

Successfully switched from needo to Linuxserver.io Plex Media Server. Permissions change took less than 20 seconds. Plex Pass version up and running as if nothing changed.  8)

 

Tried to add a new TV episode tonight and Plex refused to acknowledge the new file in season folder. Looked on Plex site and found others complaining about this latest version too. Mods were asking for logs so I load up the appdata share and while drilling in to the folder I noticed a .lock file. Looks like the permissions failed to finish?

 

Anyway I investigate further and find that ALL my TV shows are shown as "unavailable" in Plex. Its like it can't read that share at all. Movies are fine it seems.

 

I removed Linuxserver.io Plex docker and reinstalled Needo Plex docker. Presto chango, all my TV shows are back and it found the new episode. Same version of Plex. Clearly something failed in the switch to Linuxserver.io and failed silently.

 

Updating Plex version today and noticed that while I thought I had installed Needo's (didn't pay attention to what template was being used), in fact I had reinstalled Linuxserver.io so that was the fix to the permissions thing since it worked fine after that.  My bad lol

Link to post

It doesn't seem to be updating automatically. It was. But now, while at Version 0.9.15.6 it is telling me to update manually. I don't know how to do that. However, I have completely reinstalled the docker. And I'm still at this version. I'm hoping to get Version 0.9.16.0.1754.

 

Any thoughts?

Link to post

It doesn't seem to be updating automatically. It was. But now, while at Version 0.9.15.6 it is telling me to update manually. I don't know how to do that. However, I have completely reinstalled the docker. And I'm still at this version. I'm hoping to get Version 0.9.16.0.1754.

 

Any thoughts?

 

What do you have your VERSION variable set to?

Link to post

I'm also a little confused about how to keep my Plex Media Server up-to-date. It seems every few weeks a new version of the container comes out and it updates to a new version of Plex when I install it, but I can't seem to figure out how to update Plex on it's own.

 

I have seen a few posts about setting the version variable, but I can't seem to figure out how to do that on the Docker page of the webUI - the only thing I can set is Volume Mappings.

 

Could anyone fill me in on what I'm missing?

 

Cheers,

 

whiteatom

Link to post

I'm also a little confused about how to keep my Plex Media Server up-to-date. It seems every few weeks a new version of the container comes out and it updates to a new version of Plex when I install it, but I can't seem to figure out how to update Plex on it's own.

 

I have seen a few posts about setting the version variable, but I can't seem to figure out how to do that on the Docker page of the webUI - the only thing I can set is Volume Mappings.

 

Could anyone fill me in on what I'm missing?

 

Cheers,

 

whiteatom

 

Restart the container, that is the only way that is recommended.

Link to post

I'm also a little confused about how to keep my Plex Media Server up-to-date. It seems every few weeks a new version of the container comes out and it updates to a new version of Plex when I install it, but I can't seem to figure out how to update Plex on it's own.

 

I have seen a few posts about setting the version variable, but I can't seem to figure out how to do that on the Docker page of the webUI - the only thing I can set is Volume Mappings.

 

Could anyone fill me in on what I'm missing?

 

Cheers,

 

whiteatom

 

Restart the container, that is the only way that is recommended.

 

Nevermind.. that wasn't the issue.. the little tiny "Advanced View" slider that I had not seen. Just flipped it and found the variables and now all is well.

 

Thanks anyway!

Link to post

 

I'm also a little confused about how to keep my Plex Media Server up-to-date. It seems every few weeks a new version of the container comes out and it updates to a new version of Plex when I install it, but I can't seem to figure out how to update Plex on it's own.

 

I have seen a few posts about setting the version variable, but I can't seem to figure out how to do that on the Docker page of the webUI - the only thing I can set is Volume Mappings.

 

Could anyone fill me in on what I'm missing?

 

Cheers,

 

whiteatom

 

Restart the container, that is the only way that is recommended.

 

Nevermind.. that wasn't the issue.. the little tiny "Advanced View" slider that I had not seen. Just flipped it and found the variables and now all is well.

 

Thanks anyway!

 

You dont need to set the version at all, the container will update plex itself to latest version when you start the container up, thus  restart=update :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.