[Support] Linuxserver.io - Plex Media Server


4830 posts in this topic Last Reply

Recommended Posts

  • Replies 4.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Go to the appdata share and look in Plex\Library\Application Support\Plex Media Server\Crash Reports You will find folders for your previous versions named as the release version.

Yep, seems like the problem.   Not to be outdone... google.  And what do I find.... Hoopster's post from over a year ago. I see your post here regarding the iGPU not being enabled corr

Application Name: Plex Media Server Application Site: https://plex.tv/ Docker Hub: https://hub.docker.com/r/linuxserver/plex/ Github: https://github.com/linuxserver/docker-plex  

Posted Images

I'm having a small permissions problem that I'm not sure how to fix, hoping this is the right place to post for help.

 

Whenever I copy a file .bundle or video file to my shares Plex is unable to see it. I'm connecting over SMB with my file copy (furby) user account. With Mac OS (10.11) and Finder. (gt is my local account).

 

Do I need to set the permissions each time I copy a file over? And if so what should it be?

 

Via Terminal, mounted as a share on Mac OS I get:

 

mbp02:Season 6 gt$ ls
Archer (2009) - S06E01 - The Holdout.mkv
Archer (2009) - S06E02 - Three to Tango.mkv
Archer (2009) - S06E03 - The Archer Sanction.mkv
Archer (2009) - S06E04 - Edie's Wedding.mkv
Archer (2009) - S06E05 - Vision Quest.mkv
Archer (2009) - S06E06 - Sitting.mkv
Archer (2009) - S06E07 - Nellis.mkv
Archer (2009) - S06E08 - The Kanes.mkv
Archer (2009) - S06E09 - Pocket Listing.mkv
Archer (2009) - S06E10 - Reignition Sequence.mkv
Archer (2009) - S06E11 - Achub Y Morfilod.mkv
Archer (2009) - S06E12 - Drastic Voyage (1).mkv
Archer (2009) - S06E13 - Drastic Voyage (2).m4v
mbp02:Season 6 gt$ ls -l
total 20541704
-rwx------@ 1 gt  staff  934235779  9 Jan  2015 Archer (2009) - S06E01 - The Holdout.mkv
-rwx------  1 gt  staff  868042912 17 Jan  2015 Archer (2009) - S06E02 - Three to Tango.mkv
-rwx------@ 1 gt  staff  939863010 23 Jan  2015 Archer (2009) - S06E03 - The Archer Sanction.mkv
-rwx------@ 1 gt  staff  827798274 30 Jan  2015 Archer (2009) - S06E04 - Edie's Wedding.mkv
-rwx------@ 1 gt  staff  793319712  7 Feb  2015 Archer (2009) - S06E05 - Vision Quest.mkv
-rwx------@ 1 gt  staff  819392223 13 Feb  2015 Archer (2009) - S06E06 - Sitting.mkv
-rwx------@ 1 gt  staff  810843815 20 Feb  2015 Archer (2009) - S06E07 - Nellis.mkv
-rwx------@ 1 gt  staff  875287898 27 Feb  2015 Archer (2009) - S06E08 - The Kanes.mkv
-rwx------@ 1 gt  staff  826319474  6 Mar  2015 Archer (2009) - S06E09 - Pocket Listing.mkv
-rwx------@ 1 gt  staff  403380291 13 Mar  2015 Archer (2009) - S06E10 - Reignition Sequence.mkv
-rwx------@ 1 gt  staff  878573666 20 Mar  2015 Archer (2009) - S06E11 - Achub Y Morfilod.mkv
-rwx------@ 1 gt  staff  927908597 31 Mar  2015 Archer (2009) - S06E12 - Drastic Voyage (1).mkv
-rwx------  1 gt  staff  612380388 15 Feb 18:37 Archer (2009) - S06E13 - Drastic Voyage (2).m4v

 

but when I SSH/Telnet in I get

root@Tower:/mnt/disk1/TV Shows/Archer (2009)/Season 6# ls
Archer\ (2009)\ -\ S06E01\ -\ The\ Holdout.mkv           Archer\ (2009)\ -\ S06E07\ -\ Nellis.mkv
Archer\ (2009)\ -\ S06E02\ -\ Three\ to\ Tango.mkv       Archer\ (2009)\ -\ S06E08\ -\ The\ Kanes.mkv
Archer\ (2009)\ -\ S06E03\ -\ The\ Archer\ Sanction.mkv  Archer\ (2009)\ -\ S06E09\ -\ Pocket\ Listing.mkv
Archer\ (2009)\ -\ S06E04\ -\ Edie's\ Wedding.mkv        Archer\ (2009)\ -\ S06E10\ -\ Reignition\ Sequence.mkv
Archer\ (2009)\ -\ S06E05\ -\ Vision\ Quest.mkv          Archer\ (2009)\ -\ S06E11\ -\ Achub\ Y\ Morfilod.mkv
Archer\ (2009)\ -\ S06E06\ -\ Sitting.mkv                Archer\ (2009)\ -\ S06E12\ -\ Drastic\ Voyage\ (1).mkv
root@Tower:/mnt/disk1/TV Shows/Archer (2009)/Season 6# ls -l
total 9682283
-rw-rw-rw- 1 nobody users 934235779 Jan  9  2015 Archer\ (2009)\ -\ S06E01\ -\ The\ Holdout.mkv
-rw-rw-rw- 1 nobody users 868042912 Jan 17  2015 Archer\ (2009)\ -\ S06E02\ -\ Three\ to\ Tango.mkv
-rw-rw-rw- 1 nobody users 939863010 Jan 23  2015 Archer\ (2009)\ -\ S06E03\ -\ The\ Archer\ Sanction.mkv
-rw-rw-rw- 1 nobody users 827798274 Jan 30  2015 Archer\ (2009)\ -\ S06E04\ -\ Edie's\ Wedding.mkv
-rw-rw-rw- 1 nobody users 793319712 Feb  7  2015 Archer\ (2009)\ -\ S06E05\ -\ Vision\ Quest.mkv
-rw-rw-rw- 1 nobody users 819392223 Feb 13  2015 Archer\ (2009)\ -\ S06E06\ -\ Sitting.mkv
-rw-rw-rw- 1 nobody users 810843815 Feb 20  2015 Archer\ (2009)\ -\ S06E07\ -\ Nellis.mkv
-rw-rw-rw- 1 nobody users 875287898 Feb 27  2015 Archer\ (2009)\ -\ S06E08\ -\ The\ Kanes.mkv
-rw-rw-rw- 1 nobody users 826319474 Mar  6  2015 Archer\ (2009)\ -\ S06E09\ -\ Pocket\ Listing.mkv
-rw-rw-rw- 1 nobody users 403380291 Mar 13  2015 Archer\ (2009)\ -\ S06E10\ -\ Reignition\ Sequence.mkv
-rw-rw-rw- 1 nobody users 878573666 Mar 20  2015 Archer\ (2009)\ -\ S06E11\ -\ Achub\ Y\ Morfilod.mkv
-rw-rw-rw- 1 nobody users 927908597 Mar 31  2015 Archer\ (2009)\ -\ S06E12\ -\ Drastic\ Voyage\ (1).mkv

 

I don't know enough to figure out why the last file is like that. I copied some other over and the same result :(

Link to post

hey guys plex webGUI General settings tab it indicates there is an update and to install this update 0.9.15.6.1714, can someone please tell me how do i manually update plex server, im using linuxserver but when i check for update there is no update

 

thanks in advanced

Link to post

hey guys plex webGUI General settings tab it indicates there is an update and to install this update 0.9.15.6.1714, can someone please tell me how do i manually update plex server, im using linuxserver but when i check for update there is no update

 

thanks in advanced

 

Restart the plex container

Link to post

Hi guys - on 2/29, plex released version 0.9.16.0.1754-23623fb.  It seems that the auto upgrade capabilities of this docker rely on grabbing info from tools.linuxserver.io/latest-plex.json  which still states:

 

    "last_checked": 1456925857,

    "version": "0.9.15.6.1714-7be11e1",

 

 

I'm curious what level of automation exists (if any?) to make sure that linuxserver.io's version of "latest" that it keeps local to linuxserver.io gets regularly updated, and at what frequency?

 

Thanks,

-Jim

Link to post

@Jim, i think it checks every 15 minutes or something like that...

 

The latest public release is Version 0.9.15.6.1714-7be11e1

 

The latest plexpass release is Version 0.9.16.0.1754-23623fb

 

Do you have VERSION set to PLEXPASS in the docker config for plex?

Link to post

I have installed this docker and did the initial library scan and all was fine. Set plex to automatically add new items to library. It's not doing that though. Also it's not adding anything new if I manually update the library.

 

My docker folders that I added to plex are

 

/movies        =        /mnt/user/movies

/series          =        /mnt/user/series

 

That's the only thing I added to the docker install. Configuration folder is default of /mnt/appdata/plex

 

Any ideas?

Link to post

I have installed this docker and did the initial library scan and all was fine. Set plex to automatically add new items to library. It's not doing that though. Also it's not adding anything new if I manually update the library.

 

My docker folders that I added to plex are

 

/movies        =        /mnt/user/movies

/series          =        /mnt/user/series

 

That's the only thing I added to the docker install. Configuration folder is default of /mnt/appdata/plex

 

Any ideas?

This definitely works for me. Are you sure the new stuff is in those locations and it is plex-compatible? Sounds like some issue you're having with plex itself rather than with this docker. Have you searched at the plex website?
Link to post

*UPDATE*

 

Nevermind, it just took *forever* to become accessible. GUI is working, streaming is working. Everything is good and right in the world. :-)

 

Original post:

 

Updated my Docker today (first time I've done that since setting up the server about a week ago) and now it doesn't work. unRAID shows it as running, but GUI is not accessible and the log shows it's just sitting at "Starting Avahi daemon". Using linuxserver/plex.latest. :-(

Link to post

*UPDATE*

 

Nevermind, it just took *forever* to become accessible. GUI is working, streaming is working. Everything is good and right in the world. :-)

 

Original post:

 

Updated my Docker today (first time I've done that since setting up the server about a week ago) and now it doesn't work. unRAID shows it as running, but GUI is not accessible and the log shows it's just sitting at "Starting Avahi daemon". Using linuxserver/plex.latest. :-(

 

I don't know...I kinda just restarted my Docker for PMS and now I'm getting this over and over:

 

--2016-03-04 00:19:39--  https://downloads.plex.tv/plex-media-server//plexmediaserver__amd64.deb
Resolving downloads.plex.tv (downloads.plex.tv)... 104.20.6.9, 104.20.7.9, 2400:cb00:2048:1::6814:609, ...
Connecting to downloads.plex.tv (downloads.plex.tv)|104.20.6.9|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-03-04 00:19:40 ERROR 404: Not Found.

 

I can't start the Plex Server or the GUI

 

UPDATE::::

Looks like it was stuck when setting VERSION variable to plexpass. When I changed it to latest it started to work.

Is there any difference? Or does it only matter if I have Plex Pass update options set in PMS?

Link to post
I can't start the Plex Server or the GUI

UPDATE::::

Looks like it was stuck when setting VERSION variable to plexpass. When I changed it to latest it started to work.

Is there any difference? Or does it only matter if I have Plex Pass update options set in PMS?

 

I get exactly the same your the plexpass version.

 

It works using latest, but that uses the latest version for non plexpass users, so plex immediately tells me there is an update to download.

 

Is there an issue get access to download the plexpass version?

 

Using version: from Plexpass latest

Upgrading from version: 0.9.16.0.1754-23623fb to version:

Link to post

I can't start the Plex Server or the GUI

UPDATE::::

Looks like it was stuck when setting VERSION variable to plexpass. When I changed it to latest it started to work.

Is there any difference? Or does it only matter if I have Plex Pass update options set in PMS?

 

I get exactly the same your the plexpass version.

 

It works using latest, but that uses the latest version for non plexpass users, so plex immediately tells me there is an update to download.

 

Is there an issue get access to download the plexpass version?

 

Using version: from Plexpass latest

Upgrading from version: 0.9.16.0.1754-23623fb to version:

 

I think maybe Plex had an issue with their servers that store the latest plexpass builds last night. I changed the variable in the docker to 'plexpass' and restarted....all is fine this morning.

Link to post

I've been leaving my Plex docker running for hours (2-3+) on both plexpass and latest and I am still unable to access the Plex UI.

Strangely, the log is also empty.

 

This also happens if I try a clean install with an empty settings directory and after deleting the docker container and image :(

 

UPDATE::

 

After clearing out the container and image again and a few more restarts, I managed to get the "latest" non Plex Pass version up and running.

Link to post

Updated to the latest UnRaid version 6.1.9.  Re-booted my server, I noticed Plex had been stopped.  So, instead of me re-starting it, I clicked on "forced update."  After I did that, Plex docker was no longer available.

 

I tried re-installing it, and nothing happens.  I went into my flash and delete everything Plex.  I tried to re-install again, and nothing.  So, I went into my phone's deleted pics, and I was able to find the Volume mappings.  Good thing I did because /config was mapped wrong lol.

 

However, I get this at the end

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="PlexMediaServer" --net="host" --privileged="true" -e TZ="America/Los_Angeles" -v "/mnt/cache/appdata/plexmediaserver":"/config":rw -v "/mnt/user/Media/Movies":"/Movies":rw -v "/mnt/user/Media/TV Shows":"/TV Shows":rw limetech/plex

Unable to find image 'Shows:/TV:latest' locally

Invalid repository name (TV), only [a-z0-9-_.] are allowed

 

 

What does "unable to find image 'Shows:TV:latest' locally" mean?

Link to post

Yeah, I can't install Plex.  I've double checked all my volume mappings, and this is what I get:

 

Pulling image: limetech/plex:latest

IMAGE ID [latest]: Pulling from limetech/plex.

IMAGE ID [83e4dde6b9cf]: Already exists.

IMAGE ID [b670fb0c7ecd]: Already exists.

IMAGE ID [29460ac93442]: Already exists.

IMAGE ID [d2a0ecffe6fa]: Already exists.

IMAGE ID [f21b69028ac0]: Already exists.

IMAGE ID [fc06acda5256]: Already exists.

IMAGE ID [ed3f43ffe5bc]: Already exists.

IMAGE ID [e9f50c1887ea]: Already exists.

IMAGE ID [efb449a26780]: Already exists.

IMAGE ID [dd874a6b16c8]: Already exists.

IMAGE ID [1c71f000e1ef]: Already exists.

IMAGE ID [5f28e93f0daa]: Already exists.

IMAGE ID [4df49f8de021]: Already exists.

IMAGE ID [da65f85a3888]: Already exists.

IMAGE ID [19fd5a5a7ee5]: Already exists.

IMAGE ID [71c90cc41820]: Already exists.

IMAGE ID [0a6c5f2f7ae9]: Already exists. Digest: sha256:6e3287a07179d03c7d46d6dc6d4a16fb0bc0f06365e012440f03f1b00f800621. Status: Image is up to date for limetech/plex:latest.

 

TOTAL DATA PULLED: 0 B

 

 

 

Command:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="PlexMediaServer" --net="host" --privileged="true" -e TZ="America/Los_Angeles" -v "/mnt/cache/appdata/plexmediaserver":"/config":rw -v "/mnt/user/Media/Movies":"/Movies":rw -v "/mnt/user/Media/TV Shows":"/TV Shows":rw limetech/plex

Unable to find image 'Shows:/TV:latest' locally

Invalid repository name (TV), only [a-z0-9-_.] are allowed

 

The command finished successfully!

 

When I go to the docker section there is no Plex application at all.

Link to post

Click the advanced slider in the Unraid Docker webui and I wouldn't be surprised if there is an orphan container there.  Delete that and try again would be my first thought.

 

I deleted the two orphan images.  I added Plex via Community Applications, and I only get another orphan image with

 

Command:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="PlexMediaServer" --net="host" --privileged="true" -e TZ="America/Los_Angeles" -v "/mnt/cache/appdata/plexmediaserver":"/config":rw -v "/mnt/user/Media/Movies":"/Movies":rw -v "/mnt/user/Media/TV Shows":"/TV Shows":rw limetech/plex

Unable to find image 'Shows:/TV:latest' locally

Invalid repository name (TV), only [a-z0-9-_.] are allowed

 

 

Link to post

I did not find a Linuxserver general thread, so I post here istead. Still relevant.

 

I am not using any dockers from Linuxserver atm, but I am maybe switching to. I have heard that to update dockers, you have to restart it.

If I go to the docker tab on my unRAID server, and click "check for updates", will the new update show up there?

Link to post

I did not find a Linuxserver general thread, so I post here istead. Still relevant.

 

I am not using any dockers from Linuxserver atm, but I am maybe switching to. I have heard that to update dockers, you have to restart it.

If I go to the docker tab on my unRAID server, and click "check for updates", will the new update show up there?

As a rule, no, although once a month we update the base image which will cause it to show up, but for app updates then a container restart, unraid array restart or docker service restart is required.

Link to post

 

I think maybe Plex had an issue with their servers that store the latest plexpass builds last night. I changed the variable in the docker to 'plexpass' and restarted....all is fine this morning.

 

Thats what I thought initially, but then I could change to latest and update, then change back to plexpass and it would update and load Plex fine.

 

If I kept on plexpass it was as though it was trying to download an unknown version and just hung there.

 

I can get around it, but am not convinced it is Plex servers.

 

Edit: Update this morning of the container, allow plexpass to run fine so far :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.