[Support] Linuxserver.io - Syncthing


245 posts in this topic Last Reply

Recommended Posts

Hi everybody

 

As I discovered Syncthing few days ago I'm pretty sure my question would seem stupid to you !

I want to backup my laptop documents on my NAS, like I did befor with my synology (with Drive)

 

I setup my syncthing folders this way in the container :

mnt/user/backups/BACKUP_XIAOMI_MI_AIR       > /sync

/mnt/user/appdata/syncthing                 > /config 

The PUID / GUID are 99/100

I have no error messages (like I read in this thread, like permission issues)

 

The problem is : all the data I want to backup is stored in the config directory on my cache drive (which is now full ^^)

So the /sync folder is not used...

What am I doing wrong ?

Edited by guilhem31
More informations
Link to post
  • Replies 244
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@mbc0, @CommandLionInterface, @CHBMB   I requested, and was granted, a change to the docker container. The solution to all your write-on-samba problems is now here. First, make s

Application Name: Syncthing Application Site:  https://syncthing.net/ Docker: https://hub.docker.com/r/linuxserver/syncthing/ Github: https://github.com/linuxserver/docker-syncthing

I am a bit ashamed to ask this as I had this problem with a previous install, posted about it, had the post answered (partially, but understood it at the time) but now I am having a similar (same?) pr

Posted Images

Syncthing offers a default folder path that starts with config, which you need to remove

 

In the container configuration for my backup location, My Host Path 2 is:  /mnt/user/

In the Syncthing app, my folder path is: /sync/Backup/Richard

 

That puts the files into a share called Backup with a subfolder called Richard

 

Link to post
4 hours ago, RichardU said:

Syncthing offers a default folder path that starts with config, which you need to remove

 

In the container configuration for my backup location, My Host Path 2 is:  /mnt/user/

In the Syncthing app, my folder path is: /sync/Backup/Richard

 

That puts the files into a share called Backup with a subfolder called Richard

 

Thanks a lot for your hints. It seems to be the right thing to do, but in my Syncthing app (via the webUI) I can't change the folder path, the input is grey :

aeh2w8Z.png

So it's impossible for me to change /config/myfolder to /sync/myfolder

Link to post

I was experience terrible speeds using Syncthing in docker on unRAID... Until I pinned the docker to only use a couple of CPU cores (switch Basic View to Advanced in the docker's "edit" screen)

 

I'm now seeing bursts up to 20-30MB/sec where previously I never saw anything higher than 2-3MB/sec.

 

I can only assume this was a CPU scheduling issue (ie. is the syncthing docker waiting for all cores to be available for some reason?)

 

edit: I may have spoken to soon - occasionally I'm seeing up to 20MB/sec, but this mostly settles back to <2MB/sec after a while.  Very frustrating!

Edited by ConnectivIT
Link to post
  • 1 month later...

I think it has been asked here but I see no answer or guidance. I managed to setup Syncthing in 2 Unraid servers and they're talking to each other. Now this is not very clear.

 

How do I point Unraid 1 to an existing folder/share to sync it across to the Unraid 2?   Looks like permission issue to me? 

Screen Shot 2020-06-28 at 2.30.02 PM.png

Link to post
  • 3 weeks later...
On 8/9/2019 at 9:32 AM, Cliff said:

I am trying to get syncthing to sync to my google drive folder without success. I have mounted a google drive folder with:


mkdir -p /mnt/user/google_syncfolder
rclone mount --buffer-size 256M --fast-list --allow-other gdrive:Dump/ /mnt/user/google_syncfolder &

I can see the mounted folder and all google drive files and can also copy from/to my google drive with the use of a file-browser on unraid.

I have also added the same directory to the path in the syncthing container. But when trying to sync from a remote syncthing-server to the unraid server it just sits at 0% and then throws a sync error.

 

If I look on my google drive I can see that syncthing has created a zero-byte .tmp file for every file I am trying to sync

 

If I change the path in the syncthing container to a regular folder on the unraid server it works without problem. Can anyone explain to me how to solve this?

Did you ever get this resolved?

 

I'm having a similar issue, but with Onedrive. It's finding the folder fine, and loading some .tmp files in there (upto a few 100kb), but then throwing up sync errors (both illegal seek & operation not permitted).

 

and example of the errors:

2020-07-19 21:36:57 Puller (folder "5870" (5870), item "DSC_3452.JPG"): truncate /onedrive/pictures/.syncthing.DSC_3452.JPG.tmp: operation not permitted
2020-07-19 21:37:00 Puller (folder "5870" (5870), item "DSC_3453.JPG"): save: write /onedrive/pictures/.syncthing.DSC_3453.JPG.tmp: illegal seek

 

I've tried a load of different rclone configs e.g. changing the uid to match the syncthing docker uid etc but I continue to get the same errors.

I've tried with & without "ignore permissions" set, with no difference.

I can access & write to the rclone mount in other dockers fine.

 

Anyone got any ideas?

Link to post
On 7/19/2020 at 9:40 PM, thingie2 said:

Did you ever get this resolved?

 

I'm having a similar issue, but with Onedrive. It's finding the folder fine, and loading some .tmp files in there (upto a few 100kb), but then throwing up sync errors (both illegal seek & operation not permitted).

 

and example of the errors:

2020-07-19 21:36:57 Puller (folder "5870" (5870), item "DSC_3452.JPG"): truncate /onedrive/pictures/.syncthing.DSC_3452.JPG.tmp: operation not permitted
2020-07-19 21:37:00 Puller (folder "5870" (5870), item "DSC_3453.JPG"): save: write /onedrive/pictures/.syncthing.DSC_3453.JPG.tmp: illegal seek

 

I've tried a load of different rclone configs e.g. changing the uid to match the syncthing docker uid etc but I continue to get the same errors.

I've tried with & without "ignore permissions" set, with no difference.

I can access & write to the rclone mount in other dockers fine.

 

Anyone got any ideas?

For anyone else who find this with similar issues, I found a solution.

 

The issue is the tasks that the rclone filesystem supports. Once I realised this, and could look into rclone's capability a bit more, I found the vfs-cache-mode parameter. I've since set this to write, and it has resolved my issues.

Link to post

I haven't ever used Syncthing but I'm trying it for a phone backup. I did a fresh docker. I had it sync to the config folder for now but I cannot access the folder over SMB. I get a permission error. Docker safe perms didn't help.

Link to post
3 hours ago, BoyMeets said:

I've been trying out syncthing the last few days but can't seem to get local discovery working on a 2 routers home network. Has anyone gotten a local connection between 2 routers?

By the sounds of it there wouldn't be anything "local" when separating machines by using 2 routers.  Each router has it's own network and would only be "local" to it's own network.

 

Why don't you want to add one of them as a remote device? Takes the guessing out of it.

Link to post

Actually your issue may be something totally different ..... all of a sudden my syncthing has stopped working and I cannot get them to connect.. Not sure when Syncthing updated to 1.7.1 or if that's the problem but I cannot get my 2 machines to connect, and I've changed nothing since they were working.

 

 

Edit -- Yes indeed, I rolled back my docker version to linuxserver/syncthing:v1.6.1-ls37 and it instantly worked again.

 

Something changed leading up to the most recent 1.7.1 that broke the container.  Not sure what it could be though.

Edited by Energen
Link to post

Anyone else experiencing slow syn speeds at the moment? I have to keep restarting the docker container to get the speed back up. Syncs at 20Mbps (my internet speed limit) for 10-15 min then drops suddenly to 1Mbps or less and never recovers until a restart. Only change I've made on my end is running UnraidOS 6.9-beta25. I rolled the container back to version 1.6.1 as 1.7.1 was even worse and wouldn't sync at all. 

 

I've also tried pinning what CPUs it can use but that didn't help. Only thing that helps is restarting the container. I've checked everything i can think of on my network but there is no QOS on the router (tried it with it on and that didnt help). Re installed the docker container completely re setting everything up. Nothing seems to stop the sudden slow down. 

 

Syncing to my Cache drive before moving to the array, There is plenty of Space on the cache drive 500+GB free

Link to post
  • 2 weeks later...
On 8/10/2020 at 9:56 AM, Rowanhs said:

Anyone else experiencing slow syn speeds at the moment? I have to keep restarting the docker container to get the speed back up. Syncs at 20Mbps (my internet speed limit) for 10-15 min then drops suddenly to 1Mbps or less and never recovers until a restart. Only change I've made on my end is running UnraidOS 6.9-beta25. I rolled the container back to version 1.6.1 as 1.7.1 was even worse and wouldn't sync at all. 

 

I've also tried pinning what CPUs it can use but that didn't help. Only thing that helps is restarting the container. I've checked everything i can think of on my network but there is no QOS on the router (tried it with it on and that didnt help). Re installed the docker container completely re setting everything up. Nothing seems to stop the sudden slow down. 

 

Syncing to my Cache drive before moving to the array, There is plenty of Space on the cache drive 500+GB free

 

Yeah Rowanhs - same here. Resilio is full speed, but Syncthing not so.

Link to post
On 8/25/2020 at 8:23 AM, riff.79 said:

 

Yeah Rowanhs - same here. Resilio is full speed, but Syncthing not so.

@riff.79 yeah i've given up and am trying Resilio. Out of interest does your DL speed zig zag all over the place with Resilio? It goes really quick and then drops to zero, builds up to speed then drops again. Over and over. 

Link to post
On 8/30/2020 at 4:32 PM, Rowanhs said:

@riff.79 yeah i've given up and am trying Resilio. Out of interest does your DL speed zig zag all over the place with Resilio? It goes really quick and then drops to zero, builds up to speed then drops again. Over and over. 

Yes!  100% CPU, slow indexing and unpredictable network speed. 

Link to post
  • 4 weeks later...

I'm interested in checking in on my setup... 

I have unraid 6.8.3 running with Syncthing docker. I have /sync set as my photos, this syncs from my phone camera. I also then created a /sync2 that points to another folder to sync to my phone as well.  I also setup /sync3 for syncing my wife's phone photos... all seems to work..  I have the server side setup to ignore delete and I only have it sync when connected to home wifi.  

Is this the correct setup?  I've been watching some Lawrence systems videos and it sounds like the best practice for adding more folders/devices is for the "remote" device to reach out to the Server, is that also correct? if I want to sync more folders, do I keep adding /sync locations with the path I want to sync? 

The only issue I've had..not really an issue I guess.. my /sync2, which is on my phone, if I delete from my phone, the server reports back that it's synced up. My webUI on my phone Syncthing shows it's out of sync with X amount of files.. this shows for /sync2 and /sync..  supposed to ignore that or is there a config I have that's missed/messed up that it keeps showing out of sync? 

Link to post

Having an issue with transfer speeds on the array when Syncthing is running. Extremely slow transfer on the array from folder to folder, disable the syncthing docker and the issue is solved. Any idea what setting could be causing such an issue?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.