[Plugin] CA Fix Common Problems


Recommended Posts

Recently I've been getting the 'unRaid's built in FTP server is currently disabled, but users are defined' warning every day.  I've tried adding it to the ignored list it but it doesn't help.  So, I thought I'd try UNignoring it and then REignoring it.  However the 'Monitor Warning/Error' button doesn't work. 

 

Looking in the browser console I can see why. There is an unescaped apostrophe which is breaking the JavaScript. This is the line:

 

<input type="button" id="1360801943" value="Monitor Warning / Error" onclick="readdError("unRaid" s= built in ftp server is currently disabled, but users are defined&quot;,this.id);'<td>

 

Looks like the apostrophe in the text unRaid's built in ftp server isn't being dealt with correctly which leads to an 'Uncaught SyntaxError' when the button is clicked.  

Link to comment
3 minutes ago, Lignumaqua said:

Looks like 'unRaid's built in FTP server is running' has the same problem. The 'Monitor Warning/Error' button doesn't work because of the single quote/apostrophe breaking the JavaScript.

Any suggestions on how to fix this?

If the error came up before the Update that fixed this (2021.03.14), then you need to delete ignoreList.json from /config/plugins/fix.common.problems on the flash drive

Link to comment
12 hours ago, Squid said:

If the error came up before the Update that fixed this (2021.03.14), then you need to delete ignoreList.json from /config/plugins/fix.common.problems on the flash drive

Thanks, but I've tried that. In fact I deleted everything and started again. Still has this problem I'm afraid, the single quotes in these two error fields break the JavaScript 'Monitor Warning/Error' buttons. Version installed is 2021.03.24 

Link to comment
17 hours ago, isrdude said:

I have a backup server that doesn't have any cache at all.  However, Fix Common Problems keeps telling me that I need to download SSD Trim?  Any clues???

Thanks in advance

I would need to see your diagnostics

Link to comment

Hi Squid!

Thanks for looking at this in advance.  This just came up out of no where. Never had a cache drive or SSD on this unit. I added the plugin and the warning went away. So you could see it, I removed the plug in and now the warning is back.  Strangely, my primary unit, that does have a SSD cache hasn't had this pop up

tower2-diagnostics-20210330-1507.zip

Edited by isrdude
Link to comment
On 3/25/2021 at 9:33 AM, trurl said:

It shouldn't be difficult to know whether or not you have a plugin installed. Look on the Plugins page.

 

What do you get from the command line with this?



ls -lah /boot/config/plugins/*.plg

 

Hello
see attached
I should be able to delete the .txz and plex should disappear
However, in the past when I have done this. Unraid GUI still shows plex as installed within the 'settings' page.

Any thoughts?
 

001.PNG

002.PNG

Edited by bombz
Link to comment
5 hours ago, bombz said:

delete the .txz

You have to delete the .plg or it will attempt to download the .txz again. Probably wouldn't succeed in this case but in general you delete the .plg file and it won't be reinstalled after rebooting.

 

Link to comment
On 3/29/2021 at 11:59 PM, Lignumaqua said:

Thanks, but I've tried that. In fact I deleted everything and started again. Still has this problem I'm afraid, the single quotes in these two error fields break the JavaScript 'Monitor Warning/Error' buttons. Version installed is 2021.03.24 

FYI - I was able to fix this (well, mask it really, I didn't fix the root problem) by editing the two addWarning() strings in tests.php to remove the apostrophes, and deleting ignoreList.json again. The strings now read 'The unRaid built in FTP server is currently disabled, but users are defined' and 'The unRaid built in ftp server is currently running'.  The buttons now work as expected. Any other error strings with apostrophes likely still have the same problem.

Link to comment
On 3/29/2021 at 12:41 PM, Squid said:

If the error came up before the Update that fixed this (2021.03.14), then you need to delete ignoreList.json from /config/plugins/fix.common.problems on the flash drive

 

Ok, so I came to post about this (FTP server running).

 

 

I deleted the /boot/config/plugins/fix.common.problems/ignoreList.json file completely, rescanned and saw that error, ignored it, resacnned again and it's still showing up like this (listed both as an active one, and an ignored one)

 

Version: 2021.03.30a 

 

image.thumb.png.bebc7de2f1caf150d3370b3ceae8ce89.png

Link to comment
3 hours ago, CorneliousJD said:

 

Ok, so I came to post about this (FTP server running).

 

 

I deleted the /boot/config/plugins/fix.common.problems/ignoreList.json file completely, rescanned and saw that error, ignored it, resacnned again and it's still showing up like this (listed both as an active one, and an ignored one)

 

Version: 2021.03.30a 

 

image.thumb.png.bebc7de2f1caf150d3370b3ceae8ce89.png

Yes, see my post above. This had been working fine but broke when the single quotes were replaced with &apos; in mid March. Unfortunately some (all?) browsers treat this as a quote which breaks the Javascript. I had to edit the strings in tests.php to remove the apostrophes before I could get it to work. I'm sure Squid will post an update. 

Link to comment

I'm getting a template URL warning about my zigbee2mqtt docker. It seems that it is checking the opposite templates for the 2 available zigbee2mqtt images.

As per the image below, the original one I was using is named zigbee2mqtt and was the image on selfhosters' repository. It is checking against digiblur's repository.

This seems to be confirmed by reinstalling the selfhoster image as zigbee2mqtt_test and then the digiblur image as zigbee2mqtt_digiblur.


image.thumb.png.5678831e3e4ececc160b864249c96220.png
 

Link to comment
16 minutes ago, racingsquirrel said:

I'm getting a template URL warning about my zigbee2mqtt docker. It seems that it is checking the opposite templates for the 2 available zigbee2mqtt images.

As per the image below, the original one I was using is named zigbee2mqtt and was the image on selfhosters' repository. It is checking against digiblur's repository.

This seems to be confirmed by reinstalling the selfhoster image as zigbee2mqtt_test and then the digiblur image as zigbee2mqtt_digiblur.


image.thumb.png.5678831e3e4ececc160b864249c96220.png
 

I know.  Talking with the guys on which one of them to remove.

  • Like 1
Link to comment
4 hours ago, trurl said:

Fixed

 

 

Also on today's update, a new warning will be issued under 2 circumstances:

 

The string xmrig is found in your go file, or a process named xmrig is running.

 

If it's found in your go file, then most likely your entire system has been compromised and a hacker has edited your go file to automatically install xmrig on every boot

 

If it's a process, two scenarios exist

  1. You're purposely running it.  In which case this warning is safe to ignore
  2. You've possibly installed a compromised container via a random dockerHub search that is masking the fact that it's installing xmrig as it's primary purpose.

 

For reference, xmrig is mining software, and since malware, viruses, ransomware etc are now passe, Compromising a system to instead mine for bitcoin is the hack of choice.

Link to comment

Long time user of this plugin and have run into an issue after updating to the latest UNRAID version (6.9.2).

 

For some reason, the plugin thinks I have multiple NICs installed in my system and reports the following error:

 

eth1 and eth2 both have IP addresses on the 192.168.3.0 network. This is rarely a valid configuration

 

Neither eth1 or eth2 show up in ifconfig nor in the Settings page (just eth0).  At one point, I did install a 10Gb NIC but have since removed it over a year ago.  Not sure why the plugin would still think it's the case.

 

Current plugin version:  2021.04.10

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.