Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

3306 posts in this topic Last Reply

Recommended Posts

@Martyzzz Just a random educated guess - if you're running a separate database, check that the ip address of the database didn't change, that happened to me once and with a new motherboard install with a new NIC, it may be likely.  @can0199 yes I have, but I have no idea if I will be much help as it was a while ago now, here's my config if that helps.  I have a vague recollection I had to change a config file somewhere.

 

Only Office Document Server

407512055_ScreenShot2019-12-23at07_47_53.thumb.png.2889be591c217d91d8f26ec2d6a4c447.png

 

Nextcloud

1510061124_ScreenShot2019-12-23at07_49_33.thumb.png.85aac38d3ac7bb5d28c9ba164e239c52.png

Share this post


Link to post

how to update?

I have the error

"Check for expected files

Parsing response failed. File not found."

in nextcloud.

Edited by Nosirus

Share this post


Link to post
37 minutes ago, Nosirus said:

how to update?

I have the error

"Check for expected files

Parsing response failed. File not found."

in nextcloud.

Try the terminal, it's more reliable in general.

Share this post


Link to post

I'm still running Nextcloud 16 and I have been having the annoying task of re authenticating my windows client machines to access nextcloud docker after each reboot.

According to this thread, some servers seem to require libgnome-keyring. 

Is that true of the nexcloud docker and if show, how to add?

Share this post


Link to post
14 minutes ago, eds said:

I'm still running Nextcloud 16 and I have been having the annoying task of re authenticating my windows client machines to access nextcloud docker after each reboot.

According to this thread, some servers seem to require libgnome-keyring. 

Is that true of the nexcloud docker and if show, how to add?

That thread is in reference to the desktop client. libgnome-keyring is a Linux desktop package for the Gnome desktop.  So basically nothing related to your problem with Windows clients

Edited by CHBMB

Share this post


Link to post

Hi All -

 

I have read back over 15 pages of this thread along with hours of Googling and it seems like no one has found a solution (or posted if they did) to the “Error when assembling chunks, status code 504” error when transferring larger files. It seems like it occurs whenever the file is larger than about 2 Gb. Also, in order to clear the persistent ‘processing files’ after the 504 error, I just restart the Nextcloud container.

 

I am running the latest LSIO containers of LetsEncrypt, MariaDB, and Nextcloud (shoutout to SpaceInvader One). I am using the container web GUI to ‘copy’ files from a Windows 10 box. While 80% of the files go across like their collective a$$es are on fire, some take quite a while to ‘uploading’ and ‘processing files’.

I have found many posts indicating changing certain config files parameters, but other than two of them most don’t seem to exist in the container version; particularly the PHP changes suggested.

 

So, I ask the Community at large if you have had any similar experiences and what, if any, resolutions they may have applied.

 

I have attached chunks of the log files from LetsEncrypt and Nextcloud to show some of the recent errors. Thanks in advance for any assistance!

 

Nextcloud – 17.0.2                 PHP - Version: 7.3.12

 

NEXTCLOUND-PHP-error-log.txt NEXTCLOUND-Ngnix-error-log.txt LETSENCRYPT-Ngnix-access.log

Edited by TechMed
edit a pronoun

Share this post


Link to post
9 hours ago, TechMed said:

Hi All -

 

I have read back over 15 pages of this thread along with hours of Googling and it seems like no one has found a solution (or posted if they did) to the “Error when assembling chunks, status code 504” error when transferring larger files. It seems like it occurs whenever the file is larger than about 2 Gb. Also, in order to clear the persistent ‘processing files’ after the 504 error, I just restart the Nextcloud container.

 

I am running the latest LSIO containers of LetsEncrypt, MariaDB, and Nextcloud (shoutout to SpaceInvader One). I am using the container web GUI to ‘copy’ files from a Windows 10 box. While 80% of the files go across like their collective a$$es are on fire, some take quite a while to ‘uploading’ and ‘processing files’.

I have found many posts indicating changing certain config files parameters, but other than two of them most don’t seem to exist in the container version; particularly the PHP changes suggested.

 

So, I ask the Community at large if you have had any similar experiences and what, if any, resolutions they may have applied.

 

I have attached chunks of the log files from LetsEncrypt and Nextcloud to show some of the recent errors. Thanks in advance for any assistance!

 

Nextcloud – 17.0.2                 PHP - Version: 7.3.12

 

NEXTCLOUND-PHP-error-log.txt 4.53 kB · 0 downloads NEXTCLOUND-Ngnix-error-log.txt 9.95 kB · 0 downloads LETSENCRYPT-Ngnix-access.log 10.53 kB · 0 downloads

Have you had this setup for a long time? Then it might be time to delete some of the config files in both letsencrypt and nextcloud container. It will then be recreated, but using the latest one. There is a date at the top of the files and if you don't have any date, it's very old.

In letsencrypt it's these files:

default

nginx.conf

proxy.conf

ssl.conf

 

In Nextcloud:

default

 

Remember to back up the files first, but do not keep the backups in the same folder as the original file.

 

Do you use our reverse proxy config?

Share this post


Link to post

Hi @saarg,

Thanks a bunch for replying.

 

4 hours ago, saarg said:

Have you had this setup for a long time?

Fresh install - four days, maybe.

 

4 hours ago, saarg said:

There is a date at the top of the files

These log files are just clips from from about the middle down. I can provide the entire file(s) if needed.

 

4 hours ago, saarg said:

Do you use our reverse proxy config?

Yes, it is the LSIO image; I am following Ed's install guide from his video's for installing Nextcloud and LetsEncrypt.

 

Thanks again for replying!

 

P.S. Do you have any links to follow for:

     - How to force delete a file and folder that will not delete from the GUI

     - (this may belong over in the LetsEncrypt thread) how to check on an Edgerouter that hairpin is actually working?

Share this post


Link to post
7 minutes ago, TechMed said:

Hi @saarg,

Thanks a bunch for replying.

 

Fresh install - four days, maybe.

 

These log files are just clips from from about the middle down. I can provide the entire file(s) if needed.

 

Yes, it is the LSIO image; I am following Ed's install guide from his video's for installing Nextcloud and LetsEncrypt.

 

Thanks again for replying!

 

P.S. Do you have any links to follow for:

     - How to force delete a file and folder that will not delete from the GUI

     - (this may belong over in the LetsEncrypt thread) how to check on an Edgerouter that hairpin is actually working?

Have you installed any of the containers before at one point?

You can verify this by checking the files I mentioned earlier. They are in the appdata folders  of the containers.

Share this post


Link to post
51 minutes ago, saarg said:

Have you installed any of the containers before at one point?

A few months back, but I thought I removed everything out of the appdata folder. The new install(s) looked like a fresh install when installed a few days ago.

 

5 hours ago, saarg said:

There is a date at the top of the files and if you don't have any date, it's very old.

I have attached all of the files.

Looking at them it appears that the 'default' from Nextcloud does not have a date.

 

So just for complete clarity your saying: stop the containers (LetsEncrypt, MariaDB, and Nextcloud), backup the files listed, DELETE the files listed above, restart the containers, and let those files rebuild themselves?

 

default -from LetsEncrypt default -from Nextcloud nginx.conf proxy.conf ssl.conf

Share this post


Link to post
20 hours ago, CHBMB said:

Try the terminal, it's more reliable in general.

when I run the update command

sudo -u abc php7 /config/www/nextcloud/occ upgrade

Nextcloud is already latest version

 

I'm in 17.0.1...

Share this post


Link to post
when I run the update command
sudo -u abc php7 /config/www/nextcloud/occ upgrade
Nextcloud is already latest version
 
I'm in 17.0.1...
So it's working?

Sent from my Mi A1 using Tapatalk

Share this post


Link to post
2 hours ago, TechMed said:

A few months back, but I thought I removed everything out of the appdata folder. The new install(s) looked like a fresh install when installed a few days ago.

 

I have attached all of the files.

Looking at them it appears that the 'default' from Nextcloud does not have a date.

 

So just for complete clarity your saying: stop the containers (LetsEncrypt, MariaDB, and Nextcloud), backup the files listed, DELETE the files listed above, restart the containers, and let those files rebuild themselves?

 

default -from LetsEncrypt 2.96 kB · 0 downloads default -from Nextcloud 3.32 kB · 0 downloads nginx.conf 1.85 kB · 0 downloads proxy.conf 1.05 kB · 1 download ssl.conf 1.24 kB · 0 downloads

 

Try setting the client_max_body_size in the default file of nextcloud to 0 instead of 10G and see if that helps. Remember to restart the container after the change.

Share this post


Link to post

Hello, I really need help with nextcloud i get everything with mariadb and nextcloud just the letsencrypt part is messing me up.Heres the error i am getting.

 

Challenge failed for domain pokey.ddns.net
http-01 challenge for pokey.ddns.net
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:
- The following errors were reported by the server:

Domain: pokey.ddns.net
Type: connection
Detail: Fetching
http://pokey.ddns.net/.well-known/acme-challenge/KrfzfxBK7A7T_X35-D_D_gnPHHDOfO8GKK2yVPKkqdA:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

Share this post


Link to post
8 minutes ago, saarg said:

Try setting the client_max_body_size

I will; I changed it to the 10G based on some of the other posts/sites solutions that were out there. That line was originally set to '0'.

 

Out of curiosity, and an attempt to understand, does setting it to zero basically make the value unlimited?

Thanks again for your assistance!

Share this post


Link to post

Just to follow up: I have made the change but will not be able to test until much later tonight or tomorrow morning (US-EST).

Thanks for the suggestions.

Gotta run...

J

Share this post


Link to post
6 hours ago, Pokey said:

Hello, I really need help with nextcloud i get everything with mariadb and nextcloud just the letsencrypt part is messing me up.Heres the error i am getting.

 

Challenge failed for domain pokey.ddns.net
http-01 challenge for pokey.ddns.net
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:
- The following errors were reported by the server:

Domain: pokey.ddns.net
Type: connection
Detail: Fetching
http://pokey.ddns.net/.well-known/acme-challenge/KrfzfxBK7A7T_X35-D_D_gnPHHDOfO8GKK2yVPKkqdA:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

 

That's an error with LetsEncrypt, nothing to do with Nextcloud.  You're not going to be able to get any further until you sort that out.  Suggest you post in the LetsEncrypt support thread, including the above log and with your docker run command (see the docker faq to find out how to get that)  and screenshots of your port forwards in your router/firewall.

Share this post


Link to post

 

11 hours ago, saarg said:

Try setting the client_max_body_size in the default file of nextcloud to 0

Unfortunately that did not work, same error.

Sadly this one popped up as well: An exception occurred while executing 'UPDATE `oc_file_locks` SET `lock` = `lock` + 1, `ttl` = ? WHERE `key` = ? AND `lock` >= 0' with params [1577163023, "files\/7190a9b863f60ecb007e84a38723d83a"]: SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

 

The file I tried to transfer is a 2.4 Gb .iso file.

Are there any further potential fixes you might be aware of?

Thanks again for your assistance.

Share this post


Link to post
3 hours ago, TechMed said:

 

Unfortunately that did not work, same error.

Sadly this one popped up as well: An exception occurred while executing 'UPDATE `oc_file_locks` SET `lock` = `lock` + 1, `ttl` = ? WHERE `key` = ? AND `lock` >= 0' with params [1577163023, "files\/7190a9b863f60ecb007e84a38723d83a"]: SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

 

The file I tried to transfer is a 2.4 Gb .iso file.

Are there any further potential fixes you might be aware of?

Thanks again for your assistance.

These are not normal errors, so there is something wrong somewhere in you setup. Looks like a database error, so might be your mariadb container.

Post the docker run command for nextcloud and mariadb.

Share this post


Link to post

Happy Christmas Eve!

 

Apparently, my attempt to lookup and understand and implement the ‘docker run’ command was ineffective; I wound up blowing up my configs. Fortunately, I am an avid backer-upper so I was able to restore the config(s) – shout out to Squid!

 

Would you mind sharing the correct syntax for the usage of the command?

docker run mariadb and docker run nextcloud most assuredly are not it 😊

 

Thanks! I will post results immediately afterwards.

Appreciate it.

Edited by TechMed
missing text

Share this post


Link to post
On 12/22/2019 at 4:13 PM, Marshalleq said:

@eds that doesn't sound normal.  I don't have to do that anyway.

I was afraid you would write that...

 

On 12/22/2019 at 4:25 PM, CHBMB said:

That thread is in reference to the desktop client. libgnome-keyring is a Linux desktop package for the Gnome desktop.  So basically nothing related to your problem with Windows clients

Yes, the desktop client is the issue.  I should have been clearer.  It's when I reboot the windows machines I need to re authenticate, not rebooting the server.  That link appeared to be saying the missing file was on the server side. 

 

Anyway, is there a way to debug this?

Share this post


Link to post
3 hours ago, eds said:

I was afraid you would write that...

 

Yes, the desktop client is the issue.  I should have been clearer.  It's when I reboot the windows machines I need to re authenticate, not rebooting the server.  That link appeared to be saying the missing file was on the server side. 

 

Anyway, is there a way to debug this?

 

There probably is, but I don't know how.  I still think it's a client side issue tbh.

Share this post


Link to post

Hi, can we rename the machine in nextcloud?

 

Under Settings>Administration>System, could we change the machine name? (the d2dd33036abf?)

Server.thumb.PNG.9a0940e89a19ce5b14fb5a00be2ffa8e.PNG

 

Additionally, what happen to the cpu info? can it be fixed?

 

Thanks

Share this post


Link to post

 

11 minutes ago, Anders said:

Hi, can we rename the machine in nextcloud?

 

Under Settings>Administration>System, could we change the machine name? (the d2dd33036abf?)


Add "--hostname=xxxxxx" in "Extra Parameters" for the container ("ADVANCED VIEW" on)
 

Capture_ServerUpdateContainer_-_Google_Chrome_2019-12-25_01-16-17_03530768.png

Edited by Niklas

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.