Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

2480 posts in this topic Last Reply

Recommended Posts

Getting a very strange issue atm. I have files that I am trying to upload from my desktop using the synced folder. pics and videos mostly. With all the videos I get the error 413 request entity too large. I understand this relates to a client_max_body_size variable somewhere being set too small. So i went through all the .conf files and replaced the proxy.conf variable to 0. This is the only one that I could find with the variable set to 10M. There is also a client_body_buffer_size 16k but im not sure if that effects it at all?

 

This only occurs with the synced folder in windows. I can access the webui and upload that way just fine. Thats the thing I find strange. 

Any ideas?

Share this post


Link to post

These is more than one place (file) where client_max_body_size Is set. I believe there are at least two. Set both and restart the service or restart the docker. It’s a redundancy in the config and causes some confusion. I would provide more details, but on vacation right now away from a real computer. 

Share this post


Link to post
4 hours ago, L0rdRaiden said:

I have done a fresh install following spaceinvaders video and I get the following error

 

imagen.thumb.png.aa486cf14c6a2ac15b874224116e6422.png

 

how can I apply this fix in the docker container? occ db:convert-filecache-bigint

https://docs.nextcloud.com/server/13/admin_manual/configuration_database/bigint_identifiers.html

Supossely I can fix this with this command but when I run it on the nextcloud docker console I get

root@44d2677c0b9a:/$ sudo -u www-data php occ db:convert-filecache-bigint
sudo: unknown user: www-data
sudo: unable to initialize policy plugin
root@44d2677c0b9a:/$

Share this post


Link to post
3 minutes ago, DZMM said:

thanks - I can't find the my.cnf file??

I think is "custom.cnf" file in mariadb docker folder but be sure your Mariadb docker log (accesible from unraid interface) doesnt give you this warning, you have to fix it changing permisions

chmod 0444 cfg/mysql-5.7/custom.cnf

imagen.png.d84f8597390545aeaac2af1b494bd325.png

Share this post


Link to post
15 hours ago, snowboardjoe said:

These is more than one place (file) where client_max_body_size Is set. I believe there are at least two. Set both and restart the service or restart the docker. It’s a redundancy in the config and causes some confusion. I would provide more details, but on vacation right now away from a real computer. 

ive checked all the .conf files I could find and they all seem to say client_max_body_size 0. I just ment that the proxy.conf is the only place I found it set to 10M but I changed it and still no joy. But again as i said it only seems to effect the windows client. I have updated to the latest client just to see if that helped but no joy ATM. 

Share this post


Link to post

You can find all files that use that setting and output what the value is using this command from the console of letsencrypt docker:

 

find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;

 

This will spit out all matching files and the value assigned. The Nginx config has redundant configuration options and each iteration as it parses through the config resets the value (last one wins).

Share this post


Link to post
3 hours ago, snowboardjoe said:

You can find all files that use that setting and output what the value is using this command from the console of letsencrypt docker:

 


find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;

 

This will spit out all matching files and the value assigned. The Nginx config has redundant configuration options and each iteration as it parses through the config resets the value (last one wins).

Thanks for the help. i just tried that command and i got this issue

 

find: -exec requires an argument

Share this post


Link to post
51 minutes ago, tazire said:

Thanks for the help. i just tried that command and i got this issue

 

find: -exec requires an argument

Make sure your copy and paste is accurate. Here were my results:

root@cfeed5230df2:/$ find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;
/config/nginx/nginx.conf:       client_max_body_size 0;
/config/nginx/proxy-confs/nextcloud.subdomain.conf:    client_max_body_size 0;
/config/nginx/proxy.conf:client_max_body_size 0;
root@cfeed5230df2:/$

Sounds like something got truncated after the -exec parameter. It's possible it found no *.conf? That would be weird. 

Share this post


Link to post
On 12/23/2018 at 3:03 AM, snowboardjoe said:

Make sure your copy and paste is accurate. Here were my results:


root@cfeed5230df2:/$ find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;
/config/nginx/nginx.conf:       client_max_body_size 0;
/config/nginx/proxy-confs/nextcloud.subdomain.conf:    client_max_body_size 0;
/config/nginx/proxy.conf:client_max_body_size 0;
root@cfeed5230df2:/$

Sounds like something got truncated after the -exec parameter. It's possible it found no *.conf? That would be weird. 

ok i went in through putty rather than the console and got the following result

 

root@553d247f5e00:/$ find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;
/config/nginx/nginx.conf:       client_max_body_size 0;
 

 

appears that its not finding every instance in every file. I know it is also in the proxy.conf and the nextcloud.conf but again each one is set to 0. 

Share this post


Link to post
13 hours ago, tazire said:

ok i went in through putty rather than the console and got the following result

 

root@553d247f5e00:/$ find /config/nginx -name \*.conf -exec grep -H client_max_body_size {} \;
/config/nginx/nginx.conf:       client_max_body_size 0;
 

 

appears that its not finding every instance in every file. I know it is also in the proxy.conf and the nextcloud.conf but again each one is set to 0. 

can confirm, some weird Windows client issue. Fixed today by remove/resync account in Win client v.2.5.1final

Share this post


Link to post

Can anyone help me with this, I have installed everyting following the instructions of Spaceinvaders video and error related to this

https://docs.nextcloud.com/server/15/admin_manual/configuration_database/bigint_identifiers.html

imagen.png.b005fef7517758c6469b3c07a20d1e6e.png

but when I execute this command in the nextcloud docker container I get this error

root@e8bafe322241:/$ sudo -u www-data ./occ db:convert-filecache-bigint
sudo: unknown user: www-data
sudo: unable to initialize policy plugin

 

how can I fix it? probably it's a complete noob error but I'm not very experienced yet with linux commands.

Edited by L0rdRaiden

Share this post


Link to post
6 minutes ago, L0rdRaiden said:

Can anyone help me with this, I have installed everyting following the instructions of Spaceinvaders video and error related to this

https://docs.nextcloud.com/server/15/admin_manual/configuration_database/bigint_identifiers.html

imagen.png.b005fef7517758c6469b3c07a20d1e6e.png

but when I execute this command in the nextcloud docker container I get this error


root@e8bafe322241:/$ sudo -u www-data ./occ db:convert-filecache-bigint
sudo: unknown user: www-data
sudo: unable to initialize policy plugin

 

how can I fix it? probably it's a complete noob error but I'm not very experienced yet with linux commands.

 

You can try using the abc user instead. There is no www-data user in out nextcloud container. 

Share this post


Link to post
4 minutes ago, L0rdRaiden said:

Can anyone help me with this, I have installed everyting following the instructions of Spaceinvaders video and error related to this

https://docs.nextcloud.com/server/15/admin_manual/configuration_database/bigint_identifiers.html

imagen.png.b005fef7517758c6469b3c07a20d1e6e.png

but when I execute this command in the nextcloud docker container I get this error


root@e8bafe322241:/$ sudo -u www-data ./occ db:convert-filecache-bigint
sudo: unknown user: www-data
sudo: unable to initialize policy plugin

 

how can I fix it? probably it's a complete noob error but I'm not very experienced yet with linux commands.

 

Programs run as abc--not www-data. Pretty sure you need to specify the PHP interpreter too. So, it should look like this:

sudo -u abc php /config/www/nextcloud/occ db:convert-filecache-bigint

 

Share this post


Link to post
On 12/25/2018 at 11:07 AM, Pankoz said:

can confirm, some weird Windows client issue. Fixed today by remove/resync account in Win client v.2.5.1final

 This.... fair play thanks for that. deleted and re added my account and all is working as it should be. 

Share this post


Link to post

@saarg @snowboardjoe

It worked thanks a lot

root@e8bafe322241:/$ sudo -u abc php /config/www/nextcloud/occ db:convert-filecache-bigint
Following columns will be updated:

* filecache.mtime
* filecache.storage_mtime

This can take up to hours, depending on the number of files in your instance!
Continue with the conversion (y/n)? [n] y

 

Edited by L0rdRaiden

Share this post


Link to post

How can I backup my nextcloud data folder?

 

(or any folder in unraid for that matter but specifically this folder since nexctloud has ruined my my data once already)

Share this post


Link to post
On 1/18/2017 at 9:55 AM, kamhighway said:

Solved File Upload Size Limitation 

 

I had been fiddling with the LSIO's letsencrypt container to make it work as a reverse proxy for LSIO's Nextcloud.  The reverse proxy works, but file uploads are limited to 10MB.  The solution is to edit the file proxy.conf which for me resides in /mnt/cache/appdata/letsencrypt_lsio/nginx. The first line in that file is:

 

client_max_body_size 10m;

 

Change to:

 

client_max_body_size 0;  #This turns off checking and everything works.

This Solved the same issue i had ! thank you ! i have been racking my brain over this for hours sifting through config files. And here it was. One silly little line. Thanks.

 

The weird part for me was that if i loaded something through the browser, the 10MB limit did not apply, i could upload any size i wanted. But, the IOS app and windows sync application would be spit of 413 errors for files larger than 10MB. Very odd that the browser ignored this limit. Maybe someone more versed in this can shed some light on that. Thought i'd share. 

Share this post


Link to post

Hi,

i try to connect an external storage to nextcloud.

But It's just an infinitely long loading screen

Here you can see my configuration

temp.PNG

temp2.PNG

Share this post


Link to post
2 hours ago, Abigel said:

Here you can see my configuration

fill all empty fields, use "." for domain, if you have not one.

Share this post


Link to post
Posted (edited)

Hi everyone, I installed nextcloud with Spaceinvader One's video, so I use MariaDB in combination with Nextcloud. I also use Redis. Everything works so far, but I'm having the problem that I always get the following error with files that are larger than about 1GB: 

 

Quote

2019/01/02 21:09:19 [error] 310#310: *2821 upstream timed out (110: Operation timed out) while reading response header from upstream, client: 172.18.0.3, server: _, request: "MOVE /remote.php/dav/uploads/User/523027301/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "subdomain.domain.com:443"

 

The whole thing runs in connection with the letsencrypt docker as reverse proxy, so with nginx. I already searched the web and changed some parameters in the different config files, but the timeout still occurs, no matter which screw I turn. The problem happens by uploading via the windows nextcloud client.

 

Does anyone got an idea or had the same problem before?

 

Thanks in advance.

Edited by pappaq

Share this post


Link to post
53 minutes ago, pappaq said:

Hi everyone, I installed nextcloud with Spaceinvader One's video, so I use MariaDB in combination with Nextcloud. I also use Redis. Everything works so far, but I'm having the problem that I always get the following error with files that are larger than about 1GB: 

 

 

The whole thing runs in connection with the letsencrypt docker as reverse proxy, so with nginx. I already searched the web and changed some parameters in the different config files, but the timeout still occurs, no matter which screw I turn. The problem happens by uploading via the windows nextcloud client.

 

Does anyone got an idea or had the same problem before?

 

Thanks in advance.

I dare to say very carefully that I have solved the problem. I set the parameter

Quote

fastcgi_read_timeout 30m;

 in the nginx.conf of Nextcloud and since then it seems to work. Maybe just a coincidence, but according to the log it seems very likely. If the error occurs again, I'll get back to you here.

 

Have a nice evening.

Share this post


Link to post
1 hour ago, pappaq said:

I dare to say very carefully that I have solved the problem. I set the parameter

 in the nginx.conf of Nextcloud and since then it seems to work. Maybe just a coincidence, but according to the log it seems very likely. If the error occurs again, I'll get back to you here.

 

Have a nice evening.

I think I found a solution

 

Inside of the let's encrypt conf file for nextcloud I found

 


    location / {
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_nextcloud nextcloud;
        proxy_max_temp_file_size 2048m;
        proxy_pass https://$upstream_nextcloud:443;
    }
}
 

Which makes sense why my files stop at 2GB. I'll give it a try and check again

Share this post


Link to post

I am working on trying to connect to my Nextcloud. I was able to connect to my nextcloud and then made the changes to be able to access it from the web and now I can't get into it. Keeps telling me error 522: connection timed out. I am guessing it has something to do with the reverse proxy but I have no idea where to begin to troubleshoot. If I can provide any additional information to try and help, please let me know.

Share this post


Link to post
On 1/1/2019 at 6:14 PM, uldise said:

fill all empty fields, use "." for domain, if you have not one.

same problem

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.