[SUPPORT] pihole for unRaid - Spants repo

Recommended Posts

I am having a problem with the latest PiHole setup.  I use the Br0 interface and give it a separate IP address from the IP address of the server.  This used to work in 6.8 version of unraid, but started to throw massive errors when I updated to 6.11.  


t 27 12:38:24 Tower kernel: vetha58e1c6: renamed from eth0
Oct 27 12:38:24 Tower  avahi-daemon[2174]: Interface vethd89dac8.IPv6 no longer relevant for mDNS.
Oct 27 12:38:24 Tower  avahi-daemon[2174]: Leaving mDNS multicast group on interface vethd89dac8.IPv6 with address fe80::28c0:30ff:fe29:6f35.
Oct 27 12:38:24 Tower kernel: docker0: port 3(vethd89dac8) entered disabled state
Oct 27 12:38:24 Tower kernel: device vethd89dac8 left promiscuous mode
Oct 27 12:38:24 Tower kernel: docker0: port 3(vethd89dac8) entered disabled state
Oct 27 12:38:24 Tower  avahi-daemon[2174]: Withdrawing address record for fe80::28c0:30ff:fe29:6f35 on vethd89dac8.
Oct 27 12:47:10 Tower kernel: br-5180425399c9: port 2(veth78638f9) entered disabled state


This keeps spamming in the logs when I have PiHole container active.  Any solutions?

Edited by Ben deBoer
Link to comment
On 10/17/2022 at 11:50 AM, idscomm said:

Hey, I know this message is 2 years old but I am currently struggling with Pi-hole hostname ... kept using random generic name. Would you be able to tell me if this is still working? I am not sure what you mean by extra parameters... 



Please accept my apologies for the delay...

In the Pihole container (edit) and switch to advanced view.

Add the following to the Extra Parameters: --hostname=nameyouwant








  • Like 1
Link to comment

Good Afternoon,


First time Unraid user here... I am having the issue of I can only setup pihole to work DHCP mode, due to my router. Which once enabled in Pihole it works like it should. ( pihole DHCP on, router DHCP off).


My issue is anytime I have to reset my host Unraid machine, my Unraid machine cannot get a local ip address so the unraid web ui never starts. I have to turn my DCHP server off again , enable through my router, then everything goes back to working properly.


Is there an option im missing here to prevent this from happening on the next reboot?



Link to comment

what should i change?


If I change the fixed IP to ( the address I have for my Unraid server) I get the following error:


Command executiondocker run
  -e TZ="America/Los_Angeles"
  -e HOST_OS="Unraid"
  -e HOST_HOSTNAME="Tower"
  -e 'TCP_PORT_53'='53'
  -e 'UDP_PORT_53'='53'
  -e 'UDP_PORT_67'='67'
  -e 'TCP_PORT_80'='80'
  -e 'TCP_PORT_443'='443'
  -e 'PIHOLE_DNS_'=';'
  -e 'TZ'='America/Chicago'
  -e 'WEBPASSWORD'='admin'
  -e 'INTERFACE'='Bridge'
  -e 'ServerIP'=''
  -e 'ServerIPv6'=''
  -e 'IPv6'='False'
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:80]/admin'
  -l net.unraid.docker.icon='https://i.imgur.com/OWkNcEn.png'
  -v '/mnt/user/appdata/pihole/pihole/':'/etc/pihole/':'rw'
  -v '/mnt/user/appdata/pihole/dnsmasq.d/':'/etc/dnsmasq.d/':'rw'
  --restart=unless-stopped 'pihole/pihole:latest'

docker: Error response from daemon: Address already in use.



Im lost here....


Screenshot 2022-11-06 164121.png

1Screenshot 2022-11-06 164232.png

Edited by Mrtj18
Link to comment

When you setup/installed unraid you should have set a staticIP for the unraid server instead of DHCP. This way even if DHCP is not available which is your case, The server will still work on your private subnet as its manually set and knows how to route across your network without contacting DHCP. 

Link to comment
28 minutes ago, Mrtj18 said:

Is there a way to double check, what I may have set the static IP to be? When I did the initial setup?

My box is offline atm due to moving. You access the Unraid WebGUi and then in the admin settings you can access network (Likely) settings for the host. From there that should give you an indication of how the IP address is setup.

  • Like 1
Link to comment
6 hours ago, Kilrah said:

I was talking of manually setting the ip of the unraid server itself, settings->network settings

Oh okay gotcha, thanks for the help. I found my static IP for my unraid server and plugged it in to the server IP option towards the bottom, and the docker image built correctly... Thank you for the direction!

Link to comment

I still can't get this to work..... I may just have to stick with the rpi zero config i have. After correcting my settings in the network panel of unraid. I still have the issue after every reboot, the system still does not have Internet connection, even though I set the IP address to static.😞

Link to comment
  • 3 weeks later...

By the way I figured out my issue, If anyone reads this, there is a required port section in the docker container setup. I had to open port 67 on my router for the DCHP server to work correctly, and assign it to my lan ip for my unraid server. I have never seen this mentioned anywhere. Hope this helps someone, that maybe stuck like I was.

Link to comment
  • 2 weeks later...

Pi-hole recently stopped working on my Unraid machine. When attempting to fix the container, I noticed the custom br0 network type was missing from the dropdown menu within the container settings. Running the following fixed my issue and restored br0:


rm /var/lib/docker/network/files/local-kv.db
/etc/rc.d/rc.docker restart


I hope this helps. 

Link to comment
  • 4 weeks later...
On 1/5/2022 at 9:49 AM, norp90 said:

Having issues getting latest release working?


- If pihole running but status in UI/API is not shoiwn active, add env. variable 'DNSMASQ_USER' with value = 'root'. This should be fixed soon in a new release, they are working on it, so remove this variable again once new update released and see if it's no longer required.


- Other issues? Do a review of all of your docker template env. variables vs. the current recommend and optional ones here https://github.com/pi-hole/docker-pi-hole. There have been a lot of changes recently that haven't been reflected in Unraid automatically. I suggest removing old ones no longer in use or only optional and see if that fixes issues, then add back any you know you need. The changes in the DNS ones to a single PIHOLE_DNS one was a big change recently to watch for.

1 Year later and i got the exact same Problem, i was about to give up but saw ur post. I tried it and it WORKS!!! Thanks!

Link to comment

I'm having issues with forwarded ports being intermittently inaccessible when the pihole docker is running, specifically Plex and Overseer. Both are running in their own network but don't have their own IP. I've tried giving them their own IP, but my crappy Google Wifi router doesn't allow me to select a static IP'd device to set a port forward - very frustrating. 


Seems like my options are to run pihole from a separate device or look into another router. 

Link to comment

How do I migrate PiHole to a docker on a new server?  I have an older unRAID server and a newer server.  I am migrating dockers, etc to the new server.  I don't see any sort of an export settings function in the PiHole web UI - how do I export my settings and whitelist to my new docker?  Dockers on both machines are running PiHole 5.14.2.

Link to comment

To answer my own question - On the web UI under the Settings page there is a tab called Teleporter.  That allows you to export and import settings.


Not an obvious name, at least not to me, but it appears to work well once you find it.

Link to comment

Recently I moved my Unraid server to different subnet 192.168.68.x instead 192.169.0.x, in this process I lost my custom network config, I tried to recreate it, but custom network is created in 172.x subnet. How do I create a custom network so I can use a static IP in 192.168.68.x subnet?

Sent from my SM-G998B using Tapatalk

Link to comment
On 1/19/2023 at 11:13 AM, Ademar said:

why does the container run with "--cap-add=NET_ADMIN"? It seems to work fine without it.


Copy and pasted from the pihole entry on dockerhub.


  • As of 2022.04.01, setting CAP_NET_ADMIN is only required if you are using Pi-hole as your DHCP server. The container will only try to set caps that are explicitly granted (or natively available)

Link to comment

Does anyone else have the problem that the Docker overview for pihole says "not available" in the update column? So far it worked without problems and with all my other Docker containers the update check works. I have already tried suggestions from the forum (DNS change), but the problem persists with the pihole container.

Link to comment
8 hours ago, FDM80 said:


Copy and pasted from the pihole entry on dockerhub.


  • As of 2022.04.01, setting CAP_NET_ADMIN is only required if you are using Pi-hole as your DHCP server. The container will only try to set caps that are explicitly granted (or natively available)

Thanks. "Required Port" 67 could also be named something else to make it clear it is only needed for DHCP?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.