[Support] Linuxserver.io - Unifi-Controller


923 posts in this topic Last Reply

Recommended Posts

  • Replies 922
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Success, so far, I'm running 5.14.23-ls76 now.   So, to summarize, to those who wish to move from LTS (5.6.42) to 5.14.23-ls76, you must first use 5.10.24-ls21 to upgrade the database.

OK Pete, just because you are Asking, I'll bite.   Container set to 2GB limit and restarted.  DPI still on.   If the container crashes and I have to restart it, no big deal.  This

Sorry, I may have missed something completely earlier in discussions but mine also had this issue as it looks like dockerhub linuxserver.io shows version 6.1.71 attached to the tag 'latest' which it i

Posted Images

On 12/27/2019 at 8:29 PM, dukiethecorgi said:

Where would I place my config.gateway.json file? This is for a USG 3P router.  I've tried placing it in appdata\unifi-controller\data folder with no effect.

 

 

I seem to be having the same issue. Settings are not being honored. When I SSH back into the USG, the firewall is still enabled.

Link to post

Try this ..

 

https://help.ubnt.com/hc/en-us/articles/215458888-UniFi-USG-Advanced-Configuration

 

 Once the contents of the file has been validated, save it by naming it config.gateway.json and placing it under the <unifi_base>/data/sites/site_ID directory stored on the Controller.

Link to post
14 hours ago, rorton said:

Try this ..

 

https://help.ubnt.com/hc/en-us/articles/215458888-UniFi-USG-Advanced-Configuration

 

 Once the contents of the file has been validated, save it by naming it config.gateway.json and placing it under the <unifi_base>/data/sites/site_ID directory stored on the Controller.

That's what I had been doing and it was working. Now it sort of isn't. When I create the .json I actually save it on the USG then pull it according to this.

 

https://larskleeblatt.net/?p=36

 

It was working just fine. Thought I'd done something wrong in the syntax, but that wasn't it. It really seems like it's ignoring the file.

Link to post

stun issues.

 

Every time I upgrade the docker container to the latest version, I have to ssh into most/alll devices (four total) and manually 'set-inform' in order for them to appear in the unifi controller as provisioned, and in order to see attached clients.  When I do, they still show up with yellow exclamation icons, indicating stun failure.

 

Same thing happens whenever I reboot an AP; they show as "adopting" and I have to manually 'set-inform' and still get the stun failure icon.

 

The container is being run in bridged mode with its own IP address. 

 

Any suggestions?

Edited by tucansam
Link to post
On 1/12/2020 at 10:50 AM, tucansam said:

stun issues.

 

Every time I upgrade the docker container to the latest version, I have to ssh into most/alll devices (four total) and manually 'set-inform' in order for them to appear in the unifi controller as provisioned, and in order to see attached clients.  When I do, they still show up with yellow exclamation icons, indicating stun failure.

 

Same thing happens whenever I reboot an AP; they show as "adopting" and I have to manually 'set-inform' and still get the stun failure icon.

 

The container is being run in bridged mode with its own IP address. 

 

Any suggestions?

 

I had that problem until I changed the Controller Host Name to its IP address.

Link to post

Hi, I am looking to leap to this Unifi Controller docker. My current controller runs in Win 10 ver 5.12.35.

I wanted to understand, if I can download docker from the "latest" stream, and then import my existing config ?

Obviously, my objective is avoiding a network rebuild.

 

Please advise, if this may be possible ?

Link to post
1 hour ago, Babar said:

Hi, I am looking to leap to this Unifi Controller docker. My current controller runs in Win 10 ver 5.12.35.

I wanted to understand, if I can download docker from the "latest" stream, and then import my existing config ?

Obviously, my objective is avoiding a network rebuild.

 

Please advise, if this may be possible ?

Yes, that should be all you have to do. It worked for me moving from a much older docker to this one.

Link to post

I added the Unifi controller latest version docker, but the web GUI fails to load on https://10.10.100.64:8443/ (my unraid IP address)

I tried it a couple of times, but it did not work, so I downloaded the 5.9 version, and it is also same.

 

If I jump into console, it is working fine.

Whats the fix ?

Edited by Babar
Link to post
6 hours ago, Babar said:

I added the Unifi controller latest version docker, but the web GUI fails to load on https://10.10.100.64:8443/ (my unraid IP address)

I tried it a couple of times, but it did not work, so I downloaded the 5.9 version, and it is also same.

 

If I jump into console, it is working fine.

Whats the fix ?

Impossible to say without any info.

Link to post

hey folks - so I need help with a problem + a little hand holding/how-to.

 

First, when I go to setup the docker, it fails to start because it wants to map to port 8080 for device communication (i have sabnzbd on port 8080). So to that end, is there a recommended alternative port? I'd rather not adjust sab b/c of how many other utilities rely on it.

 

Then my next question is what's a good "Idiots Guide to Moving Controllers"? I setup my unifi a long time ago and when i did it - i did not realize that the device married itself to the controller - i no longer have the computer that was the original controller. Furthermore - i don't remember all of the tweaks i made to the configuration and finally - while i would like to use my unraid server as the controller - i usually use wifi to connect into it - so i'm guessing that i'll need to attach KVM to it and i just want to make sure I don't screw it up. I looked at this https://community.ui.com/questions/Transferring-Unifi-Controller/1e541dee-e484-407e-aaec-28c2711db6d7 but when i go to wizards in EdgeOSX i get

Quote

The setup wizards are notavailable to you because you have changed the router's configuration. if you wish to use a setup wizard you must rest the router to its default configuration and then restart it.

Any advice would be welcomed.

Edited by helpermonkey
Link to post
6 hours ago, Babar said:

Here is the docker run command result.

 

docker-run.txt 1.48 kB · 1 download

Are you using unraid? The reason I ask is that you have not set the PUID & PGID values and those are default there if you use unraid and install through CA. If you are not using unraid, this is not the place to get support. Go to our discourse forum or discord.

 

Link to post
On 1/17/2020 at 5:24 PM, saarg said:

Are you using unraid? The reason I ask is that you have not set the PUID & PGID values and those are default there if you use unraid and install through CA. If you are not using unraid, this is not the place to get support. Go to our discourse forum or discord.

Of course, I am using Unraid.

Link to post

Sorry this might be a dumb question but how do I change this to run on port 8081 instead of 8080

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='unifi-controller' --net='host' -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'UDP_PORT_3478'='3478' -e 'TCP_PORT_8081'='8081' -e 'TCP_PORT_8443'='8443' -e 'TCP_PORT_8880'='8880' -e 'TCP_PORT_8843'='8843' -e 'UDP_PORT_10001'='10001' -e 'TCP_PORT_8081'='8081' -e 'PUID'='99' -e 'PGID'='100' -v '/mnt/user/appdata/unifi-controller':'/config':'rw' 'linuxserver/unifi-controller:latest' 
e44d6242138caecf565bd71a9dccdb07bb1318026ab66105a5f7caf348bf2879

The command finished successfully!

When the docker starts it looks like it still pointing to 8080

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donate/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 99-custom-scripts: executing...
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-scripts: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Port 8080 not available

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.