[Support] ich777 - Gameserver Dockers


4202 posts in this topic Last Reply

Recommended Posts

On 10/25/2020 at 5:56 AM, ich777 said:

That's also a game that I want to have a dedicated server, Satisfactory and Astroneer...

As far as I know the dedicated servers aren't released yet and if they release it for windows it's very unlikely that it works (in the case of Astroneer the dedicated server have been released for windows only at the time and it's nearly impossible to run it on linux)

Hey @ich777, have you given this any further look lately? 

Link to post
  • Replies 4.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD Do

Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

Dockers Available so far:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike: Global Offensive TeamFortress 2 ArmA3 - requested by @MrSage D

Posted Images

6 hours ago, blurb2m said:

Hey @ich777, have you given this any further look lately? 

Both games are not available from what I know for Linux (Satisfactory I checked about a week ago - no unofficial Dedicated servers out there - and Astroneer about a month ago, but don't think that much has changed).

 

3 hours ago, sweno said:

Can we get a container for Wreckfest dedicated server?

Sorry I don't create game servers for games that I don't own anymore since this is a real pain to support if something isn't working - btw. is there a dedicated server out there for Linux?

Link to post

Hey @ich777 been running your container for Valheim for several weeks now, its stable, and really .. just works great work !

 

As I venture more into the game and docker I'm wanting to figure out how to get the Valheim mods installed, in particular in a way that doesn't wipe them out for future updates.

 

Do you or anyone else have any tips on aching this, I tried scoring the threat but at 150 pages is hard going :) 

 

Eg:

InSlimVML mod loader.
BepInEx mod loader  

Link to post
5 minutes ago, falconz said:

BepInEx mod loader  

There is a option built into the Docker that you can set to true and it will automatically install the modloader and also update it on a container start/restart.

 

5 minutes ago, falconz said:

InSlimVML mod loader.

Please keep in mind that I can't include every modloader to the container, only ValheimPlus and BepInEx are supported.

Link to post
2 minutes ago, Adonis said:

Great work with conan container. Can you tell us how to autorestart server/container at fixed time?

Thanks!

Yes, download the User Scripts plugin from the CA App and create a new entry in this plugin that has the command: 'docker restart CONTAINERNAME' in it (change CONTAINERNAME to the exact name from your container).

 

You can then create a Cron entry with a fixed schedule.

 

Hope that helps.

Link to post

Noticed that my Minecraft server wasn't working, so I cracked open the logs, and noticed that it was calling a null pointer exception.

 

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Checking for 'runtime' folder---
---'runtime' folder found---
---Checking if Runtime is installed---
---Runtime found---
---Checking for Minecraft Server executable ---
---Minecraft v1.16.5 is Up-To-Date!---
---Preparing Server---
---Checking for 'server.properties'---
---'server.properties' found...
---Checking for old logs---
---Starting Server---
---Checking for old logs---
---Starting Server---
---Waiting for logs, please stand by...---
---Waiting for logs, please stand by...---
[18:03:01] [Server thread/INFO]: Stopping server
[18:03:01] [Server thread/INFO]: Saving worlds
[18:03:01] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException: null
at net.minecraft.server.MinecraftServer.a(SourceFile:572) ~[servernew.jar:?]
at net.minecraft.server.MinecraftServer.t(SourceFile:599) ~[servernew.jar:?]
at zg.t(SourceFile:567) ~[servernew.jar:?]
at net.minecraft.server.MinecraftServer.w(SourceFile:707) ~[servernew.jar:?]
at net.minecraft.server.MinecraftServer.a(SourceFile:257) ~[servernew.jar:?]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_261]
Terminated

 

Any idea how to solve this?

Link to post
2 hours ago, AlphaOmegaKappa said:

Any idea how to solve this?

Are you using a custom gersion?

Please try to stop the container, delete the runtime folder and also the server.jar and then start the container again.

Are we talking about the MinecraftBasicServer or am I wrong?

Link to post
11 hours ago, ich777 said:

Are you using a custom gersion?

Please try to stop the container, delete the runtime folder and also the server.jar and then start the container again.

Are we talking about the MinecraftBasicServer or am I wrong?

Yes, MinecraftBasicServer. No custom versions, just plain vanilla 1.16.5. I'll try to delete the runtime folder and .jar, and then update you.

 

EDIT: The same error occurs, at the same lines, after letting Minecraft generate a fresh runtime and server.jar.

Edited by AlphaOmegaKappa
Link to post
38 minutes ago, AlphaOmegaKappa said:

Yes, MinecraftBasicServer. No custom versions, just plain vanilla 1.16.5. I'll try to delete the runtime folder and .jar, and then update you.

 

EDIT: The same error occurs, at the same lines, after letting Minecraft generate a fresh runtime and server.jar.

I can't reproduce this error, is it possible that you have set the Share where the files for Minecraft are located to Use Cache 'Yes' if so please set it to 'Prefer' or 'Only'.

I attached the log: minecraft.log

Link to post
On 10/9/2020 at 5:13 PM, Cyd said:

This will hopefully shed some light on the underside working bits of building a cluster of servers for ARK:SurvivalEvolved.

 

With the inspiration (read thievery) from @growlith I present the A3C (ARK Cluster Companion Container). It and the accompanying XLM files should allow for a fairly simple stand up of a new ARK server cluster.

 

https://github.com/CydFSA/A3C

 

Go to the github, fetch the XMLs for however many servers you want to use in your new cluster, salt them to taste with your information (server names, cluster name, passwords, adminpasswords, ect...). 

 

Good Luck and Happy Hunting!

 

historical information left below (really go get the newer stuff from github)

------------------------------

We are going to start with getting -UseDynamicConfig working and talking to our config file rather than the Official one out at http://arkdedicated.com/dynamicconfig.ini , I know it feels like that should come last but bear with me.


First we have a simple http server running by itself serving up the "dynamicconfig.ini" on port 80 on its container, this is mapped out to the host on 8080 and is not really needed but makes it easy to take a quick glance at tower:8080 to see what the settings are. I ran this container first so that it would receive a predictable IP address (172.17.0.2:80) that is then used in the configurations of the remaining containers to add an entry to the hosts file (--add-host=arkdedicated.com:172.17.0.2) so that requests to http://arkdedicated.com/dynamicconfig.ini in the game servers are pointed to the container running at 172.17.0.2. If you don't want or care to use the dynamic configs, omit the ARK0 container and remove -UseDynamicConfig from the "Extra Game Parameters" of all subsequent ARK's you deploy. 

 

Next I deployed 10 ARK server instances, why 10 when there are only 9 maps? Well, I assume that Wild card will have another map for Genesis Part 2 coming in the spring so I added a container to house it, currently it is configured as a 2nd Genesis1 map with all the correct ports and paths. If they do release a new map it will only require changing the map name in the config and starting the container.

 

The ports are mapped sequentially so you will only need to insert three port forward blocks into your gateway router (UDP 7777-7796, UDP 27015-27024, TCP 27025-27034) You do not need anything forwarded to ARK0 as it is only there to talk to ARKs 1-10.

 

ARK0-dynamicconfig        tcp     80:8080
ARK1-TheIsland            Udp1 7777    UDP2 7778    UDPSteam 27015    TCPRCON 27025
ARK2-ScorchedEarth_P    Udp1 7779    UDP2 7780    UDPSteam 27016    TCPRCON 27026
ARK3-Aberration_P        Udp1 7781    UDP2 7782    UDPSteam 27017    TCPRCON 27027
ARK4-TheCenter            Udp1 7783    UDP2 7784    UDPSteam 27018    TCPRCON 27028
ARK5-Ragnarok            Udp1 7785    UDP2 7786    UDPSteam 27019    TCPRCON 27029
ARK6-Valguero_P            Udp1 7787    UDP2 7788    UDPSteam 27020    TCPRCON 27030
ARK7-CrystalIsles        Udp1 7789    UDP2 7790    UDPSteam 27021    TCPRCON 27031
ARK8-Extinction            Udp1 7791    UDP2 7792    UDPSteam 27022    TCPRCON 27032
ARK9-Genesis            Udp1 7793    UDP2 7794    UDPSteam 27023    TCPRCON 27033
ARK10-Genesis2            Udp1 7795    UDP2 7796    UDPSteam 27024    TCPRCON 27034

 

Path mappings are slightly more complex. SteamCMD is in its original location per @ich777's standard and the binary data for ARK is also in the default location. Having the server binaries shared also means that when there is an update to ARK (and/or SteamCMD) it only has to be downloaded one time rather than 10. The update procedure is to bring all of the ARKs down then start ARK1 let it update and initialize then bring the others back up en mass, as a precaution I have the wait timer on ARKs 2-10 set to 600 seconds so that if the Tower host gets rebooted ARK1 has time to pull any updates and initialize. The ARK savegame data and Server Config files are mapped into the proper location on a per container basis. This prevents each server instance from mucking up the servers config .inis (which they liked to do), this also means that you can use different options on each ark and makes managing the SavedArks less hair pully outy. The clustering function is done with a shared resource directory and a ClusterID (-clusterid=arkStar under "Extra Game Parameters") 

 

Dynamiccimfig data:
/dynamicconfig<>/mnt/cache/appdata/ark-se/dynamicconfig

 

SteamCMD:
/serverdata/steamcmd<>/mnt/user/appdata/steamcmd

 

ARK data:
/serverdata/serverfiles<>/mnt/cache/appdata/ark-se

 

Cross ARK cluster data:
/serverdata/serverfiles/clusterfiles<>/mnt/cache/appdata/ark-se/cluster

 

ARK configs and Save Data:
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK1-TheIsland
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK2-ScorchedEarth_P
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK3-Aberration
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK4-TheCenter
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK5-Ragnarok
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK6-Valguero_P
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK7-CrystalIsles
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK8-Extinction
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK9-Genesis
/serverdata/serverfiles/ShooterGame/Saved<>/mnt/cache/appdata/ark-se/ARK10-Genesis2

 

The XML files are attached below, if you chose to use them please make sure to edit them to your taste; server names, passwords, clusterIDs, ect. They can be used by placing them in /boot/config/plugins/dockerMan/templates-user then going to "Docker/Add Container" then choosing from the "Template:" drop down.

 

Or maybe @ich777 will do us all a favor and decide to add them to his already impressive XML collection  ;)  

 

 

 

ARKcluster.jpg

 

I'm looking for suggestion on what my problem is. I have recently re-deployed my cluster using this guide. This is amazing work, and I am so grateful for it. What a time saver this Will/Would be.... this is where i could use some help. see the output below from A3C. The Local Version is greater than the one reported by the API. also Mods are not updating, I have had to update them manually. I would love to hear your suggestions. Thank you in advance.

 

Update Checked At: 29/04/2021 22:51:26
local version: 327.8 arkdedicated version: 326.13
Mod Ids to check: ['839162288', '1315573129', '899987403', '1681125667', '2200048898', '902157012', '761535755', '731604991', '905971515', '821530042', '816908578', '1609138312', '2135314513', '898049820', '1404697612', '889745138', '756389708', '1814953878']
Mod "Primal Fear" ID 839162288 updated locally 1619651072.9178843 remote 1602542052. Requires Update: False
Mod "Primal Fear Aberration Expansion" ID 1315573129 updated locally 1619651073.5418887 remote 1538841359. Requires Update: False
Mod "Primal Fear Boss Expansion" ID 899987403 updated locally 1619651081.7849479 remote 1570545692. Requires Update: False
Mod "Primal Fear Extinction Expansion" ID 1681125667 updated locally 1619651082.948956 remote 1561175829. Requires Update: False
Mod "Primal Fear Genesis Expansion" ID 2200048898 updated locally 1619651083.7029614 remote 1597768923. Requires Update: False
Mod "Primal Fear Scorched Earth Expansion" ID 902157012 updated locally 1619651084.4639668 remote 1597511307. Requires Update: False
Mod "Ultra Stacks" ID 761535755 updated locally 1619651084.7889693 remote 1598141957. Requires Update: False
Mod "Structures Plus (Open Source)" ID 731604991 updated locally 1619651087.542989 remote 1615515196. Requires Update: False
Mod "Randomly Colored Dinos" ID 905971515 updated locally 1619651087.5569892 remote 1494339836. Requires Update: False
Mod "Upgrade Station v1.8i" ID 821530042 updated locally 1619651089.5620034 remote 1517787644. Requires Update: False
Mod "eco's Tek Decor" ID 816908578 updated locally 1619651091.6960187 remote 1610556706. Requires Update: False
Mod "Dino Storage v2" ID 1609138312 updated locally 1619651092.1940222 remote 1619629676. Requires Update: False
Mod "Crystal Isles Dino Addition" ID 2135314513 updated locally 1619651096.905056 remote 1614996923. Requires Update: False
Mod "Auction House v3.2.1b" ID 898049820 updated locally 1619651097.9400635 remote 1599085810. Requires Update: False
Mod "Awesome SpyGlass!" ID 1404697612 updated locally 1619651098.016064 remote 1593646441. Requires Update: False
Mod "Awesome Teleporters!" ID 889745138 updated locally 1619651098.2890658 remote 1597700547. Requires Update: False
Mod "Builder's Helmet" ID 756389708 updated locally 1619651098.3340662 remote 1548153618. Requires Update: False
Mod "Castles, Keeps, and Forts: Remastered" ID 1814953878 updated locally 1619651104.730112 remote 1582927914. Requires Update: False
0 mods updated

Link to post
16 hours ago, Richjfree1 said:

 

I'm looking for suggestion on what my problem is. I have recently re-deployed my cluster using this guide. This is amazing work, and I am so grateful for it. What a time saver this Will/Would be.... this is where i could use some help. see the output below from A3C. The Local Version is greater than the one reported by the API. also Mods are not updating, I have had to update them manually. I would love to hear your suggestions. Thank you in advance.

 

Update Checked At: 29/04/2021 22:51:26
local version: 327.8 arkdedicated version: 326.13
Mod Ids to check: ['839162288', '1315573129', '899987403', '1681125667', '2200048898', '902157012', '761535755', '731604991', '905971515', '821530042', '816908578', '1609138312', '2135314513', '898049820', '1404697612', '889745138', '756389708', '1814953878']
Mod "Primal Fear" ID 839162288 updated locally 1619651072.9178843 remote 1602542052. Requires Update: False
Mod "Primal Fear Aberration Expansion" ID 1315573129 updated locally 1619651073.5418887 remote 1538841359. Requires Update: False
Mod "Primal Fear Boss Expansion" ID 899987403 updated locally 1619651081.7849479 remote 1570545692. Requires Update: False
Mod "Primal Fear Extinction Expansion" ID 1681125667 updated locally 1619651082.948956 remote 1561175829. Requires Update: False
Mod "Primal Fear Genesis Expansion" ID 2200048898 updated locally 1619651083.7029614 remote 1597768923. Requires Update: False
Mod "Primal Fear Scorched Earth Expansion" ID 902157012 updated locally 1619651084.4639668 remote 1597511307. Requires Update: False
Mod "Ultra Stacks" ID 761535755 updated locally 1619651084.7889693 remote 1598141957. Requires Update: False
Mod "Structures Plus (Open Source)" ID 731604991 updated locally 1619651087.542989 remote 1615515196. Requires Update: False
Mod "Randomly Colored Dinos" ID 905971515 updated locally 1619651087.5569892 remote 1494339836. Requires Update: False
Mod "Upgrade Station v1.8i" ID 821530042 updated locally 1619651089.5620034 remote 1517787644. Requires Update: False
Mod "eco's Tek Decor" ID 816908578 updated locally 1619651091.6960187 remote 1610556706. Requires Update: False
Mod "Dino Storage v2" ID 1609138312 updated locally 1619651092.1940222 remote 1619629676. Requires Update: False
Mod "Crystal Isles Dino Addition" ID 2135314513 updated locally 1619651096.905056 remote 1614996923. Requires Update: False
Mod "Auction House v3.2.1b" ID 898049820 updated locally 1619651097.9400635 remote 1599085810. Requires Update: False
Mod "Awesome SpyGlass!" ID 1404697612 updated locally 1619651098.016064 remote 1593646441. Requires Update: False
Mod "Awesome Teleporters!" ID 889745138 updated locally 1619651098.2890658 remote 1597700547. Requires Update: False
Mod "Builder's Helmet" ID 756389708 updated locally 1619651098.3340662 remote 1548153618. Requires Update: False
Mod "Castles, Keeps, and Forts: Remastered" ID 1814953878 updated locally 1619651104.730112 remote 1582927914. Requires Update: False
0 mods updated

 

Wild Card has not updated the version number on http://arkdedicated.com/version

 

I will ping Jat over at WC.

 

and there was a problem with one of the Steam workshop writes not not incrementing the their version number at one point... the Dino storage one iirc... Sorry I cannt fix other peoples mistakes.

Edited by Cyd
Link to post
On 4/29/2021 at 10:13 AM, ich777 said:

I can't reproduce this error, is it possible that you have set the Share where the files for Minecraft are located to Use Cache 'Yes' if so please set it to 'Prefer' or 'Only'.

I attached the log: minecraft.log

I just checked, and the main folder where the files are is set to "Prefer", and was set to "Only" until a month ago. I also made a copy of the server using a different docker, but I'm running into the same error.

Link to post
4 hours ago, Newtious said:

any chance of a StarsOne docker?

I don't do containers that I don't own anymore, if someone really want's a gameserver then please donate the game to me, otherwise troubleshooting is a real pain for me.

 

Also I think this game has no dedicated server from what I've read online.

 

1 hour ago, AlphaOmegaKappa said:

I also made a copy of the server using a different docker, but I'm running into the same error.

Then I think something with the game or better speaking the files itself must be wrong.

 

Can you at least try it with a vanilla installation of the container?

Link to post

Does anyone know if there's any clearer documentation for the OpenRCT2 container?

The Docker hub page, and the Unraid template, say this on one of the variables - 

"The hash of the admin user (you find it on the client computer in the 'user-data/keys' folder from OpenRCT2"

What on earth does this mean!? What client is it referring too, and what path to that folder?

 

I'm guessing a lack of this variable is caused this error too: "Unable to connect to master server".

 

Thanks!

Link to post
37 minutes ago, boomam said:

What client is it referring too, and what path to that folder?

The game client itself that you use to plqy the game. ;)

 

38 minutes ago, boomam said:

I'm guessing a lack of this variable is caused this error too: "Unable to connect to master server".

Nope that's actually because the master server can't communicate with your server, have you forwarded the ports correctly so that the master server can communicate with your server?

Link to post
9 minutes ago, ich777 said:

The game client itself that you use to plqy the game. ;)

 

Nope that's actually because the master server can't communicate with your server, have you forwarded the ports correctly so that the master server can communicate with your server?

Hi.

Is this not a browser installation of OpenRCT?

 

RE: forwarded ports, no, there is no need to as i am inside my own LAN. ;-)

Link to post
38 minutes ago, boomam said:

Is this not a browser installation of OpenRCT?

I don't understand completely what you mean with this...

 

This is a dedicated server and you connect with the client or better speaking the game that runs on your computer to it so that you can play with your friends. :)

 

39 minutes ago, boomam said:

RE: forwarded ports, no, there is no need to as i am inside my own LAN. ;-)

Exactly if you want to only play inside your LAN you don't have to forward your ports, this is only necessary if you want to play over the Internet, WAN, with your friends. :)

Link to post
Posted (edited)

 

Hello, thanks for this great job of the container, especially for noobs like me :))

 

I'm using the conan exhiles container and would change the server size. How can I do that? I can't find anything in the files to change it.

Edited by sanobi
Link to post
2 hours ago, sanobi said:

I'm using the conan exhiles container and would change the server size.

I think you are talking about the maximum players that can connect or am I wrong?

 

The setting for that should be located in '.../Game.ini', to set the value search for '[/script/engine.gamesession]' and add 'MaxPlayer = 70' or whatever you prefer (if the line '[/script/engine.gamesession]' doesn't exist you have to also add it to the bottom):

[/script/engine.gamesession]
MaxPlayers = 70

(please note that the hard limit for private dedicated servers is 70).

 

You can get a full overview what to put where for example here: Click

Link to post

Hey, I have been running a Valheim server for a few weeks now without any hitches, however today. It has stopped working properly. The docker keeps resetting itself after about a minute of uptime. I have attached a photo of the logs. It gets to RecordsteamInterfaceCreation (PID63): SteamNetworkingSockets008 and stops there, and repeats. I have tried stopping and restarting the docker... I am not really sure what the error is and what to do, any help would be appreciated. 

image.thumb.png.95f9200da8363fbf3a98b21d6645b9ab.png

Link to post
4 hours ago, Skoden said:

The docker keeps resetting itself after about a minute of uptime.

What do you mean exactly? Does it restart?

 

4 hours ago, Skoden said:

I have tried stopping and restarting the docker... I am not really sure what the error is and what to do, any help would be appreciated. 

Have you got a old savegame? It seems that there is something wrong with the savegame itself if it does this now.

 

Can you try to stop the container, delete the savegame folder entirely and then start the container again and see if it stays up?

 

Keep in mind this game is in pretty early alpha and such things are likely to happen.

Thats why I built in the automatic backup function. :)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.