[Support] Linuxserver.io - NZBGet

Recommended Posts

1 minute ago, trurl said:

This should be fine. You should make the appdata share cache-prefer and it will be just like the appdata share created for new installs.

Oh I wasn't sure what that meant when I was checking it out. I will do that do now. Thanks very much for your help trurl.

Link to comment
1 minute ago, trurl said:

There is Help for most pages in the webUI. The Help button at upper right is a toggle.


Here is a more detailed explanation of the Use cache setting:


In my haste I couldn't see the difference between cache:yes and prefer. I do now! I got a shiny new 4TB red for my cache and was just eager to get it going! I ran out of bays on my server a few years ago so had to use an external usb for a make shift cache and now im appreciating all the nice perks again. I don't see an overflow to my raid happening but i have it set to prefer. Thanks for the info Trurl, very good to know!

Link to comment
  • 1 month later...
30 minutes ago, wayller said:

I'm having a problem with speeds, with both Nzbget and Sabnzbd. I download to my SSD cache, and I unrar to my SSD cache. My problem is that it starts at 50 Mb/s with the first download, and then it stops at 25 Mb/s with the rest of the downloads.

Doesn't sound like a container issue tbh if it's doing it with two different applications.

Link to comment
  • 1 month later...
  • 2 weeks later...
  • 3 weeks later...



I just came back again from OMV to unRAID.


I have a 400 MBiT Cableline and with unRAID i get about 40 - 45 MB/S where on OMV i had 49 - 50 MB with the same settings (also used this container there)


I tried Sabnzbd on unRAID where i do also have FULLSPEED @ 50 MB/S.


Downloads are going on an Samsung SSD as cachedrive  which is btrfs formatted.


Does any1 have an idea?


Thx in advance! ;)



Link to comment
On 7/29/2017 at 1:25 PM, b0mb said:

Does any1 have an idea?


For whatever reason, I've had to increase the number of connections in nzbgbet to get to the same download speed as sab. No clue why that is. I've got a 300mbps connection and I am able to saturate my download.


You may also want to take a look at performance tips on the nzbget wiki. Though my server is pretty beefy, I reduced the logging level as I just don't need that writing to my SSD constantly for every little thing.

Link to comment
  • 5 weeks later...

which cipher should be used?  Thanks






Many users have followed these instructions. All tests show that the encryption/hash combination RC4/MD5 is the fastest on all machines. To use this cipher in NZBGet set option ServerX.Cipher to:

  • If NZBGet was compiled to use OpenSSL:

  • If NZBGet was compiled to use GnuTLS:



Link to comment
Just now, jonathanm said:

Isn't that listed at the top next to the current speed?

yes, that's the overall total - in sab it would show the running cumulative number next to each file:


Name     Time to Download    Total Cumulative time

File 1       2m                            2m

File 2       4m                            6m

File 3      20m                          26m


Etc etc Not a biggie if it can't, but it was nice with sab knowing that file xx would be ready in xx hours, or even xx days in the case of my slow line

Link to comment
  • 2 weeks later...

Hi, i'm having a strange issue with Nzbget + sickbeard + nzbtomedia ...


It's related to nzbtomedia but i figured i'd try here first since... it looks like my nzbget.conf gets overwritten?


When SB sends a download to nzbget, it downloads fine, but when it calls the script, it says that SB didn't answer...

So i checked SB, and SB is up and running... restarted that container for good measures... but NZBget still says its not answering...


SO i looked at my nzbtomedia config in nzbget... for some reason when i look at the nzbtomedia part, sb adress keeps getting rewritten to   ""  for some reason..

I change it to, save, reload nzbget, and it gets back to that!


I ssh to unraid and edit nzbget.conf manually while the docker is off, save the file then start nzbget again...


After a bit of testing i figured out the nzbtosickbeard section is not really important, its the nzbtomedia script that gets called.  I noticed that it's the sbhost in that section that keeps going back to "localhost" instead of ""


It works fine for a while (2-3 weeks) and then starts acting up again.  What could make it reset itself like that?


Any idea?





Edited by stefer
Did more testing and remembered and found what fixed it last time.
Link to comment
  • 1 month later...

Hi guys. I'm hoping someone can help me.  I'm new to unRAID and struggling with getting some of my dockers up and running.   I want to have NZBget, Sonarr and Radarr working.   Here is what I have done.

  • I created a share called Downloads and set it to use cache only. 
  • I installed NZBget and set /downloads to /mnt/cache/Downloads/
  • In NZBget I set paths MainDir to /downloads
  • DestDir to ${MainDir}/complete
  • InterDir to ${MainDir}/incomplete
  • Tried Umask at 1000 and 000 (curr set to 000)
  • Set Categories for Movies and TV in NZBget  (should these be set like /mnt/cache/Downloads/complete/Movies ???)

I installed Sonarr and Radarr (both also from Linuxserver.io) 

  • set /downloads for both to the same as NZBget  /mnt/cache/Downloads/
  • set Sonarr /tv to /mnt/user/Media/TV Shows/
  • set Radarr /movies to /mnt/user/Media/Movies/

Both Sonarr and Radarr grab content and send it to NZBget.   NZBget downloads whatever files fine until it unpacks. Then it fails. 

I get errors...

  • Could not create directory /mnt/cache/Downloads/complete/TV/"insert filename here"/_unpack: could not create directory /mnt/cache: Permission denied
  • Unrar error code: 10
  • Could not delete temporary directory /mnt/cache/Downloads/complete/TV/"insert filename here"/_unpack: No such file or directory
  • Unpack for "insert filename here" Failed

I checked my permissions for the downloads share /mnt/cache/Downloads and got...


drwxrwxrwx 1 nobody users      78 Oct 23 23:59 ./
drwxrwxrwx 1 nobody users      94 Oct 23 18:30 ../
drwxrwxrwx 1 nobody users      26 Oct 24 00:58 complete/
drwxrwxrwx 1 nobody users     982 Oct 24 01:10 incomplete/
drwxrwxrwx 1 nobody users    1364 Oct 24 01:10 nzb/
-rw-rw-rw- 1 nobody users 3881250 Oct 24 01:12 nzbget.log
drwxrwxrwx 1 nobody users    1164 Oct 24 01:12 queue/
drwxrwxrwx 1 nobody users       0 Oct 24 01:10 tmp/


These same errors happen on every download.  I'm not sure how to fix it.   Any help would be greatly appreciated. 


Link to comment
6 hours ago, Tonitram said:

NZBget downloads whatever files fine until it unpacks. Then it fails. 

I get errors...

  • Could not create directory /mnt/cache/Downloads/complete/TV/"insert filename here"/_unpack: could not create directory /mnt/cache: Permission denied
  • Unrar error code: 10
  • Could not delete temporary directory /mnt/cache/Downloads/complete/TV/"insert filename here"/_unpack: No such file or directory
  • Unpack for "insert filename here" Failed


According to the mappings you said you set, NZBget and those other dockers don't know anything about /mnt/cache/Downloads. They should be referring to that folder as /downloads. So it should be trying to unpack to /downloads/complete/TV/...


Recheck all your settings.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.