[Support] Linuxserver.io - Nextcloud


Recommended Posts

1 hour ago, skois said:

Hmm, config looks ok, atleast for local it should work. Is there any logs on nextcloud logging panel?

For external i would add this:

 


  'trusted_domains' => 
  array (
    0 => '10.10.10.254:9443',
    1 => 'cloud.mydomain.me',
  ),
  'trusted_proxies' => 
  array (
    0 => 'NginxProxyManager',
  ),
  'overwrite.cli.url' => 'https://10.10.10.254:9443',
  'overwriteprotocol' => 'https',
  'overwritehost' => 'cloud.mydomain.me',

if you using swag 
change NginxProxyManager with swag 
or the name of your docker if you have named it different



For the code block there is a button on the top of the edit box </> 

Hey skios, thanks for your help. Sadly the changes to the config file didn't change the errors I'm getting. And there don't appear to be any errors in the log of nextcloud that would indicate why noting is uploading over a certain size. 

The changes I made to the config file were:

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'random characters',
  'passwordsalt' => 'different randoom characters',
  'secret' => 'longer string of random characters',
  'trusted_domains' => 
  array (
    0 => 'LAN IP: And nexcloud port',
    1 => 'mycloudURL',
  ),
  'trusted_proxies' =>
  array (
  0 => 'swag',
  ),
  'dbtype' => 'mysql',
  'version' => '19.0.6.2',
  'overwrite.cli.url' => 'https://LANIP:different nextcloud port',
  'overwriteprotocol' => 'https',
  'overwritehost' => 'mycloudURL',
  'dbname' => 'MyServerName+cloud',
  'dbhost' => 'LANIP:DPPort',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'its_me!',
  'dbpassword' => 'myPassword',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
);

Any further ideas?

Link to comment
Hey skios, thanks for your help. Sadly the changes to the config file didn't change the errors I'm getting. And there don't appear to be any errors in the log of nextcloud that would indicate why noting is uploading over a certain size. 
The changes I made to the config file were:
php$CONFIG = array ( 'memcache.local' => '\\OC\\Memcache\\APCu', 'datadirectory' => '/data', 'instanceid' => 'random characters', 'passwordsalt' => 'different randoom characters', 'secret' => 'longer string of random characters', 'trusted_domains' =>  array (   0 => 'LAN IP: And nexcloud port',   1 => 'mycloudURL', ), 'trusted_proxies' => array ( 0 => 'swag', ), 'dbtype' => 'mysql', 'version' => '19.0.6.2', 'overwrite.cli.url' => 'https://LANIP:different nextcloud port', 'overwriteprotocol' => 'https', 'overwritehost' => 'mycloudURL', 'dbname' => 'MyServerName+cloud', 'dbhost' => 'LANIP:DPPort', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'its_me!', 'dbpassword' => 'myPassword', 'installed' => true, 'maintenance' => false, 'theme' => '', 'loglevel' => 2,);

Any further ideas?

Nope,sorry, can't think of anything else right now

Sent from my Mi 10 Pro using Tapatalk

Link to comment

EDITED BIT:  I ended up restoring from [Plugin] CA Appdata Backup / Restore .... Mess around with v20.0.4 after Christmas.

 

Hi,

 

This is doing my head in... What have I done??... And how do I fix??  😕

 

Fix is prolly sooo easy, I just can't see it ATM.

 

I upgraded to 20.0.4 from settings/overview page.

 

Security & setup warnings. 

 

There are some warnings regarding your setup.

The database is missing some primary keys. Due to the fact that adding primary keys on big tables could take some time they were not added automatically. By running "occ db:add-missing-primary-keys" those missing primary keys could be added manually while the instance keeps running.

Missing primary key on table "oc_federated_reshares".

Missing primary key on table "oc_systemtag_object_mapping".

Missing primary key on table "oc_comments_read_markers".

Missing primary key on table "oc_collres_resources".

Missing primary key on table "oc_collres_accesscache".

Missing primary key on table "oc_filecache_extended".

Edited by Joc
Link to comment
EDITED BIT:  I ended up restoring from [Plugin] CA Appdata Backup / Restore .... Mess around with v20.0.4 after Christmas.
 
Hi,
 
This is doing my head in... What have I done??... And how do I fix??  
 
Fix is prolly sooo easy, I just can't see it ATM.
 
I upgraded to 20.0.4 from settings/overview page.
 
Security & setup warnings. 
 
There are some warnings regarding your setup.
The database is missing some primary keys. Due to the fact that adding primary keys on big tables could take some time they were not added automatically. By running "occ db:add-missing-primary-keys" those missing primary keys could be added manually while the instance keeps running.
Missing primary key on table "oc_federated_reshares".
Missing primary key on table "oc_systemtag_object_mapping".
Missing primary key on table "oc_comments_read_markers".
Missing primary key on table "oc_collres_resources".
Missing primary key on table "oc_collres_accesscache".
Missing primary key on table "oc_filecache_extended".
By running "occ db:add-missing-primary-keys" those missing primary keys could be added manually while the instance keeps running.
Right click on docker and go to console

Sent from my Mi 10 Pro using Tapatalk

Link to comment

Hello,

 

I recently changed the IP of my server which broke my external shares on nextcloud. When I click on external storage in the admin settings I am hit with an internal server error and the page won't load.  All other admins settings pages work and load properly. Below is the code from the most recent log. Any ides on hwo to fix this? Thank you

 

 - [22/Dec/2020:11:17:42 -0500] "GET /settings/admin/externalstorages HTTP/1.1" 500 4036 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.67 Safari/537.36 Edg/87.0.664.52"

 

This is form the nginx access log as nothing is showing in the error log

 

Link to comment

Anyone knows how to take care of these errors.

 

There are some warnings regarding your setup.

You are currently running PHP 7.2.18. Upgrade your PHP version to take advantage of performance and security updates provided by the PHP Group as soon as your distribution supports it.

Nextcloud 20 is the last release supporting PHP 7.2. Nextcloud 21 requires at least PHP 7.3.

This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them.

bcmath

Link to comment
1 hour ago, mrtek007 said:

Anyone knows how to take care of these errors.

 

There are some warnings regarding your setup.

You are currently running PHP 7.2.18. Upgrade your PHP version to take advantage of performance and security updates provided by the PHP Group as soon as your distribution supports it.

Nextcloud 20 is the last release supporting PHP 7.2. Nextcloud 21 requires at least PHP 7.3.

This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them.

bcmath

Might be time to update your container. The latest container has version 7.3.25

Link to comment

so i have nextcloud installed and since i forced update am no longer able to access my files. i now realize that i never installed mariadb or anything to play with nextcloud, just this docker. i am very much a newb and would appreciate any help that could get me back to where i SHOULD be. if i uninstall nextcloud and start from scratch will i lose everything that i currently have in my folders? i have some 15 users with thousands of pics and files in my folders and would hate to lose everything on the account. please let me know what i should do. Thanks.

Link to comment
24 minutes ago, mrtek007 said:

the current container is up to date; i'm using "linuxserver's Repository container" is there something I am missing.

You have not updated the container if it reports that you have version 7.2.

What does it say if you go to settings and under administration go to system and scroll down to PHP.

Link to comment
7 minutes ago, saarg said:

You have not updated the container if it reports that you have version 7.2.

What does it say if you go to settings and under administration go to system and scroll down to PHP.

thanks for the help, I figured it out. In my docker setting I had this "linuxserver/nextcloud:16.0.1-ls22" I changed it to "linuxserver/nextcloud", this updated the container. Again thanks!

 

Link to comment
8 hours ago, kerpster said:

so i have nextcloud installed and since i forced update am no longer able to access my files. i now realize that i never installed mariadb or anything to play with nextcloud, just this docker. i am very much a newb and would appreciate any help that could get me back to where i SHOULD be. if i uninstall nextcloud and start from scratch will i lose everything that i currently have in my folders? i have some 15 users with thousands of pics and files in my folders and would hate to lose everything on the account. please let me know what i should do. Thanks.

Hi,

 

Try adding

  'filesystem_check_changes' => 1,

to config.php, then restart.

 

It makes NC aware of added files outside of the database.

 

Merry Christmas.

Link to comment
On 12/22/2020 at 7:42 PM, skois said:

By running "occ db:add-missing-primary-keys" those missing primary keys could be added manually while the instance keeps running.
Right click on docker and go to console

Sent from my Mi 10 Pro using Tapatalk
 

Hi,

 

THANKS.  

 

I did try that but was getting some sort of "missing' error.  Can't recall exactly.  Will examine it after Chrissy.  

 

THANKYOU again and have a wonderful Christmas 🙂

  • Like 1
Link to comment
8 hours ago, BrunoVic said:

All I did was update my Docker containers only to get stuck with this response:

 

Internal Server Error The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report. More details can be found in the server log.

 

I have no clue how to recover this. I have no idea where the "server log" is.

 

This morning I am also getting this exact message. Any thoughts on what this is all about and how to go about fixing it?

 

My latest NC is 19.0.6

The Nextcloud.log is HUGE, over 310 MB, and growing all the time! 

Edited by levster
Link to comment
19 minutes ago, BrunoVic said:

Can someone help please. I have a finance document on that server that I need no later than this afternoon.

I just restored my dockers to a few days ago, and the console is back up and running. If you don't have any other option, try restoring it as well until someone can perhaps shine some light on the "proper" fix.

Link to comment
1 minute ago, BrunoVic said:

What do you mean by "other options". I am afraid to do anything with that docker container because I don't want to lose my data.

You data is unaffected, even if you completely remove the NC. You can probably just browse to that folder on your server and retrieve the file that you are looking for manually. So, if you know where your files are stored, such a networked PC, and you have access to it, just browse and find the folder/file to download manually.

Link to comment
1 minute ago, BrunoVic said:

How do I restore? Will I lose my logon creds? How do I restore the logon credentials like it was before?

Sorry, I was assuming that you have backup/restore plugin. Do you? If yes, and you have been regularly backing up the dockers... you will have the option to "go back" or restore to an earlier version of the apps/dockers. I am not a techie and my explanation is I am sure lacking. Look under Setting/User Utilities tab to see if you have Backup/Restore Appdata option. If you do not, then I am at loss of what to do next. If you do, restoring will not affect your credentialing.

Link to comment
1 minute ago, BrunoVic said:

No I am not familiar with that plugin.

I think that there are a LOT smarter people here who can guide you. however, because of the holidays, their response may be a bit delayed. 

 

In the meantime, try to find the file that you are looking for manually on your server. Your data should not be affected by the troubles with NC docker.

Link to comment

Evening All 

 

Have a question I am not sure on the answer - I have nextcloud running, but on the overview page it tells me I am not using the most current version. I am on 17.0.7 and the latest is 17.0.10

 

Is this due to whoever keeps the docker image up to date? I have told the docker to check for updates and it cant find any. Is it just a case of me waiting for someone to update it? 

I am using linuxserver/nextcloud repo. 

 

Many Thanks 

 

Link to comment

Hi everyone.

 

I'm running linuxserver docker of nextcloud ver. 20 with NginxProxyManager and I have couple of issues. Since I've seen that some of you also use NginxProxyManager I hope someone can help or at least point me at the right direction. So the problems are:
1. I'm currently able to only access my nextcloud from domain address. http://localip:port gives error 400 which is kind of expected. But when going https://localip:port I'm automatically forwarded to my domain address. I'd like to access nextcloud also locally to benefit from LAN speed.
2. Uploading big files from browser and getting "Error when assembling chunks, status code 504". The files are actually getting uploaded, but error is still displayed. Not sure if this is because limits have been removed with NC 20 (file upload limit is not displayed in UI settings > basic settings) or my client_max_body_size is 0 in nextcloud/site-confs/default and nextcloud/nginx/nginx.conf. If I understood correctly the error 504 about chunks is because of a NC timeout limits, but I don't know where should i change these limits. I've seen people change timeout limits in php.ini files and nginx/apache files, but since I don't have them or their setup is totally different I'm not sure where and what should I change to avoid this error.

 

Config.php:

<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'instanceid',
  'passwordsalt' => '29t+passwordsalt',
  'secret' => 'secret',
  'trusted_domains' => 
  array (
    0 => '192.168.1.177:444',
    1 => 'nextcloud.my.server',
  ),
  'trusted_proxies' => 
  array (
    0 => 'NginxProxyManager',
  ),
  'dbtype' => 'mysql',
  'version' => '20.0.3.2',
  'forwarded_for_headers' => array('HTTP_X_FORWARDED_FOR'),
  'overwrite.cli.url' => 'https://192.168.1.177:444',
  'overwritehost' => 'nextcloud.my.server',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.1.177:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbuser',
  'dbpassword' => 'dbpassword',
  'installed' => true,
  'filesystem_check_changes' => 1,
  'updater.secret' => 'updater.secret',
);

NginxProxyManager/nginx/proxy_host/nextcloud.conf
 

# ------------------------------------------------------------
# nextcloud.my.server
# ------------------------------------------------------------


server {
  set $forward_scheme https;
  set $server         "192.168.1.177";
  set $port           444;

  listen 8080;
listen [::]:8080;

listen 4443 ssl http2;
listen [::]:4443;


  server_name nextcloud.my.server;


  # Let's Encrypt SSL
  include conf.d/include/letsencrypt-acme-challenge.conf;
  include conf.d/include/ssl-ciphers.conf;
  ssl_certificate /etc/letsencrypt/live/npm-5/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/npm-5/privkey.pem;






  # Block Exploits
  include conf.d/include/block-exploits.conf;






  access_log /config/log/proxy_host-5.log proxy;







  location / {

    


    # Force SSL
    include conf.d/include/force-ssl.conf;







    

    # Proxy!
    include conf.d/include/proxy.conf;
  }


  # Custom
  include /data/nginx/custom/server_proxy[.]conf;
}

 

If anyone has any ideas or need me to post any more conf files, I would appreciate very much.

Link to comment
6 hours ago, servererror said:

Hi everyone.

 

I'm running linuxserver docker of nextcloud ver. 20 with NginxProxyManager and I have couple of issues. Since I've seen that some of you also use NginxProxyManager I hope someone can help or at least point me at the right direction. So the problems are:
1. I'm currently able to only access my nextcloud from domain address. http://localip:port gives error 400 which is kind of expected. But when going https://localip:port I'm automatically forwarded to my domain address. I'd like to access nextcloud also locally to benefit from LAN speed.
2. Uploading big files from browser and getting "Error when assembling chunks, status code 504". The files are actually getting uploaded, but error is still displayed. Not sure if this is because limits have been removed with NC 20 (file upload limit is not displayed in UI settings > basic settings) or my client_max_body_size is 0 in nextcloud/site-confs/default and nextcloud/nginx/nginx.conf. If I understood correctly the error 504 about chunks is because of a NC timeout limits, but I don't know where should i change these limits. I've seen people change timeout limits in php.ini files and nginx/apache files, but since I don't have them or their setup is totally different I'm not sure where and what should I change to avoid this error.

 

Config.php:


<?php
$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'instanceid',
  'passwordsalt' => '29t+passwordsalt',
  'secret' => 'secret',
  'trusted_domains' => 
  array (
    0 => '192.168.1.177:444',
    1 => 'nextcloud.my.server',
  ),
  'trusted_proxies' => 
  array (
    0 => 'NginxProxyManager',
  ),
  'dbtype' => 'mysql',
  'version' => '20.0.3.2',
  'forwarded_for_headers' => array('HTTP_X_FORWARDED_FOR'),
  'overwrite.cli.url' => 'https://192.168.1.177:444',
  'overwritehost' => 'nextcloud.my.server',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.1.177:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbuser',
  'dbpassword' => 'dbpassword',
  'installed' => true,
  'filesystem_check_changes' => 1,
  'updater.secret' => 'updater.secret',
);

NginxProxyManager/nginx/proxy_host/nextcloud.conf
 


# ------------------------------------------------------------
# nextcloud.my.server
# ------------------------------------------------------------


server {
  set $forward_scheme https;
  set $server         "192.168.1.177";
  set $port           444;

  listen 8080;
listen [::]:8080;

listen 4443 ssl http2;
listen [::]:4443;


  server_name nextcloud.my.server;


  # Let's Encrypt SSL
  include conf.d/include/letsencrypt-acme-challenge.conf;
  include conf.d/include/ssl-ciphers.conf;
  ssl_certificate /etc/letsencrypt/live/npm-5/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/npm-5/privkey.pem;






  # Block Exploits
  include conf.d/include/block-exploits.conf;






  access_log /config/log/proxy_host-5.log proxy;







  location / {

    


    # Force SSL
    include conf.d/include/force-ssl.conf;







    

    # Proxy!
    include conf.d/include/proxy.conf;
  }


  # Custom
  include /data/nginx/custom/server_proxy[.]conf;
}

 

If anyone has any ideas or need me to post any more conf files, I would appreciate very much.

About the assembling chunks problem, i found a fix.

Go to NginxProxyManager edit your nextcloud proxy host, Go to advanced tab.

Now copy the location block from your nextcloud.conf and add the following lines:

(Set the times to your liking. I was doing some testing and had this big times. Also depends on your net speed. From my testing the time you need is time_to_upload + time_to_assemble_the_chunks, so on big uploads that needs eg. 1hour to upload you need like 1hour and 5 minutes timeout).

proxy_connect_timeout 1d;
proxy_send_timeout 1d;
proxy_read_timeout 1d;
send_timeout 1d;

 

The pasted conf on your advanced tab should be like this:

location / {

    proxy_connect_timeout 1d;
proxy_send_timeout 1d;
proxy_read_timeout 1d;
send_timeout 1d;
    


    # Force SSL
    include conf.d/include/force-ssl.conf;







    

    # Proxy!
    include conf.d/include/proxy.conf;
  }


  # Custom
  include /data/nginx/custom/server_proxy[.]conf;
}


 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.