Jump to content
binhex

[Support] binhex - Radarr

189 posts in this topic Last Reply

Recommended Posts

My apologies. I never looked at what I'd actually changed the docker paths to and just looked at the docker summary 🙄

 

So it is as follows....

 

Deluge Container:

/downloads  ---> /mnt/user/downloads/

In Deluge pref:

Download to: /downloads/incomplete

Completed: /downloads/completed

 

Plugin Extractor: /Plex

Plex folder has a mapped drive as follows...

/Plex ---> /mnt/user/Plex/

 

Radarr:

/downloads ---> /mnt/user/downloads/

/Media ---> /mnt/user/Plex/

/Plex ---> /mnt/user/Plex/

 

All I want to know is how to get Radarr to deal with extracting RAR files and process the output?

I can get the extractor plugin for Deluge to extract to the Plex folder but the file is not edited to the correct name format radarr

will do with non-rared files

 

Any suggestions please?

Share this post


Link to post
23 minutes ago, Lien1454 said:

Any suggestions please?

I set my extractor plugin to extract to completed with the create a sub folder option enabled. Radarr doesn’t have any trouble processing the file if it’s still in the completed path.

Share this post


Link to post

TOPIC: Running this docker on a static IP and changing the listen address to port 80.

 

I would like to be able to use DNS to resolve my dockers on separate IPs.  So instead of http://rrl-nas.contoso.com:7878/ for radarr, I'd like a clean URL of http://radarr.contoso.com/

 

I thought I had this figured out when playing with OwnCloud, but I don't have the whole picture.  Nothing I try seems to move the listen port from 7878 to 80.  I tried settings in the UnRAID Docker UI as well as googling and trying to directly modify the config.v2.json file to change the exported port from 7878 to 80.

Nothing works.

What am I doing wrong?
 

Share this post


Link to post

So after I deleted all of my movies physically off the disk. Radarr still reports all of movies as downloaded and not missing. Is there a way to move all the movies to missing so I can get back to downloading them. 

Share this post


Link to post
1 hour ago, Shin Zearim said:

So after I deleted all of my movies physically off the disk. Radarr still reports all of movies as downloaded and not missing. Is there a way to move all the movies to missing so I can get back to downloading them. 

I haven’t tested this, but running “Update Library” should do it.

Share this post


Link to post
3 minutes ago, wgstarks said:

I haven’t tested this, but running “Update Library” should do it.

Thank you for the help, I hit that button many times but nothing changed. What I did learn from other users when they had a data loss, is to change static paths from yes to no. Radarr immediately flagged the movies to missing. I am in the middle of rebuilding my movie library now though it will take a week or two to complete everything. 

Share this post


Link to post

2 questions about Radarr ( and Sonarr for that matter)

 

 

1. Would more available RAM or More Processor Power be better for the unpacking and processing of the files?

 

2. What setting is it that determines how often the Monitored movies/series are check for a "better" copy according to your profiles

 

 

thanks in advance

Share this post


Link to post
9 hours ago, Twitchstick said:

How do I install a second instance for 4k movies?

no need just make sub-folder and direct your 4K movies to that folder. 

 

i have all my media separated out like this  media-> ABC-> Movie Folder

 

i just created another folder called 4K and place the movie there

 

Share this post


Link to post
12 minutes ago, 08deanr said:

no need just make sub-folder and direct your 4K movies to that folder. 

 

i have all my media separated out like this  media-> ABC-> Movie Folder

 

i just created another folder called 4K and place the movie there

 

I've done similar - I've shared several folders to the docker and they show up as choices when adding/scanning - "SD", "HD", "Shorts", etc.

Share this post


Link to post
On 6/14/2017 at 12:24 PM, Bluecube said:

17-6-14 17:00:01.4|Error|TaskExtensions|Task Error

[v0.2.0.696] System.Data.SQLite.SQLiteException (0x80004005): database disk image is malformed
database disk image is malformed
  at System.Data.SQLite.SQLite3.Reset (System.Data.SQLite.SQLiteStatement stmt) [0x00083] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at System.Data.SQLite.SQLite3.Step (System.Data.SQLite.SQLiteStatement stmt) [0x0003c] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at System.Data.SQLite.SQLiteDataReader.NextResult () [0x0016b] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at System.Data.SQLite.SQLiteDataReader..ctor (System.Data.SQLite.SQLiteCommand cmd, System.Data.CommandBehavior behave) [0x00090] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteDataReader:.ctor (System.Data.SQLite.SQLiteCommand,System.Data.CommandBehavior)
  at System.Data.SQLite.SQLiteCommand.ExecuteReader (System.Data.CommandBehavior behavior) [0x0000c] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at System.Data.SQLite.SQLiteCommand.ExecuteScalar (System.Data.CommandBehavior behavior) [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at System.Data.SQLite.SQLiteCommand.ExecuteScalar () [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0 
  at Marr.Data.QGen.InsertQueryBuilder`1[T].Execute () [0x00046] in C:\projects\radarr-usby1\src\Marr.Data\QGen\InsertQueryBuilder.cs:140 
  at Marr.Data.DataMapper.Insert[T] (T entity) [0x0005d] in C:\projects\radarr-usby1\src\Marr.Data\DataMapper.cs:728 
  at NzbDrone.Core.Datastore.BasicRepository`1[TModel].Insert (TModel model) [0x0002d] in C:\projects\radarr-usby1\src\NzbDrone.Core\Datastore\BasicRepository.cs:111 
  at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push[TCommand] (TCommand command, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x0013d] in C:\projects\radarr-usby1\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:82 
  at (wrapper dynamic-method) System.Object:CallSite.Target (System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandQueueManager,object,NzbDrone.Core.Messaging.Commands.CommandPriority,NzbDrone.Core.Messaging.Commands.CommandTrigger)
  at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push (System.String commandName, System.Nullable`1[T] lastExecutionTime, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x000b7] in C:\projects\radarr-usby1\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:95 
  at NzbDrone.Core.Jobs.Scheduler.ExecuteCommands () [0x00043] in C:\projects\radarr-usby1\src\NzbDrone.Core\Jobs\Scheduler.cs:42 
  at System.Threading.Tasks.Task.InnerInvoke () [0x0000f] in <a07d6bf484a54da2861691df910339b1>:0 
  at System.Threading.Tasks.Task.Execute () [0x00010] in <a07d6bf484a54da2861691df910339b1>:0 

Hmmm... A malformed database. Think a reinstall would fix that?

 

I get the same error above almost every day and have to do a database recovery or i'll completely remove the data within appdata and reinstall it an about 2 hours later the same issue can anyone help me with this?

 

all my hdd's are perfectly fine with no error's

 

 

Share this post


Link to post

@Ladrek you are most likely getting the long standing unraid bug where certain docker containers are not compatible with FUSE and this causes corruption, see link below for more details and the fix (this is for sonarr, but radarr is a fork and thus has the same issue):-

 

https://forums.unraid.net/topic/44145-support-binhex-sonarr/?do=findComment&amp;comment=714497

 

Share this post


Link to post
Just now, binhex said:

@Ladrek you are most likely getting the long standing unraid bug where certain docker containers are not compatible with FUSE and this causes corruption, see link below for more details and the fix (this is for sonarr, but radarr is a fork and thus has the same issue):-

 

https://forums.unraid.net/topic/44145-support-binhex-sonarr/?do=findComment&amp;comment=714497

 

do i need to do a fresh install or radarr?

Share this post


Link to post
9 minutes ago, Ladrek said:

do i need to do a fresh install or radarr?

i would if i were you, you have a corrupt database, so thats not a great starting position.

Share this post


Link to post
Posted (edited)
3 hours ago, binhex said:

i would if i were you, you have a corrupt database, so thats not a great starting position.

alright i will give that ago then

 

Edit: This fixed the issue & also fixed my plex issue as well lol

Edited by Ladrek

Share this post


Link to post
Posted (edited)

New install of  Binhex sabnzbdvpn and Radarr.  Tested with Sabconnect Chrome addon from workstation successfully.  

(Followed SpaceInvader Tutorial)

Network Type Bridge

VPN On

PIA

Privoxy Off

I'm in a 192.168.1.0/24 environment

 

From Binhex Radarr 

Settings -> Download Client

Add Sabnzbd

Host = ip address of Unraid Server, 8080, api key, user, PW all checked and rechecked

Test was aborted due to an error

The IP address field is highlighted during error.

 

Any suggestions on how I can start enjoying these dockers :D

 

Edit 3-24   I found the logs, and attached them.  

 

There is definitely a related error showing up

2019-03-24 08:38:31,072 DEBG 'radarr' stdout output:
[Error] Sabnzbd: Unable to connect to SABnzbd, please check your settings 

[v0.2.0.1293] NzbDrone.Core.Download.Clients.DownloadClientException: Unable to connect to SABnzbd, please check your settings ---> System.Net.WebException: Error getting response stream (ReadDoneAsync2): ReceiveFailure
  at System.Net.WebResponseStream.InitReadAsync (System.Threading.CancellationToken cancellationToken) [0x000e6] in /build/mono/src/mono/mcs/class/System/System.Net/WebResponseStream.cs:446 
  at System.Net.WebOperation.Run () [0x0018f] in /build/mono/src/mono/mcs/class/System/System.Net/WebOperation.cs:283 
  at System.Net.WebCompletionSource`1[T].WaitForCompletion () [0x0008e] in /build/mono/src/mono/mcs/class/System/System.Net/WebCompletionSource.cs:111 
  at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task`1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func`1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000e8] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:956 
  at System.Net.HttpWebRequest.GetResponse () [0x0000f] in /build/mono/src/mono/mcs/class/System/System.Net/HttpWebRequest.cs:1218 
  at NzbDrone.Common.Http.Dispatchers.ManagedHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x0012f] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\ManagedHttpDispatcher.cs:78 
  at NzbDrone.Common.Http.Dispatchers.FallbackHttpDispatcher.GetResponse (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookies) [0x000cc] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\Dispatchers\FallbackHttpDispatcher.cs:58 
  at NzbDrone.Common.Http.HttpClient.ExecuteRequest (NzbDrone.Common.Http.HttpRequest request, System.Net.CookieContainer cookieContainer) [0x0007e] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:114 
  at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00008] in C:\projects\radarr-usby1\src\NzbDrone.Common\Http\HttpClient.cs:50 
  at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.ProcessRequest (NzbDrone.Common.Http.HttpRequestBuilder requestBuilder, NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdSettings settings) [0x0001d] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:178 
   --- End of inner exception stack trace ---
  at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.ProcessRequest (NzbDrone.Common.Http.HttpRequestBuilder requestBuilder, NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdSettings settings) [0x0003a] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:186 
  at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.GetVersion (NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdSettings settings) [0x0000d] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:71 
  at NzbDrone.Core.Download.Clients.Sabnzbd.Sabnzbd.TestConnectionAndVersion () [0x00000] in C:\projects\radarr-usby1\src\NzbDrone.Core\Download\Clients\Sabnzbd\Sabnzbd.cs:362 

 

 

RADARR supervisord.log

Sab supervisord.log

Edited by BeerEngineer
Added Logs

Share this post


Link to post

After doing more testing today, Eventually I tried using MS Edge Internet Browser instead of Chrome when I saw the the fields in the Client Downloader and Index add setting appeared to be scrambling my entries on save and fail.

 

It worked with MS Edge...  Could google auto complete be injecting some garbage in there?  I hate to speculate, but it's a weird issue.

Share this post


Link to post
Posted (edited)

I'm having trouble editing or adding profiles in Radarr. When I go to edit an existing profile or add a new one, it lets me do everything up until I hit "Save". Once I hit "Save" it just spins for a second and then nothing happens.

 

I'm not having this issue in Sonarr.

 

Not seeing anything in the Logs for errors and version is up to date. It's a new install, so idk if it was working before the update or not.

 

Edit: idk if it's related, but I also can't add Trakt Lists

 

Edit2: Testing further, I've isolated it a bit. It only happens when accessing Radarr through my subdomain. If I access it directly through the port it works fine... I used the default config file from let's encrypt. 

Edited by leftovernick
Added info

Share this post


Link to post

I've been having trouble updating my Radarr image from the GUI.  The logs fail with this error: "Error occurred while executing task ApplicationUpdate: Error: SecureChannelFailure (The authentication or decryption has failed.)"

 

Please let me know either what additional info is needed or how to manually update the package.

 

Thank you very much!

Share this post


Link to post

Had an out of control Radarr docker tonight, three instances of mono at 164%+ cpu. 

First is the first few lines of top then second is the ps of the mono processes. Anything I should investigate?

Only been running Radarr for about a week after getting sick of Couchpotato. 

The docker page eventually responded and I stopped Radarr and everything has gone back to normal, for now. 

 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
  833 nobody    20   0 2512020 849136    208 R 164.9   5.3  12929:11 mono
26250 nobody    20   0 3116308   1.3g    216 R 164.9   8.4  14097:29 mono
 8833 nobody    20   0 2301536 206876     56 S 164.2   1.3  14027:21 mono
 4305 root       0 -20       0      0      0 D   9.9   0.0   6:47.54 loop2
  700 root      20   0       0      0      0 S   6.3   0.0  28:37.32 kswapd0
11003 root      20   0  229556  23348  18896 S   2.3   0.1   0:00.07 php
21251 root      20   0       0      0      0 I   2.3   0.0   0:03.55 kworker/u16:8-btrfs-endio
 2375 root      20   0       0      0      0 I   1.7   0.0   0:03.11 kworker/u16:1-btrfs-endio

 

nobody     833  150  5.2 2512020 849136 ?      Sl   Apr13 12929:32 /usr/sbin/mono --debug /usr/lib/radarr/Radarr.exe /data=/config /nobrowser /restart
nobody     880  0.4  3.8 3259644 624176 ?      Ssl  Apr14  40:02 mono --debug NzbDrone.exe -nobrowser -data=/config
nobody    8833  162  1.2 2301536 206876 ?      Rl   Apr13 14027:43 /usr/sbin/mono --debug /usr/lib/radarr/Radarr.exe /data=/config /nobrowser /restart
root     11016  0.0  0.0   5712  2040 pts/0    S+   20:06   0:00 grep mono
nobody   18319  0.5  3.2 2769340 522740 ?      Dl   Apr14  44:03 /usr/sbin/mono --debug /usr/lib/radarr/Radarr.exe /data=/config /nobrowser /restart
nobody   26250  160  8.4 3116308 1359656 ?     Rl   Apr13 14097:50 /usr/bin/mono --debug /usr/lib/radarr/Radarr.exe -nobrowser -data=/config

 

 

Share this post


Link to post
Posted (edited)

I keep getting 'Error occurred while executing task MessagingCleanup: database disk image is malformed database disk image is malformed'

I even do a fresh install and still the same issue about 15 mins later it's on a SSD

 

Capture.thumb.PNG.21d580cf8e8153895a0dcbebb99cb6bc.PNG

 

Capture.PNG

Edited by Ladrek

Share this post


Link to post
On 4/20/2019 at 3:41 AM, sol said:

Had an out of control Radarr docker tonight, three instances of mono at 164%+ cpu. 

First is the first few lines of top then second is the ps of the mono processes. Anything I should investigate?

Only been running Radarr for about a week after getting sick of Couchpotato. 

The docker page eventually responded and I stopped Radarr and everything has gone back to normal, for now. 

 

 

So I don't run Radarr (yet), but someone using the Linuxserver.io image mentioned something vaguely similar, at least with abnormally high CPU usage: 

 

Share this post


Link to post
7 hours ago, Ladrek said:

I keep getting 'Error occurred while executing task MessagingCleanup: database disk image is malformed database disk image is malformed'

I even do a fresh install and still the same issue about 15 mins later it's on a SSD

 

Capture.thumb.PNG.21d580cf8e8153895a0dcbebb99cb6bc.PNG

 

Capture.PNG

i bet you are suffering the infamous FUSE bug, see Q16. in the following link:-

https://forums.unraid.net/topic/44108-support-binhex-general/?tab=comments#comment-433612

 

Share this post


Link to post
On 4/25/2019 at 8:08 PM, Ladrek said:

i've done that already

anyone?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.