Preclear plugin


3042 posts in this topic Last Reply

Recommended Posts

  • Replies 3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi guys, this is a simple plugin that allows users to clear their disks before add them to the array.   The main characteristics of this plugin are: Modularity: can be used standalon

I think Thanks should be directed at all those members that have been dealing with the mess the last few months. @dlandon and @Squid have been working behind the scenes to try and clean up, and o

Dontlookoverthere over on the unRAID subreddit figured out how to get the plugin running again with a simple edit to the plg:   https://www.reddit.com/r/unRAID/comments/7wjpus/preclear_worki

Posted Images

I ssh'd into the box and took a look at the preclear log and found this:

 

grep: /boot/config/disk.cfg: No such file or directory

 

So I went into Tools -> New Config she's running smoothly now 8)

I forgot about that.  That one got me too.

Link to post

I am running the preclear beta plugin v2016.03.24a (installed via Apps plugin) on unraid 6.2b21.  I am not seeing SMART results from preclears.  I got the same thing on 3 drives so far.  Using the non-beta plugin on the same setup i did see SMART status, although obviously not in the same format. See below ....

 

Any ideas?

 

############################################################################################################################
#                                                                                                                          #
#                                        unRAID Server Pre-Clear of disk /dev/sdg                                          #
#                                        Cycle 4 of 4, partition start on sector 64.                                       #
#                                                                                                                          #
#                                                                                                                          #
#   Step 1 of 5 - Pre-read verification:                                                    [1:25:17 @ 97 MB/s] SUCCESS    #
#   Step 2 of 5 - Zeroing the disk:                                                        [1:14:51 @ 111 MB/s] SUCCESS    #
#   Step 3 of 5 - Writing unRAID's Preclear signature:                                                          SUCCESS    #
#   Step 4 of 5 - Verifying unRAID's Preclear signature:                                                        SUCCESS    #
#   Step 5 of 5 - Post-Read in progress:                                                                     (30% Done)    #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#   ** Time elapsed: 0:23:04 | Current speed: 132 MB/s | Average speed: 111 MB/s                                           #
#                                                                                                                          #
############################################################################################################################
#                                  Cycle elapsed time: 3:03:55 | Total elapsed time: 15:26:22                              #
############################################################################################################################


############################################################################################################################
#                                                                                                                          #
#                                                   S.M.A.R.T. Status                                                      #
#                                                                                                                          #
#                                                                                                                          #
#   ATTRIBUTE  INITIAL  CYCLE 1  CYCLE 2  CYCLE 3  STATUS                                                                  #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
#                                                                                                                          #
############################################################################################################################
#   SMART Health Status: OK                                                                                                #
###########################################################################################################################?

Link to post

I am running the preclear beta plugin v2016.03.24a (installed via Apps plugin) on unraid 6.2b21.  I am not seeing SMART results from preclears.  I got the same thing on 3 drives so far.  Using the non-beta plugin on the same setup i did see SMART status, although obviously not in the same format. See below ....

 

Any ideas?

Some controllers don't pass SMART data back, or require special parameters to do it.  Can you get a SMART report from *any* drive on that controller, using any method?

Link to post

 

 

Some controllers don't pass SMART data back, or require special parameters to do it.  Can you get a SMART report from *any* drive on that controller, using any method?

 

Yes I can get  SMART reports from the dashboard when I click the green thumbs up icon. And the non-beta script showed it when I cleared a drive with that.

 

Link to post

Hi guys, I've been using the beta version of this plug-in for the last couple of weeks on beta 21 and noticed some issues.

 

1) A few of my drives had smart disabled (not sure why, I also posted this in the unraid beta thread) After manually turning smart on everything worked well. I think it would be great if this plug-in could check whether smart is disabled and enable it as necessary.

 

2. Preclear reports are not tagged with the date in the filename so the reports for the same drives get overwritten with multiple preclears. It would be nice to be able to see the preclear history on the drives.

 

3. This new (used) drive I added had smart turned on, all attributes and capabilities can be viewed in unraid, but when I run the preclear the script does not get or show any smart data. Is there any log I can provide? Here's the preclear log: http://pastebin.com/VEBg2mnV

 

Thanks

 

Link to post

Preclear Beta 2016.03.24a : Getting this on console screen after reboot with new disk to be precleared yet... Not sure if presense of new disk is related but thought I would mention it. I recently uninstalled preclear and installed the beta in anticipation of new disk. The message is repeated twice. Disk is connected to SATA3 on mobo.

 

basename: missing operand
Link to post

I'm using the latest beta (available from cuommunity apps).  It all seems to working but the log file looks a bit messy.

 

Cycle elapsed time: 1:47:29 | Total elapsed time: 1:47:30
tput: unknown terminal "screen"
S.M.A.R.T. Status
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
SMART overall-health self-assessment test result: PASSED
tput: unknown terminal "screen"
?
tput: unknown terminal "screen"
tput: unknown terminal "screen"

tput: unknown terminal "screen"
unRAID Server Pre-Clear of disk /dev/sdc
tput: unknown terminal "screen"
Cycle 1 of 1, partition start on sector 64.
tput: unknown terminal "screen"

tput: unknown terminal "screen"
tput: unknown terminal "screen"
(25% Done)
tput: unknown terminal "screen"
tput: unknown terminal "screen"
Cycle elapsed time: 1:47:40 | Total elapsed time: 1:47:41
tput: unknown terminal "screen"
S.M.A.R.T. Status
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
SMART overall-health self-assessment test result: PASSED
tput: unknown terminal "screen"
?
tput: unknown terminal "screen"

 

repeated over and over

Link to post

I got this running the beta plugin so ended up uninstalling. There's still something not right though as i'm now seeing multiple log file entries every few seconds whereas i used to just have one entry which updated on screen when you viewed the logfile. I think this has something to do with losing my web connection each and every time i try to preclear an 8TB drive. I've run the preclear multiple times and still dont have any report to say if its good or bad. Just going to put it into service.

 

Sent from my LG-D855 using Tapatalk

 

 

Link to post

When I click start preclear nothing happens. I do not get a popup for settings. I've tried in two browsers.

 

This is what debug log is saying.

root@Dirge:/var/log# tail preclear.disk.beta.log                                                                                                                             
+ /dev/disk/by-id/ata-ST3000VN000-1HJ166_W6A04BCR
+ /dev/disk/by-id/ata-ST3750330AS_3QK01S20
+ /dev/disk/by-id/usb-Kingston_DataTraveler_2.0_5B870A00004F-0:0
Sun May 22 22:17:03 MDT 2016: get_info(/dev/disk/by-id/ata-WDC_WD30EZRX-00MMMB0_WD-WCAWZ1860188): 0
Sun May 22 22:17:03 MDT 2016: get_temp(/dev/disk/by-id/ata-WDC_WD30EZRX-00MMMB0_WD-WCAWZ1860188):0
Sun May 22 22:17:03 MDT 2016: Finished get_all_disks_info: 0
Sun May 22 22:17:03 MDT 2016: my_temp: 0
Sun May 22 22:17:03 MDT 2016: Starting get preclear status: 0
Sun May 22 22:17:03 MDT 2016: finished get preclear status: 0
Sun May 22 22:17:03 MDT 2016: get_content Finished: 0

 

ata-WDC_WD30EZRX-00MMMB0_WD-WCAWZ1860188 is the disk that requires the preclear.

 

Link to post
  • 3 weeks later...

I'm using the latest beta (available from cuommunity apps).  It all seems to working but the log file looks a bit messy.

 

Cycle elapsed time: 1:47:29 | Total elapsed time: 1:47:30
tput: unknown terminal "screen"
S.M.A.R.T. Status
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
SMART overall-health self-assessment test result: PASSED
tput: unknown terminal "screen"
?
tput: unknown terminal "screen"
tput: unknown terminal "screen"

tput: unknown terminal "screen"
unRAID Server Pre-Clear of disk /dev/sdc
tput: unknown terminal "screen"
Cycle 1 of 1, partition start on sector 64.
tput: unknown terminal "screen"

tput: unknown terminal "screen"
tput: unknown terminal "screen"
(25% Done)
tput: unknown terminal "screen"
tput: unknown terminal "screen"
Cycle elapsed time: 1:47:40 | Total elapsed time: 1:47:41
tput: unknown terminal "screen"
S.M.A.R.T. Status
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
tput: unknown terminal "screen"
SMART overall-health self-assessment test result: PASSED
tput: unknown terminal "screen"
?
tput: unknown terminal "screen"

 

repeated over and over

 

Just experienced the same with the beta and very little by way of a report after the 5 runs.  Think I will stick with the regular script from Joe and screen without messing around with plugins.

Link to post

Now running two 8tb preclears on my main and testrig (one on each), the preclear seems to work fine.

 

It would be nice if there were some kind of identifier wrt the name or ip of the server in the launched window, with two servers on the network its not visible which window is for which unraid system..

Link to post

Running 6.2b23 and I keep getting the device busy error.  I've installed the beta plugin as well as edited preclear_disk.sh with the following command:

 

sed -i -e "s/print \$8 /print \$9 /" -e "s/sfdisk -R /blockdev --rereadpt /" preclear_disk.sh

 

What am I missing?

Link to post

Running 6.2b23 and I keep getting the device busy error.  I've installed the beta plugin as well as edited preclear_disk.sh with the following command:

 

sed -i -e "s/print \$8 /print \$9 /" -e "s/sfdisk -R /blockdev --rereadpt /" preclear_disk.sh

 

What am I missing?

 

You are not the only one. I am another person who would like a complete explanation of both Preclear Disk Plugin and Preclear Disk Beta Plugin and their dependencies on one coherent post. 

 

With regard to the code for the preclear_disk.sh script, I have actually seen TWO versions of this simple command line.  Here is the other one:

 

sed -i -e "s/print \$9 /print \$8 /" -e "s/sfdisk -R /blockdev --rereadpt /" preclear_disk.sh

 

($8 and $9 are in a different order) 

 

It would be nice if someone could clarify all of this in a simple post and have some direct link to it so that one is not force to search through a 48+ page thread to try to find it! 

Link to post

It's confusing because of the many versions and because the original plugin is just a front-end for the scrip while the beta plugin is stand-alone:

 

Working with v6.2-beta:

Edited original Preclear script (command line only)

Edited unofficial faster Preclear script (command line only)

Preclear plugin with either of the edited(*) scripts

Stand-alone beta Preclear plugin

 

* When editing the script don't forget that the plugin uses the script located in /boot/config/plugins/preclear.disk/ directory.

Link to post

It's confusing because of the many versions and because the original plugin is just a front-end for the scrip while the beta plugin is stand-alone:

 

Working with v6.2-beta:

Edited original Preclear script (command line only)

Edited unofficial faster Preclear script (command line only)

Preclear plugin with either of the edited(*) scripts

Stand-alone beta Preclear plugin

 

* When editing the script don't forget that the plugin uses the script located in /boot/config/plugins/preclear.disk/ directory.

 

johnnie.black ----  First, thanks for your reply!  After reading this, am I correct in assuming that if I install the Preclear Disk Beta in a server running 6.2-beta from here:

 

          http://lime-technology.com/forum/index.php?topic=39985.510

 

That I don't need to install the preclear_disk.sh script?  The reason that I am asking is that the disk I was using to test the Preclear plugins is now my second parity disk in my Test Bed server and I don't have a disk to experiment with at the present time. 

Link to post

johnnie.black ----  First, thanks for your reply!  After reading this, am I correct in assuming that if I install the Preclear Disk Beta in a server running 6.2-beta from here:

 

          http://lime-technology.com/forum/index.php?topic=39985.510

 

That I don't need to install the preclear_disk.sh script?  The reason that I am asking is that the disk I was using to test the Preclear plugins is now my second parity disk in my Test Bed server and I don't have a disk to experiment with at the present time.

 

Correct, the beta plugin is stand-alone.

Link to post

johnnie.black ----  First, thanks for your reply!  After reading this, am I correct in assuming that if I install the Preclear Disk Beta in a server running 6.2-beta from here:

 

          http://lime-technology.com/forum/index.php?topic=39985.510

 

That I don't need to install the preclear_disk.sh script?  The reason that I am asking is that the disk I was using to test the Preclear plugins is now my second parity disk in my Test Bed server and I don't have a disk to experiment with at the present time.

 

Correct, the beta plugin is stand-alone.

Thanks Johnnie that clears everything up.

 

Quick question on the preclear script settings.  If running multiple cycles on a disk,  what's the best/fastest setting with regard the skip pre/post read options?

Link to post
  • trurl featured, unfeatured and pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.