[Support] Linuxserver.io - Duplicati


348 posts in this topic Last Reply

Recommended Posts

I guess the way to tell if this is a bug in unraid or a bug in duplicati would be to set up an SMB share and send huge amounts of data to it and see if it locks up. I'm not sure how to try that out- I have a share set up already, just need another docker that will send loads of data to it. Any ideas?

Link to post
  • 2 weeks later...
  • Replies 347
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi Guys. I have made a video about setting up and configuring Duplicati on unRAID for cloud and network backups.  

Application Name: Duplicati Application Site: https://www.duplicati.com/ Docker Hub: https://hub.docker.com/r/linuxserver/duplicati/ Github: https://github.com/linuxserver/docker-duplic

Not sure if this is the issue you're having but it has to do with existing session data at least in the x64 version of Duplicati.   When in the web UI, for Chrome, right click "inspect" go t

Posted Images

On 12/28/2018 at 4:03 PM, jj_uk said:

Today, I added a SMB share, mounted into the unassigned devices plugin and started backing up to that.

The share is on another unraid server on the LAN. The share is mounted as Read/Write/Slave, and the a username/password is used to log into the share.

 

When the backup is run (manually at this point), after about 5 mins, 2 CPU cores lock at 100% and duplicati stops working. I cannot stop the docker, the only exit is to do a hard reset of the server.

This exact same thing consistently happens to me. Basically I can't backup my pictures folder into a SMB share - locks the Duplicati docker and then the whole server.

Link to post
1 hour ago, jj_uk said:

Are you able to use krusader to backup the same photos to the smb share as a test?

 

If that also fails then it's an unraid issue, otherwise it's duplicati.  

I will try that, but I believe there's already an issue with unraid because a docker should never bring the server down.

Link to post

Hi

 

I am testing this docker now and although everything seems to be working fine there is one issue. I have set it to backup a small folder every three hours and to keep the last 10 backups.

After about 24 hours I see that it have backed up every three hours from the log (or at least it seems like it), but there is only the first version. 

 

Any ideas?

 

 

Link to post

Hi,

I'm trying to backup to a mounted unassigned device formatted with xfs. I can't seem to find the path to browse to the disk and if I manually enter the path I get an error:  /mnt/disk/ access is denied. Any idea what I'm doing wrong here?

 

Thanks in advance.

Edited by rpowers
Link to post
Hi,
I'm trying to backup to a mounted unassigned device formatted with xfs. I can't seem to find the path to browse to the disk and if I manually enter the path I get an error:  /mnt/disk/ access is denied. Any idea what I'm doing wrong here?
 
Thanks in advance.
I believe /mnt/disks/nameofdrive

Sent from my Pixel 2 XL using Tapatalk

Link to post
I manually enter the /mnt/disks/nameofdrive but the error returns Access to the path "/mnt/disks" is denied. I should also say that the first message is a create folder: The folder /mnt/disks/nameofdrive does not exist. Create it now?
Does it work with on the main screen? That's how I did it.

Sent from my Pixel 2 XL using Tapatalk

Link to post
Just now, rpowers said:

Hi,

Yes, I can click on that and it will pop up and I can see the folders I have created but when I use that path in duplicati I get the error message.

Last thing before out of options. Can you use Krusader? If so can you navigate to that through there?

Link to post
On 1/11/2019 at 11:54 PM, makutaku said:

This exact same thing consistently happens to me. Basically I can't backup my pictures folder into a SMB share - locks the Duplicati docker and then the whole server.

On 12/29/2018 at 11:18 AM, jj_uk said:

I guess the way to tell if this is a bug in unraid or a bug in duplicati would be to set up an SMB share and send huge amounts of data to it and see if it locks up. I'm not sure how to try that out- I have a share set up already, just need another docker that will send loads of data to it. Any ideas?

I'm having the exact same problem. Created an SMB share on my backup server. Did a fresh install of Duplicati. When backup starts it soon locks up and 2 CPU cores are pegged at 100%. I can't stop or even kill duplicati when this happens. I can't shut down/reboot as the server is never able to stop the docker service. It's kind of crazy. I've already had to hard reset once (ouch), but i tried again and it happened again right away.

 

is anyone else using SMB shares and not having this problem?

 

Edit: I copied 6 gigs (2000+ files) to the SMB share using Krusader and it copied just fine. Definitely looks to be a Duplicati issue.

Edited by Kewjoe
Link to post
  • 2 weeks later...
On 1/22/2019 at 6:44 AM, Kewjoe said:

I'm having the exact same problem. Created an SMB share on my backup server. Did a fresh install of Duplicati. When backup starts it soon locks up and 2 CPU cores are pegged at 100%. I can't stop or even kill duplicati when this happens. I can't shut down/reboot as the server is never able to stop the docker service. It's kind of crazy. I've already had to hard reset once (ouch), but i tried again and it happened again right away.

 

Edit: I copied 6 gigs (2000+ files) to the SMB share using Krusader and it copied just fine. Definitely looks to be a Duplicati issue.

 

My workaround was to run FTP server pointing to the SMB share disk. Then duplicati backs up via FTP.

Link to post
  • 2 weeks later...

Error: Detected non-empty blocksets with no associated blocks!

 

Anyone else get this error? It happens with one of my backups which runs fine the first couple of times but inevitably gives me this error after a couple days. I see others getting this error on their forums but no fix. Does anyone here have any suggestions?

 

Thanks in advance,

 

Ryan.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.