[Support] binhex - Jackett


binhex

258 posts in this topic Last Reply

Recommended Posts

  • Replies 257
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

im on it guys, looks like there has been a switch to .net core which requires changes to the code which ive now done, new image now building

I pushed my luck a bit more as i got a little friendly with one of the dev's on Jackett and mentioned him in another one of my open enhancements, this one is to automatically disable index sites when

@cybrnook

Posted Images

1 hour ago, renocz said:

Hi, i posted a solution for that on the linuxserver.io - Jackett thread

I think it should solve your issue ;) 

I kown but I don’t see any of these settings in Jackett configuration.

 

So I’ll wait the next docker update

Edited by thymon
Link to post
  • 1 month later...

I have posted some of this info in a reply in the delugevpn thread, but I think it really belongs here.

 

 I find that the Jacket rarbg fetcher sometimes fetches a 1.3kB file containing html which says something about enabling cookies, instead of the legitimate torrent file of around 80kB.  I'm still struggling with this.  Resetting the configuration of the rarbg fetcher in Jacket seems to make it work once, then the next time it fails again. 

 

In case it makes a difference, I'm using Jacket with CouchPotato.

 

Has anyone else encountered this or, better, found a solution.

 

I've never had any success with the 1337 or isohunt fetchers.

Link to post
4 minutes ago, PeterB said:

I have posted some of this info in a reply in the delugevpn thread, but I think it really belongs here.

 

 I find that the Jacket rarbg fetcher sometimes fetches a 1.3kB file containing html which says something about enabling cookies, instead of the legitimate torrent file of around 80kB.  I'm still struggling with this.  Resetting the configuration of the rarbg fetcher in Jacket seems to make it work once, then the next time it fails again. 

 

In case it makes a difference, I'm using Jacket with CouchPotato.

 

Has anyone else encountered this or, better, found a solution.

 

I've never had any success with the 1337 or isohunt fetchers.

Look a few posts up RE: Flaresolver 

Link to post
On 12/10/2020 at 8:36 AM, xxDeadbolt said:

Has the magdl.com indexer disappeared for anyone else? Had this set up but seems to have gone after a recent update, I think. Trying to track back to find out exactly when but no joy so far

Had forgotten about this for a while, but it seems the site maintainer requested the removal, in case anyone was wondering or had the same issue.

Link to post
  • 4 weeks later...

Anyone having issues accessing the gui? Seems to have just been today for me. Logs look fine, just can't access gui & Radarr/Sonarr both say indexers down. This is Jackett log:

 

2021-02-25 12:24:57,088 DEBG 'jackett' stdout output:
02-25 12:24:57 Info Jackett startup finished in 2.346 s

2021-02-25 12:24:57,088 DEBG 'jackett' stdout output:
Hosting environment: Production
Content root path: /usr/lib/jackett/Content
Now listening on: http://[::]:9117
Application started. Press Ctrl+C to shut down.

 

Radarr/Sonarr just show a 503:ServiceUnavailable message.

Link to post
41 minutes ago, xxDeadbolt said:

Anyone having issues accessing the gui? Seems to have just been today for me. Logs look fine, just can't access gui & Radarr/Sonarr both say indexers down. This is Jackett log:

 


2021-02-25 12:24:57,088 DEBG 'jackett' stdout output:
02-25 12:24:57 Info Jackett startup finished in 2.346 s

2021-02-25 12:24:57,088 DEBG 'jackett' stdout output:
Hosting environment: Production
Content root path: /usr/lib/jackett/Content
Now listening on: http://[::]:9117
Application started. Press Ctrl+C to shut down.

 

Radarr/Sonarr just show a 503:ServiceUnavailable message.

are you by any chance routing jackett through another container?

Link to post
21 minutes ago, xxDeadbolt said:

Yup, routing it through your rTorrentvpn container. 

ok, due to tightening of iptable rules you will need to add the web ui port for jackett to the ADDITIONAL_PORTS env var defined for rtorrentvpn.

Link to post

Awesome, sorted! I assume this is the case, but just to double check: am I ok to delete the manual key I created for jackett to run through it, now that it's in the additional_ports?

 

image.png.2f157f6a31ff0b34d59e4a737fe270fd.png
 

 

Edit: Oops, tried it and it broke again. Sorted once I added it back 🤣

 

Cheers binhex!

Edited by xxDeadbolt
Link to post
2 minutes ago, xxDeadbolt said:

Strange, all my indexers are failing now 😕

after adding in the ports this will cause the vpn container to restart, and because the networks are links you will now also need to restart any other containers routed through the vpn container, which in your case is jackett.

Link to post

Think it's fixed now - for some reason, I had the proxy settings set to use the rTorrent/privoxy port 8118 in my jackett settings. I removed that, since it's routing through the container anyway and it's fine now.

Cheers again!

Link to post
Just now, xxDeadbolt said:

Think it's fixed now - for some reason, I had the proxy settings set to use the rTorrent/privoxy port 8118 in my jackett settings. I removed that, since it's routing through the container anyway and it's fine now.

Cheers again!

ahh yes that would do it :-), thanks for letting me know i was half way through trying to replicate the issue 🙂

Link to post
18 minutes ago, binhex said:

ahh yes that would do it :-), thanks for letting me know i was half way through trying to replicate the issue 🙂

Can I check - is the privoxy/port 8118 not able to be used with the iptable tightening now? I used the same proxy settings on radarr/sonarr and the indexers were failing in them until I removed it. I'm not entirely sure I need the proxy on them, tbh, when the indexer traffic is being routed through the vpn on rTorrent, but just wondering if this is what's affecting it.

Link to post
9 minutes ago, xxDeadbolt said:

Can I check - is the privoxy/port 8118 not able to be used with the iptable tightening now? I used the same proxy settings on radarr/sonarr and the indexers were failing in them until I removed it. I'm not entirely sure I need the proxy on them, tbh, when the indexer traffic is being routed through the vpn on rTorrent, but just wondering if this is what's affecting it.

lol this is blowing my mind a little, so you have radarr and sonarr both set to point at privoxyvpn, and then the index site is pointing at jackett which is routed through rtorrentvpn, right?.

 

i would need a strong drink to work all that out and the routing implications, but for now i would say just drop the proxy, its not required at all, as jackett is safely doing the biz for you via routing through the vpn tunnel, no need to make things overly complex eh.

Link to post
3 minutes ago, binhex said:

lol this is blowing my mind a little, so you have radarr and sonarr both set to point at privoxyvpn, and then the index site is pointing at jackett which is routed through rtorrentvpn, right?.

 

i would need a strong drink to work all that out and the routing implications, but for now i would say just drop the proxy, its not required at all, as jackett is safely doing the biz for you via routing through the vpn tunnel, no need to make things overly complex eh.

haha yeah that's it. I can't remember setting the proxy manually in radarr/sonarr tbh, so I must've done it a long time ago & never had a reason to change it before now. All working fine now though 🙂

Link to post

Second attempt at clarifying what I'm after haha.

 

So, with the changes to the binhex VPN dockers I wanted to verify if I was utilizing Jackett properly. Sonarr and Radarr are currently configured to tunnel through the VPN and have been updated with the proper host setting: 'localhost'. Now, within Jackett these buttons are still using 192.168.1.x causing Sonarr and Radarr to error while grabbing indexers.

image01.png.c955713745106d5c90be63ca6164864c.png

 

To fix this, within Sonarr/Radarr I edited what the "Copy Torznab Feed" gives me and replaced 192.168.1.x with 'localhost'. With this, both dockers pass while checking the indexers!

image02.png.7c437ec62f21f10d8d2fa2c577921466.png

 

Is this the correct way to update these settings? Can I set something up within Jackett so I do not have to manually change the ip address when adding a new indexer?

 

Thanks again for your help and time. I'm learning quite a bit!

Link to post
15 hours ago, JimmyGerms said:

Second attempt at clarifying what I'm after haha.

 

So, with the changes to the binhex VPN dockers I wanted to verify if I was utilizing Jackett properly. Sonarr and Radarr are currently configured to tunnel through the VPN and have been updated with the proper host setting: 'localhost'. Now, within Jackett these buttons are still using 192.168.1.x causing Sonarr and Radarr to error while grabbing indexers.

image01.png.c955713745106d5c90be63ca6164864c.png

 

To fix this, within Sonarr/Radarr I edited what the "Copy Torznab Feed" gives me and replaced 192.168.1.x with 'localhost'. With this, both dockers pass while checking the indexers!

image02.png.7c437ec62f21f10d8d2fa2c577921466.png

 

Is this the correct way to update these settings? Can I set something up within Jackett so I do not have to manually change the ip address when adding a new indexer?

 

Thanks again for your help and time. I'm learning quite a bit!

This doesn't answer your question directly, but in Sonarr/Radarr you can also set them up to use all your configured indexers in jacket, see example from Radarr below. That way you only have to set up one indexer, once, in sonarr/radarr. If you add new indexers to jackett, they will be automatically included by the other apps.
Doesn't work if you need different indexers for the different apps though...

730099726_ScreenShot2021-02-27at9_45_39am.png.aa17b2a57aeccf6c9ad65763091db36a.png

Link to post

I seem to be having similar issues to @xxDeadbolt in that I can access Jackett using the GUI on port 9117 and testing the 5 indexers I have in Jackett all work as expected, each reporting a result with a green tick mark.

 

In the Jackett GUI I have configured the proxy to point at the binhex-rTorrentVPN endpoint on port 8118 which I know is working as I can connect through that proxy with my desktop machine and it gives a different IP address than my home IP address.

 

The issue I have is that I can't get Radarr or Sonarr to connect to Jackett (all @binhex repos). I get errors like this from Sonarr:

NzbDroneErrorPipeline  Invalid request Validation failed: -- Unable to connect to indexer, check the log for more details

TorznabUnable to connect to indexer: HTTP request failed: [503:ServiceUnavailable] [GET] at [http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab/api?t=caps&apikey=(removed)

HttpClientHTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab/api?t=caps&apikey=(removed) 503.ServiceUnavailable

 

and this from Radarr:

2021-3-1 17:02:48.0|Warn|HttpClient|HTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab?t=caps&apikey=(removed) 503.ServiceUnavailable 2021-3-1 17:02:50.1|Warn|HttpClient|HTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab?t=caps&apikey=(removed) 503.ServiceUnavailable 2021-3-1 17:02:50.1|Warn|Torznab|Unable to connect to indexer

 

From checking the logs, the errors first started 26 Feb so I don't know if there was a change to one or more of the containers that might have caused an issue as the 4 containers seemed to have been working reasonably well until then. Reinstalling Jackett after nuking the install made no difference.

 

I've tried to add the 9117 port to rTorrent in both the Container Variable: ADDITIONAL_PORTS section and as a separate Container Port as @xxDeadbolt did without any noticeable effect. I may be getting my wires crossed though...

 

I'm out of ideas on what else to try.

 

Any help very gratefully received.

 

Link to post
2 minutes ago, DrBazUK said:

I seem to be having similar issues to @xxDeadbolt in that I can access Jackett using the GUI on port 9117 and testing the 5 indexers I have in Jackett all work as expected, each reporting a result with a green tick mark.

 

In the Jackett GUI I have configured the proxy to point at the binhex-rTorrentVPN endpoint on port 8118 which I know is working as I can connect through that proxy with my desktop machine and it gives a different IP address than my home IP address.

 

The issue I have is that I can't get Radarr or Sonarr to connect to Jackett (all @binhex repos). I get errors like this from Sonarr:

NzbDroneErrorPipeline  Invalid request Validation failed: -- Unable to connect to indexer, check the log for more details

TorznabUnable to connect to indexer: HTTP request failed: [503:ServiceUnavailable] [GET] at [http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab/api?t=caps&apikey=(removed)

HttpClientHTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab/api?t=caps&apikey=(removed) 503.ServiceUnavailable

 

and this from Radarr:

2021-3-1 17:02:48.0|Warn|HttpClient|HTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab?t=caps&apikey=(removed) 503.ServiceUnavailable 2021-3-1 17:02:50.1|Warn|HttpClient|HTTP Error - Res: [GET] http://192.168.0.50:9117/api/v2.0/indexers/all/results/torznab?t=caps&apikey=(removed) 503.ServiceUnavailable 2021-3-1 17:02:50.1|Warn|Torznab|Unable to connect to indexer

 

From checking the logs, the errors first started 26 Feb so I don't know if there was a change to one or more of the containers that might have caused an issue as the 4 containers seemed to have been working reasonably well until then. Reinstalling Jackett after nuking the install made no difference.

 

I've tried to add the 9117 port to rTorrent in both the Container Variable: ADDITIONAL_PORTS section and as a separate Container Port as @xxDeadbolt did without any noticeable effect. I may be getting my wires crossed though...

 

I'm out of ideas on what else to try.

 

Any help very gratefully received.

 

see the support thread for rTorrentVPN and click on the 'recommended post'.

Link to post
17 minutes ago, binhex said:

see the support thread for rTorrentVPN and click on the 'recommended post'.

Thank you!

Q26 solved the issue.

 

For anyone else facing the same issue - this is what solved it:

inside both Radarr and Sonarr in the General tab > Proxy settings and "Ignored Addresses" and adding the IP address of my UNRAID server to the Ignored Addresses field.

 

Thanks Binhex, stellar support as always.

  • Like 1
  • Thanks 1
Link to post

New to Jackett due to the tightening of iptables issue. Am I correct in assuming that if my indexer isn’t listed then this docker is of no use or could I still use it to route download clients thru? Using nzbplanet for nzb’s and rarbg for torrents.

 

On a side note, I was using Privoxy to route Sonarr, Radarr and Lidarr thru DelugeVPN. Adding the “Additional_Ports” variable for these dockers to DelugeVPN and ignoring my server’s IP address has restored the download client connection to DelugeVPN but not NZBgetVPN. Assuming I can’t make the same changes to NZBgetVPN because a docker update would be required to recognize the Additional Ports variable? Is there a fix to get NZBgetVPN working similar to DelugeVPN or should I bite the bullet and bind these containers to DelugeVPN?

Edited by betaman
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.