Jump to content
binhex

[Support] binhex - Jackett

137 posts in this topic Last Reply

Recommended Posts

Overview: Support for Docker image arch-jackett in the binhex repo.

Application: Jackett - https://github.com/Jackett/Jackett

Docker Hub: https://hub.docker.com/r/binhex/arch-jackett/

GitHub: https://github.com/binhex/arch-jackett

Documentationhttps://github.com/binhex/documentation

 

For other Docker support threads and requests, news and Docker template support for the binhex repository please use the "General" thread here


If you appreciate my work, then please consider buying me a beer  :D

 

btn_donate_SM.gif

Edited by binhex

Share this post


Link to post

for my own notes (and anybody else who cares), i found out that somebody created a issue on github to enhance jackett to allow a single "all" aggregated list, this is exactly what i was looking for, as adding each index site from jackett in sickrage sucks, here is the comment and an example, gonna play with this tonight:-

In the latest pre-release you now can use "all" as indexers in torznab/potato urls:
http://127.0.0.1:9117/torznab/all?apikey=&cat=5040,5030

now if only they would allow aggregated logical groupings of index sites (e.g. TV, movies, etc), think i might have to suggest that :-).

Share this post


Link to post

Is anyone else not able to get Jackett to work lately? 

 

Sonarr, Radarr are install correctly. 

 

Jackett installs just fine, when adding a search engine like TPB or EZTV, everything tests fine.

When adding the TorzNAB (custom) and inputting the info, I keep getting generic error in Sonarr's log. Google and other searching isn't really yielding any direction...

 

 

Screen Shot 2018-01-29 at 12.08.08 PM.png

Screen Shot 2018-01-29 at 12.07.21 PM.png

Screen Shot 2018-01-29 at 12.08.46 PM.png

Share this post


Link to post
On ‎1‎/‎29‎/‎2018 at 3:09 PM, mkyb14 said:

Is anyone else not able to get Jackett to work lately? 

 

Sonarr, Radarr are install correctly. 

 

Jackett installs just fine, when adding a search engine like TPB or EZTV, everything tests fine.

When adding the TorzNAB (custom) and inputting the info, I keep getting generic error in Sonarr's log. Google and other searching isn't really yielding any direction...

 

 

I couldn't get this to work either. I also had issues adding some of the indexers in general.

 

However, I think the anime category would have to be a numeric value also, like the categories above.

Edited by jebusfreek666

Share this post


Link to post
12 hours ago, jebusfreek666 said:

 

I couldn't get this to work either. I also had issues adding some of the indexers in general.

 

However, I think the anime category would have to be a numeric value also, like the categories above.

 

i will see if i get time to have a look into it, im using it myself.

Share this post


Link to post

Try TorrentPotato preset instead of customNZB if you are actually searching against a torrent site.

My Radarr is setup this way, still used the jackett nzb link though

 

FYI you should obscure your API key when posting on forums etc

Edited by tjb_altf4

Share this post


Link to post
3 hours ago, binhex said:

 

i will see if i get time to have a look into it, im using it myself.

I am not really sure what the deal is, but I am pretty sure it has to do with the sonarr/radarr side of things. I can test the connection to TPB in jackett, and it works fine. But copying and pasting the URL provided does not work.

 

Also, is there an updated version of jackett available? I see the above post has ETTV. The only public ones on the docker that I have is Rarbg and TPB. I would also like to see EZTV, and thought these were already included?

Share this post


Link to post

@mkyb14 works for me fine, remove whats in anime categories thats probably your problem, where did you get that from?, it looks like tpb doesn't have a anime specific category.

 

@jebusfreek666 - its the latest release, the only reason there were only two showing is cos mkyb14 only had enabled 2 index sites, there are a LOT more to choose from (via the add indexer button).

 

tip of the day: you can actually consolidate all enabled index feeds from jackett by changing the url from <named index site> to "all", this means you dont need to add each index site manually to sonarr, radarr etc.

Share this post


Link to post
1 hour ago, binhex said:

@jebusfreek666 - its the latest release, the only reason there were only two showing is cos mkyb14 only had enabled 2 index sites, there are a LOT more to choose from (via the add indexer button).

 

tip of the day: you can actually consolidate all enabled index feeds from jackett by changing the url from <named index site> to "all", this means you dont need to add each index site manually to sonarr, radarr etc.

 

I know that he only had 2 added in the picture. What I was saying was that it seems like there is only 2 public sites listed on the jackett docker, or only 2 that do not require username and password info. I could be wrong, but I think all the others listed are either semi-private or private. But I am not 100% sure about that.

 

As for adding multiple index feeds from jackett with one link in sonarr/radar, and changing the url, what format would that look like then? I am assuming https://serverIp:port/all? is that it?

Share this post


Link to post
17 hours ago, jebusfreek666 said:

What I was saying was that it seems like there is only 2 public sites listed on the jackett docker,

 

im not sure where you are looking but i see literally dozens of "public" index sites listed in the ui, none of which require username or password *shrug*.

 

17 hours ago, jebusfreek666 said:

As for adding multiple index feeds from jackett with one link in sonarr/radar, and changing the url, what format would that look like then? I am assuming https://serverIp:port/all? is that it?

 

so for example you would configure sonarr/radarr etc with the following:-

http://<host ip>:<port number>/api/v2.0/indexers/all/results/torznab/

 

Share this post


Link to post

I'm having trouble connecting to Jackett from Radarr/Sonarr when using delguevpn privoxy.

 

I have Jackett and Radarr proxy settings set-up as below.

 

Jackett

lLxm97n.png

 

Radarr

xRIvzNs.png

 

Radarr is able to connect fine to deluge, and Jackett is able to connect fine to the indexers.

However, Radarr is unable to connect to Jackett. When I turn off the proxy settings of Radarr, I am able to connect.

 

Any ideas? I'm new to this so let me know if I'm missing something obvious.

Share this post


Link to post

Updated jackett today and it will not start.  Anyone else having issues?

 

 

https://hub.docker.com/u/binhex/

2018-03-14 00:15:05.160125 [info] Host is running unRAID
2018-03-14 00:15:05.194667 [info] System information Linux 5283996a00a8 4.14.16-unRAID #1 SMP PREEMPT Wed Jan 31 08:51:39 PST 2018 x86_64 GNU/Linux
2018-03-14 00:15:05.225716 [info] PUID defined as '99'
2018-03-14 00:15:05.256712 [info] PGID defined as '100'
2018-03-14 00:15:05.321786 [info] UMASK defined as '000'
2018-03-14 00:15:05.356231 [info] Permissions already set for volume mappings
chown: cannot access '/usr/share/Jackett': No such file or directory
chown: cannot access '/opt/Jackett': No such file or directory

Edited by rmilyard

Share this post


Link to post
1 hour ago, ATEglauer said:

Same issue here.  

 

Looks like new update just came out.  Mine seems to be working now.

Share this post


Link to post

I just installed Jackett and was setting it up but then I mistakenly changed the setting to not allow external connections (stupid, I know). It immediately kicked me out of the Web UI and I can't access it again. I tried reinstalling the container (with and without a server reboot), and I tried accessing it from the web UI directly on the server but that also didn't let me in. Is there any way I can either reset all settings back to default and start again, or somehow change the external connections setting from command line or in the docker settings?

 

Sorry if this is obvious, I'm quite new to this and I can't find any instructions or relevant info on google.

Share this post


Link to post
9 hours ago, Janddy said:

I just installed Jackett and was setting it up but then I mistakenly changed the setting to not allow external connections (stupid, I know). It immediately kicked me out of the Web UI and I can't access it again. I tried reinstalling the container (with and without a server reboot), and I tried accessing it from the web UI directly on the server but that also didn't let me in. Is there any way I can either reset all settings back to default and start again, or somehow change the external connections setting from command line or in the docker settings?

 

Sorry if this is obvious, I'm quite new to this and I can't find any instructions or relevant info on google.

 

open file /config/Jackett/ServerConfig.json with something like notepad++ (not notepad) and then change this line to match below:-

 

  "AllowExternal": true,

save and restart container, then murmur the phrase "if i ain't broke dont fix it" over and over again.

Share this post


Link to post

That did it, thank you. All set up and working well now. I will resist the urge to experiment with settings I don't understand in future.

Thanks for all you do binhex!

Share this post


Link to post

Thanks binhex.

 

Perhaps wording such as "non-local host" instead of "external" might clarify and save a few headaches.

Thanks again for you work.

Edited by DingHo
grammar

Share this post


Link to post

I'm getting an issue when trying to add yts indexer:
 

Quote

An error occured while configuring this indexer
An error occurred while sending the request: Error: TrustFailure (One or more errors occurred.)



OS: unRAID 6.5.0.
Kernel: Linux 4.14.26-unRAID x86_64
OpenSSL: 1.0.2n
CPU: Ryzen 1600

I've tried the troubleshooting step for this issue on the Jackett master README too:
 

Output: root@NAS:~# wget -O - https://curl.haxx.se/ca/cacert.pem | cert-sync /dev/stdin
-bash: cert-sync: command not found
--2018-07-22 10:24:12-- https://curl.haxx.se/ca/cacert.pem
Resolving curl.haxx.se (curl.haxx.se)... 151.101.82.49, 2a04:4e42:13::561
Connecting to curl.haxx.se (curl.haxx.se)|151.101.82.49|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 213947 (209K) [application/x-pem-file]
Saving to: ‘STDOUT’ 0%[ ] 0 --.-KB/s in 0s

Cannot write to ‘-’ (Success).

Share this post


Link to post

Hello Binhex,

 

There is a new version of Jackett that fixes the tracker Horrible Subs. Do you know when you will be able to update the docker? The reference fix is here:

 

https://github.com/Jackett/Jackett/issues/3957

 

Thank you for your hard work.

 

Share this post


Link to post

Hi guys,


Radarr would only work when the URL had the exact ip address of my unraid box, but it wouldn't if I set the URL as "localhost:9117(...)" or "127.0.0.1:9117(...)". Not sure why that is happening.
 

On 2/7/2018 at 8:55 AM, binhex said:

so for example you would configure sonarr/radarr etc with the following:-


http://<host ip>:<port number>/api/v2.0/indexers/all/results/torznab/

 

Right now my URL is set to "http://10.0.7.15:9117/torznab/all/". Is there a difference between that and the URL you mentioned, i.e. "http://10.0.7.15:9117/api/v2.0/indexers/all/results/torznab/"?

Share this post


Link to post
2 minutes ago, Azyx said:

Radarr would only work when the URL had the exact ip address of my unraid box, but it wouldn't if I set the URL as "localhost:9117(...)" or "127.0.0.1:9117(...)". Not sure why that is happening.

because if you set the url to localhost then radarr will try to connect to jackett using the localhost address inside the radarr container, obviously the radarr container is only running radarr (and not jackett) and thus it fails.

 

not sure what the difference is with the url's but mine works :-).

Share this post


Link to post
24 minutes ago, binhex said:

because if you set the url to localhost then radarr will try to connect to jackett using the localhost address inside the radarr container, obviously the radarr container is only running radarr (and not jackett) and thus it fails.

 

not sure what the difference is with the url's but mine works :-).

Thanks for the reply!

Yea but they both have their network set to bridge. Both have the same IP address. Wouldn't at leats the loopback work? Or am I missing something?

Share this post


Link to post
1 hour ago, Azyx said:

Thanks for the reply!

Yea but they both have their network set to bridge. Both have the same IP address. Wouldn't at leats the loopback work? Or am I missing something?

Think of each container as a tiny VM. loopback only works inside each individual container. Container to container communication goes through the docker network.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.