Skip to content
View in the app

A better way to browse. Learn more.

Unraid

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

[Support] ich777 - Gameserver Dockers

Featured Replies

33 minutes ago, ich777 said:

What path is set in terms of the Game Files? Do you use /mnt/cache/appdata/... or /mnt/user/appdata/...?

 

If you have set the appdata share to be moved from the Cache to the Array by the Mover, that's the issue but I would strongly recommend that you leave your your appdata share always on the Cache and not move it to the Array, otherwise you have to set the path to /mnt/user/appdata/...

 

Indeed, I have the SteamCMD on mnt/user/appdata and Server files on mnt/cache/appdata/conanexiles.  I intended to put all appdata on Disk 1 of the Array, but it does seem that some files exist in the array and others on cache upon reviewing the folders...and the mover never seems to move appdata to disk 1.

 

At this point, should I:

A.) change the server files to mnt/user/appdata and manually move everything from cache to user, or

B.) is the optimal route to fresh install my dockers on cache and point appdata to cache?

C.) other option?

 

Thank you so much for helping diagnose this

  • Replies 12.6k
  • Views 2.3m
  • Created
  • Last Reply

Top Posters In This Topic

Most Popular Posts

  • Just thought I'd share my experience setting up a Valheim server with this docker app from @ich777(thank you!)   You don't need to worry about Steam authentication for Valheim, the default a

  • Dockers Available:   SteamCMD DedicatedServers: CounterStrike: Source CounterStrike 2 TeamFortress 2 ArmA3 - requested by @MrSage Deathmatch Classic

  • This will hopefully shed some light on the underside working bits of building a cluster of servers for ARK:SurvivalEvolved.   With the inspiration (read thievery) from @growlith I present th

Posted Images

I did option A by moving the disk1 files to the corresponding cache directories, and all is well.  Changed the server files to point to cache now.

 

Thank you @ich777!

15 hours ago, ich777 said:

I can't confirm that, it is totally working in my case with the legacy parameters that are listed here.

 

Anyways, I will look into it how it has to be modified to support the new settings.xml file.

 

I've investigated a bit further and it seems to be recommended that you have indeed a settings.xml but that most commands are still passed over through the command line: Click

 

Thanks for looking into that!!!
 

Yes the settings are still passed over the Command line. Then are written into the XML. The handy thing is you can hugely simplify the command line and just make changes to the XML and it will read all the relevent settings from that .xml. So you're command line is as simple as

-loadlatest <savefoldername> <worldnames>  -settingspath "Path to custom location for a settings.xml" Also by default it checks for a settings.XML in the same directory of the .exe for the rest of the settings. The settings.xml file will only be generated once you launch a game with a -settings arg in the commandline in the new method. I have started just using the -settingspath arg with no additional args and it will generate the file on first boot. Then I edit the .xml and restart the server.

Trouble is in your script BTW thats some really clean coding you've done. You insert the legacy args -batchmode -nographics etc forcing it into legacy mode and that i think is what was tripping me up. I was trying to use the newer commands and it just would not work at the time.

 

But it all come down to the game is buggy as heck when running in the legacy mode for whatever reason. Lots of MP issue show up when launched that way and I have no idea why.

Edited by thlillyr

Hi, i was here a couple weeks back after getting my Valheim server up and running for the first time with your docker.. then on a reboot, the whole install was nuked and started fresh somehow.

 

Once i had it up and running again.. it was great for 11 days, until today, when I noticed save file corruption and high memory usage, so I shut down the docker, restarted my NAS and the docker.

 

I know your product has nothing to do with the potential memory leak and save files.. but upon restarting the Docker my entire valheim install was again wiped. I was hoping you could have a quick look through the attached Docker log and see if you recognize a reason why it might have reinstalled everything and wiped me again. That would help me figure out where to start my newbie troubleshooting :)

 

thanks..

 

 

valheim log.txt

  • Author
2 minutes ago, cakeman said:

Hi, i was here a couple weeks back after getting my Valheim server up and running for the first time with your docker.. then on a reboot, the whole install was nuked and started fresh somehow.

What path is set in your template for the game files?

If you are using /mnt/cache/appdata/... you have to ensure that the files for the appdata share in this case stay on the Cache pool in this case and are not moved to the Array.

You can however change the path to /mnt/user/appdata/... but some games have issues and wouldn't even start.

 

The above described is most likely what happens to you because the mover is moving the data off of the Cache and to the Array and because you are using /mnt/cache/appdata/... it is not able to find the savegame/data anymore.

Hello, I would like to access the console but unfortunately nothing is displayed... the only place where I see the server information is in the logs.

But in the logs we cannot execute commands.

 

image.thumb.png.e51a0c591f0042d12b152ff527d6ee34.png

  • Author
3 minutes ago, Logidroid said:

But in the logs we cannot execute commands.

You have to do that over RCON, it is not possible to interact directly with the console from the game server through the container.

17 hours ago, ich777 said:

You simply can do that with a cron job via User Scripts.

docker container restart CONTAINERNAME

 

About the saves, the container usually should save the game when shutting down.

That's what I thought aswell but I tried it and manually started the script once to check if it works.

 

The server rolled back like 15 minutes and didn't save the world state, it saved the character state though.

 

But I'll try your solution regardless and will observe for a few days and report back.

On 12/17/2023 at 6:47 AM, ich777 said:

I already posted something like that (I think it was a reddit post) but that is more like a workaround not a fix.

 

I would recommend to investigate further why it is not working with the network check enabled.

Time to eat some words, my friend couldn't connect to the server and then I removed the port forwarding rules from my router and restarted the server and it 'worked' just as before so my port forwarding hasn't been correct! 

 

image.png.abba3eccd2af59f2e494d1823eb1d04b.png

 

 

This is what I need to input to add a port rule:

 

image.png.2768e07e888e26e875526c63ff248424.png

 

Should I add 172.17...... 27016 to internal or external? And then I give the 192. to my friend to join the server, correct?

  • Author
1 hour ago, Maxplosive said:

Should I add 172.17...... 27016 to internal or external? And then I give the 192. to my friend to join the server, correct?

No, internal host is 192.168.0.34 with the according protocol (in this case UDP) and the port <- you have to create three entries here.

 

External host needs to be empty and External port needs to be the same as the internal one.

25 minutes ago, ich777 said:

No, internal host is 192.168.0.34 with the according protocol (in this case UDP) and the port <- you have to create three entries here.

 

External host needs to be empty and External port needs to be the same as the internal one.

 

Like this? Left external host empty.

image.png.a82b0a15606eeb8f47c6825d3c2775cc.png

 

 

Now I get the Failed to get public ip error again:

{
  "IpAddress": "0.0.0.0",
  "GamePort": 8766,
  "QueryPort": 27016,
  "BlobSyncPort": 9700,
  "ServerName": "Test",
  "MaxPlayers": 8,
  "Password": "test",
  "LanOnly": false,
  "SaveSlot": 1,
  "SaveMode": "Continue",
  "GameMode": "Normal",
  "SaveInterval": 600,
  "IdleDayCycleSpeed": 0.0,
  "IdleTargetFramerate": 5,
  "ActiveTargetFramerate": 60,
  "LogFilesEnabled": false,
  "TimestampLogFilenames": true,
  "TimestampLogEntries": true,
  "SkipNetworkAccessibilityTest": false,
  "GameSettings": {},
  "CustomGameModeSettings": {}
}
#DSL [Self-Tests] [Config] Dedicated Server configuration file is valid.
#DSL [Self-Tests] [Networking] Testing public accessibility...
0060:fixme:nsi:ipv6_forward_enumerate_all not implemented
0060:fixme:nsi:ipv6_forward_enumerate_all not implemented
01b0:fixme:iphlpapi:NotifyAddrChange (Handle 0000000058B70218, overlapped 0000000058B70220): stub
01d0:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
01d0:fixme:wbemprox:client_security_SetBlanket 000000006E7A0E80, 000000000266CAF0, 10, 0, (null), 3, 3, 0000000000000000, 0
01d0:fixme:wbemprox:client_security_Release 000000006E7A0E80
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
01d0:fixme:wbemprox:enum_class_object_Next timeout not supported
Setting breakpad minidump AppID = 1326470
0060:fixme:mountmgr:query_property Faking StorageDeviceProperty data
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
0060:fixme:mountmgr:query_property Faking StorageDeviceProperty data
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
01d8:fixme:kernelbase:AppPolicyGetThreadInitializationType FFFFFFFFFFFFFFFA, 000000005B42FE10
src\clientdll\steamengine.cpp (3114) : Assertion Failed: Attempt to call interface with invalid hSteamUser /+/ 1, appid=1326470, hpipe=131073, inprocess, thread=432
src\common\interfacemap.cpp (890) : Assertion Failed: IPC call to IClientHTTP::ReleaseHTTPRequest returned failure code 12
src\clientdll\steamengine.cpp (3114) : Assertion Failed: Attempt to call interface with invalid hSteamUser /+/ 1, appid=1326470, hpipe=131073, inprocess, thread=432
0024:fixme:iphlpapi:CancelIPChangeNotify (overlapped 0000000058B70220): stub
src\common\interfacemap.cpp (890) : Assertion Failed: IPC call to IClientHTTP::ReleaseHTTPRequest returned failure code 12
CWorkThreadPool::~CWorkThreadPool: work complete queue not empty, 2 items discarded.
CWorkThreadPool::~CWorkThreadPool: work processing queue not empty: 1 items discarded.
#DSE Invalid public ip [0.0.0.0]
#DSE [Self-Tests] [Networking] Failed to get public ip from Steam.
#DSE [Self-Tests] Please restart the server.

4 minutes ago, Maxplosive said:

 

Like this? Left external host empty.

image.png.a82b0a15606eeb8f47c6825d3c2775cc.png

 

 

Now I get the Failed to get public ip error again:

{
  "IpAddress": "0.0.0.0",
  "GamePort": 8766,
  "QueryPort": 27016,
  "BlobSyncPort": 9700,
  "ServerName": "Test",
  "MaxPlayers": 8,
  "Password": "test",
  "LanOnly": false,
  "SaveSlot": 1,
  "SaveMode": "Continue",
  "GameMode": "Normal",
  "SaveInterval": 600,
  "IdleDayCycleSpeed": 0.0,
  "IdleTargetFramerate": 5,
  "ActiveTargetFramerate": 60,
  "LogFilesEnabled": false,
  "TimestampLogFilenames": true,
  "TimestampLogEntries": true,
  "SkipNetworkAccessibilityTest": false,
  "GameSettings": {},
  "CustomGameModeSettings": {}
}
#DSL [Self-Tests] [Config] Dedicated Server configuration file is valid.
#DSL [Self-Tests] [Networking] Testing public accessibility...
0060:fixme:nsi:ipv6_forward_enumerate_all not implemented
0060:fixme:nsi:ipv6_forward_enumerate_all not implemented
01b0:fixme:iphlpapi:NotifyAddrChange (Handle 0000000058B70218, overlapped 0000000058B70220): stub
01d0:fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
01d0:fixme:wbemprox:client_security_SetBlanket 000000006E7A0E80, 000000000266CAF0, 10, 0, (null), 3, 3, 0000000000000000, 0
01d0:fixme:wbemprox:client_security_Release 000000006E7A0E80
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
01d0:fixme:wbemprox:enum_class_object_Next timeout not supported
Setting breakpad minidump AppID = 1326470
0060:fixme:mountmgr:query_property Faking StorageDeviceProperty data
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
0060:fixme:mountmgr:query_property Faking StorageDeviceProperty data
0060:fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
01d8:fixme:kernelbase:AppPolicyGetThreadInitializationType FFFFFFFFFFFFFFFA, 000000005B42FE10
src\clientdll\steamengine.cpp (3114) : Assertion Failed: Attempt to call interface with invalid hSteamUser /+/ 1, appid=1326470, hpipe=131073, inprocess, thread=432
src\common\interfacemap.cpp (890) : Assertion Failed: IPC call to IClientHTTP::ReleaseHTTPRequest returned failure code 12
src\clientdll\steamengine.cpp (3114) : Assertion Failed: Attempt to call interface with invalid hSteamUser /+/ 1, appid=1326470, hpipe=131073, inprocess, thread=432
0024:fixme:iphlpapi:CancelIPChangeNotify (overlapped 0000000058B70220): stub
src\common\interfacemap.cpp (890) : Assertion Failed: IPC call to IClientHTTP::ReleaseHTTPRequest returned failure code 12
CWorkThreadPool::~CWorkThreadPool: work complete queue not empty, 2 items discarded.
CWorkThreadPool::~CWorkThreadPool: work processing queue not empty: 1 items discarded.
#DSE Invalid public ip [0.0.0.0]
#DSE [Self-Tests] [Networking] Failed to get public ip from Steam.
#DSE [Self-Tests] Please restart the server.

 

 

No steam user in my docker image.thumb.png.93826f75a5c6c9483528adf2da3247b2.png

Hi - thanks for all the hardwork. I know you have two versions of Quake 3, any chance you are up for a 3rd version? This one is actively maintained unlike the others providing vulkan support making it playable on more devices.

 

Quake3e - Github

  • Author
12 hours ago, Maxplosive said:

Like this? Left external host empty.

Exactly, with that it will forward requests from all IP addresses on the three ports from external (WAN) your specified internal IP address and port.

 

12 hours ago, Maxplosive said:

#DSE Invalid public ip [0.0.0.0]

Are you sure that you are not behind a CG-NAT? Do you have other services running on your server which are reachable from outside your network?

Do you have a static or dynamic external IP address?

 

You can add this to your config file (please stop the container and then edit the config file) :

"SkipNetworkAccessibilityTest": true,

Source from that on Reddit: Click

  • Author
3 hours ago, updawg said:

Hi

Sorry but I don't accept any requests anymore because I now have almost 200 apps on the CA App.

10 hours ago, ich777 said:

Exactly, with that it will forward requests from all IP addresses on the three ports from external (WAN) your specified internal IP address and port.

 

Are you sure that you are not behind a CG-NAT? Do you have other services running on your server which are reachable from outside your network?

Do you have a static or dynamic external IP address?

 

You can add this to your config file (please stop the container and then edit the config file) :

"SkipNetworkAccessibilityTest": true,

Source from that on Reddit: Click

 

Really terrible at networking, how do I know if I'm behind a CG-NAT? I don't know much about my internet since it's included in the rent. I saw that I have DHCP enabled, does that affect anything? 

 

image.png.88fc5d182d3befa8ad2c77f7679baaee.png

 

If add SkipNetwork, then it used to run previously but I think my friend couldn't connect, only I could. I don't know if you're familiar with it but my friend is connected to my server with Tailscale, can he connect through that since it only seems  to work 'locally' for me?

 

 

Edit: Actually I think it works now, have to have a friend double check but I connected to my phones hotspot so I was outside of the network and found the server on the list of dedicated servers and could connect! 

 

Yep now it works :)

Edited by Maxplosive

I have an older unraid version 6.9.1, but it's been stable for the purpose it serves.

 

Installing any game server docker, fails at updating streamcmd. I've used this before and always been quite straightforward. I had this docker running on another server I shutdown, I expected to start it up easily on this machine.

 

Focus was on installing ich777/steamcmd:valheim but tried 5 others at least.

 

Console log only shows

---Ensuring UID: 99 matches user---
---Ensuring GID: 100 matches user---
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Taking ownership of data...---
---Starting...---
SteamCMD not found!
steamcmd.sh
linux32/steamcmd
linux32/steamerrorreporter
linux32/libstdc++.so.6
linux32/crashhandler.so
---Update SteamCMD---

 

If I use the console on Valheim docker and run steamcmd manually, I get the following error.

 

root@b6c7065c4195:/serverdata/steamcmd# ./steamcmd.sh 
Redirecting stderr to '/root/Steam/logs/stderr.txt'
threadtools.cpp (3409) : Assertion Failed: Failed to create thread (error 0x1)

 

If I install steamcmd/steamcmd from the command line using the cs go example, only changing the local paths. This error keeps popping up in the log.

 

src/clientdll/cminterface.cpp (2861) : Assertion Failed: m_VecNetAdrNetFilterCMs.Count() > 0

 

I also tried cm2network/steamcmd which seemed to install and download all the initial steam files.

 

Am I missing something really simple here?

Edited by Tuftuf

Hi there!

 

I'm trying to host the Don't starve togheter container and I'm not entirely sure how to host the game server, for example wich port do i have to forward from my firewall? It may be a dumb question but I didn't exactly find any guide that specify the ports.

Another question, does the server get the "Cluster name" that I assignd? or is it different?

Thanks

Edited by SpicyNugget

  • Author
3 hours ago, Tuftuf said:

Installing any game server docker, fails at updating streamcmd. I've used this before and always been quite straightforward. I had this docker running on another server I shutdown, I expected to start it up easily on this machine.

Sorry but I can't support that old Unraid versions since if you scroll back about 100 pages users had the same issue when 6.10 was released and they told me they where still on 6.8.3 and a upgrade solved the issue.

 

The cause of the issue is that I use fairly new base images and they are simply most of the times are not compatible anymore with the runc version that is used on such old Unraid versions.

  • Author
5 hours ago, Maxplosive said:

If add SkipNetwork, then it used to run previously but I think my friend couldn't connect, only I could. I don't know if you're familiar with it but my friend is connected to my server with Tailscale, can he connect through that since it only seems  to work 'locally' for me?

Lol, then you don't have to port forward anything, he just needs to connect with your local IP from your server (it could be the case that you have to enable LAN only but I don't know how to do that for SotF).

 

However what you are doing is a big security risk since he can basically is in your local network, but that's up to you.

 

5 hours ago, Maxplosive said:

Yep now it works :)

Glad that you've figured it out.

  • Author
1 hour ago, SpicyNugget said:

wich port do i have to forward from my firewall?

The ports which are specified in the template.

 

1 hour ago, SpicyNugget said:

It may be a dumb question but I didn't exactly find any guide that specify the ports.

I always specify the ports with the appropriate protocol in my containers, you don't need more or less, just the ports specified in there.

 

1 hour ago, SpicyNugget said:

Another question, does the server get the "Cluster name" that I assignd? or is it different?

IIRC that you assigned.

Have you read the description from the container to how to create a token and so on?

You should just look all up, watch the logs and then we can troubleshoot.

 

Here is also a good guide on how to set up a dedicated server, everything initially is done by the container, simply start at the Token here.

Hey ich, I went back through the forum looking at the comments about farm sim 22 and I was just curious on if you ever did try setting something up, or if you still needed two copies of the game to even try it.

 

If you haven't tried yet and would still be willing to give it a shot, I'd be willing to get you the copies of the game, if you're interested in that.

 

Thanks again for all you do

  • Author
29 minutes ago, Tonborghini said:

If you haven't tried yet and would still be willing to give it a shot, I'd be willing to get you the copies of the game, if you're interested in that.

Please look at that post:

 

Hi Ich,

 

I've tried using the arkse docker and AMP docker both using steamcmd, but can't get the server to show up on the public steam server list. Using the ARKSE app with steamcmd on UNRAID v6.12.6. I currently have the network type set as "Host" to avoid any NAT'ing problems. I am able to discover the game in steam LAN tab as 192.168.1.9:7777 and in UNRAID console using "netstat -lptun" it shows it binding to 0.0.0.0 port 7777 but NOT as "LISTEN". Not sure if this is a problem or not.

I'm confident the portforwarding rules are set correctly as I have a minecraft server running in another docker and working, although those communicate over tcp.

 

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
udp        0      0 0.0.0.0:7777            0.0.0.0:*                           15771/docker-proxy  
udp        0      0 0.0.0.0:7778            0.0.0.0:*                           15744/docker-proxy  
udp        0      0 0.0.0.0:27015           0.0.0.0:*                           15722/docker-proxy                  
udp6       0      0 :::7777                 :::*                                15779/docker-proxy  
udp6       0      0 :::7778                 :::*                                15750/docker-proxy    
udp6       0      0 :::27015                :::*                                15728/docker-proxy  

 

image.png.c1a6312a4c29291b62a85e6ec27a04b2.png

 

image.thumb.png.25caaec77f247559c24e074c6c15d4cd.png

Mikrotik Portforwading settings

image.thumb.png.4e53aa88d39b76e645dd1db67779a462.png

There seems to be traffic coming in on port 27015 and forwarding correctly to my internal server 192.168.1.9


image.png.c81cd2a0541b0222300133cf7e61d11c.png

Edited by vovik

  • Author
7 hours ago, vovik said:

AMP docker

I have no AMP Docker, just a AMP LXC container.

 

7 hours ago, vovik said:

but can't get the server to show up on the public steam server list

Are you talking about the Steam or the In-Game Server list?

 

7 hours ago, vovik said:

I currently have the network type set as "Host" to avoid any NAT'ing problems.

I really would recommend to not use Host and instead use the default bridge network.

 

7 hours ago, vovik said:

it shows it binding to 0.0.0.0 port 7777 but NOT as "LISTEN"

This is perfectly fine.

 

7 hours ago, vovik said:

Mikrotik Portforwading settings

I'm not that familiar with MikroTik port forwarding but shouldn't you also set the destination address to your servers internal IP address? As said, I might miss something here because I'm not that familiar with MikroTik port forwarding is working.

 

Are you sure all the boxes in the in game server list are ticked correctly? ARK is really picky about those check boxes and values on the in game server list and one wrong set check box can prevent the server from showing up.

 

Have you yet tried to connect with your public IP to from the in game console to the server?

Have you yet tried to connect to the server from outside your network just to make sure it is not a Hair pin NAT issue?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.