[Plugin] CA Appdata Backup / Restore v2.5


Recommended Posts

17 hours ago, Whaler_99 said:

Doesn't work at least on my system. I can excluded an entire selection, but that isn't what I want. I want to exclude my Plex cache and transcode folders only.


You can put multiple values in with commas, mine looks like this:-


/mnt/user/appdata/binhex-plexpass/Plex Media Server/cache,/mnt/user/appdata/binhex-plexpass/Plex Media Server/Metadata,/mnt/user/appdata/binhex-plexpass/Plex Media Server/Media


Link to comment
1 hour ago, MammothJerk said:

I found that the support link at the bottom of the page links to the old support page, and you haven't added yourself to the credits.😁

Will be fixed in the rewrite


10 minutes ago, doesntaffect said:

Is there a possibility to see the progress (and potentially time left) of the backup process in the Unraid GUI?

No. But I can try to integrate some info in future version.

  • Like 1
Link to comment

That would be amazing. Thank much @KluthR

What would also be nice is a scheduler, so that the backup of setups with several (large) container can be spread across time. 


In my context I have a photoprism container with 50K photos and several other container and the backup runs from 03:00am to 4pm. 


While the backup is running my network related containers are still down and I wonder if I can start them while the backup is still running?

Edited by doesntaffect
Link to comment

Question.  I did a backup from one unraid server and want to restore (well did) to a new unraid box.  What's the easiest way to get the containers to show up after a restore?  They do not show up in previous apps because they were never installed on that box before.  Thanks!

Link to comment

Two things


Am I mistaken or was the setting on the previous version to keep X number of backups not X days worth? That to me seems like a better option.


I have all my Plex data on a dedicated NVMe, is there any way to include that in the backup.

If not I imaging there's a lot of users out there that are configured the same way, perhaps a fork of this could be possible to address that exact scenerio and run for Plex only.

Link to comment
7 hours ago, Kilrah said:

You can copy the xml files in



from one box to another, then they will show up in Previous Apps. 

Awesome! Thank you.  Ended up copying them over and just adding the container manually but it worked!  

Link to comment
3 hours ago, shiftylilbastrd said:

have all my Plex data on a dedicated NVMe, is there any way to include that in the backup

Not yet. But such things are planned. I always try to find more time to make all the changes. I guess I can tell more February.


there will also be some betas of the new plugin version which are available for all to test.


My goal is to be done with the release of the next unraid version. The current plugin version will definitively have issues with the next unraid version.

Edited by KluthR
Link to comment



I too am also seeing the error notifications and '-error" extension on the filename but do see what appears to be a full sized backup.  I am not sure if I should tick the box to ignore the errors and nothing I have found in this thread seems to inform me.  How can I tell if the errors that are registering are able to be ignored?  The last one in the log says "A error occurred somewhere. Not deleting old backup sets of appdata" but i do see 2 other in there that say "tar verify failed! "and "tar creation/extraction failed!"  however the tar file is still created.  Any help is appreciated! 

Link to comment

Hi everyone,


I just updated from V2 to V3. V2 had been running solid since I installed it. I am unable to get V3 to run at all.  A manual run produces no logs in the 3rd tab.  I've verified that all my settings are the same as V2.


I have verified all paths, and rebooted unraid. I have tried running manually with all dockers stopped, and nothing.  Not a single line in the 3rd tab where the logs should be.



  • I set the notification settings to notify on start and stop, and running manually does not product a notification. 
  • As noted above I tried running with all dockers stopped, but if I try running it with my dockers running they are not shutdown.  It is as if the plugin does not start at all.
  • When running manually it warns me that the target folder will be overwritten.  I click ok, and am taken to the 3rd tab, which shows "Backup / Restore Status: Not Running"










Edited by calvados
Added EDIT section with more details
Link to comment
14 hours ago, jbrown705 said:

I am not sure if I should tick the box to ignore the errors

Looking at your log, you have several containers set to not stop but still back up its data. Thats the one and only reason.


You have two options:

  • If its your intention: Live with it and enable the ignore errors-option
  • Let the plugin stop the containers and get consistent backups.


7 hours ago, calvados said:

I am unable to get V3 to run at all

Which Unraid version?


Can you open the syslog window (from within unraid), start the backup and check if something is being logged there?

Link to comment
12 minutes ago, KluthR said:

Which Unraid version?


Can you open the syslog window (from within unraid), start the backup and check if something is being logged there?


Unraid Version: 6.11.5


When running manually syslog shows:

Jan 26 23:16:12 ur CA Backup/Restore: It doesn't appear that the array is running.  Exiting CA Backup


The array is running though, my storage in on a ZFS zpool:



Edited by calvados
Link to comment
7 hours ago, Squid said:

If user shares are not enabled

Correct, I have user shares disabled as I do not use them.  I run ZFS only.  This had no impact on the V2 version of the plugin.


6 hours ago, KluthR said:

Ok. Will check a solution and make a hotfix for now.

Thank you so much @KluthR:)



Link to comment
  • KluthR changed the title to [Plugin] CA Appdata Backup / Restore v2.5

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.