Jump to content
linuxserver.io

[Support] Linuxserver.io - Nextcloud

4077 posts in this topic Last Reply

Recommended Posts

Hello, I'm using v18.0.4 using subdomain reverse proxy and I'm stuck at "Extracting" step with the "Can't handle ZIP file. Error code is: 28" error shown.

I'm using the latest images of both "linuxserver/nextcloud" & "linuxserver/letsencrypt".

 

Any ideas what I can do to resolve this situation?

Share this post


Link to post
28 minutes ago, UNOPARATOR said:

Hello, I'm using v18.0.4 using subdomain reverse proxy and I'm stuck at "Extracting" step with the "Can't handle ZIP file. Error code is: 28" error shown.

I'm using the latest images of both "linuxserver/nextcloud" & "linuxserver/letsencrypt".

 

Any ideas what I can do to resolve this situation?

Take a look here:

 

https://github.com/nextcloud/updater/issues/135

Share this post


Link to post

I'm having issues regarding Nextcloud and LE.

When I go to mydomain.tld/nextcloud after setting everything up (configuring the LE proxy and editting nextcloud config), all I see is the picture below.  Not sure why I don't get any login boxes.

6Q9yyq4.jpg

 

Any ideas?

Share this post


Link to post
Posted (edited)

Hey, nextcloud is running fine for small files, but now i have some problems with large files. I wanted to handle a 4GB File and this were the issues i encountered:

 

(A) by uploading the file, i got a message "Error when assembling chunks, status code 504", however the file was uploaded correctly i confirmed it by comparing the hash with the original file, so I dont worry too much about this.

(B) when downloading this large file, my docker.img gets filled. Including that no other containers webinterface respond. is there a way to avoid this situation?

Edited by Greyberry

Share this post


Link to post
On 5/31/2020 at 10:05 PM, Mihle said:

So after longer time than I wanted I set up preview generator for thumbnails.
Its working fine for images that stored in Nextcloud itself.
But for storage added as external storage, the previews are created, but neither web Nextcloud or the app actually uses the previews created.

Nextcloud is instead creating new thumbnails instead for some reason. Anyone know why?

I guess no one knows.

Share this post


Link to post
On 6/3/2020 at 8:10 PM, musicking said:

Anyone able to get the new document CODE server working in nextcloud 19 behind letsencrypt/nginx? I added the

location ~ ^\/nextcloud\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {

But still couldn't connect :(

i have the same problem. 😕

Share this post


Link to post

Hey guys,

 

Has anyone enabled the GeoBlocker app inside Nextcloud? I keep Getting this down below. I know it says to enable the exec() on php.ini but i don't know what command should i put in the php.ini and is the php.ini location is \mnt\user\appdata\nextcloud\php. I also read is not a good idea to enable exec(). Can someone please help me figure this out. I saw on my logs inside nextcloud some ip addresses of someone from Germany trying to get in the nextcloud instance. 

 

Status of the chosen service:

"Geoiplookup": ERROR: Service seem to be not installed on the host of the Nextcloud server or not reachable for the web server or is wrongly configured (is the database for IPv4 and IPv6 available?!). Maybe the use of the php function exec() is disabled in the php.ini.

Share this post


Link to post
On 7/1/2016 at 3:22 AM, linuxserver.io said:

docker exec -it nextcloud updater.phar

Thanks to @DoItMyselfToo, I used to above command (which was available at the first page) in the unraid's terminal and all went fine.

I will never try to upgrade from the Web UI ever again!

And I suggest the same to everyone too. 👍

Share this post


Link to post

Having some weird issues with the web UI being incredibly slow after the last couple of upgrades. I know it's not bandwidth or speed issues with my server, because for instance my Jellyfin and Airsonic servers are as snappy as ever running on the same machine. I have my own domain of which nextcloud is a sub on going through let's encrypt, but I know that's not an issue either, since the aforementioned Jellyfin and Airsonic servers are also sub domains of the same also through let's encrypt.

 

Nextcloud docker logs are clean. All checks passed on the Security and Setup section. Though this does pop up in the logging section, not sure if it's related:

 

Quote

[core] Error: Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [2002] Connection refused at <<closure>>

 0. /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php line 889
    OC\DB\Connection->connect()
 1. /config/www/nextcloud/lib/private/DB/Connection.php line 194
    Doctrine\DBAL\Connection->executeQuery("SELECT * FROM `oc_appconfig`", [], [], null)
 2. /config/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Query/QueryBuilder.php line 200
    OC\DB\Connection->executeQuery("SELECT * FROM `oc_appconfig`", [], [])
 3. /config/www/nextcloud/lib/private/DB/QueryBuilder/QueryBuilder.php line 216
    Doctrine\DBAL\Query\QueryBuilder->execute()
 4. /config/www/nextcloud/lib/private/AppConfig.php line 331
    OC\DB\QueryBuilder\QueryBuilder->execute()
 5. /config/www/nextcloud/lib/private/AppConfig.php line 109
    OC\AppConfig->loadConfigValues()
 6. /config/www/nextcloud/lib/private/AppConfig.php line 287
    OC\AppConfig->getApps()
 7. /config/www/nextcloud/lib/private/legacy/OC_App.php line 883
    OC\AppConfig->getValues(false, "installed_version")
 8. /config/www/nextcloud/lib/private/TemplateLayout.php line 164
    OC_App::getAppVersions()
 9. /config/www/nextcloud/lib/private/legacy/OC_Template.php line 185
    OC\TemplateLayout->__construct("error", "")
10. /config/www/nextcloud/lib/private/Template/Base.php line 132
    OC_Template->fetchPage()
11. /config/www/nextcloud/lib/private/legacy/OC_Template.php line 334
    OC\Template\Base->printPage()
12. /config/www/nextcloud/index.php line 63
    OC_Template::printExceptionErrorPage(Doctrine\DBAL\DBALException {}, 500)

GET /index.php/204
from 73.169.171.95 at 2020-06-07T07:01:31+00:00

Thoughts?

Share this post


Link to post

Normal for docker image to show full when someone is downloading or uploading to nextcloud? I show it jumping around a lot!

Share this post


Link to post

I can't use nextcloud in iframe in organizr anymore.

 

any ideas? 🥺

Share this post


Link to post

Hello - I've been running this container together with Onlyoffice Document Server and it's been working great. Today I tried to upgrade nextcloud from 18.0.4 to 18.0.6 and I'm getting the error below. Not sure how to proceed from here. My nextcloud instance is now stuck in the upgrade phase. Please advise.

 

Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
2020-06-09T13:18:51+00:00 Set log level to debug
2020-06-09T13:18:51+00:00 Turned on maintenance mode
2020-06-09T13:18:51+00:00 Repair step: Repair MySQL collation
2020-06-09T13:18:51+00:00 Repair info: All tables already have the correct collation -> nothing to do
2020-06-09T13:18:51+00:00 Repair step: Repair SQLite autoincrement
2020-06-09T13:18:51+00:00 Repair step: Copy data from accounts table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Repair step: Drop account terms table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Updating database schema
2020-06-09T13:18:51+00:00 Updated database
2020-06-09T13:18:51+00:00 Updating <documentserver_community> ...
2020-06-09T13:18:52+00:00 Repair step: Rebuild font library
2020-06-09T13:18:52+00:00 Exception: sh: ../../tools/allfontsgen: not found

2020-06-09T13:18:52+00:00 Update failed
2020-06-09T13:18:52+00:00 Maintenance mode is kept active
2020-06-09T13:18:52+00:00 Reset log level

Keep maintenance mode active? [y/N] n
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Maintenance mode disabled

 

Share this post


Link to post
13 minutes ago, learnin2walk said:

Hello - I've been running this container together with Onlyoffice Document Server and it's been working great. Today I tried to upgrade nextcloud from 18.0.4 to 18.0.6 and I'm getting the error below. Not sure how to proceed from here. My nextcloud instance is now stuck in the upgrade phase. Please advise.

 


Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
2020-06-09T13:18:51+00:00 Set log level to debug
2020-06-09T13:18:51+00:00 Turned on maintenance mode
2020-06-09T13:18:51+00:00 Repair step: Repair MySQL collation
2020-06-09T13:18:51+00:00 Repair info: All tables already have the correct collation -> nothing to do
2020-06-09T13:18:51+00:00 Repair step: Repair SQLite autoincrement
2020-06-09T13:18:51+00:00 Repair step: Copy data from accounts table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Repair step: Drop account terms table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Updating database schema
2020-06-09T13:18:51+00:00 Updated database
2020-06-09T13:18:51+00:00 Updating <documentserver_community> ...
2020-06-09T13:18:52+00:00 Repair step: Rebuild font library
2020-06-09T13:18:52+00:00 Exception: sh: ../../tools/allfontsgen: not found

2020-06-09T13:18:52+00:00 Update failed
2020-06-09T13:18:52+00:00 Maintenance mode is kept active
2020-06-09T13:18:52+00:00 Reset log level

Keep maintenance mode active? [y/N] n
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Maintenance mode disabled

 

I have a similar problem.  Whilst trying to do the same upgrade I'm now stuck on the Maintenance page and can't access nextcloud:

 

 

1436607442_FireShotCapture162-Nextcloud.thumb.png.23a4497674e3e68ff9bd12f629f60344.png

Share this post


Link to post
1 hour ago, DZMM said:

I have a similar problem.  Whilst trying to do the same upgrade I'm now stuck on the Maintenance page and can't access nextcloudimageproxy.php?img=&key=e5eec7c5c933ca16imageproxy.php?img=&key=e5eec7c5c933ca16imageproxy.php?img=&key=e5eec7c5c933ca16:

 

imageproxy.php?img=&key=e5eec7c5c933ca16

 

1436607442_FireShotCapture162-Nextcloud.thumb.png.23a4497674e3e68ff9bd12f629f60344.png

Spaceinvader has a video about nextcloud explaining how to modify a file to change next to not be in maintenance mode.

 

All that you need to do is edit a text file and change a line from "true" to flase" but I can't remember where this file is located.

Share this post


Link to post
19 hours ago, scubieman said:

Normal for docker image to show full when someone is downloading or uploading to nextcloud? I show it jumping around a lot!

I've asked before quite a few times, nobody seems to know so I had to stop using Nextclould! Which is a shame! If you find out please post here as I think a few others have also asked in the past and I for one would like to switch it back on!

Share this post


Link to post
1 hour ago, Alec.Dalessandro said:

Spaceinvader has a video about nextcloud explaining how to modify a file to change next to not be in maintenance mode.

 

All that you need to do is edit a text file and change a line from "true" to flase" but I can't remember where this file is located.

 

Go to /mnt/user/appdata/nextcloud/www/nextcloud/config/ open the config.php and at the bottom you will see ‘maintance’ => true change it to false. 

Share this post


Link to post

Maintenance is set to 'false' on my config.php, yet I'm getting the screen below. Not sure how to get unstuck from this.

 

 

Capture.PNG

Share this post


Link to post
3 hours ago, DZMM said:

I have a similar problem.  Whilst trying to do the same upgrade I'm now stuck on the Maintenance page and can't access nextcloudimageproxy.php?img=&key=e5eec7c5c933ca16imageproxy.php?img=&key=e5eec7c5c933ca16imageproxy.php?img=&key=e5eec7c5c933ca16:

 

imageproxy.php?img=&key=e5eec7c5c933ca16

 

1436607442_FireShotCapture162-Nextcloud.thumb.png.23a4497674e3e68ff9bd12f629f60344.png

Go to this folder and edit the config.php file with notepad++ and change the "maintenance" from true to false. restart nextcloud docker

\\SERVER\appdata\nextcloud\www\nextcloud\config\config.php

 

'maintenance' => false,

Share this post


Link to post
Posted (edited)
4 hours ago, learnin2walk said:

Hello - I've been running this container together with Onlyoffice Document Server and it's been working great. Today I tried to upgrade nextcloud from 18.0.4 to 18.0.6 and I'm getting the error below. Not sure how to proceed from here. My nextcloud instance is now stuck in the upgrade phase. Please advise.

 


Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
2020-06-09T13:18:51+00:00 Set log level to debug
2020-06-09T13:18:51+00:00 Turned on maintenance mode
2020-06-09T13:18:51+00:00 Repair step: Repair MySQL collation
2020-06-09T13:18:51+00:00 Repair info: All tables already have the correct collation -> nothing to do
2020-06-09T13:18:51+00:00 Repair step: Repair SQLite autoincrement
2020-06-09T13:18:51+00:00 Repair step: Copy data from accounts table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Repair step: Drop account terms table when migrating from ownCloud
2020-06-09T13:18:51+00:00 Updating database schema
2020-06-09T13:18:51+00:00 Updated database
2020-06-09T13:18:51+00:00 Updating <documentserver_community> ...
2020-06-09T13:18:52+00:00 Repair step: Rebuild font library
2020-06-09T13:18:52+00:00 Exception: sh: ../../tools/allfontsgen: not found

2020-06-09T13:18:52+00:00 Update failed
2020-06-09T13:18:52+00:00 Maintenance mode is kept active
2020-06-09T13:18:52+00:00 Reset log level

Keep maintenance mode active? [y/N] n
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Maintenance mode disabled

 

I have the same Problem with my nextcloud. It looks like the Document Server updated app to not work properly.
I solved this by disabled the "Document Server" with the terminal.
Open the nexcloud terminal window and type this command


Lists all your current isntalled apps
  occ app:list


then I searched for the Document Server and used this command to disable it.
occ app:disable  documentserver_community

Now I can login to nextcloud and see the user interface again.

Edited by tomibi
  • Like 2
  • Thanks 3

Share this post


Link to post

Thank you for your response. Disabling the "documentserver_community" app allowed me to finish the upgrade to 18.0.6.

Share this post


Link to post
On 6/6/2020 at 2:40 AM, Greyberry said:

Hey, nextcloud is running fine for small files, but now i have some problems with large files. I wanted to handle a 4GB File and this were the issues i encountered:

 

(A) by uploading the file, i got a message "Error when assembling chunks, status code 504", however the file was uploaded correctly i confirmed it by comparing the hash with the original file, so I dont worry too much about this.

(B) when downloading this large file, my docker.img gets filled. Including that no other containers webinterface respond. is there a way to avoid this situation?

Please see this post of mine

 

 

Share this post


Link to post
On 6/10/2020 at 3:12 AM, tomibi said:

I have the same Problem with my nextcloud. It looks like the Document Server updated app to not work properly.
I solved this by disabled the "Document Server" with the terminal.
Open the nexcloud terminal window and type this command


Lists all your current isntalled apps
  occ app:list


then I searched for the Document Server and used this command to disable it.
occ app:disable  documentserver_community

Now I can login to nextcloud and see the user interface again.

I had this problem and this fixed worked for me as well, thank you!

Share this post


Link to post

I've been on v16 for some time and finally went through the multiple upgrade process to get to 18. Everything went well but my homepage shows what appears to be a spinning icon (as if it's scanning for something). The icon never goes away. Restarting the container doesn't help. This is on Firefox. Only add-on is UBlock Origin which is disabled for my Nextcloud host.

 

Any ideas?

Capture.PNG

Share this post


Link to post
7 minutes ago, jserio said:

I've been on v16 for some time and finally went through the multiple upgrade process to get to 18. Everything went well but my homepage shows what appears to be a spinning icon (as if it's scanning for something). The icon never goes away. Restarting the container doesn't help. This is on Firefox. Only add-on is UBlock Origin which is disabled for my Nextcloud host.

 

Any ideas?

 

 

To answer my own question, it looks like it has something to do with "Use rich workplaces." Disabling this removes the icon.

Share this post


Link to post

I was having the same issues as the other folks. The fixes in the above posts fixed the issues.

 

In Nextcloud docker cli enter:  occ app:disable documentserver_community

 

In Unraid cli enter: docker exec -it nextcloud updater.phar

 

Updating from the Unraid cli seems like the way to go!

 

Thank you!

nextcloud1.png

nextcloud2.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.