Jump to content
binhex

[Support] binhex - Sonarr

465 posts in this topic Last Reply

Recommended Posts

13 minutes ago, gridrunner said:

Here is a video I put together for how to install and configure Binhex's Sonarr container :

Well, I looked for this on your YouTube channel but missed it. Almost posted some sort of smarta$$ remark in this thread last night about missing SpaceInvader videos. Glad I didn't. Wouldn't want to look stupid(er).:D

Share this post


Link to post
38 minutes ago, wgstarks said:

Well, I looked for this on your YouTube channel but missed it. Almost posted some sort of smarta$$ remark in this thread last night about missing SpaceInvader videos. Glad I didn't. Wouldn't want to look stupid(er).:D

lol. It would look any stupider than how i spelt Apologise in that sonarr video 

Edited by gridrunner

Share this post


Link to post
16 hours ago, gridrunner said:

Here is a video I put together for how to install and configure Binhex's Sonarr container :

 

 

love your work gridrunner, it def does relieve the support load having these videos, problem is im running out of space to link to them in my signature :-).

Share this post


Link to post

Hi, thanks for your work, everything works ok.

 

Is it possible to add the "preferred word" tab in settings? I would like to get some x265 files.

 

Regards.

Share this post


Link to post
35 minutes ago, milio said:

Hi, thanks for your work, everything works ok.

 

Is it possible to add the "preferred word" tab in settings? I would like to get some x265 files.

 

Regards.

 

i don't develop the application, i just allow you to run it.

Share this post


Link to post

My friend sorry I just saw that this is just a concept from someone in case it can be included in a new app version.

 

Regards.

Share this post


Link to post
17 minutes ago, milio said:

My friend sorry I just saw that this is just a concept from someone in case it can be included in a new app version.

 

Regards.

 

np, if you want enhancements to the application then your best bet is to post it on their github repo:- https://github.com/Sonarr/Sonarr/issues/new

Share this post


Link to post

Hi Binhex I'm hoping you can help.
I've been trying to setup your Docker container without success. Having issues with Emby and Radarr too so don't know if they are related?
Log is below, thanks!

2017-08-27 19:31:47.007763 [info] Host is running unRAID
2017-08-27 19:31:47.045790 [info] System information Linux cc6fbc10d9dc 4.9.30-unRAID #1 SMP PREEMPT Fri May 26 13:56:36 PDT 2017 x86_64 GNU/Linux
2017-08-27 19:31:47.095635 [info] PUID defined as '99'
2017-08-27 19:31:47.137707 [info] PGID defined as '100'
2017-08-27 19:31:47.308762 [info] UMASK defined as '000'
2017-08-27 19:31:47.352697 [info] Permissions already set for volume mappings
2017-08-27 19:31:47.409647 [info] Starting Supervisor...
2017-08-27 19:31:47,851 CRIT Set uid to user 0
2017-08-27 19:31:47,851 INFO Included extra file "/etc/supervisor/conf.d/sonarr.conf" during parsing
2017-08-27 19:31:47,855 INFO supervisord started with pid 7
2017-08-27 19:31:48,858 INFO spawned: 'sonarr' with pid 42
2017-08-27 19:31:48,858 INFO reaped unknown pid 8
2017-08-27 19:31:49,204 DEBG 'sonarr' stdout output:
[Info] Bootstrap: Starting Sonarr - /usr/lib/sonarr/NzbDrone.exe - Version 2.0.0.4949

2017-08-27 19:31:49,484 DEBG 'sonarr' stdout output:
[Info] AppFolderInfo: Data directory is being overridden to [/config]

2017-08-27 19:31:49,756 DEBG 'sonarr' stdout output:
[Info] MigrationLogger: *** Migrating data source=/config/nzbdrone.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***

2017-08-27 19:31:49,861 DEBG 'sonarr' stdout output:



2017-08-27 19:31:49,861 INFO success: sonarr entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2017-08-27 19:31:51,325 DEBG 'sonarr' stdout output:
[Fatal] ConsoleApp: EPIC FAIL!

[v2.0.0.4949] NzbDrone.Core.Datastore.CorruptDatabaseException: Database file: /config/nzbdrone.db is corrupt, restore from backup if available. See: https://github.com/Sonarr/Sonarr/wiki/FAQ#i-am-getting-an-error-database-disk-image-is-malformed ---> System.Data.SQLite.SQLiteException: disk I/O error
disk I/O error
at System.Data.SQLite.SQLite3.Prepare (System.Data.SQLite.SQLiteConnection cnn, System.String strSql, System.Data.SQLite.SQLiteStatement previous, System.UInt32 timeoutMS, System.String& strRemain) [0x0033c] in <61a20cde294d4a3eb43b9d9f6284613b>:0
at System.Data.SQLite.SQLiteCommand.BuildNextCommand () [0x00068] in <61a20cde294d4a3eb43b9d9f6284613b>:0
--- End of inner exception stack trace ---
at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationContext migrationContext) [0x00136] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0
at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationType migrationType) [0x00010] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0
at NzbDrone.Core.Datastore.DbFactory.RegisterDatabase (NzbDrone.Common.Composition.IContainer container) [0x00006] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0
at NzbDrone.Host.Bootstrap.Start (NzbDrone.Host.ApplicationModes applicationModes, NzbDrone.Common.EnvironmentInfo.StartupContext startupContext) [0x0003d] in <d2aa8471dce1470d8d07b077ed3fa5e1>:0
at NzbDrone.Host.Bootstrap.Start (NzbDrone.Common.EnvironmentInfo.StartupContext startupContext, NzbDrone.Host.IUserAlert userAlert, System.Action`1[T] startCallback) [0x00075] in <d2aa8471dce1470d8d07b077ed3fa5e1>:0
at NzbDrone.Console.ConsoleApp.Main (System.String[] args) [0x00013] in <e7e74f1ad35044249cce48fb51646d85>:0


2017-08-27 19:31:51,333 DEBG 'sonarr' stdout output:
Press enter to exit...


 

sonarr-settings.jpg

Share this post


Link to post
Hi Binhex I'm hoping you can help.
I've been trying to setup your Docker container without success. Having issues with Emby and Radarr too so don't know if they are related?
Log is below, thanks!
2017-08-27 19:31:47.007763 [info] Host is running unRAID2017-08-27 19:31:47.045790 [info] System information Linux cc6fbc10d9dc 4.9.30-unRAID #1 SMP PREEMPT Fri May 26 13:56:36 PDT 2017 x86_64 GNU/Linux2017-08-27 19:31:47.095635 [info] PUID defined as '99'2017-08-27 19:31:47.137707 [info] PGID defined as '100'2017-08-27 19:31:47.308762 [info] UMASK defined as '000'2017-08-27 19:31:47.352697 [info] Permissions already set for volume mappings2017-08-27 19:31:47.409647 [info] Starting Supervisor...2017-08-27 19:31:47,851 CRIT Set uid to user 02017-08-27 19:31:47,851 INFO Included extra file "/etc/supervisor/conf.d/sonarr.conf" during parsing2017-08-27 19:31:47,855 INFO supervisord started with pid 72017-08-27 19:31:48,858 INFO spawned: 'sonarr' with pid 422017-08-27 19:31:48,858 INFO reaped unknown pid 82017-08-27 19:31:49,204 DEBG 'sonarr' stdout output:[info] Bootstrap: Starting Sonarr - /usr/lib/sonarr/NzbDrone.exe - Version 2.0.0.49492017-08-27 19:31:49,484 DEBG 'sonarr' stdout output:[info] AppFolderInfo: Data directory is being overridden to [/config]2017-08-27 19:31:49,756 DEBG 'sonarr' stdout output:[info] MigrationLogger: *** Migrating data source=/config/nzbdrone.db;cache size=-10485760;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***2017-08-27 19:31:49,861 DEBG 'sonarr' stdout output:2017-08-27 19:31:49,861 INFO success: sonarr entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)2017-08-27 19:31:51,325 DEBG 'sonarr' stdout output:[Fatal] ConsoleApp: EPIC FAIL![v2.0.0.4949] NzbDrone.Core.Datastore.CorruptDatabaseException: Database file: /config/nzbdrone.db is corrupt, restore from backup if available. See: https://github.com/Sonarr/Sonarr/wiki/FAQ#i-am-getting-an-error-database-disk-image-is-malformed ---> System.Data.SQLite.SQLiteException: disk I/O errordisk I/O errorat System.Data.SQLite.SQLite3.Prepare (System.Data.SQLite.SQLiteConnection cnn, System.String strSql, System.Data.SQLite.SQLiteStatement previous, System.UInt32 timeoutMS, System.String& strRemain) [0x0033c] in <61a20cde294d4a3eb43b9d9f6284613b>:0at System.Data.SQLite.SQLiteCommand.BuildNextCommand () [0x00068] in <61a20cde294d4a3eb43b9d9f6284613b>:0--- End of inner exception stack trace ---at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationContext migrationContext) [0x00136] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0at NzbDrone.Core.Datastore.DbFactory.Create (NzbDrone.Core.Datastore.Migration.Framework.MigrationType migrationType) [0x00010] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0at NzbDrone.Core.Datastore.DbFactory.RegisterDatabase (NzbDrone.Common.Composition.IContainer container) [0x00006] in <e8ad39d438bc4c448bfbd968b0f74ec6>:0at NzbDrone.Host.Bootstrap.Start (NzbDrone.Host.ApplicationModes applicationModes, NzbDrone.Common.EnvironmentInfo.StartupContext startupContext) [0x0003d] in <d2aa8471dce1470d8d07b077ed3fa5e1>:0at NzbDrone.Host.Bootstrap.Start (NzbDrone.Common.EnvironmentInfo.StartupContext startupContext, NzbDrone.Host.IUserAlert userAlert, System.Action`1[T] startCallback) [0x00075] in <d2aa8471dce1470d8d07b077ed3fa5e1>:0at NzbDrone.Console.ConsoleApp.Main (System.String[] args) [0x00013] in <e7e74f1ad35044249cce48fb51646d85>:02017-08-27 19:31:51,333 DEBG 'sonarr' stdout output:Press enter to exit...


 
sonarr-settings.thumb.jpg.094b97d96c119ac07c9ff52cc2e302f6.jpg

Probably due to the fuse/docker bug in unraid, do the following:- https://forums.lime-technology.com/index.php?/topic/44145-[support]-binhex---Sonarr#entry580906

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

I recently installed Sonarr on my unraid server - however - i can't tell if it's working. Nothing is queued and nothing seems to have been downloaded (I have a good bit of shows included - so i'm just surprised).

 

I checked the health and there are no errors, NZBGeek is my indexer, and sabnzbd is my download client. I even double checked things against this Spaceinvaders video.... any ideas?

 

Edited by helpermonkey

Share this post


Link to post

Did you test the connection to the download client?

Share this post


Link to post
4 hours ago, Squid said:

Did you test the connection to the download client?

I did indeed - and after a few days - it finally started working ... however, another question has popped up - so i have some renaming preferences setup in sonarr; however, when i look at the "completed" files in SAB, nothing has been renamed. in order to automatically rename, organize, and copy from my SAB folder to my TV Shows folder - do i need to change settings in Sonarr or in SAB? Or somewhere else perhaps?

Share this post


Link to post
4 minutes ago, helpermonkey said:

I did indeed - and after a few days - it finally started working ... however, another question has popped up - so i have some renaming preferences setup in sonarr; however, when i look at the "completed" files in SAB, nothing has been renamed. in order to automatically rename, organize, and copy from my SAB folder to my TV Shows folder - do i need to change settings in Sonarr or in SAB? Or somewhere else perhaps?

Sonarr will rename the completed downloads when it imports them. This should follow the naming pattern you set in Sonarr media management settings.

Share this post


Link to post
51 minutes ago, wgstarks said:

Sonarr will rename the completed downloads when it imports them. This should follow the naming pattern you set in Sonarr media management settings.

Yeah, i'm getting the "no files found are eligible for import" display in my history - but in looking at my file permissions, i have things set to 777. i have zero idea how to fix this problem ... is there a log file i can post here that might help someone tell me what i'm doing wrong?

Share this post


Link to post

When I ran into this it was because I didn't have matching /data paths in my Sonarr docker and my Deluge docker. Are both of yours mapped to the same folder?

Share this post


Link to post
1 hour ago, helpermonkey said:

after a few days - it finally started working

On already existing shows, Sonarr does not look for missing episodes etc unless you explicitly tell it to.  Normally it just looks at an RSS feed to see what's new.  If a missing episode happens to be in the feed, then it will download it.  Have it search for those episodes you're missing

Share this post


Link to post
34 minutes ago, wgstarks said:

When I ran into this it was because I didn't have matching /data paths in my Sonarr docker and my Deluge docker. Are both of yours mapped to the same folder?

Gotcha -

I had:

/data  /mnt/user/Downloads/Sabnzbd/

/data  /mnt/user/Downloads/Sonarr/

Will Sonarr rename stuff already in that folder or do i need to run them through filebot and move them manually?

 

26 minutes ago, Squid said:

On already existing shows, Sonarr does not look for missing episodes etc unless you explicitly tell it to.  Normally it just looks at an RSS feed to see what's new.  If a missing episode happens to be in the feed, then it will download it.  Have it search for those episodes you're missing

 

I thought I had done that properly but i can't tell. So here's is a screen shot of a profile i've setup for quality - the show page for S04 of IASIP and the Wanted Page.... the existing episodes don't show up on the wanted even though i've got them highlighted to do so...

Screen Shot 2017-09-01 at 1.57.08 PM.png

Screen Shot 2017-09-01 at 1.56.26 PM.png

Screen Shot 2017-09-01 at 1.56.47 PM.png

Share this post


Link to post
5 minutes ago, helpermonkey said:

Will Sonarr rename stuff already in that folder or do i need to run them through filebot and move them manually?

No idea. I'd probably move them manually. It's not really an issue with the docker so you might try asking in the Sonarr forum.

 

9 minutes ago, helpermonkey said:

thought I had done that properly but i can't tell. So here's is a screen shot of a profile i've setup for quality - the show page for S04 of IASIP and the Wanted Page.... the existing episodes don't show up on the wanted even though i've got them highlighted to do so..

This is probably over simplifying but Sonarr will check your missing episodes against any new torrents posted on the sites you have setup in your indexers, using RSS sync. It won't search torrents that aren't newly posted. To check existing torrents you'll need to click the search button associated with each season or episode that you're missing.

 

Once again I recommend the Sonarr forums. I'm sure you'll get some answers here, but there will likely be many more resources there to answer your question regarding the app itself.

Share this post


Link to post
1 minute ago, wgstarks said:

No idea. I'd probably move them manually. It's not really an issue with the docker so you might try asking in the Sonarr forum.

 

This is probably over simplifying but Sonarr will check your missing episodes against any new torrents posted on the sites you have setup in your indexers, using RSS sync. It won't search torrents that aren't newly posted. To check existing torrents you'll need to click the search button associated with each season or episode that you're missing.

 

Once again I recommend the Sonarr forums. I'm sure you'll get some answers here, but there will likely be many more resources there to answer your question regarding the app itself.

Prudent advice - thanks!

Share this post


Link to post

Hi Guys. 

Sorry Ive been lurking for a while, reading learning etc. But Im stuck on something that even a spaceinvader video can't help with. Recently Sonarr has becoming incredibly slow while processing an RSSsync. Talking like an hour plus to process 900 releases, while consuming around 30% cpu the whole time. Radarr does the same in just a couple of seconds. 

 

Anyone know of a quick fix or is it reinstall time?

 

*Update*

 

Magically it's fixed itself after a few says with no intervention. 

 

*Update 2*

 

Its happening again, fml.

Edited by calypsoSA
update

Share this post


Link to post

Any help is appreciated.

 

I have had deluge and sonarr working together for 3 weeks(straight). Without reboot or issue. I had a blonde moment this past week. The power went out so i took the opportunity to remove the cache drive i had planned to remove. Unbeknownst to me all of my configs were housed on this cache drive. I started the server and the array and all of my dockers were there but none of my info was present. figuring out what happened I reintroduced the missing cache drive and now sonarr will not work. all of the other dockers seemed to recover without issue. I am sure i corrupt something. My Problem is i have uninstalled, deleted the config folders reinstalled sonarr and now i cannot add Files/Folders to my watch list for sonarr. The docker itself seems to function like it did before i but when i import existing series folders i get this " Folder is not writable by user nobody". It seems to me the permissions inside the docker are screwy. Any thought on this? I have tried all i can think of right now to get this to work. Well short of SSH into sonarr and chown 777 everything on the server which seems a bit dumb.

 

 

Also if no one has input on this could someone point me in the direction of importing all of my disks to a new Unraid? If so i will just start over.(extremely frustrated with myself)

Share this post


Link to post

Please ignore my previous post. I got a few hours sleep and thought about it on the way to work. My allocated HDDs are full to the point of cut off which i set to have 750GB per Hdd free. This means when i went to add the folders they were non write storage due to acting full. i just added my downloads section which does not have an upper limit and it added properly. at least this is what i believe to be happening. My main is not accessible from work or i would try it from here.

Share this post


Link to post
On 30/09/2017 at 8:45 AM, calypsoSA said:

Hi Guys. 

Sorry Ive been lurking for a while, reading learning etc. But Im stuck on something that even a spaceinvader video can't help with. Recently Sonarr has becoming incredibly slow while processing an RSSsync. Talking like an hour plus to process 900 releases, while consuming around 30% cpu the whole time. Radarr does the same in just a couple of seconds. 

 

Anyone know of a quick fix or is it reinstall time?

 

*Update*

 

Magically it's fixed itself after a few says with no intervention. 

 

*Update 2*

 

Its happening again, fml.

 

no idea sorry, as i suspect this is more likely to be an issue with the application rather than the container itself your best bet is to post your question on the github/forum for the application, it could well be a newly introduced bug.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.