[Support] Linuxserver.io - Nextcloud


Recommended Posts

On 3/3/2021 at 11:47 AM, skois said:

for now i just disabled the app, as i only have couple of users, but they are using only webui, not client apps.

Also because the app blocks ".lock" files i had some problem syncing some files from my repo which i was doing some Helm Charts (they included a Chart.lock). 
I'll soon use a truenas as a storage device, so with snapshots i wont have any problems with ransom.

Hey so I see that you said you got the fix from the developer working... mind if I ask how you applied the patch?

 

 

I have tried uninstalling the app in nextcloud app page.  restarting the containter and then reinstalling the app.. (but I think it is just pulling the old 1.9.0 version.. not the one with the patch that has been committed.

 

Thanks

 

Edited by Aceriz
Link to comment
5 hours ago, Aceriz said:
Hey so I see that you said you got the fix from the developer working... mind if I ask how you applied the patch?
 
 
I have tried uninstalling the app in nextcloud app page.  restarting the containter and then reinstalling the app.. (but I think it is just pulling the old 1.9.0 version.. not the one with the patch that has been committed.
 
Thanks
 

I'm not the one that applied the patch, I was planning to do it today maybe.

It should be as easy as overwriting the mentioned file from github to the container.
But since this is merged, wait a couple of days, it will be a release i believe

Sent from my Mi 10 Pro using Tapatalk
 

Edited by skois
Link to comment
22 hours ago, Nanobug said:

Hello,
I'm getting this erorr, when I'm trying to login.

image.png.5f833ed32c7c6e00b8494f481ea355ea.png

 

I do get to the login page:
image.png.c5b5443e76908074db03d5f9016266fe.png

- I just can't loging.

 

The log said this:


2021/03/04 13:23:10 [error] 393#393: *28 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: X.X.X.X, server: _, request: "POST /login HTTP/2.0", upstream: "fastcgi://127.0.0.1:9000", host: "X.X.X.X"
2021/03/04 13:32:11 [error] 393#393: *98 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: X.X.X.X, server: _, request: "POST /login HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "subdomain.domain.com"

I've changed my domain and local IP.

 

I tried a different browser as well.

Then I tried using a direct link to a zipped file, that one works.

So it seems like the login part of Nextcloud is messed up for some reason.

 

I'm not sure what version I'm running exactly, because I don't know where to find it.

But I did check for an update before this post, so it's the latest version as of this post.

 

I've tried rebooting the container and the proxy manager as well.

I tried looking at the nginx configuration files, but I don't know exactly what to look for.

 

Does anyone have a solution for that?

 

I can't tell you what happened, but I removed the container and installed it again, using all of the same files and configuration, and it works now.

Link to comment
On 2/26/2021 at 3:40 PM, kerpster said:

Finally after weeks of working to get my system back up and running i got it updated ish... i am still having an issue accessing the settings-system section. i cant tell what version i am on, nor can i update the system if there is an update to be done. i know i am a noob so any help will need to be explained in detail. thanks.

nextcloud settings error.PNG

So still no word on this.... Any chance anyone is able to share some incite?

Edited by kerpster
Link to comment

Has anyone gotten around the 'Your web server is not properly set up to resolve "/.well-known/webfinger"'   error? I've deleted the 'default' and restarted the app, pulling down the new "default' site-config, but I'm still getting the "webfinger" error

Link to comment
43 minutes ago, Nanobug said:

The only thing I can recommend, is to use Space Invader One's videos for setting it up from scratch.

i really dont want to start from scratch... i have to much on there to do that. to many profiles and stuff already set up and in use

Link to comment
2 hours ago, kerpster said:

So still no word on this.... Any chance anyone is able to share some incite?

You can't access Settings > System or Settings in General?
Does the rest of the instance working ok?
If you can access Settings > Logging. Do this.
Reproduce the error you getting and then grab a screeshot of the logging. (so the error will be recent)
If you can't access Settings > Logging, Do this
Reproduce the error you getting and then post the "nextcloud.log" which is located in your /data folder. 

Also open the docker console on nextcloud and do

* occ status

* occ check

* occ maintenance:repair

* occ upgrade

* updater.phar

 

And post the results.
Please before posting anything, check if there is any personal info and deduct them.
 

 

Link to comment

Hello, I'm trying to update my way up into modern times. I'm currently at Nextcloud 17 an stuck. "occ update:check" shows:

Nextcloud 18.0.14 is available. Get more information on how to update at https://nextcloud.com/outdated-php-7-1/

 

The docker container in unraid is up-to-date and "php --version" shows 7.1.17. I couldn't find a solution anywhere.

What am i missing? Thanks.

Edited by Monroe1701
Link to comment
40 minutes ago, skois said:

You can't access Settings > System or Settings in General?
Does the rest of the instance working ok?
If you can access Settings > Logging. Do this.
Reproduce the error you getting and then grab a screeshot of the logging. (so the error will be recent)
If you can't access Settings > Logging, Do this
Reproduce the error you getting and then post the "nextcloud.log" which is located in your /data folder. 

Also open the docker console on nextcloud and do

* occ status

* occ check

* occ maintenance:repair

* occ upgrade

* updater.phar

 

And post the results.
Please before posting anything, check if there is any personal info and deduct them.
 

 

The issue was the Settings > System

When i click on System i get the following error:

image.png.d7c2ebcf70a2a228ca8ad26d71b669cb.png

image.png.8184f42c5342751e02fd2344dc120e16.png

 

 

Here is the printout of the commands:

root:/# occ status
  - installed: true
  - version: 21.0.0.18
  - versionstring: 21.0.0
  - edition: 
root:/# occ check
root:/# occ maintenance:repair

 - Repair MySQL collation
     - Not a mysql database -> nothing to do
 - Repair mime types
 - Clean tags and favorites
     - 0 tags of deleted users have been removed.
     - 0 tags for delete files have been removed.
     - 0 tag entries for deleted tags have been removed.
     - 0 tags with no entries have been removed.
 - Repair invalid shares
 - Move .step file of updater to backup location
 - Add move avatar background job
     - Repair step already executed
 - Add preview cleanup background jobs
 - Fix potential broken mount points
     - No mounts updated
 - Repair language codes
 - Install new core bundle components
 - Add log rotate job
 - Clear frontend caches
     - Image cache cleared
     - SCSS cache cleared
     - JS cache cleared
 - Clear every generated avatar on major updates
 - Add preview background cleanup job
 - Queue a one-time job to cleanup old backups of the updater
 - Cleanup invalid photocache files for carddav
 - Add background job to cleanup login flow v2 tokens
 - Remove potentially over exposing share links
     - No need to remove link shares.
 - Clear access cache of projects
 - Reset generated avatar flag
 - Keep legacy encryption enabled
 - Check encryption key format
 - Remove old dashboard app config data
 - Add job to cleanup the bruteforce entries
 - Queue a one-time job to check for user uploaded certificates
 - Repair DAV shares
 - Update name of the stored view
 - Fix component of birthday calendars
     - 13 birthday calendars updated.
 - Regenerating birthday calendars to use new icons and fix old birthday events without year
     - Repair step already executed
 - Fix broken values of calendar objects
    0 [->--------------------------]
 - Registering building of calendar search index as background job
     - Repair step already executed
 - Register building of social profile search index as background job
 - Registering background jobs to update cache for webcal calendars
     - Added 0 background jobs to update webcal calendars
 - Registering building of calendar reminder index as background job
     - Repair step already executed
 - Clean up orphan event and contact data
     - 0 events without a calendar have been cleaned up
     - 0 properties without an events have been cleaned up
     - 0 changes without a calendar have been cleaned up
     - 0 cached events without a calendar subscription have been cleaned up
     - 0 changes without a calendar subscription have been cleaned up
     - 0 contacts without an addressbook have been cleaned up
     - 0 properties without a contact have been cleaned up
     - 0 changes without an addressbook have been cleaned up
 - Remove activity entries of private events
     - Removed 0 activity entries
 - Fix the share type of guest shares when migrating from ownCloud
 - Copy the share password into the dedicated column
 - Set existing shares as accepted
 - Purify and migrate collected mail addresses
    0 [----->----------------------]
 - Insert background jobs for all accounts
    0 [--------->------------------]
 - Make Mail itinerary extractor executable
 - Migrate Mail provisioning config from config.php to the database
     - No old config found
 - Create or update provisioned Mail accounts
     - No Mail provisioning config set
 - Update OAuth token expiration times
 - Create help command
 - Invalidate access cache for projects conversation provider
     - Invalidation not required
 - Switches from default updater server to the customer one if a valid subscription is available
     - Repair step already executed
 - Send an admin notification if monthly report is disabled
 - Add background job to check for backup codes
 - Populating added database structures for workflows
root:/# occ upgrade
Nextcloud is already latest version
root:/# updater.phar
Nextcloud Updater - version: v20.0.0beta4-11-g68fa0d4

Current version is 21.0.0.

No update available.

Nothing to do.

Edited by kerpster
Added error in log
Link to comment
13 minutes ago, kerpster said:

The issue was the Settings > System

When i click on System i get the following error:

image.png.d7c2ebcf70a2a228ca8ad26d71b669cb.png

image.png.8184f42c5342751e02fd2344dc120e16.png

 

 

Here is the printout of the commands:

root:/# occ status
  - installed: true
  - version: 21.0.0.18
  - versionstring: 21.0.0
  - edition: 
root:/# occ check
root:/# occ maintenance:repair

 - Repair MySQL collation
     - Not a mysql database -> nothing to do
 - Repair mime types
 - Clean tags and favorites
     - 0 tags of deleted users have been removed.
     - 0 tags for delete files have been removed.
     - 0 tag entries for deleted tags have been removed.
     - 0 tags with no entries have been removed.
 - Repair invalid shares
 - Move .step file of updater to backup location
 - Add move avatar background job
     - Repair step already executed
 - Add preview cleanup background jobs
 - Fix potential broken mount points
     - No mounts updated
 - Repair language codes
 - Install new core bundle components
 - Add log rotate job
 - Clear frontend caches
     - Image cache cleared
     - SCSS cache cleared
     - JS cache cleared
 - Clear every generated avatar on major updates
 - Add preview background cleanup job
 - Queue a one-time job to cleanup old backups of the updater
 - Cleanup invalid photocache files for carddav
 - Add background job to cleanup login flow v2 tokens
 - Remove potentially over exposing share links
     - No need to remove link shares.
 - Clear access cache of projects
 - Reset generated avatar flag
 - Keep legacy encryption enabled
 - Check encryption key format
 - Remove old dashboard app config data
 - Add job to cleanup the bruteforce entries
 - Queue a one-time job to check for user uploaded certificates
 - Repair DAV shares
 - Update name of the stored view
 - Fix component of birthday calendars
     - 13 birthday calendars updated.
 - Regenerating birthday calendars to use new icons and fix old birthday events without year
     - Repair step already executed
 - Fix broken values of calendar objects
    0 [->--------------------------]
 - Registering building of calendar search index as background job
     - Repair step already executed
 - Register building of social profile search index as background job
 - Registering background jobs to update cache for webcal calendars
     - Added 0 background jobs to update webcal calendars
 - Registering building of calendar reminder index as background job
     - Repair step already executed
 - Clean up orphan event and contact data
     - 0 events without a calendar have been cleaned up
     - 0 properties without an events have been cleaned up
     - 0 changes without a calendar have been cleaned up
     - 0 cached events without a calendar subscription have been cleaned up
     - 0 changes without a calendar subscription have been cleaned up
     - 0 contacts without an addressbook have been cleaned up
     - 0 properties without a contact have been cleaned up
     - 0 changes without an addressbook have been cleaned up
 - Remove activity entries of private events
     - Removed 0 activity entries
 - Fix the share type of guest shares when migrating from ownCloud
 - Copy the share password into the dedicated column
 - Set existing shares as accepted
 - Purify and migrate collected mail addresses
    0 [----->----------------------]
 - Insert background jobs for all accounts
    0 [--------->------------------]
 - Make Mail itinerary extractor executable
 - Migrate Mail provisioning config from config.php to the database
     - No old config found
 - Create or update provisioned Mail accounts
     - No Mail provisioning config set
 - Update OAuth token expiration times
 - Create help command
 - Invalidate access cache for projects conversation provider
     - Invalidation not required
 - Switches from default updater server to the customer one if a valid subscription is available
     - Repair step already executed
 - Send an admin notification if monthly report is disabled
 - Add background job to check for backup codes
 - Populating added database structures for workflows
root:/# occ upgrade
Nextcloud is already latest version
root:/# updater.phar
Nextcloud Updater - version: v20.0.0beta4-11-g68fa0d4

Current version is 21.0.0.

No update available.

Nothing to do.

i also noticed that when i click about it just get a blank blue screen. when i checked the log i get the following error:

 

[no app in context] Warning: Invalid data provided to provideInitialState by files

GET /apps/files/
from x by x at 2021-03-05T22:42:02+00:00

 

This this might be an issue as well.

Link to comment
19 minutes ago, kerpster said:

i also noticed that when i click about it just get a blank blue screen. when i checked the log i get the following error:

 

[no app in context] Warning: Invalid data provided to provideInitialState by files

GET /apps/files/
from x by x at 2021-03-05T22:42:02+00:00

 

This this might be an issue as well.

Can you please run occ integrity:check-core ? Does it report anything?

Link to comment
56 minutes ago, Monroe1701 said:

Hello, I'm trying to update my way up into modern times. I'm currently at Nextcloud 17 an stuck. "occ update:check" shows:

Nextcloud 18.0.14 is available. Get more information on how to update at https://nextcloud.com/outdated-php-7-1/

 

The docker container in unraid is up-to-date and "php --version" shows 7.1.17. I couldn't find a solution anywhere.

What am i missing? Thanks.

run "updater.phar"

after it is done withour errors do "occ upgrade"

I'd suggest a backup of nextcloud and db appdata before updating. You are several major releases behind, and things have more chances to go wrong.

Link to comment

Hey all hoping someone might be able to help me out.   Noticed the following error within nextcloud... Not sure where it is coming from or how to investigate.     It looks to be spreed app ?   but when I go to the app store page there isn't anything by that name installed ?   when I search for spreed "talk"  app shows up... 

 

any help of where to go next greatly appreciated

 

 

 

https://pastebin.com/zyzejp5j

 

Error	cron	TypeError: Argument 1 passed to OC\DB\SchemaWrapper::__construct() must be an instance of OC\DB\Connection, instance of OC\DB\ConnectionAdapter given, called in /config/www/nextcloud/apps/spreed/lib/BackgroundJob/CheckReferenceIdColumn.php on line 59
/config/www/nextcloud/apps/spreed/lib/BackgroundJob/CheckReferenceIdColumn.php - line 59:

OC\DB\SchemaWrapper->__construct()

/config/www/nextcloud/lib/public/BackgroundJob/Job.php - line 80:

OCA\Talk\BackgroundJob\CheckReferenceIdColumn->run()

/config/www/nextcloud/lib/public/BackgroundJob/TimedJob.php - line 61:

OCP\BackgroundJob\Job->execute()

/config/www/nextcloud/cron.php - line 128:

OCP\BackgroundJob\TimedJob->execute()

 

Link to comment

Hey,

 

I've been having trouble setting up this nextcloud container.

I followed this guide by spaceinvader (this installs the container with a mariadb one aswell): 

It did work when i followed it, when making the account it seemed to crash and didnt install any apps. I tried restarting the container then i could just login with the account i had made. It hadn't installed any of the apps though. So I tried testing it, upload some files etc etc and it was just super super slow, about 5-10 MB/s and the UI was also slow. So i deleted it and mariadb completely and followed the guide again, thinking i had made a mistake. The exact same thing happen, the default apps didnt install, slow ui, very slow upload etc. I then removed both dockers again and installed - just nextcloud without mariadb... Now it has an upload of about 50MB/s and the UI is somewhat faster.. Are there any issues with using the standard sqlite instead of mariadb? Is the guide outdated? Just want to be sure I installed it properly before deploying it and starting to rely on it.

Edited by Emma
My English sucks..
Link to comment
14 hours ago, Emma said:

Hey,

 

I've been having trouble setting up this nextcloud container.

I followed this guide by spaceinvader (this installs the container with a mariadb one aswell): 

It did work when i followed it, when making the account it seemed to crash and didnt install any apps. I tried restarting the container then i could just login with the account i had made. It hadn't installed any of the apps though. So I tried testing it, upload some files etc etc and it was just super super slow, about 5-10 MB/s and the UI was also slow. So i deleted it and mariadb completely and followed the guide again, thinking i had made a mistake. The exact same thing happen, the default apps didnt install, slow ui, very slow upload etc. I then removed both dockers again and installed - just nextcloud without mariadb... Now it has an upload of about 50MB/s and the UI is somewhat faster.. Are there any issues with using the standard sqlite instead of mariadb? Is the guide outdated? Just want to be sure I installed it properly before deploying it and starting to rely on it.

I was setting up my nextcloud exactly like the way in the video. I checked the upload speeds and when i add the file via webUI it was slowAF like 5MB/s. When i use the nextcloud client application in windows, it was WAY faster. maybe this is a possible workaround for you too. I am just synching the files with the app and thats it.

Link to comment
On 3/5/2021 at 8:25 PM, Dovy6 said:

Has anyone gotten around the 'Your web server is not properly set up to resolve "/.well-known/webfinger"'   error? I've deleted the 'default' and restarted the app, pulling down the new "default' site-config, but I'm still getting the "webfinger" error

any luck? i updated my docker container and deleted the default config file before that. some errors are gone, the webfinger error is still there:

image.thumb.png.ae9bfc61037c79e5c3040c48e036b5a5.png

Link to comment

Just setup Nextcloud yesterday. I'm using the Android app to auto upload my photos. It seems to have gotten down to one 3GB video that it keeps failing on with the error "Gateway Timeout."

 

Here's a snippet from my nginx error log:

2021/03/07 17:23:43 [error] 392#392: *17988 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <client IP>, server: _, request: "MOVE /remote.php/dav/uploads/matt/1b04dffbc578cbf2299ebb425426a021/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "<web.address>"
2021/03/07 17:53:34 [error] 392#392: *18656 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <client IP>, server: _, request: "MOVE /remote.php/dav/uploads/matt/1b04dffbc578cbf2299ebb425426a021/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "<web.address>"
2021/03/07 18:30:45 [error] 392#392: *19325 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <client IP>, server: _, request: "MOVE /remote.php/dav/uploads/matt/1b04dffbc578cbf2299ebb425426a021/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "<web.address>"
2021/03/07 19:02:00 [error] 392#392: *20030 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <client IP>, server: _, request: "MOVE /remote.php/dav/uploads/matt/1b04dffbc578cbf2299ebb425426a021/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "<web.address>"
2021/03/07 19:35:52 [error] 392#392: *75 upstream timed out (110: Operation timed out) while reading response header from upstream, client: <client IP>, server: _, request: "MOVE /remote.php/dav/uploads/matt/1b04dffbc578cbf2299ebb425426a021/.file HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "<web.address>"

 

I'm somewhat of a newb to unRAID and definitely to NextCloud. Does anyone know how I can fix this?

 

Thanks!

Matt

Edited by Mattaton
Link to comment

Hi guys,

 

i got some problem's with my nextcloud. The funny part is that i have access outside my network but when i am home nothing. I got message server is not accesible. I have done everything on spaceinvander video but don't know when i lost access. Also web console doesen't react. Also when i connected via hotspot i saw that i got message in nextcloud log. It looks like i am blocked from nextcloud to connect:

 

{"reqId":"1rTkjrkN49MBqHDaExDl","level":2,"time":"2021-03-07T01:18:39+00:00","remoteAddr":"192.168.88.34","user":"techgeek","app":"no app in context","method":"GET","url":"/core/preview?fileId=22&x=32&y=32","message":"Host 192.168.88.10 was not connected to because it violates local access rules","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36","version":"21.0.0.18","id":"6045e3a2938eb"}.

 

Is there a workaround? Sorry for my ENGLISH.

Edited by techgeeksvk
Link to comment
8 hours ago, techgeeksvk said:

Hi guys,

 

i got some problem's with my nextcloud. The funny part is that i have access outside my network but when i am home nothing. I got message server is not accesible. I have done everything on spaceinvander video but don't know when i lost access. Also web console doesen't react. Also when i connected via hotspot i saw that i got message in nextcloud log. It looks like i am blocked from nextcloud to connect:

 

{"reqId":"1rTkjrkN49MBqHDaExDl","level":2,"time":"2021-03-07T01:18:39+00:00","remoteAddr":"192.168.88.34","user":"techgeek","app":"no app in context","method":"GET","url":"/core/preview?fileId=22&x=32&y=32","message":"Host 192.168.88.10 was not connected to because it violates local access rules","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36","version":"21.0.0.18","id":"6045e3a2938eb"}.

 

Is there a workaround? Sorry for my ENGLISH.

Did this ever worked? In order to access nextcloud from inside the network and outside you need a router that supports NAT Hairpining

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.