Unraid OS version 6.6.2 available


limetech

75 posts in this topic Last Reply

Recommended Posts

Quote

Linux kernel:

version 4.18.14

OOT Intel 10gbps netowrk drivers: ixgbe-5.5.1, ixgbevf-4.5.1

 

Unfortunately, this update has still not fixed the issue I have with my onboard Intel 10gbps NICs (Supermicro X11SPH-nCTF). The boot syslog shows this error, just like V6.61:

 

Oct 14 18:57:58 unSERVER kernel: i40e 0000:67:00.0: Error I40E_AQ_RC_EINVAL adding RX filters on PF, promiscuous mode forced on
Oct 14 18:57:59 unSERVER kernel: i40e 0000:67:00.1: Error I40E_AQ_RC_EINVAL adding RX filters on PF, promiscuous mode forced on

 

I did some research online and it seems like this supposedly should have been fixed with new network drivers from Intel:

 

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892105

 

But not in my case, unfortunately. 

Link to post
  • Replies 74
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

What exactly would you have us do?  Send a strongly worded email to Gigabyte?

To upgrade: If you are running any 6.4 or later release, click 'Check for Updates' on the Tools/Update OS page. If you are running a pre-6.4 release, click 'Check for Updates' on the Plu

Your device doesn't use those drivers you quoted.   It uses the i40e driver.   Current OOB version from intel is 2.4.10   No idea if it compiles with latest kernel's yet.

Posted Images

Update 2

I joined the unraid server to the domain.

Windows 10 boxes can see \\tower but openelec wants a password i inputed domain user and password and is working

Windows XP does work after entering domain user/pass for connected share. 

 

Yea team

 

 

Link to post
7 hours ago, dlandon said:

The new Docker container size display is crowding on my system.

19059471_CrowdingonDocker.png.84807020a4034c0fab10ec63bfc7fb7e.png

 

7 hours ago, bonienl said:

Can you empty your browser's cache and try again

 

@bonienl @dlandon  This only happens when the browser's font size has been enlarged beyond its "normal" (on my system, "large" is fine, but "very large" shows the same thing as the pic.

Edited by Squid
Link to post
3 hours ago, highdefinitely said:

 

Unfortunately, this update has still not fixed the issue I have with my onboard Intel 10gbps NICs (Supermicro X11SPH-nCTF). The boot syslog shows this error, just like V6.61:

 


Oct 14 18:57:58 unSERVER kernel: i40e 0000:67:00.0: Error I40E_AQ_RC_EINVAL adding RX filters on PF, promiscuous mode forced on
Oct 14 18:57:59 unSERVER kernel: i40e 0000:67:00.1: Error I40E_AQ_RC_EINVAL adding RX filters on PF, promiscuous mode forced on

 

I did some research online and it seems like this supposedly should have been fixed with new network drivers from Intel:

 

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892105

 

But not in my case, unfortunately. 

Your device doesn't use those drivers you quoted.

 

It uses the i40e driver.

 

Current OOB version from intel is 2.4.10

 

No idea if it compiles with latest kernel's yet... Intel seems to be dragging there feet.

Link to post

This update has completely messed up my system. After updating, it is just stuck on mounting the drive with the array starting. I have downgraded back to 6.6.1 and even tried updating to 6.6.0 -RC4 and nothing works. I've run xfs repair with no problems. The only thing that will start my array back up is to disable my user shares.

Link to post
56 minutes ago, jwiese997 said:

This update has completely messed up my system. After updating, it is just stuck on mounting the drive with the array starting. I have downgraded back to 6.6.1 and even tried updating to 6.6.0 -RC4 and nothing works. I've run xfs repair with no problems. The only thing that will start my array back up is to disable my user shares.

Re-enable user shares and post your diagnostics (might have to do via the command line)

diagnostics
Link to post
13 minutes ago, jwiese997 said:

If I was going to guess, its all these lines

Oct 14 18:33:43 Tower nginx: 2018/10/14 18:33:43 [error] 3903#3903: *2107 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.15, server: , request: "POST /plugins/unassigned.devices/UnassignedDevices.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "tower", referrer: "http://tower/Main"

Try booting into safe mode.  If that works, delete every reference on /boot/config/plugins to unassigned devices (since it's not even installed).  And close any other open browser windows.

Edited by Squid
Link to post
31 minutes ago, Squid said:

If I was going to guess, its all these lines


Oct 14 18:33:43 Tower nginx: 2018/10/14 18:33:43 [error] 3903#3903: *2107 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.15, server: , request: "POST /plugins/unassigned.devices/UnassignedDevices.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "tower", referrer: "http://tower/Main"

Try booting into safe mode.  If that works, delete every reference on /boot/config/plugins to unassigned devices (since it's not even installed).  And close any other open browser windows.

It did boot into safe mode. I removed what you said to, but it didn't fix the issue. Here's the updated diagnostic

tower-diagnostics-20181014-1918.zip

Link to post
6 minutes ago, hawihoney said:

Did update two server to 6.6.2 this morning. All user shares are gone now - on both servers. "Enable user shares" is set to "Yes" in "Global Share settings". "User Shares" list on "Shares" page is empty.

 

Diagnostics of one server attached.

 

tower-diagnostics-20181015-0817.zip

Looks like a package conflict with one of them from DevPack or maybe one of the other plugins?  Try Safe Mode and see if your shares are back.

Link to post

Couldn't wait. Need these servers.

 

Did delete all txz files in /boot/config/plugins/[DevPack|NerdPack]/[6.5|6.6]. User Shares are back again. Thanks for now.

 

The DevPack/NerdPack plugins are of great help. But they are always a bulk of problems. Is there a way to bind them more closely to main Unraid in case of version compatibility and compile options?

 

 

Link to post
1 hour ago, hawihoney said:

Couldn't wait. Need these servers.

 

Did delete all txz files in /boot/config/plugins/[DevPack|NerdPack]/[6.5|6.6]. User Shares are back again. Thanks for now.

 

The DevPack/NerdPack plugins are of great help. But they are always a bulk of problems. Is there a way to bind them more closely to main Unraid in case of version compatibility and compile options?

 

 

The Devpack/Nerdpack plugins are an extreme example of the basic problem with using plugins (rather than dockers).   Every time unRAID is updated all packages that can be installed need to be reviewed (and potentially updated) for compatibility with the new release.  If a plugin overwrites any components used by core Unraid it can break things.    Since Limetech take no responsibility for testing against plugins it is up to the maintainers of the plugins to do this. I cannot see any way to easily resolve this.

 

One thing that might help with identifying if plugins are causing issues could be to force the reboot after installing an OS update to come up in Safe Mode.   It might also help to make the Safe Mode option more visible in the GUI as I am sure that many who run Unraid in headless mode may not even realize (or remember) that this is a boot time option.

Link to post

Update from 6.6.1 went fine so far except from the VM restart issue reported couple posts above. Restarting a VM from inside or within Unraid causing Unraid to show the VM as "not running". You can't start the VM from the web gui nor from the cl. Only way to fix it is to stop the VM from inside.

 

596572308_vmrestarterror.JPG.4e6577576f703cc3ce0cd7c009a3db01.JPG   850780848_virsherror.JPG.073fcadfc498bef5304c64b7c25be2de.JPG

Link to post
12 minutes ago, itimpi said:

The Devpack/Nerdpack plugins are an extreme example of the basic problem with using plugins (rather than dockers).   Every time unRAID is updated all packages that can be installed need to be reviewed (and potentially updated) for compatibility with the new release.  If a plugin overwrites any components used by core Unraid it can break things.    Since Limetech take no responsibility for testing against plugins it is up to the maintainers of the plugins to do this. I cannot see any way to easily resolve this.

I'm an old Perl coder and do use a ton of GUI-less scripts. So Perl (with some additional modules) and SQLite are the things I need most. Do you know about a docker for something like that?

 

Link to post

I could not see anything from the Release Notes, but does anyone know if 6.6.2 fixes the issue of Custom Parity Check Schedules being ignored. I have Checks scheduled for the first Monday of the month every 3rd month, and since updating to 6.6.1 Parity Checks have commenced EVERY Monday.

Link to post

just updated from 6.5.3, everything works oke, it's only kills my VM xml files! i cant finds them! if i recreate the vm with the (still there) .img files, will the VM be back?

1 harddisk didn't survived the reboot, swapped it for a new one and its currently rebuilding... this is the first time i 'test' the paity function :D

one thing what still wont work is the temperature monitoring of the Threadrippers chips...

i do use NFS and SMB, will monitor it...

Edited by sjaak
Link to post
18 minutes ago, sjaak said:

it's only kills my VM xml files!

This is likely a problem with libvirt.img and not directly related to this release, you should start a thread on the general support forum and don't forget to please post your diagnostics: Tools -> Diagnostics

Link to post
  • limetech unfeatured and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.