[Support] binhex - qBittorrentVPN


binhex

1281 posts in this topic Last Reply

Recommended Posts

  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@binhex Does the container only use a single .ovpn file from the appdata directory for configuration? Can I put all of the PIA port-forwarding capable server .ovpn files in there so that it can try th

Support for multi remote endpoints and PIA 'Next-Gen' networks now complete, see Q19 and Q20 for details:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

I think some of the PIA servers are having issues with Wireguard?   I usually use Toronto CA, but had to change to Ontario CA to get it to work.

Posted Images

Hey @binhex,

 

I get the following errors when i run qbittorrentvpn.  If I stop the docker, and remove the "perms.txt" file, then relaunch the image, the error goes away for a little while, but then it returns like herpes.  Any help to point me in the right direction.

 

I'm running the docker as UID=3501, GID=100, so although the user isn't the standard 99:100 that unraid expects, they are part of the same group, and the permissions look to be fine with a cursory look.

Nobody is 99:100
dockoper is 3501:100

When I started up docker:
-rwxrwxr-x 1 nobody   users  192 Apr 12 00:02 qBittorrent-data.conf*
-rwxrwxr-x 1 dockoper users 3661 Apr 12 00:02 qBittorrent.conf*

No complaints from docker from when it was started at 12:01am (when I started it) until 8am, from the supervisord.log:

2021-04-12 00:01:46,148 DEBG 'watchdog-script' stdout output:
[info] Privoxy process started
[info] Waiting for Privoxy process to start listening on port 8118...

2021-04-12 00:01:46,153 DEBG 'watchdog-script' stdout output:
[info] Privoxy process listening on port 8118

2021-04-12 08:00:47,292 DEBG 'watchdog-script' stderr output:
sed: preserving permissions for ‘/config/qBittorrent/config/sed5mxUuB’: Operation not permitted

2021-04-12 08:01:17,501 DEBG 'watchdog-script' stderr output:
sed: preserving permissions for ‘/config/qBittorrent/config/sedxoHbVt’: Operation not permitted

2021-04-12 08:01:47,644 DEBG 'watchdog-script' stderr output:
sed:

 

And I have no idea when exactly, but the permission/ownership changed at some point:

-rwxrwxr-x 1 nobody   users  197 Apr 12 12:36 qBittorrent-data.conf*
-rw-rw-rw- 1 nobody   users 3660 Apr 12 12:40 qBittorrent.conf

 

 

Edited by mooky
Link to post
14 hours ago, mooky said:

And I have no idea when exactly, but the permission/ownership changed at some point:

i can only assume that something is running unraid ui/tools/'new permissions' tool from unraid, you arent doing that right? other question is your /config folder defined for this container nested inside another containers defined /config folder? e.g.:-

/mnt/cache/appdata/sonarr/binhex-qbittorrent

 

this could cause an issue where if the uid and gid are set for sonarr (in this example) to puid=99 pgid=100 then it could overwrite the permissions of the child folder and files, which in this example is binhex-qbittorrent, you see what im saying?, i dont know if this is the case though.

Link to post
4 hours ago, binhex said:

change the endpoint, see q28 for how to do this:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

May I ask if there is a list of end points that support port forwarding for wireguard for PIA?  I se that list in supervisord but it doesnt say this is a list that supports port forwarding and i tried a few but they still give the same error.  I am in the US on the east coast if that matters.

Link to post
10 minutes ago, sittingmongoose said:

I se that list in supervisord but it doesnt say this is a list that supports port forwarding

it is, you should see 'List of PIA endpoints that support port forwarding' shown in the log just before it lists them, no?

 

10 minutes ago, sittingmongoose said:

i tried a few but they still give the same error.

try some of the others, it could well be a temporary outage from pia, it happens!.

Link to post
5 minutes ago, binhex said:

it is.

 

try some of the others, it could well be a temporary outage from pia, it happens!.

So there was a browser cache issue, even though it was working it was failing to load.  Not sure if some of the earlier ones worked or not but denmark worked for me.

Link to post

Hello 

 

Let me first say thank you for making my life so much easier by developing this container. 

 

But since a day i cant access the webUI of binhex-qbittorrentvpn also programs using qbittorrent cant connect to it.

 

I have attached the log file, hope that someone can help

 

supervisord.log

Link to post
26 minutes ago, Jarno said:

Hello 

 

Let me first say thank you for making my life so much easier by developing this container. 

 

But since a day i cant access the webUI of binhex-qbittorrentvpn also programs using qbittorrent cant connect to it.

 

I have attached the log file, hope that someone can help

 

supervisord.log 485.43 kB · 1 download

 

this is your issue, taken from your log:-

2021-04-13 09:07:57 TCP: connect to [AF_INET]213.152.188.12:443 failed: Connection refused

it looks like your openvpn config file '/config/openvpn/nl913.nordvpn.com.tcp.ovpn' is out of date, re-download from your vpn provider and replace the existing one.

Link to post
17 minutes ago, binhex said:

 

this is your issue, taken from your log:-


2021-04-13 09:07:57 TCP: connect to [AF_INET]213.152.188.12:443 failed: Connection refused

it looks like your openvpn config file '/config/openvpn/nl913.nordvpn.com.tcp.ovpn' is out of date, re-download from your vpn provider and replace the existing one.

Thank you, this fixed it for me 

Link to post
13 hours ago, BirdHeezy said:

I'm having this same issue. Can't seem to figure it out! 

I think some of the PIA servers are having issues with Wireguard?

 

I usually use Toronto CA, but had to change to Ontario CA to get it to work.

Link to post

I'd just like to preface this by saying I'm new to Unraid and dockers etc., so I apologise if I leave out anything important!

 

I can't connect to any of the peers on the torrent. The connection status symbol at the bottom is yellow, although I'm not sure whether that's relevant. When I add a torrent, I announce to the tracker just fine and I can see the total peers and seeds. Initially, I'll connect to a handful of peers but then they'll all disconnect, I don't get any data and I can't connect to them after that.

 

As for my setup. I have a remote dedicated server on which I've installed Wireguard server. I chose the relevant options when installing the docker, placed the .conf file and as far as I'm aware, all is well. The server shows a successful handshake and the ipleak.net magnet test shows my dedicated server IP instead of my home IP. I also added port forwarding rules to my Unifi Dream Machine for the port listed in the client, 6881.

 

I feel like I've probably done something silly though, so I'd appreciate any thoughts or input anyone has.

supervisord.log

Edited by Benji
attached log
Link to post
On 4/13/2021 at 10:26 AM, binhex said:

change the endpoint, see q28 for how to do this:- https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

I deleted my config and started again with this container before I saw this reccomendation. Problem is that now the script fails before the line that creates this config file so now i'm kind of stuck. If the solution is to change the endpoint, this endpoint has been unavailable for 2 weeks, is it worth therefor changing the default endpoint on the script to one that still works? NEw PIA users of this container will have the same problem as me, in that the endpoint can't be chosen.

 

I've also attached my logs just in case it's actually something different. https://pastebin.com/raw/WPMphfub

Link to post
21 hours ago, MiniKold said:

This may have been answered in another post and I looked past it, but it seems my settings for this docker are resetting whenever my server restarts. Any way I can get these to sti/ck?

Havw you defined your config directory as a permanent or bound volume?

Link to post
4 minutes ago, northyomv said:

Hi @binhex, could you please update this image with the changes made on the deluge version for getting tokens?

Yes don't worry I will press the trigger tonight, just having a time gap to ensure no issues with delugevpn before proceeding to roll out to all images.

Link to post
5 minutes ago, binhex said:

Yes don't worry I will press the trigger tonight, just having a time gap to ensure no issues with delugevpn before proceeding to roll out to all images.

You're the best! I don't mind testing it on a loop for a few hours and sending the logs if you could do with a hand

Link to post

Ok I'm sure I'm just using it wrong but I can't seem to figure out why my torrents are stuck at 'Downloading Metadata'. I'm sure its just because I have the Port Forwarding wrong. Do I have to forward a port on my router to go with the one that PIA is assigning the container? If so how do I account for the fact that it changes each time the container starts? Thanks in advance because at this point any help is appreciated.

Link to post

I can't download torrents from their URLs. Nothing happens when I try to do that.

I looked at the logs file and all I see is the following log -

"Downloading '{someTorrentUrl}', please wait..."

 

Happens also in linuxserver docker.

 

Any idea? I'm using the default settings, only disabled the vpn and changed the port via the web ui.

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.