Jump to content
scubieman

wsdd 100% using 1 core

39 posts in this topic Last Reply

Recommended Posts

wsdd was running 100%. I was backing up to backblaze via the VM through SMB. I shut down all dockers and vm's and it was still running high.

 

Wondering how do i restart the service wsdd? I believe it was at 100% because of the backup happening at that time.

 

image.png.bf85c0d68df4fc8a3e03821e4c83a79c.png

 

Share this post


Link to post

@scubieman I have seen this (wsdd at 100% on 1 core or thread) twice as well.  In both cases, as expected, a reboot fixed it. 

 

It happened when I had an Acronis backup running which backs up a PC/laptop to my unRAID server.  The core/thread changes but one remains pegged at 100% even when the backup completes.  A reboot is require to clear it.

 

I actually had a bug report ready to go and did not post as I want to gather more info and confirm it only happens during backup.  The last time I saw this was three days ago, but another backup is scheduled for tonight.

 

Since it is wsdd, this is only a 6.8.0-RC issue.

Edited by Hoopster

Share this post


Link to post

I wonder what triggers the bug to cause wsdd to peg 1 cpu. I ran across this tonight on 6.8 Stable. About the only thing I have running using Samba from other systems is 1 Win10 system that does media scans using 'media center master'.

 

I looked through the syslog but didn't find anything related to it nor any indications of things going sideways, so I didnt gather diagnostics. Instead I disabled WS-Discovery option.

Share this post


Link to post

I have the same issue since update to 6.8 stable.
I discovered 100% usage on 1 core of "wsdd" process after synching a Nextcloud Client to DockerNextcloudServer.

Share this post


Link to post

You can disable it, but you may not be able to see the server shares show up under 'network' in Windows 10 clients, but you can still browse them manually by server name or IP

Share this post


Link to post

Hi, 6.8.2, no -i br0 and experiencing the same issue. Stopping and starting the array seemed to stop it spiking a CPU for me. Would be good to know the root case. Thanks,

Edited by User01
forgot to add last sentence.

Share this post


Link to post

The only sure way to prevent this is to disable wsdd in your unraid settings.

Share this post


Link to post
Posted (edited)

Same happening to me with 6.8.3.

 

edit: noticed there is already a bug report about this

Edited by lamer

Share this post


Link to post

Any fix that doesn't kill browsing for windows machines? This has been ongoing for months..... kinda sucks that I basically don't have access to one of my CPU cores for VMs/Containers/etc...  Is this a more generic SMB problem or something unraid specific?

 

 

Share this post


Link to post
10 hours ago, mindedc said:

Is this a more generic SMB problem or something unraid specific?

I don't think Limetech had anything to do with the development of the wsd daemon.  Since the problem only occurs when wsdd is running, the problem lies either with the daemon itself, or an interaction with wsdd and some other driver or kernel module.

Share this post


Link to post

I just had this same thing, although killing the VM didn't resolve it. I then disabled each docker container in turn to see what it was, still nothing. Then finally disabled docker, then enabled it again and it quietened down. First time its happened for me though, so could just be a one time thing. I did also have a container that corrupted on me and I had to re-install it not long before this behaviour started.

Share this post


Link to post
1 hour ago, clinkydoodle said:

I just had this same thing, although killing the VM didn't resolve it. I then disabled each docker container in turn to see what it was, still nothing. Then finally disabled docker, then enabled it again and it quietened down. First time its happened for me though, so could just be a one time thing. I did also have a container that corrupted on me and I had to re-install it not long before this behaviour started.

Try this:
 

 

Share this post


Link to post

Thanks I haven't done it yet, but if it happens again ill give it a go. Still going strong after just restarting docker.

Share this post


Link to post

I have this same problem, wsdd process pegging one of the CPU's.

Simply changing any one of the parameters on the Shares tab results in the problem going away for a few hours.

I am running Version 6.8.3 2020-03-05

I have made some changes recently but I don't see why that would be a cause.

I am slowly backing out my changes to see if I can isolate it.

Need an effective fix for this.

 

Share this post


Link to post

I too had this issue for the last few days.

 

Used TOP to get process ID, then killed it, than typed WSDD

 

Windows network locations showed back up after restarting typing just WSDD, or, that did nothing, and it automagically starts back up.

 

Hopefully, it stays normal

Share this post


Link to post
Posted (edited)

NOPE   Disabling all SMB Shares does NOT make the problem go away.

 

According to BRIT in the next post, all that need be done is to disable WSD.  So I have done that.  Crossing fingers.

Edited by nhm91135

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.