Jump to content
binhex

[Support] binhex - SABnzbd

283 posts in this topic Last Reply

Recommended Posts

6 minutes ago, godbouy said:

When will this Docker support the latest version of SABNZDB?

 

what makes you think it doesnt?

Share this post


Link to post
Nevermind. I noticed the new template had some fields that I didn't have before. So, I tried installing from scratch and it works. The web ui is quite different, so I must've not updated in awhile. 
There are several different skins you can choose from, somewhere in the config. You can get back to the old UI if you prefer it. I do.

Sent from my Moto G (5) Plus using Tapatalk

Share this post


Link to post

Would it be possible to add the awk program to this image? I'm pretty sure it's been in there before but recently I've been adding it myself after noticing it is missing. It is quite useful in the pre/post scripts.

 

pacman -S awk

 

Share this post


Link to post

I'm having trouble defining paths.  This hasn't been an issue before in older versions of Sab that I've used.

 

Whenever I try to put in a custom path (ex. /mnt/user/Videos/Movies/) it gives me an error saying "docker-compose mount path must be absolute".  I'm not sure how to get any more absolute than what I'm already putting in.  Any ideas on how to solve this?

Share this post


Link to post
4 hours ago, CUclimber said:

/mnt/user/Videos/Movies/

 

if you are trying to enter this into sabnzbd then you will struggle, as /mnt/user wont exist, you need to use the container volume mapping NOT the host volume mapping

Share this post


Link to post

I have been using sabnzbd docker for a while and it is working well. Big thanks for the development!

 

I have assigned the sabnzbd a dedicated IP separate from the docker. I had anticipated that there may be some issues related to folder mappings to the unraid raid (which now is on a different IP) and also about the connectivity with Radarr/Sonarr. However, this does not appear to be the case and things are working. Do I still need to anticipate any issues or does this magically work? If so, I am curious why mapping and connectivity still work now?

Share this post


Link to post

Query - installed SABNZBVPN, have it all up and woirking except.... files are downloading to /config/downloads instad of /data/downloads. When I look in SABNZB settings the default user folder has a  "Default Base Folder: /config" which I am not able to change (within SABNZBVPN). This is the same as the system folders.

 

Should the default base folder for User not be /data ?

 

Cheers

 

Duggie

 

OK cancel this, just had to go back to root then select data instead of config, then my downloads/complete and incomplete folder!

 

Still think the default folder for User should be Data though, would provide consistency with other containers?

 

Cheers

 

Duggie

 

 

 
Edited by Duggie264
correct my crappy spelling

Share this post


Link to post

hi guys, new to all of this, when i try to access the web ui i'm staring at this spinning gear and thats all i get.

Capture.PNG

supervisord.log

 

*edit*  ok, found the answer in a sickbeard forum, its an issue with http vs https, I dont really know what the issue was or how the fix worked but...

Edited by timbo72

Share this post


Link to post

I'm trying to get this working behind the letsencrypt docker from linuxserver.  I'm able to get all the other dockers working, but when I access MYDOMAIN.COM/sabnzbd i get  a bad gateway.  I've got the settings in sab, to use /sabnzbd to work and I've added this to my default file in appdata\letsencrypt\nginx\site-confs.

 

upstream SABnzbd {
    server 192.168.0.232:8787;
    keepalive 512;

 

location /sabnzbd {
        include /config/nginx/proxy.conf;
        proxy_pass http://localhost:8787/sabnzbd;

 

What am I missing to make this accessible outside my network. 

 

Thanks in advance!

Share this post


Link to post

Right.  So I don't know if this is sonarr, or sab, so I'll start here.

 

Let me preface this by say that, aside from regular updates when I notice a new software version, there has been *zero* configuration change to my setup for over six months.  When I first (finally) got everything running smoothly, everything ran perfectly.  Over time, things slowly degrade, despite *zero* config changes, and I'm at a point now where I need help.

 

What is happening:

 

A show exists in sonarr, and its directory exists on my server, and it is 100% up to date, every episode is downloaded, in either 480 or 720p or 1080p.

 

Looking at sab's download log, I'll see a particular episode will be downloaded for said show, two or three times.  Usually I'll have to obfuscated version, an SDTV version, and a 720 or 1080 version.  All downloaded.  But when I check the actual show's directory, the file(s) sab downloaded are not there.  When I check sab's working directory, for complete and incomplete downloads, the files aren't there either.  But hovering over sab's download log shows a very clear path (to the working directory) for where it placed the file.

 

So multiple versions of the same (existing) episodes are downloading, and then disappearing.  And if there is only an SDTV version of the show on the server, and sab says it downloaded a 720 or 1080 version, that show is not there.

Share this post


Link to post

So I'm attempting to setup Mylar right now and trying to get it to work with SAB so that it'll properly move and organize files when they're down downloading but I'm stuck in a rut.  I followed all the directions here (https://www.htpcguides.com/configure-mylar-sabnzbd-nzbget-usenet-comics/#comment-2744634922 ), though there wasn't a default scripts folder so I made one, and then edited the provided script files as necessary. The issue I'm running into now is that after doing so I keep getting this error.

 

https://imgur.com/hZWcZUe

 

I ended up following a Google trail to a comment in the Linuxserver sab docker page that had the same issue with the preferences issue. The suggestion was to "chmod +x" but i am both unsure how to do that nor if it will actually fix my issue. 

 

Any idea where I've screwed up?

 

EDIT. I also believe this to be my docker run info. 

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="binhex-sabnzbd" --net="bridge" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "UMASK"="000" -e "PUID"="99" -e "PGID"="100" -p 8080:8080/tcp -p 8090:8090/tcp -v "/mnt/user/Downloads/":"/data":rw -v "/mnt/user/appdata/binhex-sabnzbd":"/config":rw binhex/arch-sabnzbd

8367181f30ab887ca775c4b3d7541fdf2b3be4659a5c1639f7d869dca62d5940

 

I'm also not able to open the .ini file or find my config file which I'm not totally sure about. Where it'd meant to be their just isn't a directory. 

Edited by Lawlanator

Share this post


Link to post
11 hours ago, Lawlanator said:

unsure how to do that

chmod +x /mnt/user/appdata/binhex-sabnzbd/scripts/ComicRN.py

Share this post


Link to post
10 hours ago, Squid said:

 


chmod +x /mnt/user/appdata/binhex-sabnzbd/scripts/ComicRN.py

 

 

I think this worked, but now I'm running into this error "/usr/bin/env: ‘python’: No such file or directory " when downloading with the script.

 

I'm assuming it has something to do with this supposed to be being installed on a Windows Machine with Python and this being UnRAID with it's dockers is making it complicated. My real issue is I haven't been able to track down exactly what's telling it to look for that directory in any of the configs I can think of, meaning I'm not entirely sure I'm not even sure what's telling it to look for that directory let alone if it's a Mylar or a Sab issue.

Share this post


Link to post

Hello,

Every now and then when I download a very big discussion such as a UHD movie (60+Gb) the unraring fails.

It seems that the downloaded files, sitting on the Cache drive, are unrared also on the Cache drive or something like that.

And then the Cache drive is not big enough and the procedure fails.

If I try later on, I guess when some or all of the files are commited to the NAS the the same unrar succeeds.

 

Is there a way to configure Unraid and/or Sabnzbd as to unsure this does not happen anymore?

Share this post


Link to post
16 minutes ago, xtrips said:

Is there a way to configure Unraid and/or Sabnzbd as to unsure this does not happen anymore?

Try Prefer on the use cache setting for the downloads share.

Share this post


Link to post
23 minutes ago, xtrips said:

Hello,

Every now and then when I download a very big discussion such as a UHD movie (60+Gb) the unraring fails.

It seems that the downloaded files, sitting on the Cache drive, are unrared also on the Cache drive or something like that.

And then the Cache drive is not big enough and the procedure fails.

If I try later on, I guess when some or all of the files are commited to the NAS the the same unrar succeeds.

 

Is there a way to configure Unraid and/or Sabnzbd as to unsure this does not happen anymore?

 

In Sabnzbd adjust the min free space setting under 'config - folders - minimum free space for temporary downloads folder'.  Probably set at least double what you expect the largest single download to be.  Another option is to put in a disk using unassigned devices to only use for download processing.

Share this post


Link to post
1 hour ago, Squid said:

Try Prefer on the use cache setting for the downloads share.

 

What do you mean? Where is this setting? Sabnzbd or Unraid?

Share this post


Link to post
 
What do you mean? Where is this setting? Sabnzbd or Unraid?
unRaid. Share setting. Prefer means that if I he cache drive is full it will write to the array instead. YMMV as it depends though if unRaid knows the size of the file being unpacked in advance

Share this post


Link to post
57 minutes ago, Squid said:
1 hour ago, xtrips said:
 
What do you mean? Where is this setting? Sabnzbd or Unraid?

unRaid. Share setting. Prefer means that if I he cache drive is full it will write to the array instead. YMMV as it depends though if unRaid knows the size of the file being unpacked in advance

I have no idea what you mean. I run 6.5.1 RC4 and there is no prefer setting under shares.

Share this post


Link to post

Click on the share from the shares tab.  Use Cache setting.  Press Help for a full description

Share this post


Link to post

Is the /config path now somehow hardcoded in this docker? On the docker page it doesn't show up and Host Path 1 seems to be missing. This is when newly setting up this docker on unraid 6.5.1-RC5

 

I want my finished download to end up in /mnt/user/media/DVD, /mnt/user/media/BluRay, /mnt/user/media/mkv etc. etc. How do I set this up?

 

On a older install of this docker on a server that was updated to unraid 6.5.0 Host Path 1 does show up and the /config path is still editable, why is this changed in the current version of the docker? Or is something else going on?

Share this post


Link to post
29 minutes ago, dikkiedirk said:

Is the /config path now somehow hardcoded in this docker?

It appears when you hit show more settings.

 

30 minutes ago, dikkiedirk said:

I want my finished download to end up in /mnt/user/media/DVD, /mnt/user/media/BluRay, /mnt/user/media/mkv etc. etc

Personally, I would let Radarr, etc do the moving rather than Sab, but in this case you would do something like map /complete to /mnt/user/media, and set up your Categories as DVD, BluRay, mkv etc, and tell Sab to move completed downloads to /complete

Share this post


Link to post

So it is not possible to edit the /config path anymore? Why is that? And why is it still possible on the older install? So. the docker has indeed been changed?

 

Besides I don't have a /complete mapping, I only see a /data mapping.

 

And where are all those keys for?

 

 

Share this post


Link to post

You can edit it all day long.

 

In basic view mode, you can simply type the appropriate path, or in advanced view the Edit button will appear.

52 minutes ago, dikkiedirk said:

Besides I don't have a /complete mapping, I only see a /data mapping.

On any application nothing is stopping you from adding any additional mappings.  You pretty much have to anyways to access your media within a container.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.