[Support] Djoss - HandBrake


1067 posts in this topic Last Reply

Recommended Posts

*Solved*

 

there were two issues.

 

1) I had output set to a sub directory within the storage path. Seeing the post above by Djoss that storage was readonly it made me think that the read only permissions were applying to the subdirectory as well. Moved the output folder to a level above the storage folder allowed it to write the output file.

 

2) within the GUI the destination directory shows as being set to a "folder" named output. it is not clear that this folder name is actually just a pointer to the folder selected in the output path of the docker. Showing the name of the user selected output folder within the GUI would be a good improvement to the UX of the docker.

Link to post
  • 2 weeks later...
  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Support for HandBrake docker container Application Name: HandBrake Application Site: https://handbrake.fr/ Docker Hub: https://hub.docker.com/r/jlesage/handbrake/ Github: https://github.com/jlesage/d

Try the latest version, which have Quick Sync support. See https://github.com/jlesage/docker-handbrake#intel-quick-sync-video for more details on how to use it.

In fact all you need to do is map the "/watch2" folder of the container: Edit the container. Add a new "Path": Set the host path to where you want your second watch folder.

Posted Images

12 hours ago, yanksno1 said:

Any of you guys using this docker to encode a 4K Blu-ray (to hopefully a good quality but lesser file size)? Wondering what settings you're using if you are. Thanks! 

I don't use it specifically for this, but I do use it to reduce file sizes/resolutions of stuff I don't need/want in their original format.  Basically any setting you choose that's below 4K will result in a smaller file.

 

I personally don't believe in the 4K hype and wouldn't make any difference visually even if you have a 4K screen to watch it on (I do, and 4K looks the same as 1080, which looks the same as 720, which looks just as good as 480... but my eyes are older), so I'd say just choose whichever resolution you want to give it a shot.  You can encode only a small part of the bluray to see what the output would be like, you don't have to do the entire thing.

 

When I do convert stuff, I've been using Matroska/H.265 usually either 720p or 480p if it's something silly like an animation.  You could start with 1080p and see how that looks to you.

Link to post

well, saying 4k does look about the same as 1080, 720 or even 480 ... and i also have old eyes ;)

 

its a mix of resolution AND bitrate, multi pass is also a better way to encode a video ... also u can play with vbr settings instead cbr.

 

and also, your TV should be setup properly, most TV's i look at are at default settings with all kinda crap picture enhancements turned on,

then yes, the difference aint big .. due wrong settings on TV.

 

a good 1080p quality on a good setted up TV with a decent upscaler will almost look equal to 4k.

 

But, encoding will always be a quality loss compared to the original ...

Edited by alturismo
Link to post

Hi all, I just installed this container to rip my family videos. I alread had QSV in boot/config/go for plex

 

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
#Setup drivers for hardware transcoding in Plex
modprobe i915
chmod -R 777 /dev/dri

so I just added /dev/dri to my profileimage.thumb.png.d7de86c444c631b4888fb8c689e2c55f.png 

 

I was expecting to see the custom preset but it's not there. I checked the log for error but this is what I got:

 

[cont-init.d] 95-check-qsv.sh: executing...
[cont-init.d] 95-check-qsv.sh: Processor: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz
[cont-init.d] 95-check-qsv.sh: exited 0.

 

I checked on the list and this processo support QSV

 

https://ark.intel.com/content/www/us/en/ark/products/75461/intel-xeon-processor-e3-1225-v3-8m-cache-3-20-ghz.html

 

So can someone please help me to find out why isn't working?

 

Thank you in advance!

 

Link to post
6 hours ago, Jokerigno said:

Hi all, I just installed this container to rip my family videos. I alread had QSV in boot/config/go for plex

 


#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &
#Setup drivers for hardware transcoding in Plex
modprobe i915
chmod -R 777 /dev/dri

so I just added /dev/dri to my profileimage.thumb.png.d7de86c444c631b4888fb8c689e2c55f.png 

 

I was expecting to see the custom preset but it's not there. I checked the log for error but this is what I got:

 

[cont-init.d] 95-check-qsv.sh: executing...
[cont-init.d] 95-check-qsv.sh: Processor: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz
[cont-init.d] 95-check-qsv.sh: exited 0.

 

I checked on the list and this processo support QSV

 

https://ark.intel.com/content/www/us/en/ark/products/75461/intel-xeon-processor-e3-1225-v3-8m-cache-3-20-ghz.html

 

So can someone please help me to find out why isn't working?

 

Thank you in advance!

 

Your variable should go in the Extra Parameters section like so:

image.png.9261e8e35afe7ee14657f4f95e62712e.png

Link to post
2 hours ago, cybrnook said:

Your variable should go in the Extra Parameters section like so:

image.png.9261e8e35afe7ee14657f4f95e62712e.png

You can also add an element to the template with  "Config Type" of "Device", which do the same thing.

Link to post
8 hours ago, Jokerigno said:

I was expecting to see the custom preset but it's not there.

Custom preset ?  What you should see is a new "Video encoder" for QSV, under the Video tab.

Link to post

Hey y'all, this forum has been a gem, and I'm excited to join the community.

 

Today, this one's got me stumped.

 

Similar to above...

 

I've tried applying every suggestion I've come across to get Handbrake to use Quick Sync. It works fine in Plex. No errors in the docker log. The activity log states that my cpu doesn't support QSV, which is wrong.

 

[13:35:25] gtkgui: HandBrake 1.3.3 (2020062200) - Linux x86_64 - https://handbrake.fr
[13:35:25] hb_display_init: attempting VA driver 'iHD'
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib/dri/iHD_drv_video.so
libva info: va_openDriver() returns -1
[13:35:25] hb_display_init: attempting VA driver 'i965'
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'i965'
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
[13:35:25] hb_display_init: attempting VA default driver
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
Cannot load libnvidia-encode.so.1
[13:35:25] hb_init: starting libhb thread
[13:35:25] hb_init: starting libhb thread
[13:35:25] hb_init: starting libhb thread
[13:39:18] CPU: Intel(R) Xeon(R) CPU E3-1245 v5 @ 3.50GHz
[13:39:18]  - Intel microarchitecture Skylake
[13:39:18]  - logical processor count: 8
[13:39:18] Intel Quick Sync Video support: no

 

Am I interpreting this wrong?

 

Plenty of folks have reported using this cpu and QSV successfully with Handbrake.

 

I've been testing with a mostly unchanged container, other than the mandatory additions. This is the docker command being run:

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker create --name='HandBrake-test' --net='bridge' --privileged=true -e TZ="America/Phoenix" -e HOST_OS="Unraid" -e 'AUTOMATED_CONVERSION_PRESET'='General/Very Fast 1080p30' -e 'AUTOMATED_CONVERSION_FORMAT'='mp4' -e 'AUTOMATED_CONVERSION_KEEP_SOURCE'='1' -e 'AUTOMATED_CONVERSION_NON_VIDEO_FILE_ACTION'='ignore' -e 'AUTOMATED_CONVERSION_OUTPUT_DIR'='/output' -e 'AUTOMATED_CONVERSION_OUTPUT_SUBDIR'='' -e 'USER_ID'='100' -e 'GROUP_ID'='100' -e 'UMASK'='000' -e 'APP_NICENESS'='' -e 'DISPLAY_WIDTH'='1280' -e 'DISPLAY_HEIGHT'='768' -e 'SECURE_CONNECTION'='0' -e 'X11VNC_EXTRA_OPTS'='' -e 'AUTOMATED_CONVERSION_NON_VIDEO_FILE_EXTENSIONS'='jpg jpeg bmp png gif txt nfo' -e 'AUTOMATED_CONVERSION_SOURCE_STABLE_TIME'='5' -e 'AUTOMATED_CONVERSION_SOURCE_MIN_DURATION'='10' -e 'AUTOMATED_CONVERSION_CHECK_INTERVAL'='5' -e 'AUTOMATED_CONVERSION_MAX_WATCH_FOLDERS'='5' -e 'AUTOMATED_CONVERSION_NO_GUI_PROGRESS'='0' -e 'AUTOMATED_CONVERSION_HANDBRAKE_CUSTOM_ARGS'='' -e 'AUTOMATED_CONVERSION_INSTALL_PKGS'='libva-dev libdrm-dev' -p '7803:5800/tcp' -p '7903:5900/tcp' -v '/mnt/user':'/storage':'ro' -v '':'/watch':'rw' -v '/mnt/user/downloads/post_process/':'/output':'rw' -v '/mnt/disks/ua_nvme/appdata/HandBrake-test2':'/config':'rw' --device /dev/dri 'jlesage/handbrake:latest'

 

Please see my signature for system specs.

Edited by brandonhowlett
New info
Link to post
3 hours ago, brandonhowlett said:

Hey y'all, this forum has been a gem, and I'm excited to join the community.

 

Today, this one's got me stumped.

 

Similar to above...

 

I've tried applying every suggestion I've come across to get Handbrake to use Quick Sync. It works fine in Plex. No errors in the docker log. The activity log states that my cpu doesn't support QSV, which is wrong.

 


[13:35:25] gtkgui: HandBrake 1.3.3 (2020062200) - Linux x86_64 - https://handbrake.fr
[13:35:25] hb_display_init: attempting VA driver 'iHD'
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /usr/lib/dri/iHD_drv_video.so
libva info: va_openDriver() returns -1
[13:35:25] hb_display_init: attempting VA driver 'i965'
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'i965'
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
[13:35:25] hb_display_init: attempting VA default driver
libva info: VA-API version 1.6.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
Cannot load libnvidia-encode.so.1
[13:35:25] hb_init: starting libhb thread
[13:35:25] hb_init: starting libhb thread
[13:35:25] hb_init: starting libhb thread
[13:39:18] CPU: Intel(R) Xeon(R) CPU E3-1245 v5 @ 3.50GHz
[13:39:18]  - Intel microarchitecture Skylake
[13:39:18]  - logical processor count: 8
[13:39:18] Intel Quick Sync Video support: no

 

Am I interpreting this wrong?

 

Plenty of folks have reported using this cpu and QSV successfully with Handbrake.

 

I've been testing with a mostly unchanged container, other than the mandatory additions. This is the docker command being run:


/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker create --name='HandBrake-test' --net='bridge' --privileged=true -e TZ="America/Phoenix" -e HOST_OS="Unraid" -e 'AUTOMATED_CONVERSION_PRESET'='General/Very Fast 1080p30' -e 'AUTOMATED_CONVERSION_FORMAT'='mp4' -e 'AUTOMATED_CONVERSION_KEEP_SOURCE'='1' -e 'AUTOMATED_CONVERSION_NON_VIDEO_FILE_ACTION'='ignore' -e 'AUTOMATED_CONVERSION_OUTPUT_DIR'='/output' -e 'AUTOMATED_CONVERSION_OUTPUT_SUBDIR'='' -e 'USER_ID'='100' -e 'GROUP_ID'='100' -e 'UMASK'='000' -e 'APP_NICENESS'='' -e 'DISPLAY_WIDTH'='1280' -e 'DISPLAY_HEIGHT'='768' -e 'SECURE_CONNECTION'='0' -e 'X11VNC_EXTRA_OPTS'='' -e 'AUTOMATED_CONVERSION_NON_VIDEO_FILE_EXTENSIONS'='jpg jpeg bmp png gif txt nfo' -e 'AUTOMATED_CONVERSION_SOURCE_STABLE_TIME'='5' -e 'AUTOMATED_CONVERSION_SOURCE_MIN_DURATION'='10' -e 'AUTOMATED_CONVERSION_CHECK_INTERVAL'='5' -e 'AUTOMATED_CONVERSION_MAX_WATCH_FOLDERS'='5' -e 'AUTOMATED_CONVERSION_NO_GUI_PROGRESS'='0' -e 'AUTOMATED_CONVERSION_HANDBRAKE_CUSTOM_ARGS'='' -e 'AUTOMATED_CONVERSION_INSTALL_PKGS'='libva-dev libdrm-dev' -p '7803:5800/tcp' -p '7903:5900/tcp' -v '/mnt/user':'/storage':'ro' -v '':'/watch':'rw' -v '/mnt/user/downloads/post_process/':'/output':'rw' -v '/mnt/disks/ua_nvme/appdata/HandBrake-test2':'/config':'rw' --device /dev/dri 'jlesage/handbrake:latest'

 

Please see my signature for system specs.

Try to clear the variable "AUTOMATED_CONVERSION_INSTALL_PKGS".  Installing libva and libdrm through this variable will override/downgrade the versions that come with the image.

Link to post
31 minutes ago, Djoss said:

Try to clear the variable "AUTOMATED_CONVERSION_INSTALL_PKGS".  Installing libva and libdrm through this variable will override/downgrade the versions that come with the image.

That was it!

 

It's interesting because I added those two packages while trying to get it to work. Go figure.

 

Thank you @Djoss!

Link to post
On 7/18/2020 at 9:28 PM, Djoss said:

Custom preset ?  What you should see is a new "Video encoder" for QSV, under the Video tab.

OK got it. And now that I selected this new encoder is will be used by default? I mean with all the auto conversion?

Link to post
13 hours ago, Jokerigno said:

OK got it. And now that I selected this new encoder is will be used by default? I mean with all the auto conversion?

You need to save your settings as a new preset.  Then configure the automatic video converter to use this preset (see the Automatic Video Converter: Preset setting).

Link to post
On 7/29/2020 at 11:21 AM, Jokerigno said:

OK but when I select it and try to run handbrake it says encode error!

Are you getting the error from the auto converter, the UI or both?

Link to post
On 7/30/2020 at 10:38 PM, pinion said:

Is there a way to boost the audio on the output?

Under the Audio/Track Selection tab, you have an option to adjust the gain of the audio track.

Link to post

Hello everyone, 

I am quite new the unraid and docker system and I just wanted to double check if my docker config is right. 

I am using a i3 9100, enabled QSV by adding modprobe i915 and I also can select the QSV profiles in the GUI. 

 

When converting a 1080p ts file to h264 1080 mpr my cores are running an ~85%. 

I this right? Honestly I expected a much lower load 

Thanks a lot and stay safe 

Link to post
1 hour ago, Bob@unraid said:

Hello everyone, 

I am quite new the unraid and docker system and I just wanted to double check if my docker config is right. 

I am using a i3 9100, enabled QSV by adding modprobe i915 and I also can select the QSV profiles in the GUI. 

 

When converting a 1080p ts file to h264 1080 mpr my cores are running an ~85%. 

I this right? Honestly I expected a much lower load 

Thanks a lot and stay safe 

You should try to look at/compare the encoding speed (it should be faster than non-QSV encoder).  Enabling QSV doesn't mean that the CPU is not affected.  There is also the decoding part that (I think) is not accelerated.

Link to post
1 hour ago, Bob@unraid said:

When converting a 1080p ts file to h264 1080 mpr my cores are running an ~85%. 

I this right? Honestly I expected a much lower load 

Thanks a lot and stay safe 

Depends on the video settings and encoding parameters; however, relatively high CPU loads with Handbrake QSV encoding is normal; especially if you are comparing it to CPU utilization with Plex and QSV.

 

Handbrake only uses QSV encoding.  Decoding is still done by the CPU as are all subtitles and audio tracks.

 

With QSV encoding in Handbrake my CPUs average in the high 60% to mid 70% CPU utilization.  Without QSV encoding (all CPU for everything), CPU utilization is in the mid 90% range across all CPUs.

 

However, QSV encoding is much faster than straight CPU encoding.

Link to post

I posted this on github but unfortunately i have received no answers since 6 days:

 

Title: Unraid docker. Encode failed with h.265 or h.264 (QSV) (Intel GPU, J4105) #142

 

Hello everbody,

i am using this docker on my Unraid NAS Version 6.8.3. I could succesfully add my Intel GPU to the docker image, but sad´ly i got an error:

`------- CONVERSION OUTPUT Thu Aug 6 13:40:58 CEST 2020 -------
[13:40:58] hb_display_init: attempting VA driver 'iHD'
libva info: VA-API version 1.8.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
Cannot load libnvidia-encode.so.1
[13:40:59] hb_init: starting libhb thread
[13:40:59] thread 1467b39d4b20 started ("libhb")
HandBrake 1.3.3 (2020080500) - Linux x86_64 - https://handbrake.fr
4 CPUs detected
Opening /watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4...
[13:40:59] CPU: Intel(R) Celeron(R) J4105 CPU @ 1.50GHz
[13:40:59] - logical processor count: 4
[13:40:59] Intel Quick Sync Video support: yes
[13:40:59] - Intel Media SDK hardware: API 1.33 (minimum: 1.3)
[13:40:59] - H.264 encoder: yes
[13:40:59] - preferred implementation: hardware (any) via ANY
[13:40:59] - capabilities (hardware): breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[13:40:59] - H.265 encoder: yes (8bit: yes, 10bit: yes)
[13:40:59] - preferred implementation: hardware (any) via ANY
[13:40:59] - capabilities (hardware): bpyramid icq vsinfo opt1
[13:40:59] hb_scan: path=/watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:323: failed opening UDF image /watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2585: nav_get_title_list(/watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4/) failed
[13:40:59] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[13:40:59] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4':
Metadata:
major_brand : mp42
minor_version : 0
compatible_brands: isommp42
creation_time : 2019-04-07T11:13:14.000000Z
Duration: 00:17:51.60, start: 0.000000, bitrate: 499 kb/s
Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, bt709), 1280x720 [SAR 1:1 DAR 16:9], 368 kb/s, 25 fps, 25 tbr, 12800 tbn, 50 tbc (default)
Metadata:
creation_time : 2019-04-07T11:13:14.000000Z
handler_name : ISO Media file produced by Google Inc. Created on: 04/07/2019.
Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 127 kb/s (default)
Metadata:
creation_time : 2019-04-07T11:13:14.000000Z
handler_name : ISO Media file produced by Google Inc. Created on: 04/07/2019.
[13:40:59] scan: decoding previews for title 1

Scanning title 1 of 1, preview 1, 0.00 %[13:40:59] scan: audio 0x1: aac, rate=44100Hz, bitrate=127999 Unknown (AAC LC) (2.0 ch) (127 kbps)

Scanning title 1 of 1, preview 3, 30.00 %
Scanning title 1 of 1, preview 7, 70.00 %[13:41:00] scan: 10 previews, 1280x720, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[13:41:00] scan: supported video decoders: avcodec qsv
[13:41:00] libhb: scan thread found 1 valid title(s)

Using preset: modthom

title 1:

stream: /watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4

duration: 00:17:51

size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 25.000 fps

autocrop: 0/0/0/0

chapters:

1: duration 00:17:51

audio tracks:

1, Unknown (AAC LC) (2.0 ch) (127 kbps) (iso639-2: und)

subtitle tracks:
[13:41:00] Starting work at: Thu Aug 6 13:41:00 2020

[13:41:00] 1 job(s) to process
[13:41:00] json job:
{
"Audio": {
"AudioList": [],
"CopyMask": [
"copy:mp3",
"copy:aac",
"copy:ac3",
"copy:dts",
"copy:dtshd",
"copy:eac3",
"copy:flac",
"copy:truehd"
],
"FallbackEncoder": "none"
},
"Destination": {
"AlignAVStart": false,
"ChapterList": [
{
"Duration": {
"Hours": 0,
"Minutes": 17,
"Seconds": 51,
"Ticks": 96444077
},
"Name": ""
}
],
"ChapterMarkers": false,
"File": "/output/.AFkSzD/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mkv",
"InlineParameterSets": false,
"Mp4Options": {
"IpodAtom": false,
"Mp4Optimize": false
},
"Mux": "mkv"
},
"Filters": {
"FilterList": [
{
"ID": 6,
"Settings": {
"mode": 1
}
},
{
"ID": 12,
"Settings": {
"crop-bottom": 0,
"crop-left": 0,
"crop-right": 0,
"crop-top": 0,
"height": 720,
"width": 1280
}
}
]
},
"Metadata": {},
"PAR": {
"Den": 1,
"Num": 1
},
"SequenceID": 0,
"Source": {
"Angle": 0,
"Path": "/watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4",
"Range": {
"End": 1,
"Start": 1,
"Type": "chapter"
},
"Title": 1
},
"Subtitle": {
"Search": {
"Burn": true,
"Default": false,
"Enable": false,
"Forced": false
},
"SubtitleList": []
},
"Video": {
"ColorFormat": 0,
"ColorMatrix": 1,
"ColorPrimaries": 1,
"ColorRange": 1,
"ColorTransfer": 1,
"Encoder": "qsv_h265",
"Level": "auto",
"Options": "",
"Preset": "quality",
"Profile": "auto",
"QSV": {
"AsyncDepth": 4,
"Decode": false
},
"Quality": 28.0,
"Tune": "",
"Turbo": false,
"TwoPass": false
}
}
[13:41:00] Starting Task: Encoding Pass
[13:41:00] Skipping crop/scale filter
[13:41:00] job configuration:
[13:41:00] * source
[13:41:00] + /watch/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mp4
[13:41:00] + title 1, chapter(s) 1 to 1
[13:41:00] + container: mov,mp4,m4a,3gp,3g2,mj2
[13:41:00] + data rate: 499 kbps
[13:41:00] * destination
[13:41:00] + /output/.AFkSzD/Magic Home RGBW LED-Controller - Ersteinrichtung und Tasmota flashen haus-automatisierung.com -4K-.mkv
[13:41:00] + container: Matroska (libavformat)
[13:41:00] * video track
[13:41:00] + decoder: h264
[13:41:00] + bitrate 368 kbps
[13:41:00] + filter
[13:41:00] + Framerate Shaper (mode=1)
[13:41:00] + frame rate: 25.000 fps -> constant 25.000 fps
[13:41:00] + Output geometry
[13:41:00] + storage dimensions: 1280 x 720
[13:41:00] + pixel aspect ratio: 1 : 1
[13:41:00] + display dimensions: 1280 x 720
[13:41:00] + encoder: H.265 (Intel Media SDK)
[13:41:00] + preset: quality
[13:41:00] + profile: auto
[13:41:00] + level: auto
[13:41:00] + quality: 28.00 (ICQ)
[13:41:00] + color profile: 1-1-1
[13:41:00] sync: expecting 26790 video frames
[13:41:00] hb_display_init: using VA driver 'iHD'
libva info: VA-API version 1.8.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
[13:41:00] qsv_hevc_make_header: MFXVideoCORE_SyncOperation failed (-17)
ERROR: encqsvInit: qsv_hevc_make_header failed
ERROR: Failure to initialise thread 'Quick Sync Video encoder (Intel Media SDK)'
[13:41:00] vfr: 0 frames output, 0 dropped and 0 duped for CFR/PFR
[13:41:00] vfr: lost time: 0 (0 frames)
[13:41:00] vfr: gained time: 0 (0 frames) (0 not accounted for)
[13:41:00] h264-decoder done: 0 frames, 0 decoder errors
[13:41:00] sync: got 0 frames, 26790 expected
[13:41:00] Finished work at: Thu Aug 6 13:41:00 2020

[13:41:00] libhb: work result = 3

Encode failed (error 3).
HandBrake has exited.`

Activity log:

'[18:07:35] gtkgui: HandBrake 1.3.3 (2020080500) - Linux x86_64 - https://handbrake.fr
[18:07:35] hb_display_init: attempting VA driver 'iHD'
libva info: VA-API version 1.8.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
Cannot load libnvidia-encode.so.1
[18:07:35] hb_init: starting libhb thread
[18:07:35] hb_init: starting libhb thread
[18:07:35] hb_init: starting libhb thread
[18:07:41] gtkgui: Custom Preset: /custom/modthom
[18:07:41] Starting work at: Thu Aug 6 18:07:41 2020

[18:07:41] 1 job(s) to process
[18:07:41] json job:
{
"Audio": {
"AudioList": [],
"CopyMask": [
"copy:mp3",
"copy:aac",
"copy:ac3",
"copy:dts",
"copy:dtshd",
"copy:eac3",
"copy:flac",
"copy:truehd"
],
"FallbackEncoder": "none"
},
"Destination": {
"AlignAVStart": false,
"ChapterList": [
{
"Duration": {
"Hours": 0,
"Minutes": 1,
"Seconds": 9,
"Ticks": 6222690
},
"Name": ""
}
],
"ChapterMarkers": false,
"File": "/output/Felix Wal Spielzeug 19.07.2020 (1).mkv",
"InlineParameterSets": false,
"Mp4Options": {
"IpodAtom": false,
"Mp4Optimize": false
},
"Mux": "mkv"
},
"Filters": {
"FilterList": [
{
"ID": 6,
"Settings": {
"mode": 1
}
},
{
"ID": 12,
"Settings": {
"crop-bottom": 0,
"crop-left": 0,
"crop-right": 0,
"crop-top": 0,
"height": 1080,
"width": 1920
}
}
]
},
"Metadata": {
"Name": "Felix Wal Spielzeug 19.07.2020"
},
"PAR": {
"Den": 1,
"Num": 1
},
"SequenceID": 0,
"Source": {
"Angle": 0,
"Path": "/storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv",
"Range": {
"End": 1,
"Start": 1,
"Type": "chapter"
},
"Title": 1
},
"Subtitle": {
"Search": {
"Burn": true,
"Default": false,
"Enable": false,
"Forced": false
},
"SubtitleList": []
},
"Video": {
"ColorFormat": 0,
"ColorMatrix": 1,
"ColorPrimaries": 1,
"ColorRange": 1,
"ColorTransfer": 1,
"Encoder": "qsv_h265",
"Level": "auto",
"Options": "",
"Preset": "quality",
"Profile": "auto",
"QSV": {
"AsyncDepth": 4,
"Decode": false
},
"Quality": 28.0,
"Tune": "",
"Turbo": false,
"TwoPass": false
}
}
[18:07:41] CPU: Intel(R) Celeron(R) J4105 CPU @ 1.50GHz
[18:07:41] - logical processor count: 4
[18:07:41] Intel Quick Sync Video support: yes
[18:07:41] - Intel Media SDK hardware: API 1.33 (minimum: 1.3)
[18:07:41] - H.264 encoder: yes
[18:07:41] - preferred implementation: hardware (any) via ANY
[18:07:41] - capabilities (hardware): breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[18:07:41] - H.265 encoder: yes (8bit: yes, 10bit: yes)
[18:07:41] - preferred implementation: hardware (any) via ANY
[18:07:41] - capabilities (hardware): bpyramid icq vsinfo opt1
[18:07:41] hb_scan: path=/storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:323: failed opening UDF image /storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2585: nav_get_title_list(/storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv/) failed
[18:07:52] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[18:07:52] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv':
Metadata:
creation_time : 2020-07-19T21:10:17.000000Z
ENCODER : Lavf58.29.100
Duration: 00:01:09.14, start: 0.000000, bitrate: 9812 kb/s
Stream #0:0: Video: hevc (Main), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 1k tbn, 25 tbc (default)
Metadata:
DURATION : 00:01:09.141000000
Stream #0:1: Audio: aac (LC), 48000 Hz, stereo, fltp (default)
Metadata:
title : Stereo
DURATION : 00:01:09.141000000
[18:07:52] scan: decoding previews for title 1
[18:07:52] scan: audio 0x1: aac, rate=48000Hz, bitrate=1 Unknown (AAC LC) (2.0 ch)
[18:07:54] scan: 10 previews, 1920x1080, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[18:07:54] scan: supported video decoders: avcodec qsv
[18:07:54] libhb: scan thread found 1 valid title(s)
[18:07:54] Starting Task: Encoding Pass
[18:07:54] Skipping crop/scale filter
[18:07:54] job configuration:
[18:07:54] * source
[18:07:54] + /storage/media/Videos/Sonstige Videos/Private Videos/Felix Wal Spielzeug 19.07.2020.mkv
[18:07:54] + title 1, chapter(s) 1 to 1
[18:07:54] + container: matroska,webm
[18:07:54] + data rate: 9812 kbps
[18:07:54] * destination
[18:07:54] + /output/Felix Wal Spielzeug 19.07.2020 (1).mkv
[18:07:54] + container: Matroska (libavformat)
[18:07:54] * video track
[18:07:54] + decoder: hevc
[18:07:54] + filter
[18:07:54] + Framerate Shaper (mode=1)
[18:07:54] + frame rate: 25.000 fps -> constant 25.000 fps
[18:07:54] + Output geometry
[18:07:54] + storage dimensions: 1920 x 1080
[18:07:54] + pixel aspect ratio: 1 : 1
[18:07:54] + display dimensions: 1920 x 1080
[18:07:54] + encoder: H.265 (Intel Media SDK)
[18:07:54] + preset: quality
[18:07:54] + profile: auto
[18:07:54] + level: auto
[18:07:54] + quality: 28.00 (ICQ)
[18:07:54] + color profile: 1-1-1
[18:07:54] sync: expecting 1728 video frames
[18:07:54] hb_display_init: using VA driver 'iHD'
libva info: VA-API version 1.8.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_8
libva info: va_openDriver() returns 0
[18:07:54] qsv_hevc_make_header: MFXVideoCORE_SyncOperation failed (-17)
[18:07:54] encqsvInit: qsv_hevc_make_header failed
[18:07:54] Failure to initialise thread 'Quick Sync Video encoder (Intel Media SDK)'
[18:07:54] vfr: 0 frames output, 0 dropped and 0 duped for CFR/PFR
[18:07:54] vfr: lost time: 0 (0 frames)
[18:07:54] vfr: gained time: 0 (0 frames) (0 not accounted for)
[18:07:54] hevc-decoder done: 0 frames, 0 decoder errors
[18:07:54] sync: got 0 frames, 1728 expected
[18:07:54] Finished work at: Thu Aug 6 18:07:54 2020

[18:07:54] libhb: work result = 3
'

My NAS system:

 

Asrock J4105 with 4 GB DDR3(or4?) RAM
Docker is installed on a Cache SSD of the brand Patriot (Burst).

Btw the encoding works without the iGPU Video Codecs for example h.265 or h.264.

Thank you for your great work and thank you for your future answers.

Have a nice day.
Greetings from Germany.
Raptor2k

 

(maybe somebody in this forum knows the answers. Thx)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.