Unraid OS version 6.10.3 available

Recommended Posts

5 hours ago, itimpi said:

Most of the time the upgrades are painless but is always worth taking precautions against anything going wrong.   Make sure you have a backup of your flash drive before attempting the upgrade as you can then easily revert by copying the backup back onto the flash drive.  

It is a good idea to turn of auto-start of the array until you have done an initial check after the upgrade.   Temporarily disabling the Docker and VM services is also not a bad idea.


The one item that most frequent lay causes problems is if you have VMs with hardware pass-through as the IDs of the hardware can change.   In the worst case you can find an ID associated with a GPU now ends up assigned to a HBA.  Make sure that you do not have my VMs set to auto-start until you can check the passed through hardware.


Thank You! It seems to be going smooth so far!

Link to comment
  • 1 month later...

Update from 6.9.2 to 6.10.3 worked. BUT:

nfsd makes a huge mess with ownership and permissions. Some shares are ok, some not. No idea why.

So I downgraded unraid to 6.9.2 again and the shares are all ok again - without any additional work.


I did A LOT of research finding a solution to the issue without any success. please fix this.

Link to comment
  • 2 months later...
  • SpencerJ unpinned this topic
  • SpencerJ unfeatured this topic
  • 1 month later...
On 7/4/2022 at 8:26 PM, JoeUnraidUser said:


I had permission issues with my dockers after the upgrade and fixed the problems by running the following:

chown -cR nobody:users /mnt/user/appdata/*
chmod -cR ug+rw,ug+X,o-rwx /mnt/user/appdata/*




I've been fighting issues with Sonarr not being able to rename and copy files into their respective folders.  It can create a new folder in the root folder, for example the TV Shows folder, but when it tries to write the file into the existing folder associated with the show, I get this;


Import failed, path does not exist or is not accessible by Sonarr: /tv/South.Park.S26E02.720p.HDTV.x264-SYNCOPY/. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder


I wanted to try your fix, but where do I run those commands?  Do I run them from the terminal window in the web interface?  Should I backup the folders before changing the permissions?  Thanks so much.  This has been driving me crazy for months.


Link to comment

@trurl Thank you for the reply.  I pasted in the wrong error message.  That error message was because I deleted the folder that Sonarr was trying to copy from before I deleted the pending task in Sonarr.  That's why it couldn't find the folder. 


This is the error message I normally get and has been plaguing me since the unRAID upgrade.  I've found countless other people that have the same issue, none of which have been able to find a resolution.


Couldn't import episode /tv/Bar.Rescue.S08E24.JJs.Sports.Bust.720p.HULU.WEBRip.AAC2.0.H264-WhiteHat/c792f9dda2404c18ae20be60fc539e15.mkv: Access to the path '/tv/Bar.Rescue.S08E24.JJs.Sports.Bust.720p.HULU.WEBRip.AAC2.0.H264-WhiteHat/c792f9dda2404c18ae20be60fc539e15.mkv' is denied.

Edited by Spyderturbo007
Link to comment
On 2/28/2023 at 12:23 PM, trurl said:

Tools-New permissions on the User Shares involved. 


No luck. I'm still getting the access denied error message.


Couldn't import episode /tv/BBQ.Pitmasters.S05E12.1080p.WEB.h264-SKYFiRE/9c91bc0e4af94d48b5cc4ae5bc5777a3.mkv: Access to the path '/tv/BBQ.Pitmasters.S05E12.1080p.WEB.h264-SKYFiRE/9c91bc0e4af94d48b5cc4ae5bc5777a3.mkv' is denied.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.